No sound or distorted sound from certain Audigy models by default due to digital output being unmuted

Bug #106380 reported by OldGaf
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Wishlist
Ubuntu Audio Team

Bug Description

Card is detected and all channels available in alsamixer but I get no sound.

uname -a
2.6.20-14-generic #2 SMP Thu Apr 12 22:53:19 UTC 2007 i686 GNU/Linux

lspci
01:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
01:0a.1 Input device controller: Creative Labs SB Audigy Game Port (rev 03)
01:0a.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audigy [Audigy 1 [SB0090]], device 0: emu10k1 [ADC Capture/Standard PCM
Playback]

(subdevices 0 - 31 listed)

card 0: Audigy [Audigy 1 [SB0090]], device 2: emu10k1 efx [Multichannel Capture/ PT Playback]

(subdevices 0 - 7 listed)

card 0: Audigy [Audigy 1 [SB0090]], device 3: emu10k1 [Multichannel Playback]
Subdevices: 1/1
  Subdevice #0: subdevice #0

Card does 4.1 under Dapper and Edgy "out of the box" on same PC.

Revision history for this message
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested at https://help.ubuntu.com/community/DebuggingSoundProblems ? Thanks in advance.

Revision history for this message
Timbuck.3 (timbuck-3) wrote :

Same thing here
""sorry jut fixed it""
In Kmix Check of, the Audigy Analog/Digital Output Jack

Revision history for this message
OldGaf (linux-nialm) wrote :

Confirmed fix from Timbuck.

 The Audigy Analog/Digital Output Jack should not be enabled by default.

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-audio
status: Needs Info → Confirmed
Revision history for this message
polpak (polpak) wrote :

Also confirmed. Default Feisty install w/ Multimedia audio controller: Creative Labs SB Audigy (rev 03) produces no sound.

Had to disable the Audigy Analog/Digital Output Jack to get things working properly.

Revision history for this message
Matti Lindell (mlind) wrote :

I can confirm this on Feisty. I'm using Audigy1.
The problem seems to be in /etc/init.d/alsa-utils, when card's volume status is initialized by calling initscript with 'reset' parameter.

Here's the part from the script that enables "Analog/Digital Output Jack" for Audigy:
  # Some machines need one or more of these to be on;
  # others need one or more of these to be off:
  #
  # switch_control "External Amplifier" on
  switch_control "Audigy Analog/Digital Output Jack" on
  switch_control "SB Live Analog/Digital Output Jack" on

The first switch needs to be 'off' in my case. I've seen couple posts about this same issue in the ubuntuforums.org.
Bumping the priority a little

Changed in alsa-utils:
importance: Undecided → Medium
Revision history for this message
Daniel T Chen (crimsun) wrote :

Again, as the comment from Thomas in the initscript notes, some devices need this element unmuted. This in an intractable issue. We cannot detect which cards need it.

Revision history for this message
Matti Lindell (mlind) wrote :

Okay, thanks for the clarification.
I guess the comment from alsa-utils (1.0.9+1.0.10rc1-1) doesn't apply then
"
- initscript: Don't set "Audigy Analog/Digital Output Jack"
  The driver should set this up properly
"

I wonder why Debian leaves these lines commented?

Revision history for this message
Chris (crewof502) wrote :

Much easier to fix than you guys imply with directly editing /etc/init.d/alsa-utils :)
----------------------------

- Right click on the speaker icon (Volume Control) on the top panel.
- Make sure that Volume control is using your device Audigy 1, et cetera.
           - If wrong device, change it by clicking, File
           - Change Device
           - Select your device
- From here some new tabs should show up in the main window.
- Click the Switches Tab
- Uncheck Audigy Analog / Digital Output Jack

-----------------------------
That's it. Much easier and don't have to edit the alsa-utils script, which didn't work for me anyway.

Revision history for this message
Martin Olsson (mnemo) wrote :

I also had this exact problem. First I was a little bit disappointed that the sound didn`t work because it worked in previous versions. I`m glad I found this page though, and I`m glad the fix was so easy. My sounds works great now!

Martin

Revision history for this message
Juan Angulo Moreno (apostols) wrote :

I dont have sound with Feisty, my system have:

* ii alsa-utils 1.0.13-1ubuntu ALSA utilities
* uname -a: Linux vicious 2.6.20-16-generic
* aplay --list-devices:

tarjeta 0: Audigy2 [Audigy 2 ZS [SB0353]], dispositivo 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Capture/Standard PCM Playback]
  Subdispositivos: 32/32
  Subdispositivo #0: subdevice #0
  Subdispositivo #1: subdevice #1
  Subdispositivo #2: subdevice #2
  Subdispositivo #3: subdevice #3
  Subdispositivo #4: subdevice #4
  Subdispositivo #5: subdevice #5
  Subdispositivo #6: subdevice #6
  Subdispositivo #7: subdevice #7
  Subdispositivo #8: subdevice #8
  Subdispositivo #9: subdevice #9
  Subdispositivo #10: subdevice #10
  Subdispositivo #11: subdevice #11
  Subdispositivo #12: subdevice #12
  Subdispositivo #13: subdevice #13
  Subdispositivo #14: subdevice #14
  Subdispositivo #15: subdevice #15
  Subdispositivo #16: subdevice #16
  Subdispositivo #17: subdevice #17
  Subdispositivo #18: subdevice #18
  Subdispositivo #19: subdevice #19
  Subdispositivo #20: subdevice #20
  Subdispositivo #21: subdevice #21
  Subdispositivo #22: subdevice #22
  Subdispositivo #23: subdevice #23
  Subdispositivo #24: subdevice #24
  Subdispositivo #25: subdevice #25
  Subdispositivo #26: subdevice #26
  Subdispositivo #27: subdevice #27
  Subdispositivo #28: subdevice #28
  Subdispositivo #29: subdevice #29
  Subdispositivo #30: subdevice #30
  Subdispositivo #31: subdevice #31
tarjeta 0: Audigy2 [Audigy 2 ZS [SB0353]], dispositivo 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdispositivos: 8/8
  Subdispositivo #0: subdevice #0
  Subdispositivo #1: subdevice #1
  Subdispositivo #2: subdevice #2
  Subdispositivo #3: subdevice #3
  Subdispositivo #4: subdevice #4
  Subdispositivo #5: subdevice #5
  Subdispositivo #6: subdevice #6
  Subdispositivo #7: subdevice #7
tarjeta 0: Audigy2 [Audigy 2 ZS [SB0353]], dispositivo 3: emu10k1 [Multichannel Playback]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
tarjeta 0: Audigy2 [Audigy 2 ZS [SB0353]], dispositivo 4: p16v [p16v]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
tarjeta 1: Intel [HDA Intel], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

* lspci
05:04.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
05:04.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)

The Audigy Analog/Digital Output Jack is not be enabled and alsamixer is unmuted all controls.

Thanks,

Revision history for this message
PutPut (puterized) wrote :

Thank you. Fixed my problem with garbled/distorted sound. SB0090 SB Audigy on an ASUS MB with NForce 3-250 Chipset

Revision history for this message
Martin Olsson (mnemo) wrote :

I booted Gutsy LiveCD on my desktop today and I can confirm that this bug is still active in Gutsy. It's still very easy to fix though, just double-click the sound icon and inside "volume control" dialog you select the "Switches" tab, and finally you uncheck the checkbox called "Audigy Analog/Digital Output Jack". Sound will starts to work right away when you uncheck this checkbox.

Revision history for this message
James Westby (james-w) wrote :

I also hit this issue.

Daniel T Chen: the comment says some *machines* need it. It is possible that this means devices,
but I think it means that some users will use the digital output.

To me it makes sense to disable this by default, as someone who uses digital output
may be more likely to realise that is the issue, and also that enabling this option is
probably far more obvious to someone using digital output.

I realise this will probably annoy some digital output users.

Thanks,

James

Revision history for this message
James Westby (james-w) wrote :

I also hit this issue.

Daniel T Chen: the comment says some *machines* need it. It is possible that this means devices,
but I think it means that some users will use the digital output.

To me it makes sense to disable this by default, as someone who uses digital output
may be more likely to realise that is the issue, and also that enabling this option is
probably far more obvious to someone using digital output.

Also analogue output is probably also currently more common.

I realise this will probably annoy some digital output users.

Thanks,

James

Revision history for this message
OldGaf (linux-nialm) wrote :

"To me it makes sense to disable this by default, as someone who uses digital output
may be more likely to realize that is the issue, and also that enabling this option is
probably far more obvious to someone using digital output.

Also analogue output is probably also currently more common."

I completely agree. If someone wants didgital out, it would be "normal" for them to change setting to achieve this. Conversely anyone who has just installed an operating system would expect that the sound should work by defaut for a regulare PC.

 The "issue" is still in Gusty.

Revision history for this message
James Westby (james-w) wrote :

Hi,

I was testing the hardy beta and found I had no sound. It
was a couple of minutes before I remembered this issue
and enabled analogue ouput and got sound back.

Thanks,

James

Revision history for this message
Timbuck.3 (timbuck-3) wrote : Re: No sound from Audgy 1 by default due to digital output being default

Same bug with Hardy beta, rc, and Final..........
Same solution:

In Kmix Check of, the Audigy Analog/Digital Output Jack

Revision history for this message
Daniel T Chen (crimsun) wrote : Re: No sound from certain Audigy models by default due to digital output being unmuted

There is a lot of misunderstanding regarding the 'Audigy Analog/Digital Output Jack' mixer element. Certain Sigmatel codecs require this element to be UNmuted to have audible analog audio from the speaker jack. An increasing number of Sigmatel codecs require this element to be muted to have audible analog audio from the speaker jack. I'm happy to recommend that the initscript be changed to mute the above element, but we WILL cause a regression for people whose codecs require the element to be muted.

Again, this issue is intractable, well documented, and well hinted in various avenues. Regardless which approach is chosen, someone is going to be "left in the cold".

Changed in alsa-utils:
status: Confirmed → Triaged
Revision history for this message
nullack (nullack) wrote :

Tagged as regression-potential because this used to work by default in Hardy, now not in Intrepid on the same hardware.

Isnt it possible to better query the specific hardware and correctly set the toggle as needed?

Revision history for this message
Daniel T Chen (crimsun) wrote :

nullack, no, it's not possible to query the hardware to set the mixer element yet. Either we mute it by default and risk a (smaller) proportion of users experiencing one regression, or we leave it unmuted by default and risk a(n increasingly larger) proportion of users experiencing the opposite regression. There's no magic bullet, and not even the udev work being done in upstream git can help [yet].

Given the number of users experiencing this issue, we should mute the control in the initscript and just accept the fallout.

Revision history for this message
nullack (nullack) wrote :

Daniel, respectfully I do not accept its not possible. When I lspci vvn my hardware I get specific data back about the type of card I have - it knows I have an Audigy2 along with specific attributes of the card. It seems to be unnecessary bifurcation. By querying the hardware more fully, which seems possible by existing commands, it would be possible to be a win win for both scenarios.

Revision history for this message
Kzin (wmkzin) wrote :

Confirmed in Intrepid Release 2.6.27-7-generic
Daniel, if it is indeed not possible to query the hardware, my suggestion would be to prompt the user. Like when you change your menu.lst for grub, if there are changes in the file it lets the user make the decision to keep theirs or overwrite with the package maintainer's version.

If the user is prompted somehow with information and the option to enable or disable, then given directions on how to access the setting it would be a lot more "friendly" and people wouldn't have to spend x time trying to find this post. Or, heaven forbid, they don't even really know whats going on and are just trying the OS for the first time.

Just my 2 bits =)

Revision history for this message
Adam Williamson (awilliamson) wrote :

What's going to happen is that ALSA will be adapted so that, in all cases, 'muted' gives analog output, and 'unmuted' gives digital. That will basically fix the problem. But it will take a bit of time, as ALSA has to be coded to understand which way to set it up for each different codec.

Revision history for this message
Erkki Kaila (eokaila) wrote :

This, seemingly general error, hit me too.

thanks EKa

Revision history for this message
Steve Beattie (sbeattie) wrote :

Removing regression-potential and marking as regression-release.

Revision history for this message
shinew (xun911) wrote :

Hi, I seemed to be hit with this problem too. Except that I've tried all the fixed and there is no sound... :( any other suggestion?

I'm using audigy2 zs platinum, I hear the login/logout sounds but nothing else. tried editing the alsa-utils file & uncheck the mixer's digital output checkbox. none worked...

thanks!

Daniel T Chen (crimsun)
Changed in alsa-utils:
importance: Medium → Wishlist
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.0.18-1ubuntu8

---------------
alsa-utils (1.0.18-1ubuntu8) jaunty; urgency=low

  * debian/init: Mute *Analog/Digital Control for Creative cards
    by default (LP: #106380)
  * debian/README.init.cs4236: Include in /usr/share/doc/alsa-utils
    so that users of snd-cs4236 (e.g., ThinkPad 600) can have
    audible sound (LP: #41990)
  * fix_misspelling_speaker-test_man_page.patch: Fix misspelling
    in speaker-test(1) (LP: #296148)
  * Last upload fixed LP: #272865

 -- Daniel T Chen <email address hidden> Sun, 01 Feb 2009 16:12:42 -0500

Changed in alsa-utils:
status: Fix Committed → Fix Released
Revision history for this message
The J (me100313) wrote :

I just figured out this issue today after not having sound for about a week using Jaunty. I did update to the latest package but still had no sound because of this bug, so it may not be fixed for people upgrading to the latest alsa-utils.

One bug that it *did* fix was that Alsa seemed to be ignoring my alsa-base settings, meaning that Alsa kept using my ATI HDMI Audio as the default.

Revision history for this message
Sander Smeenk (ubuntu-freshdot) wrote :

JFYI, i installed Jaunty Release Candidate on April 17th, updated to what's available today (19th). Audio stopped working.

One of the comments state the mixer-element 'Audigy Analog/Digital Output Jack' needs to be switched -off-.
On my system it's the complete oposite, i have to switch it -on- to get audio.

I'm using 'analog' 5.1 speakers connected by 3.5mm plugs.

Revision history for this message
The J (me100313) wrote : Re: [Bug 106380] Re: No sound or distorted sound from certain Audigy models by default due to digital output being unmuted

Thanks for the info! I'll remember that when I upgrade to the release
version. One issue I did run into was that my alsa mixer settings were not
being saved, so I would have to mute that A/D Output Jack on every startup.
 "aslactl store" would come back with a message saying "/home/jd not our
directory!". I got around this by changing the /etc/asound.conf (I think
that's it) by hand.

On Sun, Apr 19, 2009 at 10:17 AM, Fluor <email address hidden> wrote:

> JFYI, i installed Jaunty Release Candidate on April 17th, updated to
> what's available today (19th). Audio stopped working.
>
> One of the comments state the mixer-element 'Audigy Analog/Digital Output
> Jack' needs to be switched -off-.
> On my system it's the complete oposite, i have to switch it -on- to get
> audio.
>
> I'm using 'analog' 5.1 speakers connected by 3.5mm plugs.
>
> --
> No sound or distorted sound from certain Audigy models by default due to
> digital output being unmuted
> https://bugs.launchpad.net/bugs/106380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Daniel T Chen (crimsun) wrote : Re: [Bug 106380] Re: No sound or distorted sound from certain Audigy models by default due to digital output being unmuted

On Sun, 19 Apr 2009, The J wrote:

> version. One issue I did run into was that my alsa mixer settings were not
> being saved, so I would have to mute that A/D Output Jack on every startup.
> "aslactl store" would come back with a message saying "/home/jd not our
> directory!". I got around this by changing the /etc/asound.conf (I think

Can you reproduce this symptom in jaunty with:
sudo -i
alsactl store

Revision history for this message
The J (me100313) wrote : Re: [Bug 106380] Re: No sound or distorted sound from certain Audigy models by default due to digital output being unmuted

Unfortunately, I'm having a completely unrelated issue with my install, so
I'm going to wipe it and install the release version fresh. I'll let you
know when that happens, though.
On Sun, Apr 19, 2009 at 3:58 PM, Daniel T Chen <email address hidden>wrote:

> On Sun, 19 Apr 2009, The J wrote:
>
> > version. One issue I did run into was that my alsa mixer settings were
> not
> > being saved, so I would have to mute that A/D Output Jack on every
> startup.
> > "aslactl store" would come back with a message saying "/home/jd not our
> > directory!". I got around this by changing the /etc/asound.conf (I think
>
> Can you reproduce this symptom in jaunty with:
> sudo -i
> alsactl store
>
> --
> No sound or distorted sound from certain Audigy models by default due to
> digital output being unmuted
> https://bugs.launchpad.net/bugs/106380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

tags: added: iso-testing
Revision history for this message
The J (me100313) wrote :

I realize it's a bit late, but my sound has been working fine in Karmic.
Just thought I'd give an update.

On Nov 17, 2009 2:03 PM, "Ubuntu QA Website" <email address hidden> wrote:

** Tags added: iso-testing

--

No sound or distorted sound from certain Audigy models by default due to
digital output being unmute...

Revision history for this message
Daniel Stone (danielstone) wrote :

Thank you for your update.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers