Realtek ALC269VB internal mic only records a high-pitched whine

Bug #799058 reported by Adam Monsen on 2011-06-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I'm not sure if this is in alsa-driver, I think I'm using pulseaudio. Also, I'm not sure why this shows up as "Realtek"... I think it's Intel HD Audio or something.

I don't hear anything I'm actually trying to record, just a loud high-pitched whine / squeal. Same result with arecord, Skype, gnome-sound-recorder, and "ubuntu-bug audio".

Sound playback works fine using the built-in speakers.

Using a USB Headset, sound recording (and playback) works fine.

lspci reports "00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-base 1.0.24+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: adamm 1446 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe500000 irq 45'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0269,1458a950,00100100 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 12
CheckboxSubmission: 5f9ff44393f2c8d5c8eb2ad7237c9341
CheckboxSystem: 0531969bcfd4f03af7405c98dc94a948
Date: Fri Jun 17 23:51:37 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:Intel failed
Symptom_Card: Internal Audio - HDA Intel
Symptom_Jack: Mic, Internal
Symptom_Type: High background noise, or volume is too low
Title: [To be filled by O.E.M., Realtek ALC269VB, Mic, Internal] Background noise or low volume
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/14/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Spring Peak
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: To be filled by O.E.M.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrSpringPeak:bd10/14/2010:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrAC5G3N-S8_F4:rvnTobefilledbyO.E.M.:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: AC5G3N-S8_F4
dmi.sys.vendor: To be filled by O.E.M.

Adam Monsen (meonkeys) wrote :
Adam Monsen (meonkeys) on 2011-06-18
description: updated
David Henningsson (diwic) wrote :

Hi Adam, could you try the following:

Open gnome-volume-control (by clicking speaker icon, then sound preferences). Go to input tab and make sure "Internal Mic" is selected.
If this does not help, could you open a terminal, execute the "alsamixer" command, navigate (with arrow keys) to the "Input Source" item and make sure it is set to "Internal Mic"?

Please report back and tell us if it helped or not. Thanks!

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Adam Monsen (meonkeys) wrote :

That fixed it. Yay!

Sorry, I thought I tried that before I filed this issue.

I've also since upgraded my kernel to 2.6.39 (to fix an unrelated bug with my Atheros wifi card - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/761176), so I suppose it's possible the new kernel had some effect.

At any rate, thank you!

David Henningsson (diwic) wrote :

Thanks for reporting back.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers