Ubuntu

Sound capture (microphone) works on LiveCD, but don't work after installation

Reported by Leo on 2010-05-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Daniel T Chen
Lucid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Lucid
Low
Steve Conklin

Bug Description

When LiveCD session sound capture work.
Right after installation it doesn't.
Ubuntu 10.04_amd64.
Notebook Aser Aspire 5110.

Workaround.
After installation make next:
In file /etc/modprobe.d/alsa-base.conf
add string:
options snd-hda-intel position_fix=1,
and restart.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: leo-lucid 1998 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf8400000 irq 16'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1025009f,00100002 HDA:14f12bfa,1025009f,00090000'
   Controls : 23
   Simple ctrls : 13
Date: Fri May 21 23:58:06 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 08/22/2008
dmi.bios.vendor: Acer
dmi.bios.version: V3.13
dmi.board.name: Navarro
dmi.board.vendor: Acer
dmi.board.version: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvrV3.13:bd08/22/2008:svnAcer:pnAspire5110:pvrV3.13:rvnAcer:rnNavarro:rvrN/A:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 5110
dmi.product.version: V3.13
dmi.sys.vendor: Acer

Leo (llenchikk) wrote :
Daniel T Chen (crimsun) wrote :

I've pushed a patch for this to stable@ and upstream.

Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: New → In Progress
madbiologist (me-again) wrote :

The abovementioned fix is now upstream in kernel 2.6.32.16.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Steve Conklin (sconklin) wrote :

SRU Justification

Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch.

The 2.6.32.21 upstream stable patch set is now available and contains fixes for this problem. It should be included in the Ubuntu kernel as well.

Related commits in the Lucid repo are:

8cbe9bd ALSA: hda: Use LPIB for Acer Aspire 5110

Changed in alsa-driver (Ubuntu):
milestone: none → lucid-updates
Steve Conklin (sconklin) on 2010-08-31
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Lucid):
importance: Undecided → Low
milestone: none → lucid-updates
status: New → Fix Committed
assignee: nobody → Steve Conklin (sconklin)
Changed in alsa-driver (Ubuntu Lucid):
status: New → Fix Committed
milestone: none → lucid-updates

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

Could people affected by this please test the proposed kernel and let us know whether the issue is resolved? We are awaiting confirmation that the problem is fixed by the proposed kernel.

See the previous comment for information about how to get proposed kernels.

Thanks!

Steve

Leo (llenchikk) wrote :

I have proposed kernel installed (2.6.32-25-generic).
I did next:
- delete string:
    options snd-hda-intel position_fix=1
  from file /etc/modprobe.d/alsa-base.conf;
- restart notebook;
- look into sound capture monitor (no reaction on microfon voice);
- try sound recorder (no sound capture);
- try skype (no sound capture).

My actions are correct?

Stefan Bader (smb) wrote :

...hm cross-posting via email may or may not work. Manually adding and hoping LP does not think otherwise later...

This is updating a set of bugs, so things said may or may not be exactly matching the bug report itself.

There is a set of bug reports which, reading feedback from reporters, do not seem to be fixed by the patches which were thought to fix them. All of these patches are part of some upstream stable release, so if a real fix is found, it
should be submitted there as well.
Quickly reading over the reports they all seem to be positional quirk fixes in ALSA. In one of the reports David had a quick look and had the suspicion that the code path of activating the fix may not be hit at all.
So while not fixing the bug all patches are not causing things to regress. Due to automatic processes, these bugs will get changed by a bot to fixed when the proposed kernel moves to updates and the bugs need to be re-opened then.

David, Daniel, maybe you can have a look at the test feedback and find out why the quirks have no effect?

Thanks,
Stefan

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/465942
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/587546
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/580749
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/551949
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/583983

tags: added: verification-failed
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (43.7 KiB)

This bug was fixed in the package linux - 2.6.32-25.44

---------------
linux (2.6.32-25.44) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Stefan Bader ]

  * Revert "SAUCE: sync before umount to reduce time taken by ext4 umount"
    - LP: #543617, #585092

  [ Steve Conklin ]

  * Revert "SAUCE: tulip: Let dmfe handle davicom on non-sparc"
    - LP: #607824

  [ Tim Gardner ]

  * [Config] Added ums-cypress to udeb
    - LP: #576066

  [ Upstream Kernel Changes ]

  * Revert "PCI quirk: Disable MSI on VIA K8T890 systems"
    - LP: #607824
  * Revert "PCI quirks: disable msi on AMD rs4xx internal gfx bridges"
    - LP: #607824
  * Revert "(pre-stable) Input: psmouse - reset all types of mice before
    reconnecting"
    - LP: #607824
  * Revert "jbd: jbd-debug and jbd2-debug should be writable"
    - LP: #607824
  * Revert "ext4: Make fsync sync new parent directories in no-journal
    mode"
    - LP: #615548
  * Revert "ext4: Fix compat EXT4_IOC_ADD_GROUP"
    - LP: #615548
  * Revert "ext4: Conditionally define compat ioctl numbers"
    - LP: #615548
  * Revert "ext4: restart ext4_ext_remove_space() after transaction
    restart"
    - LP: #615548
  * Revert "ext4: Clear the EXT4_EOFBLOCKS_FL flag only when warranted"
    - LP: #615548
  * Revert "ext4: Avoid crashing on NULL ptr dereference on a filesystem
    error"
    - LP: #615548
  * Revert "ext4: Use bitops to read/modify i_flags in struct
    ext4_inode_info"
    - LP: #615548
  * Revert "ext4: Show journal_checksum option"
    - LP: #615548
  * Revert "ext4: check for a good block group before loading buddy pages"
    - LP: #615548
  * Revert "ext4: Prevent creation of files larger than RLIMIT_FSIZE using
    fallocate"
    - LP: #615548
  * Revert "ext4: Remove extraneous newlines in ext4_msg() calls"
    - LP: #615548
  * Revert "ext4: init statistics after journal recovery"
    - LP: #615548
  * Revert "ext4: clean up inode bitmaps manipulation in ext4_free_inode"
    - LP: #615548
  * Revert "ext4: Do not zero out uninitialized extents beyond i_size"
    - LP: #615548
  * Revert "ext4: don't scan/accumulate more pages than mballoc will
    allocate"
    - LP: #615548
  * Revert "ext4: stop issuing discards if not supported by device"
    - LP: #615548
  * Revert "ext4: check s_log_groups_per_flex in online resize code"
    - LP: #615548
  * Revert "ext4: fix quota accounting in case of fallocate"
    - LP: #615548
  * Revert "ext4: allow defrag (EXT4_IOC_MOVE_EXT) in 32bit compat mode"
    - LP: #615548
  * Revert "ext4: rename ext4_mb_release_desc() to ext4_mb_unload_buddy()"
    - LP: #615548
  * Revert "ext4: Remove unnecessary call to ext4_get_group_desc() in
    mballoc"
    - LP: #615548
  * Revert "ext4: fix memory leaks in error path handling of
    ext4_ext_zeroout()"
    - LP: #615548
  * Revert "ext4: check missed return value in ext4_sync_file()"
    - LP: #615548
  * Revert "ext4: Issue the discard operation *before* releasing the blocks
    to be reused"
    - LP: #615548
  * Revert "ext4: Fix buffer head leaks after calls to
    ext4_get_inode_loc()"
    - LP: #615548
  * Revert "ex...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-09-27
Changed in linux (Ubuntu Lucid):
status: Fix Released → Triaged
Leo (llenchikk) wrote :

I can confirm this bug in Ubuntu 10.10. Workaround in Bug Description still work.

Daniel T Chen (crimsun) wrote :

@Leo David's patches fixing the core portion of this parsing landed some time ago but weren't in the Lucid release. Please follow https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules, and attempt to reproduce the symptom.

Leo (llenchikk) wrote :

I just install Ubuntu 11.04. Sound capture works after installation. So issue fixed at this release!

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
Leo (llenchikk) on 2014-02-24
tags: added: verification-done-lucid
removed: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers