Main Menu Editor alacarte is Completely Broken in xubuntu 12.10

Bug #1079953 reported by Leo H on 2012-11-17
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
alacarte (Ubuntu)
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

Main Menu Editor alacarte is Completely Broken in xubuntu 12.10

SYSTEM: Fresh install of xubuntu 12.10 (i386) using the official xubuntu .iso image, fully updated as of today.

The 'Main Menu' editor (alacarte) is completely broken in xubuntu 12.10. Changes in the xubuntu Applications Menu made with alacarte are not effected. For example:

-- Ticking/unticking boxes in alacarte does not stick.
-- New menu items created with alacarte are not put in place.
-- Menu items deleted with alacarte remain in place.
-- Moving items from one menu folder to another with alacarte no longer works.
-- .desktop files of any menu item opened (with or without (!) change) in alacarte simply accumulate in /home/[user]/.local/share/applications, without further effect.
-- sudo alacarte in a terminal no longer works.

It appears that alacarte is dependent on an item (gnome-desktop-item-edit) provided by the gnome-panel package which is not not compiled with alacarte and which is not otherwise installed under xubuntu. (See also Launchpad Bug #656735 -- https://bugs.launchpad.net/ubuntu/+source/alacarte/+bug/656735). However, the full gnome-panel is an alien package under xfce, and it should not be installed under xubuntu as it pulls in a mass of redundant and undesirable non-xfce gnome desktop functionality. (Note: exo-utils for xfce,which provides exo-desktop-item-edit, IS fully installed but this does not resolve the above bugs.)

Apart from these bugs, alacarte has limited functionality, it is prone to crashing, and it is awkward to handle. Many of these problems have a very long history and are never properly addressed.

It seems better if the alacarte Applications Menu Editor in xubuntu would be replaced as standard (or at least as an option through the (x)ubuntu repos) by LXMenuEditor (http://lxmed.sourceforge.net/).

Jasper St. Pierre (jstpierre) wrote :

As the upstream maintainer of alacarte, if you have any of these crashes, I'd love to see them. I do not know of

The editing bug may be caused not respecting $XDG_MENU_PREFIX.

http://git.gnome.org/browse/alacarte/commit/?id=a4db6799f41947b5cd08231e77d41c561d94170a

This commit should fix it. Please try this patch and tell me if it works.

Replacing the gnome-panel desktop item editor has been on my list for a little while, but I'm swamped with other tasks so far. I'll try to hack something up this weekend.

Dmitry Shachnev (mitya57) wrote :

@Jasper: one of crashes is bug 1057600, for example.

Lionel Le Folgoc (mrpouit) wrote :

Keep only one issue per bug report, please. Otherwise it's too complicated to track what's been fixed and what's still open. Thanks.

> -- Ticking/unticking boxes in alacarte does not stick.
> -- New menu items created with alacarte are not put in place.
> -- Menu items deleted with alacarte remain in place.
> -- Moving items from one menu folder to another with alacarte no longer works.

Already fixed in Bug #1069207 for raring, and currently available in quantal-proposed for testing.

> (Note: exo-utils for xfce,which provides exo-desktop-item-edit, IS fully installed but this does not resolve the above bugs.)

I patched alacarte in Ubuntu to call exo-desktop-item-edit when the environment variable $XDG_CURRENT_DESKTOP is equal to "XFCE". If you installed Xubuntu and didn't change the session startup it should be fine.

> It seems better if the alacarte Applications Menu Editor in xubuntu would be replaced as standard
> (or at least as an option through the (x)ubuntu repos) by LXMenuEditor (http://lxmed.sourceforge.net/).

Try menulibre instead, at least it's not in java. :P

Lionel Le Folgoc (mrpouit) wrote :

And, *please*, don't suscribe all random teams with "xubuntu" in their name. :(
("Xubuntu Bugs Team" is enough)

Leo H (leo-h-hildebrandt) wrote :

I can confirm that the updated version of alacarte currently in quantal-proposed does restore some functionality as regards the first three items mentioned in my earlier post (tick boxes, create new menu items, delete menu items).

However

-- Drag and drop of a menu item within a menu folder (rearrange menu item order) still does not work.

-- Drag and drop of a menu item from one menu folder to another still does not work.

-- Moving a menu item up or down within a menu folder with the arrow keys can only be done one position at the time. This takes about 15 seconds the be effected per step. Until this step takes effect, further clicks on the up or down arrow keys are ignored. During this process alacarte claims 95%-100% of CPU and over 50MiB of memory for a fresh standard installation of xubuntu 12.10 with only some 15 additional menu items.

-- Ticking or unticking a menu item box, adding new menu items, and deleting menu items makes similarly excessive time, CPU and memory demands.

In summary, the alacarte update works in a way, but slower than my pet escargot which is not à la carte. At the same time alacarte claims the whole system and turns it into a pressure cooker.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alacarte (Ubuntu):
status: New → Confirmed
BavarianPH (bavarianph) wrote :

when ubuntu went to "Unity" (actually should be called "Chaos and Confusion"), and then lied about how happy users are about it,
they destroyed everthing else easy.

Such as the Main Menu.

It can no longer be edited to users satisfaction.

True it took hours to make my own appnames, to sort them to my own directories, just as I wanted;
(because they refused to simplify them and just make them menu text files, that could easily be moved,
copied, deleted, backed up, and especially renamed and re-iconed.

But atleast I could personalize the menu and thereby streamline my activities.)
Now, I am chained to the whims of the programmers, Linux masters, and just as I feared,
IT'S REALLY JUST ALL ABOUT MONEY AND POWER, NO open NO freedom!

FIX the MENU, I know YOU can, IF you wanted to!
I cannot, I am only a dumb, unimportant user!!!

BavarianPH

Download full text (4.3 KiB)

The menu specification, which Unity follows, existed since long before
Unity was in the planning stages. Furthermore, the "Main Menu" application
used to edit menus is currently maintained by me, and I am not a Canonical
employee. They do not pay me any money, and I have no power over
Canonical's choices.

The bug here, about not working in Xubuntu, is a combination of two issues:
one is that the application did not respect the $XDG_MENU_PREFIX
environment, and the other is that due to legacy code, the application
depended on a binary installed as part of gnome-panel, so the desktop file
editor didn't work. Both have now been fixed. I do not know of Xubuntu's
update schedule, but a new unstable release that fixes the issue is out,
and the stable release will be part of GNOME 3.8. You can find it here:
ftp://ftp.gnome.org/pub/gnome/sources/alacarte/3.7/

If you have other suggestions on how to improve the usability of the menu
editor application, please let me know, and I'll try to take your
suggestions into account.

On Sun, Mar 3, 2013 at 2:26 PM, BavarianPH <email address hidden> wrote:

> when ubuntu went to "Unity" (actually should be called "Chaos and
> Confusion"), and then lied about how happy users are about it,
> they destroyed everthing else easy.
>
> Such as the Main Menu.
>
> It can no longer be edited to users satisfaction.
>
> True it took hours to make my own appnames, to sort them to my own
> directories, just as I wanted;
> (because they refused to simplify them and just make them menu text files,
> that could easily be moved,
> copied, deleted, backed up, and especially renamed and re-iconed.
>
> But atleast I could personalize the menu and thereby streamline my
> activities.)
> Now, I am chained to the whims of the programmers, Linux masters, and just
> as I feared,
> IT'S REALLY JUST ALL ABOUT MONEY AND POWER, NO open NO freedom!
>
> FIX the MENU, I know YOU can, IF you wanted to!
> I cannot, I am only a dumb, unimportant user!!!
>
> BavarianPH
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1079953
>
> Title:
> Main Menu Editor alacarte is Completely Broken in xubuntu 12.10
>
> Status in “alacarte” package in Ubuntu:
> Confirmed
>
> Bug description:
> Main Menu Editor alacarte is Completely Broken in xubuntu 12.10
>
> SYSTEM: Fresh install of xubuntu 12.10 (i386) using the official
> xubuntu .iso image, fully updated as of today.
>
> The 'Main Menu' editor (alacarte) is completely broken in xubuntu
> 12.10. Changes in the xubuntu Applications Menu made with alacarte
> are not effected. For example:
>
> -- Ticking/unticking boxes in alacarte does not stick.
> -- New menu items created with alacarte are not put in place.
> -- Menu items deleted with alacarte remain in place.
> -- Moving items from one menu folder to another with alacarte no longer
> works.
> -- .desktop files of any menu item opened (with or without (!) change)
> in alacarte simply accumulate in /home/[user]/.local/share/applications,
> without further effect.
> -- sudo alacarte in a terminal no longer works.
>
> It appears that alacarte is depend...

Read more...

Dmitry Shachnev (mitya57) wrote :

Ubuntu now has alacarte ≥ 3.7 (in fact, I have just synced alacarte 3.10.0, which adds no new features compared to 3.7.90, but fixes some important bugs).

Changed in alacarte (Ubuntu):
status: Confirmed → Fix Released
Bladeforce (adec2010) wrote :

Using Ubntu 13.10 and have alacarte 3.10 and still have no functionality at all

Bryce Nesbitt (bryce2) wrote :

Using 12.04, fresh upgrade, fully patched:
 alacarte launches but clicking *Properties* or *New Item* results in a crash.
Checking [x] report this error does nothing apparent.

Bryce Nesbitt (bryce2) wrote :

And pressing HELP gives: The URI ‘ghelp:user-guide?menu-editor#menu-editor’ does not point to a valid page.

Changed in alacarte (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers