Ubuntu

alacarte needs to depend on gnome-panel

Reported by Anton Lashkov on 2010-10-08
230
This bug affects 67 people
Affects Status Importance Assigned to Milestone
alacarte (Debian)
Fix Released
Unknown
alacarte (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: alacarte

Description: Ubuntu maverick (development branch)
Release: 10.10
Linux onto-laptop 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:34:50 UTC 2010 i686 GNU/Linux

alacarte:
  Установлен: 0.13.2-0ubuntu1
  Кандидат: 0.13.2-0ubuntu1
  Таблица версий:
 *** 0.13.2-0ubuntu1 0

I can't edit item in gnome menu. When i press button "properties", in terminal:

Traceback (most recent call last):
  File "/usr/share/alacarte/Alacarte/MainWindow.py", line 626, in on_properties_button_clicked
    self.on_edit_properties_activate(None)
  File "/usr/share/alacarte/Alacarte/MainWindow.py", line 383, in on_edit_properties_activate
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
  File "/usr/lib/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1141, in _execute_child
    raise child_exception
OSError: [Errno 2] Нет такого файла или каталога

Perhaps it occurred after I remove the gnome-panel, i using AWN

Alexander Gnodtke (gnodtke) wrote :

Does the problem persist if you switch back to gnome-panel?

What does the following mean? Нет такого файла или каталога

Changed in alacarte (Ubuntu):
status: New → Incomplete
Anton Lashkov (onto) wrote :

Problem is decide then i switch back to gnome-panel. But i don't use gnome-panel and I remove her with "aptitude remove gnome-panel".

When i press button "properties", in terminal:

Traceback (most recent call last):
  File "/usr/share/alacarte/Alacarte/MainWindow.py", line 626, in on_properties_button_clicked
    self.on_edit_properties_activate(None)
  File "/usr/share/alacarte/Alacarte/MainWindow.py", line 383, in on_edit_properties_activate
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
  File "/usr/lib/python2.6/subprocess.py", line 623, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1141, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Anton Lashkov (onto) on 2010-10-10
summary: - Don't edit menu items, don't add launch button on desktop.
+ Don't edit menu items, don't add launch button on desktop. (without
+ gnome-panel)

Hi Anton,

I did not understand what you meant by saying: "Problem is decide then i switch back to gnome-panel."

In order to work on this bug, we need to learn which steps are necessary to reproduce it.

As a first step, could you please reinstall gnome-panel and deactivate awn to see if the problem is still there?

Thanks, alex

Anton Lashkov (onto) wrote :

Hi Alexander,

Sorry, my English is bad.

When i reinstall gnome-panel (with dependences: evolution-data-server evolution-data-server-common gnome-applets gnome-applets-data gnome-panel-data indicator-applet indicator-messages indicator-sound libedataserverui1.2-8 libgee2 libido-0.1-0 ), my problem is solving. I can edit menu items, add launch button on desktop, use Alt+F1, Alt+F2 (this keys, don't work without gnome-panel too) again.

Maybe problem in some library, which are dependence of gnome-panel?

Thanks, Anton

Travis Watkins (amaranth) wrote :

gnome-desktop-item-edit is a program provided by the gnome-panel package which alacarte uses to display the item editor used for editing menu items. The alacarte package needs to depend on gnome-panel to ensure this is installed.

Changed in alacarte (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
summary: - Don't edit menu items, don't add launch button on desktop. (without
- gnome-panel)
+ alacarte needs to depend on gnome-panel
Anton Lashkov (onto) wrote :

Very strange dependence. Ok, i install gnome-panel, but it's not true solution. I think, it's necessary to make package of all programs, which alacarte is needed.

susema (susema) wrote :

I installed gnome-panel and it solved.

Anton Lashkov (onto) wrote :

I solve the problem by adding "gnome-desktop-item-edit" from package "gnome-panel" in the package "alacarte" (just rebuild the package).

Changed in alacarte (Debian):
status: Unknown → New
Glenn Sommer (gsommer) wrote :

I can confirm this is the same on 11.10.
The user still manually have to install gnome-panel to get alacarte working.

Jayes (johan-spee) wrote :

I can confirm that this exact same bug STILL exists on 12.04 !

Shirakawasuna (shirakawasuna) wrote :

I'm amazed that this bug still isn't fixed - it entirely prevents adding new menu entries.

Tobeus (bkdragon23) wrote :

I can confirm this bug is still in 12.04 x64. Unable to edit or add items in main menu.

tags: added: dependency packaging precise quantal
Hendrik Knackstedt (hennekn) wrote :

Hasn't been fixed for more than 2 years! Why can't we just add the dependency to the Ubuntu package instead of waiting for the Debian people? This obviously is an acceptable workaround.

lordamit (lordamit) wrote :

Hi all,i n case this problem persists - try the patch here.

https://bugs.launchpad.net/ubuntu/+source/alacarte/+bug/1089438

This is applicable for XFCE, LXDE.

Fabounet (fabounet03) wrote :

Now when we tell other people that bugs in open-source projects are fixed rapidly, they can laugh ...

Seriously, Alacarte needs to have its own item editor, it's non-sense to install a deprecated package to get the job done.

Just copy-paste the damn piece of code from gnome-panel into alacarte.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alacarte - 3.7.90-0ubuntu1

---------------
alacarte (3.7.90-0ubuntu1) saucy; urgency=low

  [ Jeremy Bicha ]
  * New upstream release.
  * debian/control.in:
    - Drop no longer needed dependency on gnome-panel (LP: #656735)
  * debian/patches/git_use_glib-gerror.patch: Dropped, applied in new version

  [ Robert Ancell ]
  * debian/control:
    - Use standards version 3.9.4
  * debian/patches/40-call-exo-d-i-e-on-xfce.patch:
  * debian/patches/50-xdg-menu-prefix.patch:
    - No longer applicable
 -- Jeremy Bicha <email address hidden> Tue, 04 Jun 2013 21:58:04 -0400

Changed in alacarte (Ubuntu):
status: Triaged → Fix Released
Changed in alacarte (Debian):
status: New → Fix Released
taj (othertaj) wrote :

Problem still exists in 13.10 64-bit Xubuntu without gnome-panel (I use xfce4 not gnome)
alacarte 3.10.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.