no icon in kde menu

Bug #108742 reported by jcfp on 2007-04-21
10
Affects Status Importance Assigned to Milestone
acidrip (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: acidrip

On feisty, acidrip's entry in the kde menu does not have an icon .

In /usr/share/applications/acidrip.desktop (part of the acidrip package) "gnome-cd.png" is specified as an icon. This file appears to be part of various gnome related packages such as gnome-accessibility-themes-extras, gnome-humility-icon-theme, and gnome-media-common. None of these are installed on my kubuntu system or listed as dependencies of the acidrip package.

Related branches

Siegfried Gevatter (rainct) wrote :

Also, just "gnome-cd" should be listed on the .desktop file, instead of "gnome-cd.png".

Changed in acidrip:
importance: Undecided → Wishlist
Paul Bartell (paul-bartell) wrote :

Im going to get this patched.

Changed in acidrip:
status: New → In Progress
Paul Bartell (paul-bartell) wrote :

ok heres the patch.

Changed in acidrip:
status: In Progress → Fix Committed
Siegfried Gevatter (rainct) wrote :

Thanks for your work on this! However, there are some issues with your patch:

 - Don't delete the original (Debian) maintainer, but instead change him to XSBC-Original-Maintainer.
 - If there is a "dirs" file in the debian folder, add "usr/share/pixmaps/" to it, but don't put a mkdir on the debian/rules.
 - On the changelog, the correct syntax is "(LP: #08742)", not "lp:#108742".
 - On the .desktop file, just write "Icon=acidrip", without the extension. If you can find a .xpm, it would be good to put it in usr/share/pixmaps too.

Also, when you post a debdiff don't set the bug as "Fix Commited", set it to "Confirmed" and subscribe "ubuntu-universe-sponsors" ("ubuntu-main-sponsors", depending on the package) to it. Thanks again! :)

Changed in acidrip:
assignee: nobody → paul-bartell
status: Fix Committed → In Progress
Paul Bartell (paul-bartell) wrote :

RainCT, Thanks for the pointers, This is my first time patching a package. Well I put the changes in, and it seems to all be in order. so heres the new debdiff.

Siegfried Gevatter (rainct) wrote :

ORIGINAL MAINTAINER
Now there's a typo there (Origional). Also, the new maintainer you added (the MOTU mailing list) was OK.
(https://wiki.ubuntu.com/DebianMaintainerField)

INSTALLING THE "pixmaps" DIR
Sorry, could not look at the package yesterday. You should not create a "dirs" file, since the previous maintainers weren't using any, but instead add a "dh_installdirs usr/share/pixmaps" (after "dh_installdirs usr/share/applications") on the debian/rules file.

CHANGELOG
It's OK now (although you could start the line with a capital letter, but that isn't that important :P). I've seen now that the package hasn't been updated since over a year, so that's why you don't see any other "(LP: #xxxxx)" there, but that's how it should be written now. If it would be a Debian bug it would be written like "(Closes: #xxxxx)" (just for the case you'd like to know that ;), it doesn't matter for this fix).

Also, you are deleting a line of the previous entry ("acidrip (0.14-0.2ubuntu4) edgy; urgency=low"). This should remain untouched.

ICON NAME
That's OK now, too. The extension should never be written because in the case that the file is available in many formats then, if it has no extension, automatically the most appropriate one will be chosen.

DELETION OF FILES
Don't delete that file called "1", it doesn't get installed anyway. Everything outside the "debian" directory comes from the original tarball and should be avoided to touch, or left to Debian (if it's required to be changed for the package to work, then a patch should be created, like those in debian/patches, but this isn't the case).

Thanks for your help improving Ubuntu :)

Paul Bartell (paul-bartell) wrote :

ok. Sorry for the wait. (I was forced away from the computer for all of sunday) Anyway, heres the debdiff.

Thank you RainCT for takeing the time to show me how to correctly make a debian package.

Siegfried Gevatter (rainct) wrote :

It's almost perfect now, good work :)

There are just two issues remaining:

 - As I said on my last comment, you made a typo in debian/control, it's written XSBC-Original-Maintainer (Origi>o<nal, without the "o").

 - In debian/changelog, instead of "Modified rules file to point to correct logo." better writte "Install the provided logo and correct the .desktop file to point to it." or somewhat like that.

Paul Bartell (paul-bartell) wrote :

ok. Heres the debdiff. and thanks so much for mentoring me on this bug.

Siegfried Gevatter (rainct) wrote :

Sorry, now that I looked closer at it I've noticed that the icon you are using is not a valid icon for that, since if it's a PNG it has to be of 48x48 pixels or if it's a XPM of 32x32 pixels as described here: https://wiki.ubuntu.com/MOTU/Packages/DesktopFiles .

After consulting a MOTU (Daniel Holbach) he told me the best solution would be to add 'gnome-media-common' (the package that provides the icon gnome-cd) as a dependency.

For that, following chages have to be done:

 - The file debian/rules should be left as it was before. Don't undo the changes manually but overwrite the file with it's original, in order to avoid leaving something in the diff.

 - On the .desktop file, change the icon back to 'gnome-cd' (without the .png).

 - On debian/control, add ", gnome-media-common" (without quotation marks) on line 7 (Build-Depends).

 - Update the changelog - now it should be something like that: "Added gnome-media-common as a dependency. (LP: #108742)"

 - Also, you could fix bug 118655 too, replacing the homepage that's in debian/control ( http://acidrip.thirtythreeandathird.net/) with the new one, http://untrepid.com/acidrip/ . If you do this, mark bug 118655 as duplicate of this one (leaving a comment that it has been fixed here), and remember to add an entry to the changelog (with a own "*").

Thanks again for your interest in helping Ubuntu, and sorry that I don't noticed that before, but well, this way you will know how to fix it when a package is in fact missing a icon :).

Paul Bartell (paul-bartell) wrote :

ok. I have marked bug 118655 a duplicate. The new debdiff is appached. Sorry for the long wait. I have been on holiday/vacation. and have not been looking at my email enough.

Changed in acidrip:
assignee: paul-bartell → rainct
Siegfried Gevatter (rainct) wrote :

Looks fine to me, well done! :)

I'm assigning ubuntu-universe-sponsors to look at it, since the package is in multiverse (you can check where it is by running 'apt-cache madison packagename' if you have apt-cache installed).

Siegfried Gevatter (rainct) wrote :

*assigning = subscribing

Changed in acidrip:
status: In Progress → Confirmed
Changed in acidrip:
assignee: rainct → nobody
Barry deFreese (bddebian) wrote :

Sorry, but what is the point of the build-depends on gnome-media-common? If it is to get the icon, it should be a depends, not build depends. Also if it is to get the icon, I personally think it's a bad idea to bring in gnome-media-common just for that especially if you are a KDE user. The best option would be to use an existing icon if one exists or add an xpm icon to the package, IMO.

Siegfried Gevatter (rainct) wrote :

Oh, had not noticed he put it as a build-depend.

About why adding the dependency:
 (#ubuntu-motu)
 RainCT: what should be done if a package is using a GNOME icon (= that's not in KDE)? copy that icon and install it with the name of the package to have it on both?
 dholbach: best to depends on gnome-icon-theme (if that's where the icon is from)
 RainCT: dholbach: the icon is in gnome-media-common, so it should depend on it?
 dholbach: RainCT: it's preferrable to duplicating icons and stuff, but I know that it might be a bit heavy

Scott Kitterman (kitterman) wrote :

Speaking as a Kubuntu oriented MOTU, I disagree. I'm going to unsub UUS until there is a clear resolution.

Barry deFreese (bddebian) wrote :

There is a file: AcidRip/logo.png in the source package. Is this suitable?

Scott Kitterman (kitterman) wrote :

Sounds sensible. Anything is better than pulling a big Gnome package in. RainCT and paul-bartell ought to look in that direction and see if it is suitable size/format wise, etc.

Siegfried Gevatter (rainct) wrote :

That icon is the one that was used in the previous debdiff, but it doesn't have the right size, and I neither think that it's a real icon (it's just a big image with the name of the program and it's website's URL).

Siegfried Gevatter (rainct) wrote :

Well, then it's icon from gnome-icon-theme should be duplicated into debian/ (uuencoded, of course)?

Scott Kitterman (kitterman) wrote :

Sounds reasonable.

Siegfried Gevatter (rainct) wrote :

Paul Bartell: Are you still interested in this?

Paul Bartell (paul-bartell) wrote :

I lost the data on the computer i was using to work on the package. So It might be better if someone else could do it. (Im a bit overloaded with school and all at them moment)

Changed in acidrip:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

acidrip (0.14-0.2ubuntu5) gutsy; urgency=low

  [ Paul David Bartell ]
  * Corrected homepage URL (LP: #118655)

  [ Siegfried-Angel Gevatter Pujals (RainCT) ]
  * Added an icon to the package, for KDE (LP: #108742)
  * Added an .xpm version of the icon for the menu file
  * Improved the .desktop file
  * Bump standards to version 3.7.2

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Sat, 15 Sep 2007 18:30:19 0200

Changed in acidrip:
assignee: rainct → nobody
status: In Progress → Confirmed
Changed in acidrip:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in acidrip:
status: In Progress → Fix Committed
Siegfried Gevatter (rainct) wrote :

acidrip (0.14-0.2ubuntu5) gutsy; urgency=low

  [ Paul David Bartell ]
  * Corrected homepage URL (LP: #118655)

  [ Siegfried-Angel Gevatter Pujals (RainCT) ]
  * Added an icon to the package, for KDE (LP: #108742)
  * Added an .xpm version of the icon for the menu file
  * Improved the .desktop file
  * Bump standards to version 3.7.2

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Sat, 15 Sep 2007 18:30:19 +0200

Changed in acidrip:
status: Fix Committed → Fix Released
Changed in acidrip:
assignee: kitterman → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers