Comment 65 for bug 1574278

Hi everyone,
I've just commited a fix for this and other flickering bugs. Please abiword
from shn head and let me know how it works. I apologize for taking so long
to fix this, cheers
Martin Sevior

On Mon, 19 Mar 2018, 13:56 James Cameron, <email address hidden>
wrote:

> Thanks for the offer. Sorry, I don't have a backport of my patch for
> abiword 3.0.1, and haven't estimated the effort. Would you consider
> moving Xenial to abiword 3.0.2?
>
> At One Laptop per Child for our derivative build of Ubuntu with the
> Sugar desktop, we've worked around the flickering by setting
> GTK_THEME to adwaita in the package sugar-write-activity. This
> perturbs the timing just enough to prevent the problem on our
> supported hardware.
>
> For our upcoming Bionic build, the abiword 3.0.2-6 package doesn't
> show the problem.
>
> --
> James Cameron
> http://quozl.netrek.org/
>
> --
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
> https://bugs.launchpad.net/bugs/1574278
>
> Title:
> AbiWord text cursor starts to flicker after adding some text
>
> Status in AbiWord:
> In Progress
> Status in abiword package in Ubuntu:
> Fix Released
> Status in abiword source package in Xenial:
> Triaged
> Status in abiword source package in Zesty:
> Won't Fix
> Status in abiword package in Debian:
> Fix Released
>
> Bug description:
> After adding some text in a new document, the entire document
> (including gray page background, text, text cursor) starts to flicker
> very fast. The UI above does not flicker. This happens too on a
> different system in VirtualBox. (Lubuntu 16.04 i386)
>
> Workaround for Ubuntu 16.04 LTS
> ===============================
> 1. Open the Lubuntu menu.
> 2. Open Preferences>Customize Look and Feel
> 3. Change the theme to something other than Lubuntu-default or
> Lubuntu-dark-panel
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: abiword 3.0.1-6
> ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
> Uname: Linux 4.4.0-21-generic i686
> ApportVersion: 2.20.1-0ubuntu2
> Architecture: i386
> CurrentDesktop: LXDE
> Date: Sun Apr 24 16:12:14 2016
> ExecutablePath: /usr/bin/abiword
> InstallationDate: Installed on 2016-04-22 (2 days ago)
> InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Release i386
> (20151021)
> ProcEnviron:
> LANGUAGE=de_DE
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SourcePackage: abiword
> UpgradeStatus: Upgraded to xenial on 2016-04-22 (2 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/abiword/+bug/1574278/+subscriptions
>