AbiWord text cursor starts to flicker after adding some text

Bug #1574278 reported by Kiwikaki on 2016-04-24
174
This bug affects 38 people
Affects Status Importance Assigned to Milestone
AbiWord
In Progress
High
abiword (Debian)
Fix Released
Unknown
abiword (Ubuntu)
High
Simon Quigley
Xenial
High
Simon Quigley
Zesty
High
Simon Quigley

Bug Description

After adding some text in a new document, the entire document (including gray page background, text, text cursor) starts to flicker very fast. The UI above does not flicker. This happens too on a different system in VirtualBox. (Lubuntu 16.04 i386)

Workaround for Ubuntu 16.04 LTS
===============================
1. Open the Lubuntu menu.
2. Open Preferences>Customize Look and Feel
3. Change the theme to something other than Lubuntu-default or Lubuntu-dark-panel

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: abiword 3.0.1-6
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic i686
ApportVersion: 2.20.1-0ubuntu2
Architecture: i386
CurrentDesktop: LXDE
Date: Sun Apr 24 16:12:14 2016
ExecutablePath: /usr/bin/abiword
InstallationDate: Installed on 2016-04-22 (2 days ago)
InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Release i386 (20151021)
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: abiword
UpgradeStatus: Upgraded to xenial on 2016-04-22 (2 days ago)

Kiwikaki (kiwikaki) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1574278

tags: added: package-qa-testing
Thomas F (fricki) wrote :

I am experiencing the same problem on three laptops... Abiword flickers when either starting and typing some text or when opening an existing document.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in abiword (Ubuntu):
status: New → Confirmed
casperdeweerd (cdeweerd) wrote :

I have the same issue

Antony.S (antony-seedhouse) wrote :

Ditto with 3.0.1-6 though someone reported in Arch the problem went away with 3.0.1-5 ( https://bugs.archlinux.org/task/46659 )

Thomas Ward (teward) wrote :

I stumbled across a discussion on this in #lubuntu-devel on IRC.

I'm setting "Medium" importance on this for several reasons:
* This package is part of the lubuntu-desktop task. This means it's considered part of the Lubuntu Desktop core software set.
* This package is in the Universe repository. For general Ubuntu triage, Universe equates to Community Supported
* Based on the changelog and package history, the package has not had any updates to actual software since Vivid.
* Upstream, in Debian, the package is considered *orphaned* and has no maintainer. This has been the case since 2014.

There can be an argument made for both High or Medium - I however believe Medium fits better in this case. (This can be changed in the future if a stronger case is made for "High", or more triagers consider this to be "High" than "Medium" in this case)

Changed in abiword (Ubuntu):
importance: Undecided → Medium
Thomas Ward (teward) wrote :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=740678 is the Debian Orphaned Package bug on this.

Thomas Ward (teward) wrote :

I have confirmed this, however it is *only* the cursor, it is not the text itself or other components - it is only the cursor. This doesn't impact anything but that cursor blink rate.

summary: - AbiWord starts to flicker after adding some text
+ AbiWord text cursor starts to flicker after adding some text
Thomas Ward (teward) wrote :

I can only replicate as reported by the OP when I start triggering automated scroll downs. Pasting 15 pages of filler text was able to very quickly trigger this issue.

It actively impacts usability, so I'm bumping this to "High" actively (you can't see the top third of the document window through the flickering interference).

Changed in abiword (Ubuntu):
importance: Medium → High
Jonas (jothro) wrote :

Can confirm this bug after Upgrade from Lubuntu 14.04.4 to 16.04.
(abiword 3.0.0-4ubuntu1.1 -> abiword 3.0.1-6)

As soon as text is added, the cursor begins to blink unsteadily.
Also, Abiword then begins to use unusual amounts of CPU (not enormous, but a few percents). When minimized, there's no CPU-usage anymore.
When there's more text added, the whole documents starts to flicker, especially the background. This effect can be lessened by shrinking the Window, zooming in the document or setting focus on another window (so the cursor doesn't blink anymore).
The bigger the window and the more characters displayed, the more flickering and CPU-usage.

System: Intel i7-2670QM with integrated HD3000 Graphics.

William Geiger (whgiii-q) wrote :

I was reading some post on the Arch site and it seems compiling with GTK2 rather than GTK3 resolved the problem. I just build 3.0.1-7 package from source on my machine (using GTK3). The flickering issue seems to be down to just the cursor but I have some other build issues I need to look into.

FWIW the latest update is causing a conflict with libtidy on my system. Abiword want's the old libtidy-0.99-0 but the new libtidy5 (1:5.2.0-1) want's to have it's libs installed in the same place with the same name. As a temporary fix I uninstalled the old libtidy, installed the new libtidy5 and libtidy-dev. The only compile issue I ran into is ./configure looking for tidy/buffio.h wich is now tidy/tidybuffio.h. I just created buffio.h and linked it to tidybuffio.h. To get it to compile, do not know the consequences of doing so yet.

As I said before I have some other build issues I have to address, but I do have the program up and running, don't want to hijack this thread with it but if anyone is interested please contact me.

kozaki (tukozaki) wrote :

I confirm this issue on two Lubuntu 16.04 fresh installs. I could correct it.

First yesterday on a Core2 Duo laptop I installed the OS from the official lubuntu-16.04-i386 image.
As OP writes

> After adding some text in a new document, the *entire document* (including gray page background, text, text cursor) starts to flicker very fast. The UI above does not flicker.

Adding even a single letter has the whole content area to constantly flicker. We could reproduce this anytime launching Abiword.

Second occurence was today in a qemu-kvm VM with lubuntu that I freshly installed from Ubuntu mini/netinstall ISO.

- Opening an existing odt document has the header constantly flicker, i.e. the top 4 centimeters high banner.
- Opening Abiword (blank) and write any number of letter has the top 4 centimeters high part of the document constantly flicker.

Here is how I could correct this wrong behaviour:
- Launch lxappearance, in 'Widget' tab shift to any other one than 'Lubuntu-*', apply.
Abiword stops to flicker.

Thanks to William Geiger and Arch posters for bringing up the gtk3 settings.

Jeremy Bicha (jbicha) on 2016-06-29
description: updated
Jeremy Bicha (jbicha) wrote :

I can duplicate this bug easily by installing lubuntu-artwork and setting my gtk-theme to either of the 2 Lubuntu themes.

William, no I don't think abiword will be reverted back to gtk2 in Ubuntu.

Antony from #6 , Arch's 3.0.1-5 is just the 5th Arch version of Abiword 3.0.1; it's not the same as Debian or Ubuntu's 3.0.1-5.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-artwork (Ubuntu):
status: New → Confirmed
Changed in lubuntu-artwork (Ubuntu):
importance: Undecided → High
sudodus (nio-wiklund) wrote :

From the following post at the Ubuntu Forums, I conclude that it is a problem of the Lubuntu desktop environment.

http://ubuntuforums.org/showthread.php?t=2321942&p=13513792#post13513792

Quote Originally Posted by jrrpnani
"I have start session with Lxde desktop environment and the flicker issue does not happen. With Lubuntu desktop give me the graphic problem."

Interesting observation. I tried with a current (up to date) Lubuntu 16.04 LTS installed system.

Abiword flickers in a Lubuntu session.

But at the login screen I can also select Openbox (only the window manager, no fancy desktop environment).

Abiword does not flicker in an Openbox session.

The difference is very obvious and repeatable. I need not reboot, only log out, switch session (near the top right corner) and log into the other session.

Augustine Souza (aesouza2008) wrote :

I used the following command to test Abiword (3.0.1-6ubuntu0.16.04.1) in Lubuntu 16.04 (upgraded from 14.04 and fully updated) and in Lubuntu 16.04's Openbox session:

GTK_THEME=Theme_name abiword /usr/share/doc/abiword/copyright

The themes I tested were:
Adwaita (installed by default)
Adwaita:dark
Ambiance and Radiance (from the light-themes package)
Greybird and Numix (from the shimmer-themes package)
Lubuntu-default

In my system, both Lubuntu (LXDE + Openbox) and Openbox, only Adwaita and Adwaita:dark were flicker-free. With all the other themes listed above, there was an approximately 4 cm tall, screen-wide area that flickered shortly after the page loaded. The flickering did not affect the UI and didn't seem particularly related to the cursor.

My system is a Dell Inspiron 1545 laptop (Core2Duo, 4GB RAM, 64-bit, no GPU)

sudodus (nio-wiklund) wrote :

Augustine Souza alias vasa1 at the Ubuntu Forums found the workaroud:

*Change to the gtk theme Adwaita*

when it is available.

I found that several other themes work too without flickering (but not Lubuntu-default and Lubuntu-dark-panel).

Some of these themes render the text black in black background for marked text, others render the text dark but visible.

-o-

Workaround in a system directly from the current Lubuntu Xenial i386 iso file:

Start Abiword and edit a file. If it starts flickering, select

Menu -- Preferences -- Customize look and feel

- Select another theme alias 'widget style'

- Press the button 'Apply' and watch what happens in the Abiword window. Edit and do things to check how it works with this new theme, and stay with a theme that works for you.

For example the first one in the list, Clearlooks, works for me in a Toshiba laptop with Intel graphics from 2013,

http://www.toshiba.se/laptops/satellite-pro/c850/satellite-pro-c850-19w/

and in a desktop with nvidia graphics from 2008,

http://www.asus.com/Motherboards/M2NVM_DVI/

-o-

In Xubuntu Core, which runs the gtk theme Greybird by default, the cursor was flickering (no strips), and it was fixed by selecting the theme Adwaita, like by Augustine Souza in his upgraded Lubuntu system.

James Cameron (quozl) wrote :

Impacting OLPC.

Reproduced using Ubuntu 16.04 Xenial amd64 iso booted as live-image, plus universe, with abiword_3.0.1-6ubuntu0.16.04.1 from xenial-updates.

Workaround: switch from Ambiance to High Contrast theme.

Also affects package sugar-write-activity_97-5 which depends on package gir1.2-abiword-3.0 and thus libabiword-3.0. In my testing, the draw signal from Abi.Widget is constantly emitted by Gtk as soon as the first text is added to an empty document. The consequent Gdk redraws cause cursor and screen flicker, the severity of which scales with window size, graphics card, and CPU performance.

Related bug https://bugs.sugarlabs.org/ticket/4915 for abiword 3.0.1 on Fedora 24 combined with the Sugar Write activity.

So it would seem this is a problem introduced in Gtk or Abiword. I'm available to collaborate on this problem at depth. Contact <email address hidden>, thanks.

Changed in abiword:
importance: Unknown → High
status: Unknown → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1574278

tags: added: iso-testing
Sondra Kinsey (sondra.kinsey) wrote :

This effects both the version that ships with Lubuntu 16.04 (abiword 3.0.1-6), and the latest version in lubuntu repositories (abiword 3.0.1-6ubuntu0.16.04.1).

I would be happy to test improvements.

This bug renders Abiword unusable it is so distracting and nauseating to look at.

Confirming for Xenial (16.04.1),
Package version: 3.0.1-6ubuntu0.16.04.1

Changed in abiword:
status: Confirmed → Invalid
Julien Lavergne (gilir) wrote :

According to upstream bug, it's a gtk 3.18 bug which Abiword triggered. An update to 3.20 fix the issue, which is the case on yakkety. To fix the bug on 16.04, we have to find the correct gtk fix (which may not be that easy).

Changed in abiword (Ubuntu):
status: Confirmed → Invalid
Changed in lubuntu-artwork (Ubuntu):
status: Confirmed → Invalid
Changed in lubuntu-artwork (Ubuntu Xenial):
status: New → Invalid
Changed in gtk+3.0 (Ubuntu):
status: New → Fix Released
Changed in abiword (Ubuntu Xenial):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu Xenial):
status: New → Confirmed
Uwe Geuder (ubuntulp-ugeuder) wrote :

Using Xubuntu 16.04 with all updates here.

I can confirm both the original flickering and the effectiveness of the work-around "GTK_THEME=adwaita abiword".

Download full text (4.0 KiB)

Yes, but we can't force an app to use a custom theme, modifying all Ubuntu
distros as a workaround, instead of actually fixing the problem. Apps must
use any theme.

On Wed, 14 Sep 2016 23:51 Uwe Geuder, <email address hidden> wrote:

> Using Xubuntu 16.04 with all updates here.
>
> I can confirm both the original flickering and the effectiveness of the
> work-around "GTK_THEME=adwaita abiword".
>
> --
> You received this bug notification because you are a member of Lubuntu
> Packages Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1574278
>
> Title:
> AbiWord text cursor starts to flicker after adding some text
>
> Status in AbiWord:
> Invalid
> Status in abiword package in Ubuntu:
> Invalid
> Status in gtk+3.0 package in Ubuntu:
> Fix Released
> Status in lubuntu-artwork package in Ubuntu:
> Invalid
> Status in abiword source package in Xenial:
> Invalid
> Status in gtk+3.0 source package in Xenial:
> Confirmed
> Status in lubuntu-artwork source package in Xenial:
> Invalid
>
> Bug description:
> After adding some text in a new document, the entire document
> (including gray page background, text, text cursor) starts to flicker
> very fast. The UI above does not flicker. This happens too on a
> different system in VirtualBox. (Lubuntu 16.04 i386)
>
> Workaround
> ==========
> 1. Open the Lubuntu menu.
> 2. Open Preferences>Customize Look and Feel
> 3. Change the theme to something other than Lubuntu-default or
> Lubuntu-dark-panel
>
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.04
> Package: abiword 3.0.1-6
> ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
> Uname: Linux 4.4.0-21-generic i686
> ApportVersion: 2.20.1-0ubuntu2
> Architecture: i386
> CurrentDesktop: LXDE
> Date: Sun Apr 24 16:12:14 2016
> ExecutablePath: /usr/bin/abiword
> InstallationDate: Installed on 2016-04-22 (2 days ago)
> InstallationMedia: Lubuntu 15.10 "Wily Werewolf" - Release i386
> (20151021)
> ProcEnviron:
> LANGUAGE=de_DE
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SourcePackage: abiword
> UpgradeStatus: Upgraded to xenial on 2016-04-22 (2 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/abiword/+bug/1574278/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: product=abiword; status=Invalid; importance=High;
> assignee=None;
> Launchpad-Bug: distribution=ubuntu; sourcepackage=abiword;
> component=universe; status=Invalid; importance=High; assignee=None;
> Launchpad-Bug: distribution=ubuntu; sourcepackage=gtk+3.0; component=main;
> status=Fix Released; importance=Undecided; assignee=None;
> Launchpad-Bug: distribution=ubuntu; sourcepackage=lubuntu-artwork;
> component=universe; status=Invalid; importance=High; assignee=None;
> Launchpad-Bug: distribution=ubuntu; distroseries=xenial;
> sourcepackage=abiword; component=universe; status=Invalid;
> importance=Undecided; assignee=None;
> Launchpad-Bug: distribution=ubuntu; distroseries=xenial;
> sourcepackage=gtk+3.0; component=main; status=Confirmed;
> importance=Undecided; assignee=None;
> La...

Read more...

Uwe Geuder (ubuntulp-ugeuder) wrote :

I wrote:

  I can confirm [...] the effectiveness of the work-around "GTK_THEME=adwaita abiword".

With some more testing I have to qualify that statement a bit: With the adwaita theme the behaviour is clearly improved compared to the default. I have not seen text flickering so far. But the cursor still flickers a bit and sometimes disappears completely until some new text is entered.

James Cameron (quozl) wrote :

Uwe, do you have a method to reproduce flickering with the GTK_THEME=adwaita?

Even so, the workaround is a major improvement, and the best we have, so I'll add it to my OLPC derivative of the Ubuntu sugar-write-activity package. http://dev.laptop.org/~quozl/y/1bkIWb.txt

Changed in abiword:
status: Invalid → In Progress

add to grub, radeon.dpm=1, according to this link

https://help.ubuntu.com/community/RadeonDriver#Testing_the_driver
makes flickering slower but it does not stop.
GLX version 1.4 and AMD RV710

I changed grub as xorg used high cpu, when opening abi documents.

Jeremy Bicha (jbicha) wrote :

I'm reopening the Abiword task since there is apparently a flickering problem with abiword on Ubuntu 17.04 Alpha (using GTK 3.22) and one of the developers pointed back to this bug.

http://bugzilla.abisource.com/show_bug.cgi?id=13815#c24

Changed in abiword (Ubuntu):
status: Invalid → Confirmed
tags: added: zesty
Changed in abiword (Ubuntu Xenial):
status: Invalid → Confirmed
importance: Undecided → High
description: updated
Brian (thwaller) wrote :

I am running Ubuntu Zesty 17.04 and have this flickering issue. The above fix of changing the theme does nothing to correct the issue. I was using 16.10 prior and did not have this problem. Only after the upgrade did this start to happen. Is there any update on a possible fix for this?

James Cameron (quozl) wrote :

G'day Brian! Yes, the theme workaround began not working for me with 17.04. Yes, the problem can come and go with any changes to the hardware, kernel, X server, or libraries. There is a fix that makes the situation a lot better, see my post last week on the upstream bug https://bugzilla.abisource.com/show_bug.cgi?id=13791#c46 (attachment 5839).

Brian (thwaller) wrote :

thank you James. I will have a look.

Brian (thwaller) wrote :

@James- I am sorry, but could you provide a bit of direction on applying that fix? I understand the + and - aspect, but unsure of where/how to apply that. My install was just done through package manager, I wonder if this fix needs to be compiled in?

James Cameron (quozl) wrote :

G'day Brian. Yes, it needs to be compiled in. Download the Ubuntu source package, apply the patch, build the package, then install it. If you've not done that before, you may find it quite complicated. You might enable deb-src entries in your /etc/apt/sources.list file, then "apt-get update", then "apt-get source abiword", then apply the patch, then install build dependencies with "apt-get build-dep abiword", then build with "dpkg-buildpackage", then install with "dpkg -i". There are different ways to do all this, but that's the simplest I can think of. Sorry, I didn't keep the result.

Brian (thwaller) wrote :

@James- Thanks, I can do the compile and build easy enough. Only question I have then is for the patch, is there an automated way to apply it to the file? I do not have experience in applying changes in this manner, but I can always just change the code. Just hoping to learn more here so I can participate better in the future.

James Cameron (quozl) wrote :

G'day Brian. The patch command automatically applies a patch to a set of files. The particular patch has a sacrificial path element so the --strip 1 option should be used. The --dry-run option is also useful for testing. So it would be "patch --strip 1 --dry-run < file.patch", where file.patch is what was downloaded from the upstream bug report. If that works, repeat again without the --dry-run.

Brian (thwaller) wrote :

@James- Thanks for all the help. I went through the steps and in the end, nothing was any different. I was at least able to learn some of the steps used here which I really appreciate. I did not see anything too unusual... there was an error on not being able to sign in the end and many warnings throughout (ex. depreciated items, defined but not used variables, etc), but the build did finish and I was able to verify that the patch applied to the proper file. My guess is either something was not right or my experience is just too limited resulting in user error somewhere.

Let me know if and when there are any other options. Thanks again, I really do appreciate what I have learned in the process with your direction.

James Cameron (quozl) wrote :

G'day Brian. Good to hear. For local testing, the signing can be
ignored; there's an option to skip it. The warnings sound familiar,
but are normal. For me, the patch did fix the flickering of the whole
screen, but did not fix the flickering cursor. Guess next steps
upstream involve reproducing and debugging in depth to find out why
the flickering happens.

Henk Terhell (hterhell) wrote :

I have experienced that Abiword cannot be used on plain Debian Stretch, Lubuntu 17.04 and Xubuntu 17.04, all using gtk-3.22. Heavy flickering or moving of paper borders occurs, which stops, together with disappearing cursor, after about 8 seconds without activity. Changing the theme does not have any effect.

Brian (thwaller) wrote :

Maybe I did not mess it up then. I would agree that the warnings I saw were all non-critical, and it did complete. I am using MATE 17.04 64 bit., gtk 3.22 and is about exactly as Henk explains above. I can also confirm that changing the theme makes no difference for me, and I believe now that the patch is not effective either. I was using 16.10 prior to the upgrade and all worked fine.

Sondra Kinsey (sondra.kinsey) wrote :

I experienced this bug in Lubuntu 16.04, and found it made Abiword unusable. I recently installed Lubuntu 17.04 on a different computer and was disappointed to discover the bug is still present with my fresh installation!

That said, I'm not 100% sure my bug is the same as what is reported here. Above, and at the following places, is described the whole screen flickering when document not empty
- https://www.youtube.com/watch?v=r1lPas9-DuQ&feature=youtu.be
- https://bugzilla.abisource.com/show_bug.cgi?id=13791
- https://bugs.sugarlabs.org/ticket/4915

However, my experience is that Abiword flashes from the top edge of the background (below the ruler) to about an inch into the page on the top, and from the left edge of the background to an eigth of an inch into the page on the left. When I zoom in or out on the document, the same area of the screen flickers. This happens even on an empty document.

I think this is the same problem
- https://askubuntu.com/questions/818219/abiword-documents-borders-keeps-flashing

I tried this:
  for i in `ls /usr/share/themes`; do echo $i; GTK_THEME="$i" abiword; done
It was the same for every theme, including Adwaita.

Any hope for a fix?

Henk Terhell (hterhell) wrote :

Your observation on the visual effects is likely the same as mine which I reported as bug #1649001. However this was considered as a duplicate of #1574278.
Focuswriter or LibreOffice Writer can be installed as suitable alternatives.

Henk Terhell (hterhell) wrote :

Note the flashing/flickering effect in the YouTube video "Lubuntu 17.10 Alpha 2 Stable As Ever" at 3'44".
https://youtu.be/3tKVjBCA_Nw

Mikhail N (mikhailnov) wrote :

Confirm the bug with the dafault Xubuntu theme.
$ env GTK_THEME=Abiword
solves the problem, no more flickering

James Cameron (quozl) wrote :

> GTK_THEME=Abiword solves the problem, no more flickering

Does not solve for me on Artful 17.10.

Henk Terhell (hterhell) wrote :

> GTK_THEME=Abiword solves the problem, no more flickering

Also for me it did not solve the problem on Lubuntu Artful 17.10.

oscar (opolofdez) wrote :

Used the same test that Sondra on #43 and also with no luck on any theme

Lubuntu 17.04

James Cameron (quozl) wrote :

Thanks for the bump, I'd forgotten to update this bug.

I found the cause of the problem and fixed it for systems using Xorg. It was a race condition, and is affected by speed of computer, speed of graphics, other processes, and theme drawing. That's why it may not happen for some people. You can find my patch in the upstream bug report https://bugzilla.abisource.com/show_bug.cgi?id=13791 and my summary at Sugar Labs https://bugs.sugarlabs.org/ticket/4915

I'll be shipping the fix on the laptops we make at One Laptop per Child.

However, my fix was not tested on Wayland and caused AbiWord to fail differently under Wayland, and upstream (correctly) refused to accept the patch as is, and nobody seems to have done anything since.

I'm not using Wayland, and I'm not paid to support Wayland, so I'm unable to easily work further on the problem.

But if any of you really need it to work using Xorg (e.g. Lubuntu), my patch should be fine, and I'm happy to explain what the problem was in detail.

Upstream would obviously benefit from someone who can program C++ with GTK+ on both Xorg and Wayland. If this is you, please offer to help them. It has been almost two years since this problem first began, and it is slowly but surely destroying the usability of AbiWord. Sad to see the old girl go.

Simon Quigley (tsimonq2) on 2017-09-25
Changed in abiword (Ubuntu Xenial):
assignee: nobody → Simon Quigley (tsimonq2)
status: Confirmed → In Progress
Simon Quigley (tsimonq2) wrote :

Since Wayland is not supported by Lubuntu, the only flavor that ships it by default, and stock Ubuntu has their own replacement, I'm willing to have this fix in Ubuntu.

I uploaded a fix to ppa:tsimonq2/universe-upload-testing. It would be great if someone could test it and if it works, I'll upload it.

Here's the diff: https://launchpadlibrarian.net/338474460/abiword_3.0.2-3_3.0.2-3ubuntu1~ppa1.diff.gz

James Cameron (quozl) wrote :

Thanks. Reviewed abiword_3.0.2-3_3.0.2-3ubuntu1~ppa1.diff.gz ... looks right to me.

Simon Quigley (tsimonq2) wrote :

Ok, did you get a chance to test it or did you just review the diff?

James Cameron (quozl) wrote :

Sorry Simon, I had already tested my patch with my own local package, I didn't think you'd need me to test your package of it, and I'm hoping to hear if anybody else has tested it. ;-)

On a 17.10 Artful VM with Sugar, the Sugar desktop does not appear, some other problem, so I'm not able to test there yet.

On a 17.04 Zesty VM with Sugar, installed your libabiword-3.0_3.0.2-3ubuntu1~ppa1_amd64.deb and the flickering problem has gone. So your package works for me there.

Any chance of a 16.04 Xenial update? A "gir1.2-abi-3.0 breaks gir1.2-abiword-3.0" problem occurs, easily explained.

Simon Quigley (tsimonq2) on 2017-09-30
no longer affects: lubuntu-artwork (Ubuntu)
no longer affects: gtk+3.0 (Ubuntu)
no longer affects: gtk+3.0 (Ubuntu Xenial)
no longer affects: lubuntu-artwork (Ubuntu Xenial)
Changed in abiword (Ubuntu Zesty):
importance: Undecided → High
Changed in abiword (Ubuntu Artful):
status: Confirmed → In Progress
Changed in abiword (Ubuntu Zesty):
status: New → Confirmed
Changed in abiword (Ubuntu Xenial):
status: In Progress → Confirmed
Changed in abiword (Ubuntu Artful):
assignee: nobody → Simon Quigley (tsimonq2)
Changed in abiword (Ubuntu Zesty):
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

Uploaded to Artful, I can confirm it fixes the problem. I'll upload packages to test this in my PPA before Monday.

Changed in abiword (Ubuntu Artful):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.2-3ubuntu1

---------------
abiword (3.0.2-3ubuntu1) artful; urgency=high

  * Fix flickering (LP: #1574278).

 -- Simon Quigley <email address hidden> Sun, 24 Sep 2017 20:52:22 -0500

Changed in abiword (Ubuntu Artful):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-10-01
Changed in abiword (Ubuntu Xenial):
status: Confirmed → Triaged
Changed in abiword (Ubuntu Zesty):
status: Confirmed → Triaged
Changed in abiword (Debian):
status: Unknown → Fix Released
Jeremy Bicha (jbicha) on 2017-10-02
no longer affects: abiword (Ubuntu Artful)
sudodus (nio-wiklund) wrote :

Thanks for squashing this bug :-)

Henk Terhell (hterhell) wrote :

Also I can confirm this annoying flashing has gone on Lubuntu 17.10.
Great!

oscar (opolofdez) wrote :

Hi, any chance to see this patch applied on Zeisty?

Thanks in advance

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.