Sticky keys disabled when pressed twice

Reported by cerasus.k@gmail.com on 2012-05-13
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Ubuntu 12.04, 32 bit

When pressing a modifier once (ALT, SHIFT, CTRL, etc) it sticks for the next keypress. This is normal behavior. However, if pressed twice it should stick untill pressed a third time (this allows to simulate holding it down). Instead, when pressed twice the modifier gets "released".

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/998877/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Please check that the option "disable if key pressed twice" is not enabled, If that does not solve your problem please let us know

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in ubuntu:
status: New → Invalid
cerasus.k@gmail.com (cerasus-k) wrote :

No, checking that option does nothing, since it affects the case where two _different_ keys are pressed simulataneously. What Im experiencing is that the same modifier key get deaktivated if pressed twice. An example: if I press Shift once and type several letters the first letter is uppercase: Aaaaa. If I press Shift twice and type several letters; what should happen is _all_ letters be uppercase. What happens instead is this: aaaaa. No letter is uppercase, because Shift got "unpressed"/"unstuck". Same behavior with all modifier keys (Shift, Ctrl, Alt, Win, Alt Gr).

And I would strongly argue that this _is_ a bug and a (big) problem, because all previous versions of Ubuntu and others OSs (inluding Windows) had/have the correct behavior of sticky keys: press once → stick for next keystroke, press twice → stick "forever", press third time → unstick.

I asked a friend to test this on his installation of 12.04, and he had the same, incorrect behavior.

I hope I was able to clarify my point. Please do not mark this report as invalid, because this bug renders 12.04 useless for someone who needs sticky keys (including me). Im sorry for the poor wording in the title.

Changed in ubuntu:
status: Invalid → Incomplete

It is definitely a bug. Today I've upgraded my Ubuntu to 12.04 and sticky keys stopped working as expected - pressed twice unlocks key instead of locking it until third click. Without sticky keys working properly using Ubuntu for people with disabilities became difficult.

Changed in ubuntu:
status: Incomplete → New
cerasus.k@gmail.com (cerasus-k) wrote :

Thank you, Filip, for confirming. Unfortunatly, I do not know where to look (in which package), otherwise I could look into the responsible code and maybe come up with a patch myself. Can anyone give me a hint?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Steven Edwards (cureadvocate) wrote :

cerasus-k: check the xkbset package. If not there, it may be a bug in Wayland's X client.

I upgraded today and was very disappointed.

Steven Edwards (cureadvocate) wrote :

Did sticky keys work properly in 11.10?

yes, in all previous versions they worked properly

Steven Edwards (cureadvocate) wrote :

Argh! We'll have to see what's changed, then. Is there a site to search through all of 12.04's source code?

Steven Edwards (cureadvocate) wrote :

12.04 has a libx11-doc package that contains documentation for libx11-dev, which controls the accessibility features. I think this is the relevant section:

http://www.x.org/releases/current/doc/libX11/XKB/xkblib.html#Keyboard_State

Steven Edwards (cureadvocate) wrote :

Fails in Kubuntu as well. :/

Thomas Lindroth (thomas-8472) wrote :

and in Xubuntu

Steven Edwards (cureadvocate) wrote :

The bug is definitely in Xorg/xserver--it exists across multiple distributions, including Fedora. OpenSUSE 12.1 is the newest I can find that works--if only because uses 7.6; Ubuntu 12.04 uses 7.7.

The change HAD to occur between tags 1.10.4 and 1.11.3 in the git repo, but I can't pin it down.

John Fox (sirjohndfox) wrote :

This is happening in Wheezy too, it's drive me crazy... any luck yet? is it an xkbset problem?

Same bug in Ubuntu 12.10 as well

Anyone had any luck yet? I, too, tried browsing through X's source code, but still no progress. Any hints?

I have not seen any movement on this bug.

On Monday, December 2, 2013 4:26 AM, "<email address hidden>" <email address hidden> wrote:

Anyone had any luck yet? I, too, tried browsing through X's source code,
but still no progress. Any hints?

--
You received this bug notification because you are subscribed to a
duplicate bug report (993915).
https://bugs.launchpad.net/bugs/998877

Title:
  Sticky keys disabled when pressed twice

Status in X.Org X server:
  New
Status in Ubuntu:
  Confirmed

Bug description:
  Ubuntu 12.04, 32 bit

  When pressing a modifier once  (ALT, SHIFT, CTRL, etc) it sticks for
  the next keypress. This is normal behavior. However, if pressed twice
  it should stick untill pressed a third time (this allows to simulate
  holding  it down). Instead, when pressed twice the modifier gets
  "released".

To manage notifications about this bug go to:
https://bugs.launchpad.net/xorg-server/+bug/998877/+subscriptions

Steven Edwards (cureadvocate) wrote :

The bug still exists in Debian Jessie, too. I plan on dedicating some time to fixing this bug later this week.

Steven: Maybe we could join "resources"?

Steven Edwards (cureadvocate) wrote :

cerasus: tell me what you have in mind.

I have sent requests to both the xorg and wayland development mailing lists asking for help, but nobody has offered to point me in the right direction.

I used distrowatch to narrow the bug's source down to between versions 1.10.6 and 1.11.1. If I knew how to build X and a simple X cient (e.g., Xterm), I might be able to use git bisect to find the exact commit that introduced the bug. Once I locate the source of the error, it should be fairly simple to fix it.

Steven Edwards (cureadvocate) wrote :

Debian's xterm git repo:

git://anonscm.debian.org/pkg-xorg/app/xterm

Debian's xorg git repo:

git://git.debian.org/git/pkg-xorg/debian/xorg

Who knows? Maybe it'll be easier now that I have both git repos? :)

I have some commitments I need to complete before Sunday (hopefully before Saturday), but if I have time, I'll see what I can figure out. (It's possible that all we need to do is build and install Squeeze's version of xorg, 1:7.6+8~bpo60+1, in Wheezy... but that seems way too easy.)

Today I live-booted an image of Ubuntu 14.04 and the sticky keys worked correctly. Going to install it today/next days and try it out. Can anyone confirm?

Steven Edwards (cureadvocate) wrote :

Confirmed in VirtualBox.

Careful with VirtualBox because the guest OS seems to "use" the sticky keys
of the host OS, as the key signals seem to be handled by the host OS first.
But with live-boot the sticky key work on previous versions, and they
suddendly do with 14.04, so I'm hopeful

2014-04-02 22:33 GMT+02:00 Steven Edwards <email address hidden>:

> Confirmed in VirtualBox.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/998877
>
> Title:
> Sticky keys disabled when pressed twice
>
> Status in X.Org X server:
> New
> Status in Ubuntu:
> Confirmed
>
> Bug description:
> Ubuntu 12.04, 32 bit
>
> When pressing a modifier once (ALT, SHIFT, CTRL, etc) it sticks for
> the next keypress. This is normal behavior. However, if pressed twice
> it should stick untill pressed a third time (this allows to simulate
> holding it down). Instead, when pressed twice the modifier gets
> "released".
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xorg-server/+bug/998877/+subscriptions
>

Did not. I meant the sticky keys did not work with previous versions, with
live-boot

2014-04-02 22:59 GMT+02:00 Evgeni Bykarskij <email address hidden>:

> Careful with VirtualBox because the guest OS seems to "use" the sticky
> keys of the host OS, as the key signals seem to be handled by the host OS
> first. But with live-boot the sticky key work on previous versions, and
> they suddendly do with 14.04, so I'm hopeful
>
>
> 2014-04-02 22:33 GMT+02:00 Steven Edwards <email address hidden>:
>
> Confirmed in VirtualBox.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/998877
>>
>> Title:
>> Sticky keys disabled when pressed twice
>>
>> Status in X.Org X server:
>> New
>> Status in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> Ubuntu 12.04, 32 bit
>>
>> When pressing a modifier once (ALT, SHIFT, CTRL, etc) it sticks for
>> the next keypress. This is normal behavior. However, if pressed twice
>> it should stick untill pressed a third time (this allows to simulate
>> holding it down). Instead, when pressed twice the modifier gets
>> "released".
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/xorg-server/+bug/998877/+subscriptions
>>
>
>

Steven Edwards (cureadvocate) wrote :

StickyKeys failed for me when using Ubuntu 12.04-13.10 in Virtualbox, so that's odd.

The fix appears to have come in xorg-server 1.15.0:

http://distrowatch.com/search.php?pkg=xorg-server&pkgver=1.15.0#pkgsearch

...I'm going to try Arch in VirtualBox tomorrow.

Ok. For me the sticky keys worked on 13.10 when running in VirtualBox on
Win 7 with sticky keys enabled. I even cheered up and thought it was fixed
untill I live bootet it...

2014-04-03 2:40 GMT+02:00 Steven Edwards <email address hidden>:

> StickyKeys failed for me when using Ubuntu 12.04-13.10 in Virtualbox, so
> that's odd.
>
> The fix appears to have come in xorg-server 1.15.0:
>
> http://distrowatch.com/search.php?pkg=xorg-
> server&pkgver=1.15.0#pkgsearch
>
> ...I'm going to try Arch in VirtualBox tomorrow.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/998877
>
> Title:
> Sticky keys disabled when pressed twice
>
> Status in X.Org X server:
> New
> Status in Ubuntu:
> Confirmed
>
> Bug description:
> Ubuntu 12.04, 32 bit
>
> When pressing a modifier once (ALT, SHIFT, CTRL, etc) it sticks for
> the next keypress. This is normal behavior. However, if pressed twice
> it should stick untill pressed a third time (this allows to simulate
> holding it down). Instead, when pressed twice the modifier gets
> "released".
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xorg-server/+bug/998877/+subscriptions
>

Ok, I now can confirm that the sticky keys do work in a full installation
of Ubuntu 14.04, 64 bit. From my side, the bug can be closed now.

2014-04-03 8:41 GMT+02:00 Evgeni Bykarskij <email address hidden>:

> Ok. For me the sticky keys worked on 13.10 when running in VirtualBox on
> Win 7 with sticky keys enabled. I even cheered up and thought it was fixed
> untill I live bootet it...
>
>
>
> 2014-04-03 2:40 GMT+02:00 Steven Edwards <email address hidden>:
>
> StickyKeys failed for me when using Ubuntu 12.04-13.10 in Virtualbox, so
>> that's odd.
>>
>> The fix appears to have come in xorg-server 1.15.0:
>>
>> http://distrowatch.com/search.php?pkg=xorg-
>> server&pkgver=1.15.0#pkgsearch
>>
>> ...I'm going to try Arch in VirtualBox tomorrow.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/998877
>>
>> Title:
>> Sticky keys disabled when pressed twice
>>
>> Status in X.Org X server:
>> New
>> Status in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> Ubuntu 12.04, 32 bit
>>
>> When pressing a modifier once (ALT, SHIFT, CTRL, etc) it sticks for
>> the next keypress. This is normal behavior. However, if pressed twice
>> it should stick untill pressed a third time (this allows to simulate
>> holding it down). Instead, when pressed twice the modifier gets
>> "released".
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/xorg-server/+bug/998877/+subscriptions
>>
>
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers