10.10 can't mount squashfs file system

Bug #636711 reported by Harrison on 2010-09-12
152
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I think I found a bug on my HP Pavilion DV1000 laptop with 10.10 beta. I boot off the live cd and it starts fine until it says the following: (note: this is read from one computer and typed on another so there may be typos)

BusyBox v1.15.3 (Ubuntu 1:1.15.3-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built in commands.

(initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: input/output error
Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs
udevd[74]: worker [395] failed while handling '/devices/virtual/block/loop0'

That is it. If this is a bug and who ever needs more info I am glad to do so.

Harrison

Harrison (harrbis) on 2010-09-13
description: updated
Monkey (monkey-libre) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. While we appreciate the difficulties you are facing, it would appear that the CD image (ISO file) you downloaded could be corrupt. There is an easy way to verify the integrity of the Ubuntu ISO files you download. Could you please visit https://help.ubuntu.com/community/HowToMD5SUM follow the instructions and report back as to whether or not the MD5SUM verified? Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
Harrison (harrbis) wrote :

I checked the MD5Sum and it is a match with the one on the download servers. In other words it is not corrupt.

I am re-burning the cd to see if it is a burning problem.

Harrison

Harrison (harrbis) wrote :

I re-burned the cd and it gives me the same problem.

Any other ideas?

Domar (domar) wrote :

I have the same problem with the final release of 10.10!

I think, thats my suggestion, that it could be my dvd-rw that is the problem.
Maybe there is no support for rewritable dvds?

I burn it on a normal cd but it's late, I'll report this in about 16 hours^^

Harrison (harrbis) wrote :

I tried the RC and it worked perfectly, still have to try the final release.

Something must have happened between the beta and RC.

Harrison

Jeff Lambert (jl-newtraxtech) wrote :

Same problem here and it is very annoying. Trying to install 10.10 final from i386-desktop. Removed all accessories on laptop (Dell D830 that runs 10.04)

Somebody suggested I download the DVD version instead, but that's heavy bandwidth for me
http://mirror.mcs.anl.gov/pub/ubuntu-iso/DVDs/ubuntu/10.10/release/

Domar (domar) wrote :

I just burned the image to a normal cd and it works.
The md5 of the cd and the dvd-rw are the same....

I got the same problem (with kubuntu 10.10 for my amd64)

          BusyBox v1.15.3 (Ubuntu 1:1.15.3-1ubuntu4) built-in shell (ash)7
          Enter 'help' for a list of built in commands.

          (initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: input/output error
          Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs
          udevd[74]: worker [395] failed while handling '/devices/virtual/block/loop0'

But I just reburn the same iso image with another PC and another CD and this time it works for me.

Nicolas Breton (nibr) wrote :

I have the same problem with a number of different configurations: 3 computers running 10.04, 3 different CD-RW burnt with the desktop 10.10 i386 iso downloaded twice, and one with the 10.04.1 i386 iso. Also tried burning on two different computers (just in case it was the CD burner that was bad). No idea what is happening but it is really annoying!!!

I'm currently downloading the DVD iso to see if it fixes the problem... will try it tomorrow. I'll also try burning on a standard (non re-writeable CD) and maybe also burning using a Windows box.

I'm a bit surprised to get this problem on so many configurations without having tons of people complaining.

Nicolas Breton (nibr) wrote :

Ohh, I forgot, yes I've checked the MD5 checksums on the iso:s

Cruster (panoskoutsias) wrote :

I confirm that the problem is connected to rewritable media. Even the CD iso burnt on a normal DVD works fine.

guardsman85 (guardsman85) wrote :

Respectfully disagree with rewriteable media notion. Having problems on CD-R's myself.

Nicolas Breton (nibr) wrote :

Changing from a CD-RW to a CD-R fixed the problem for me on two machines out of three

Mark (markjb) wrote :

I have the same issue. I was booting off the ISO in Sun Virtualbox.

Paven (lunchpad-com) wrote :

I have the same problem with my noname pc- with a assus motheboard, amd processor.

Im also having the same problem with my noname pc with asus motherboard and intel core quad processor.

This bug is also happening to me with two different machines when I try to install from the DVD. The CD release works fine.

Really. Very frustrated.
This is just unbelievable.
I grabbed the 'ubuntu-10.10-desktop-i386.iso' from the main server and tried to install some ways. All failed.
First, I installed using Wubi, got the same error when rebooting. Failed.
Then, I used both Unetbootin and Universal-USB-Installer to create a LiveUSB, got the same error. Failed.
Lastly, I desperately fetch the ISO into VirtualBox to check and it was just the same error. Failed.
All failed.
This is just unbelievable, I repeat. (The last one is the most unbelievable, IMO.)
Maybe I should try burning a actual CD ? But I think it's unnecessary and would be just waste/
Btw, I checked the MD5 sum and got match one.
Now I begin to think of the problem of the originally first ISO they ever spreaded out.

Paul Kenyon (rixoff) wrote :

I have this problem too. I'm trying to use Ubuntu Desktop 10.10 release on a CD-RW, trying to install in a KVM. Frustrating!

Rik Smoody (ubuntu-smoo) wrote :

I'm also seeing this problem on an HP Pavillion tower using CD-R

Rik Smoody (ubuntu-smoo) wrote :

I had checked the sums.
And the same disk seems to work when plugged into a different machine.
(I didn't install there, but it was ready to do so)

RJ Moore (urgemore) wrote :

Just tossing in a 'me, too' here. I'm trying to install on an IBM/Lenovo R61. I get the error whether I'm trying to install from a CD or a USB stick.

atomicmind (atomicmind) wrote :

i am getting the same error on a live usb stick (Toshiba) on a Dell mini 9v
...obviously i'll not get back to ubuntu soon...

I got this error trying to install Xubuntu 10.10 on an IBM X40 from a CD-RW disc. Kubuntu 10.10 worked fine.

unmanbearpig (itsrealmailbox) wrote :

I have the same problem with virtualbox

Jonathan Watt (jwatt) wrote :

This also affects me on my Thinkpad T410. I'm using the 10.10 DVD.

This bug has been reported for several major versions now. Given that it's a showstopper, shouldn't this be given high priority?

Jonathan Watt (jwatt) wrote :

Ah! While the 10.10 DVD ISO doesn't work, the 10.10 CD ISO - burnt to the EXACT same blank media - does!

Jeff Lambert (jl-newtraxtech) wrote :

Goodbye Ubuntu! I'm sick of wasting my time with this bug.
No matter WHAT I try, CD, DVD, USB, always this bug. 10.04 worked perfectly but so did WinXP.

Tom (thomasmca) wrote :

I get the same error booting 10.10 from USB on a new Dell M6500 laptop.

mikel (mikelpierre) wrote :

Same problem here.

Using Acer Aspire One. I've checked the md4sum and tried UNetbootin and USB Universal installer.

Tom (thomasmca) wrote :

> I get the same error booting 10.10 from USB on a new
> Dell M6500 laptop.

I got this to work by using a different thumb/flash drive -
Lexar JumpDrive failed, DaneElec drive worked.

dbclinton (dbclin) wrote :

And here are my two cents: I've tried to install the 10.10 desktop i386 iso (md5 checked out fine) on a Compaq Evo desktop using a CD and then two separate USB drives (trying on at least three separate USB ports) with no success. Each time I ended up in initramfs with messages like
mount: mounting /dev/loop0 on /filesystem.squashfs failed: input/output error
Is there any progress on this one?

Meridianox (meridianox) wrote :

I'm also getting the same problem.

I'm installing on an Acer Aspire One netbook. I'm using the ubuntu-10.10-netbook-i386.iso (works fine, burned to disc and installed on another computer). I'm installing it via USB flash drive, I tried using both Universal-USB-Installer and UNetbootin to prepare the USB drive. I also used more than one USB flash drive to test.

So far, I haven't been able to get any success.

Jouva Moufette (jouva) wrote :

I'm going to throw in my 0.025 USD here:

When attempting to use the .iso in Universal USB Installer, it extracts all files from the .iso via 7-Zip. When it does this, it claims "Data error in 'casper\filesystem.squashfs': File is broken"

Methinks the .iso(s) need(s) to be remade.

Richard Lord (richard-bigroom) wrote :

I get exactly the same problem as Jouva when using the Universal USB Installer

Me too.
On Dell Studio Laptop,
ISO image ubuntu-10.10-desktop-i386.iso downloaded from Bittorent,
with CD-R burnt with Brasero.

I'll try downloading the DVD version as suggested here, but it would make me happy to know if anyone is working on this bug?

Paul Kenyon (rixoff) on 2010-12-04
Changed in ubuntu:
status: Incomplete → Confirmed

This may be helpful. I've got two nearly identical Compaq Evo desktops
at the office. One loaded 10.10 flawlessly from the usb and the other
one died on the squashfs file system mount (using the very same usb).
Since they're so similar, the differences might be important. I've
uploaded the lshw output from both machines here (the machine which
failed to load 10.10 is running 8.10):

http://www.ncf.ca/~es625/usb_install_non_working_compaq

and here:

http://web.ncf.ca/~es625/usb_install_working_compaq

Maybe someone can figure out what's going on.

One difference that could be a factor is in the video driver:

Bad machine:
     *-pci
          description: Host bridge
          product: 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub
Interface
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 01
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel module=intel_agp <=
     *-display UNCLAIMED <=

Good machine:
    *-pci
          description: Host bridge
          product: 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub
Interface
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 01
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel <=
          resources: irq:0 memory:f8000000-fbffffff <=
      *-display <=

carlos thee G (caryo1991) wrote :

what is a CR? i tried with a cd but it gave me this:

. : [ alias break cd chdir command continue echo eval exec exit export false getopts hash help let local printf pwd read readonly return set shift source test times trap true type ulimit umask unalias unset wait [ [[ ash awk basename cat chmod chroot chvt clear cmp cp cut deallocvt df dnsdomainname du dumpkmap echo egrep env expr false fbset fdflush fgrep find grep gunzip gzip hostname ifconfig ip kill ln loadfont loadkmap ls mkdir mkfifo mknod mkswap mktemp more mount mv openvt pidof printf ps pwd readlink reset rm rmdir sed setkeycodes sh sleep sort stat static-sh stty sync tail tee test touch tr true tty unmount uname unip wc wget yes zcat

 (initramfs)

what shall I do. i want to install ubuntu no matter what but it gives me this error. Ive also confirmed that I downloaded the cd perfectly....

DOES Any1 knows how to fix this?? help me please!!!!

rjr162 (ronrossman) wrote :

I'd just like to toss in this just happened to me too.

I decided to take my hackintosh back to Ubuntu. Decided to give 10.10 a try, but get the same error as everyone else after the first screen comes up. I've never had issues with my Dell inspiron e1505 before with any version of Ubuntu (other than the broadcom wireless which I had switched in the past for an intel wireless card). I'm using the 32-bit CD image burned to a CD-R.

I just burned another copy to another disc to see how it works, and also burning 10.04 to make sure it still installs just like it use to

rjr162 (ronrossman) wrote :

Ha, just checked the MD5, and yup, it's different than that listed on the website.. time to download again *groan*

Jouva Moufette (jouva) wrote :

Yeah FYI if you're getting this, do try downloading again from a different mirror. That fixed this for me. I think the MD5s on the mirrors are what are incorrect.

Stanislav Valasek (valasek) wrote :

The same behavior for HP 620 and CD ISO burnt on CD RW drive..

IKT (ikt) wrote :

Stanislav Valasek, where you able to confirm that the MD5 was the same as the one listed on the ubuntu website?

IKT (ikt) on 2011-03-19
Changed in ubuntu:
status: Confirmed → Incomplete

Same error here

- ubuntu-10.10-desktop-i386.iso image,
- md5 checksum ok,
- burnt on a CD-R (thru a cd-dvd drive) using infraRecorder (burnt at slowest available speed)

Trying to install on a brand new packard-bell iMedia A4021FR (dvd-cd drive too).

Attachments: casper.log and dmesg output

and here comes the dmesg output

Joe Millenbach (jmillenbach) wrote :

I hit this on a box I built myself. The same media has worked on two other systems so I trust it. I tried using it a few different times and tried to add a boot parameter of "all_generic_ide" at the suggestion from a Linux Mint bug I found by Google'ing for the text. Only got around it by installing from a USB stick.

Intel P67 chipset (SandyBridge) using an Intel 3GB SATA port, not one of the 3rd party ports or 6GB SATA ports, for an "HL-DT-ST BDDVDRW GGC-H20L ATA Device". Combo HDDVD/Blu-ray drive. BIOS is set to AHCI for SATA ports. CD-R disc.

Tried booting as AHCI and UEFI to the drive in my BIOS. No difference.

E Cheddar (echeddar) wrote :

I was having the same error with unetbootin, and oddly enough, fixed it by reformatting my flash drive. I had previously formatted with the default settings using quick format in windows 7. This time, I used FAT32, but changed the File Allocation Units to 2xxx (I forget, 2048? whatever the 2-thousand-ish option was--it was the smallest option) and I also unchecked the quick format checkbox. Now it works, go figure. Using Unetbootin on a generic 8gb flash drive for Linux Mint 10 KDE.

Add me to the list that have this problem.
My target is a Thinkpad T42.
The internal DVD/CD fails. A USB-connected DVD/CD fails too.
Both complain about the /dev/loop0 mount failure.

Yes all checksums are fine.

MillenniumBug (millenniumbug) wrote :

I guess it is safe to say that this bug is confirmed :-)
Several posters have done the MD5 check.

Changed in ubuntu:
status: Incomplete → Confirmed
Zach Westfall (zwestfall) wrote :

I get this bug (Can not mount /dev/loop0) only when I have a USB drive connected. If I remove the USB drive and reboot, everything works. Using DVD with Ubuntu Rescue Remix 10.10.

beer (jonas-vejlin) wrote :

I have the same problem with kubuntu 11.04 64 bit and ubuntu 11.04 64 bit

Dngrsone (dngrsone) wrote :

I have this problem with ubuntu-11.04-desktop-amd64.iso and ubuntu-11.04-desktop-i386.iso downloaded from both the main site and torrent.

MD5 checksums match. Content burned to CD-R using Brasero through Ubuntu 10.4-desktop-amd64 on an HP Pavilion DV4 (DV4-1200US) which is what I was trying to load the live disc on.

With both Operating Systems the live OS could not be loaded and the CDROM won't read afterword-- I have to eject the CD and reinsert it (or completely turn off the laptop) if I want to try booting off the CD again.

NullZer0 (nullzero-free) wrote :

- ubuntu-11.04-desktop-i386.iso , download from main site
- MD5 checksums match.
- write iso file to USB Kingston
- both Startup Disk Creator and Universal-USB-Installer failed

Ryan Caley (ryan-caley) wrote :

I would like to give some information. I initially made a live CD on a CD-RW, and it didn't work or even mount. I remade a live CD on a CD-R, and it did work, with all the files showing on the disk and everything. I found that the MD5 checksums match, so there is no problem there.

Now, I have a Dell, and I initially just chose to boot from the CD on the startup screen. It goes through the boot process for a bit, and then ends up with two different sets of messages so far. One of them is as shown in this thread. The other one also included many Input/Output errors, and it goes like this:

Stdin: error 0
Bus error
chroot : can't execute 'debconf-communicate' : Input/Output error
/scrpts/casper-botton/IOadduser: .: line 20
can't open '/root/use/share/debconf/confmode'
grep: /root/use/ii8n/Supported: I/O error
chroot: can't execute /usr/sbin/locale-gen' : I/O error

and it goes on like that for a bit, with many other lines

Hope its some help with understanding whats going on. Then again, maybe it doesn't matter.

Ryan Caley (ryan-caley) wrote :

I would like to revoke my previous comment. My CD worked fine. I just had to press SPACE when I saw the little guy and keyboard...I wonder if others are making the same mistake, or is it just a noob mistake. Anyways, hope this helps.

Haisheng HU (hanson2010) wrote :

Same with 11.04.

Dan Connolly (connolly) wrote :

I saw this problem with 11.04.

I checked the md5sum of my .iso, and sure enough, it was bad.

The right md5sum was remarkably hard to find.
http://releases.ubuntu.com/11.04/MD5SUMS
7de611b50c283c1755b4007a4feb0379 ubuntu-11.04-desktop-amd64.iso

I suggest putting it in small print right below the big orange "download" buttons on
http://www.ubuntu.com/download/ubuntu/download
or at least a link to something like
https://help.ubuntu.com/community/HowToMD5SUM

faical117 (faical117) wrote :

I get the same error booting 11.4.10 from USB

Same here on Xubuntu 11.04:

- file xubuntu-11.04-desktop-i386.iso
- MD5 checksums match
- I burn CD again with same error

Surya Saha (ss2489) wrote :

I was having the same problem with a old Dell Optiplex desktop and 10.04.3 LTS i386 even after checking md5sums. The problems was that I was using a rewritable CD (only those were handy). Solution was to use a standard CD-R and it worked like a charm.

cozmo not (cozmonot5) wrote :

this d*mn usb will not mount the squashfs. I'm trying to install unbuntu netbook remix 10.10. When the battery and person appear at the bottom of the screen I press the right arrow key. I get then to the language selection screen, I get pass that then when I try to install to hard disk the error comes up. I haven't run Memtest 86 (fully) yet or the MD5 sum yet but I've read the forum and seems like neither helps. I've formatted a 8 gig U3 sandisk and formatted it to the Fat 32 format...and yeah it doesn't work so any other suggestions? Besides redownloading it took two freaking hours to download it just once.

David Gettis (forliberty) wrote :

Same problem here with 10.04 32-bit. Trying to run the Live CD on a Dell Intel server. Verified the MD5sum. Very frustrating, especially since this is a broken Windows machine and I was all set to send Linux gparted to the rescue. Evidently Ubuntu needs a rescue. :(

David Gettis (forliberty) wrote :

I should add that I'm using a CD-R, and that I tried the suggestion of unplugging all USB drives, to no avail.

dave holmes (daveholmes) wrote :

I got this issue booting linux mint 11 from USB using Unetbootin to an ASPIRE revo (Acer). The current OS came with the computer - linpus which is total rubbish so trying to get a decent distro on it.

I copied Echeddar (post #47 above) and reformatted the USB using the slow option on windows. This solved the problem.

Unfortunately there is a separate error now which I am about to google!

Dave

TW Burger (twburger) wrote :

RE:

BusyBox DVD installation error -

"(initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: input/output error
Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs"

I have a solution that may work for some of you:

For me this was a hardware problem. Based on a clue of a person that solved the problem by burning the image to a CD rather than a DVD I removed the CD player from my system that was connected with the DVD as a secondary device on the IDE channel. The install worked perfectly after that. I just unplugged it and that was it!

It seems that the Ubuntu installation (tried 12.04, 12.10, and 13.04 - all failed the same) can not resolve a conflict or misinterprets dual DVD/CD setups. This is not a common PC configuration now but it was common with systems that spanned the adoption of DVDs over CDs for those wanting to copy old CD material to DVDs - faster than making a coy on the HD first.

I guess I can look forward to the upcoming problems with BlueRay.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions