Hardy: Very long boot time. dmesg reveals ata* problems

Bug #231632 reported by Thomas R. N. Jansson on 2008-05-18
2
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

After a clean install of Ubuntu 8.04 on my machine the boot up process is stalling at certain point bootprocess making it very slow. I didn't experience the same problem in 7.10.

My computer consist of:
Asus P5W DH motherboard
Core 2 Duo E6600 @ 3.1 GHz
2 Gb ram.
Hitachi DeskStar T7K500 320 GB sata harddisk
LiteOn LH-18A1H - DVD drive
Club 3D X1950XT graphics card

When I look through dmesg I found what I belive is the problem namely
[ 38.395437] usb 5-7.3: configuration #1 chosen from 1 choice
[ 65.943437] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen

Which doesn't end before way later:
[ 206.659578] ata4: reset failed, giving up
[ 206.659587] ata4: EH complete
[ 206.659599] sd 3:0:0:0: [sdb] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK

I have tried to use the ata4=noprobe option but it didn't help and the boot time takes forever. I attached my bootchart.

Thomas R. N. Jansson (tjansson) wrote :

I have tried search on google and on launchpad but nothing seemed to concern 8.04. I now attached my full dmesg.

Thomas R. N. Jansson (tjansson) wrote :

I have now also tried to use the boot options "noapic acpi=off" but with no luck.

Thomas R. N. Jansson (tjansson) wrote :

Hmm I have found a workaround. This shouldn't be considered a fix. But after reading the post:
http://ubuntuforums.org/showpost.php?p=4774235&postcount=4
it turned out that the problem could be resolved by changing the SATA Mode from IDE to RAID in BIOS. Now by system boots in 25 seconds.

Thomas R. N. Jansson (tjansson) wrote :

Hmm - it turned out to create more problems by setting SATA mode from IDE to RAID on a dual boot machine. Windows BSOD'ed 5 second it's boot sequence, so I am not using this hack anymore.

Thomas R. N. Jansson (tjansson) wrote :

Finally I found a solution which is to use the boot options:
 all_generic_ide irqpoll floppy=off
in /boot/grub/menu.lst

Dariel Dato-on (odd-rationale) wrote :

Glad you found the hack! Will close this bug report. Please reopen if the problem reappears.

Thank you!

Thomas R. N. Jansson (tjansson) wrote :

Hmm - It wouldn't consider the problem solved. New users who doesn't surf launchpad will guess this by them self and will be stuck with a system that takes forever to boot? The problem wasn't present in 7.10, so it a bit of a regression and I think some time should be spent researching which change introduced the problem between 7.10 and 8.04.

willz06jw (willz06jw) wrote :

Please don't close this bug -- it affects Hardy and all other distros that use Hardy as their base ( like Mint). This problem doesn't appear in Gutsy and is killing every new user that encounters it.

Will

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers