Ubuntu

mediatomb build failure when libavformat-dev >= 4:0.7

Reported by Daniel van Vugt on 2011-05-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mediatomb (Ubuntu)
Undecided
Daniel van Vugt

Bug Description

Binary package hint: mediatomb

Note you won't even get to this build failure until you at least have the fix for gcc-4.6 support applied (https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/770964)

Unrelated proposed changes for mediatomb have suddenly started failing to build for oneiric over the last couple of weeks with:
../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegMetadataFields(zmm::Ref<CdsItem>, AVFormatContext*)':
../src/metadata/ffmpeg_handler.cc:92:25: error: 'AVFormatContext' has no member named 'title'
../src/metadata/ffmpeg_handler.cc:94:6: error: 'AVFormatContext' has no member named 'title'
../src/metadata/ffmpeg_handler.cc:96:51: error: 'AVFormatContext' has no member named 'title'
../src/metadata/ffmpeg_handler.cc:98:25: error: 'AVFormatContext' has no member named 'author'
../src/metadata/ffmpeg_handler.cc:100:6: error: 'AVFormatContext' has no member named 'author'
../src/metadata/ffmpeg_handler.cc:102:51: error: 'AVFormatContext' has no member named 'author'
../src/metadata/ffmpeg_handler.cc:104:25: error: 'AVFormatContext' has no member named 'album'
../src/metadata/ffmpeg_handler.cc:106:6: error: 'AVFormatContext' has no member named 'album'
../src/metadata/ffmpeg_handler.cc:108:51: error: 'AVFormatContext' has no member named 'album'
../src/metadata/ffmpeg_handler.cc:110:18: error: 'AVFormatContext' has no member named 'year'
../src/metadata/ffmpeg_handler.cc:112:6: error: 'AVFormatContext' has no member named 'year'
../src/metadata/ffmpeg_handler.cc:114:64: error: 'AVFormatContext' has no member named 'year'
../src/metadata/ffmpeg_handler.cc:116:25: error: 'AVFormatContext' has no member named 'genre'
../src/metadata/ffmpeg_handler.cc:118:6: error: 'AVFormatContext' has no member named 'genre'
../src/metadata/ffmpeg_handler.cc:120:51: error: 'AVFormatContext' has no member named 'genre'
../src/metadata/ffmpeg_handler.cc:122:25: error: 'AVFormatContext' has no member named 'comment'
../src/metadata/ffmpeg_handler.cc:124:6: error: 'AVFormatContext' has no member named 'comment'
../src/metadata/ffmpeg_handler.cc:126:51: error: 'AVFormatContext' has no member named 'comment'
../src/metadata/ffmpeg_handler.cc:128:18: error: 'AVFormatContext' has no member named 'track'
../src/metadata/ffmpeg_handler.cc:130:6: error: 'AVFormatContext' has no member named 'track'
../src/metadata/ffmpeg_handler.cc:132:64: error: 'AVFormatContext' has no member named 'track'
../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegResourceFields(zmm::Ref<CdsItem>, AVFormatContext*, int*, int*)':
../src/metadata/ffmpeg_handler.cc:181:71: error: 'CODEC_TYPE_VIDEO' was not declared in this scope
../src/metadata/ffmpeg_handler.cc:212:31: error: 'CODEC_TYPE_AUDIO' was not declared in this scope

According to libavformat.h, this is due to LIBAVCODEC_VERSION_* having increased and so deprecated features like those above are no longer available.

The cause appears to be this package update from 30 April:
https://launchpad.net/ubuntu/oneiric/+source/libav

Thomas Däppen (daha) on 2011-05-18
Changed in mediatomb (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Daniel van Vugt (vanvugt) wrote :

Here's a patch that fixes the build failure. It has not been functionally tested yet though.

description: updated
tags: added: patch
Daniel van Vugt (vanvugt) wrote :

And here's the final version of the patch, corrected and tested.

Changed in mediatomb (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediatomb - 0.12.1-0ubuntu2

---------------
mediatomb (0.12.1-0ubuntu2) oneiric; urgency=low

  * Introduce Upstart support to fix start-on-boot failure (LP: #212441)
  * Fix build gcc-4.6 build failure (missing correct header) (LP: #770964)
  * Added libav 0.7 support (LP: #784431)
 -- Daniel van Vugt <email address hidden> Sun, 15 May 2011 23:09:43 +0800

Changed in mediatomb (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.