Ubuntu

Activity log for bug #784431

Date Who What changed Old value New value Message
2011-05-18 06:58:51 Daniel van Vugt bug added bug
2011-05-18 07:02:51 Thomas Däppen mediatomb (Ubuntu): status New Incomplete
2011-05-18 07:02:57 Thomas Däppen mediatomb (Ubuntu): status Incomplete New
2011-05-18 07:05:09 Daniel van Vugt description Binary package hint: mediatomb Unrelated proposed changes for mediatomb have suddenly started failing to build for oneiric over the last couple of weeks with: ../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegMetadataFields(zmm::Ref<CdsItem>, AVFormatContext*)': ../src/metadata/ffmpeg_handler.cc:92:25: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:94:6: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:96:51: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:98:25: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:100:6: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:102:51: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:104:25: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:106:6: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:108:51: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:110:18: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:112:6: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:114:64: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:116:25: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:118:6: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:120:51: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:122:25: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:124:6: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:126:51: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:128:18: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc:130:6: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc:132:64: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegResourceFields(zmm::Ref<CdsItem>, AVFormatContext*, int*, int*)': ../src/metadata/ffmpeg_handler.cc:181:71: error: 'CODEC_TYPE_VIDEO' was not declared in this scope ../src/metadata/ffmpeg_handler.cc:212:31: error: 'CODEC_TYPE_AUDIO' was not declared in this scope According to libavformat.h, this is due to LIBAVCODEC_VERSION_* having increased and so deprecated features like those above are no longer available. More info: https://code.launchpad.net/~vanvugt/ubuntu/oneiric/mediatomb/fix-212441/+merge/60574 Binary package hint: mediatomb Note you won't even get to this build failure until you at least have the fix for gcc-4.6 support applied (https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/770964) Unrelated proposed changes for mediatomb have suddenly started failing to build for oneiric over the last couple of weeks with: ../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegMetadataFields(zmm::Ref<CdsItem>, AVFormatContext*)': ../src/metadata/ffmpeg_handler.cc:92:25: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:94:6: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:96:51: error: 'AVFormatContext' has no member named 'title' ../src/metadata/ffmpeg_handler.cc:98:25: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:100:6: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:102:51: error: 'AVFormatContext' has no member named 'author' ../src/metadata/ffmpeg_handler.cc:104:25: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:106:6: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:108:51: error: 'AVFormatContext' has no member named 'album' ../src/metadata/ffmpeg_handler.cc:110:18: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:112:6: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:114:64: error: 'AVFormatContext' has no member named 'year' ../src/metadata/ffmpeg_handler.cc:116:25: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:118:6: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:120:51: error: 'AVFormatContext' has no member named 'genre' ../src/metadata/ffmpeg_handler.cc:122:25: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:124:6: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:126:51: error: 'AVFormatContext' has no member named 'comment' ../src/metadata/ffmpeg_handler.cc:128:18: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc:130:6: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc:132:64: error: 'AVFormatContext' has no member named 'track' ../src/metadata/ffmpeg_handler.cc: In function 'void addFfmpegResourceFields(zmm::Ref<CdsItem>, AVFormatContext*, int*, int*)': ../src/metadata/ffmpeg_handler.cc:181:71: error: 'CODEC_TYPE_VIDEO' was not declared in this scope ../src/metadata/ffmpeg_handler.cc:212:31: error: 'CODEC_TYPE_AUDIO' was not declared in this scope According to libavformat.h, this is due to LIBAVCODEC_VERSION_* having increased and so deprecated features like those above are no longer available. The cause appears to be this package update from 30 April: https://launchpad.net/ubuntu/oneiric/+source/libav
2011-05-18 07:06:37 Daniel van Vugt attachment added fix_libav_0.7_support.patch https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/784431/+attachment/2133332/+files/fix_libav_0.7_support.patch
2011-05-18 07:43:21 Daniel van Vugt bug watch added http://sourceforge.net/support/tracker.php?aid=3291062
2011-05-18 17:32:56 Brian Murray bug added subscriber Ubuntu Review Team
2011-05-18 17:32:57 Brian Murray tags patch
2011-05-19 05:04:06 Daniel van Vugt attachment added libav_0.7_support.patch https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/784431/+attachment/2134568/+files/libav_0.7_support.patch
2011-05-25 09:21:20 Daniel van Vugt branch linked lp:~vanvugt/ubuntu/oneiric/mediatomb/fix-770964-784431
2011-06-02 03:37:12 Daniel van Vugt mediatomb (Ubuntu): status New In Progress
2011-06-02 03:37:12 Daniel van Vugt mediatomb (Ubuntu): assignee Daniel van Vugt (vanvugt)
2011-06-03 01:00:11 Launchpad Janitor mediatomb (Ubuntu): status In Progress Fix Released
2011-06-03 01:13:16 Launchpad Janitor branch linked lp:ubuntu/mediatomb