Ubuntu

mediatomb version 0.12.1-0ubuntu1 failed to build on amd64 with GCC-4.6/oneiric

Reported by Matthias Klose on 2011-04-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mediatomb (Ubuntu)
High
Daniel van Vugt

Bug Description

mediatomb version 0.12.1-0ubuntu1 failed to build on amd64 with GCC-4.6/oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2461884

Details about the rebuild:
https://lists.ubuntu.com/archives/ubuntu-devel/2011-April/033042.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2461884/+files/buildlog_ubuntu-natty-amd64.mediatomb_0.12.1-0ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1051 lines into the build log:

                 from ../src/zmmf/zmmf.h:35,
                 from ../src/autoscan.h:36,
                 from ../src/autoscan.cc:36:
../src/zmm/object.h:51:32: error: declaration of 'operator new' as non-function
../src/zmm/object.h:51:27: error: expected ';' at end of member declaration
../src/zmm/object.h:51:39: error: expected ')' before 'size'
make[3]: *** [libmediatomb_a-autoscan.o] Error 1
make[3]: Leaving directory `/build/buildd/mediatomb-0.12.1/build'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/mediatomb-0.12.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/mediatomb-0.12.1'
dh_auto_build: make -j1 returned exit code 2
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
******************************************************************************
Build finished at 20110424-1512
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/mediatomb-0.12.1

Matthias Klose (doko) on 2011-04-26
Changed in mediatomb (Ubuntu):
importance: Undecided → High
Changed in mediatomb (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Note that even with this bug fixed, a new build failure in mediatomb (oneiric) has appeared recently due to libavformat.h changes. That problem is documented here:
https://bugs.launchpad.net/ubuntu/+source/mediatomb/+bug/784431

Prior to 30 April, oneiric could build mediatomb with just a fix for bug 770964, but now you need the fix for bug 784431 too.

Daniel van Vugt (vanvugt) wrote :

A patch for this bug is already pending upstream (since 5 Feb 2011):
http://sourceforge.net/tracker/?func=detail&aid=3173314&group_id=129766&atid=715782

Changed in mediatomb (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediatomb - 0.12.1-0ubuntu2

---------------
mediatomb (0.12.1-0ubuntu2) oneiric; urgency=low

  * Introduce Upstart support to fix start-on-boot failure (LP: #212441)
  * Fix build gcc-4.6 build failure (missing correct header) (LP: #770964)
  * Added libav 0.7 support (LP: #784431)
 -- Daniel van Vugt <email address hidden> Sun, 15 May 2011 23:09:43 +0800

Changed in mediatomb (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.