[unlock] should be prompted if SIM locked on dialler and messaging

Bug #1371661 reported by Victor Tuson Palau on 2014-09-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
Critical
Olga Kemmet
dialer-app
Critical
Tiago Salem Herrmann
messaging-app
Fix Released
Critical
Tiago Salem Herrmann
dialer-app (Ubuntu)
Critical
Tiago Salem Herrmann
dialer-app (Ubuntu RTM)
Critical
Unassigned
messaging-app (Ubuntu)
Critical
Tiago Salem Herrmann
messaging-app (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Olga says : My recommendation is that we should bring up the SIM PIN unlock screen if user tries to launch the DIALER and MESSAGING apps. This can be done additionally to the indicator access. This way a user will know instantly that there is no access to this apps without unlocking the SIM.

Related connectivity-service (i-network) bug:
https://bugs.launchpad.net/indicator-network/+bug/1374082

Related branches

tags: added: rtm14
Changed in dialer-app:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Bill Filler (bfiller)
Changed in messaging-app:
status: New → Confirmed
Changed in messaging-app:
importance: Undecided → Critical
Bill Filler (bfiller) on 2014-09-19
tags: added: ota-1
Changed in dialer-app:
assignee: Bill Filler (bfiller) → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
tags: removed: ota-1
Benjamin Keyser (bjkeyser) wrote :

@Olga... can you update the wireframes and any flows to reflect this change. I think there's no new artwork required, it's a functional change.

Changed in ubuntu-ux:
importance: Undecided → Critical
assignee: nobody → Olga Kemmet (olga-kemmet)
status: New → In Progress
Bill Filler (bfiller) on 2014-09-23
Changed in dialer-app:
status: Confirmed → In Progress
Changed in messaging-app:
status: Confirmed → In Progress
tags: added: touch-2014-10-02
Olga Kemmet (olga-kemmet) wrote :

I already did. Pat, Bill and Tiago have access to the corresponding specs.

summary: - unlock should be prompted if SIM locked on dialler and messaging
+ [unlock] should be prompted if SIM locked on dialler and messaging
Changed in ubuntu-ux:
status: In Progress → Fix Committed
Bill Filler (bfiller) on 2014-09-25
Changed in dialer-app (Ubuntu):
status: New → In Progress
Changed in messaging-app (Ubuntu):
status: New → In Progress
Changed in dialer-app (Ubuntu):
importance: Undecided → Critical
Changed in messaging-app (Ubuntu):
importance: Undecided → Critical
Changed in dialer-app (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app (Ubuntu):
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Bill Filler (bfiller) on 2014-09-29
Changed in dialer-app (Ubuntu RTM):
importance: Undecided → Critical
tags: added: touch-2014-10-09
removed: touch-2014-10-02
Pat McGowan (pat-mcgowan) wrote :

I am concerned that while this addresses outgoing calls, many other functions will not work, such as any incoming call or message, network access by scopes and browser (assuming no wifi)

Was there any thought to make the lock indication more prominent? I am surprised its not even red.

I believe that adding the prompt at boot time will solve the issue for the majority as it will become an explicit decision to stay locked.

Antti Kaijanmäki (kaijanmaki) wrote :

@pat, nothing is stopping to have the "sim-locked" icons as red. Design just has to update the icons in the icon theme.

The boot prompt is tracked here:
https://bugs.launchpad.net/ubuntu-rtm/+source/indicator-network/+bug/1333121

and the related bug on the "connectivity service" to enable all these components to show the relevant unlock dialogs is there:
https://bugs.launchpad.net/indicator-network/+bug/1374082

description: updated
Bill Filler (bfiller) on 2014-10-08
Changed in messaging-app (Ubuntu RTM):
status: New → Fix Committed
Changed in messaging-app (Ubuntu):
status: In Progress → Fix Committed
Changed in dialer-app (Ubuntu RTM):
status: New → Fix Committed
Changed in dialer-app (Ubuntu):
status: In Progress → Fix Committed
Changed in messaging-app:
status: In Progress → Fix Committed
Changed in dialer-app:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
messaging-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Ship the messaging-app icon together with the package (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add initial support for the new information messageType. Notify
    users when the active sim card was switched. (LP: #1356950)
  * Don't show the attachment popup on onClicked(). Update bottom edge
    behavior (LP: #1368718)
  * Add support for sim lock. (LP: #1371661)
  * Fix black image in the mms preview. (LP: #1373462)
  * Make conversations view header fixed.
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 16:58:07 +0000

Changed in messaging-app (Ubuntu RTM):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
dialer-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Display different labels when in emergency mode and when the sim
    card is locked.
  * Remove some code duplication and make sure emergency calling is
    always available.
  * Ship the dialer-app icon in the package. (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add support for sim lock detection (LP: #1371661)
  * Remove some code duplication and make sure emergency calling is
    always available.

  [ Albert Astals ]
  * Add i18n.tr
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 17:02:04 +0000

Changed in dialer-app (Ubuntu RTM):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
messaging-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Ship the messaging-app icon together with the package (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add initial support for the new information messageType. Notify
    users when the active sim card was switched. (LP: #1356950)
  * Don't show the attachment popup on onClicked(). Update bottom edge
    behavior (LP: #1368718)
  * Add support for sim lock. (LP: #1371661)
  * Fix black image in the mms preview. (LP: #1373462)
  * Make conversations view header fixed.
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 16:58:07 +0000

Changed in messaging-app (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dialer-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
dialer-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Display different labels when in emergency mode and when the sim
    card is locked.
  * Remove some code duplication and make sure emergency calling is
    always available.
  * Ship the dialer-app icon in the package. (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add support for sim lock detection (LP: #1371661)
  * Remove some code duplication and make sure emergency calling is
    always available.

  [ Albert Astals ]
  * Add i18n.tr
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 17:02:04 +0000

Changed in dialer-app (Ubuntu):
status: Fix Committed → Fix Released
Benjamin Keyser (bjkeyser) wrote :

@antii @pat @bill

The state of the art indicator menu is monochrome by design... it's not meant as an alert/alarm bar (we raise the urgency using alerts), but rather meant as a quieter, more peaceful device dashboard. If the icon were always red, for example, it indicates an error or alarm condition which for many cases would not be really true, as users often WANT the sim to be locked, and constantly showing an error state will be more of an irritant.

This icon may not "scream" locked all on it's own, that's true, but there are multiple touchpoints telling the user their SIM is locked and inviting them to unlock if they try to use it. So, after one cycle through this experience from boot to attempting to use the dialer on a locked sim, the "locked sim" icon will make sense and be more than enough to remind users.

The overall unlock experience does not need to be communicated at all once ... the cumulative effect of all of the touchpoints will be more than enough to guide users on unlocking and educate them how to quickly check visually going foward.

Bill Filler (bfiller) on 2014-10-15
Changed in dialer-app:
status: Fix Committed → Fix Released
Changed in messaging-app:
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers