[SIM PIN] Unlock should be shown on boot

Bug #1333121 reported by Jean-Baptiste Lallement on 2014-06-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Network Menu
Fix Released
Critical
Antti Kaijanmäki
Ubuntu UX
High
Olga Kemmet
indicator-network (Ubuntu)
Critical
Antti Kaijanmäki
indicator-network (Ubuntu RTM)
Critical
Antti Kaijanmäki
unity8 (Ubuntu)
Critical
Antti Kaijanmäki
unity8 (Ubuntu RTM)
Critical
Antti Kaijanmäki

Bug Description

The current implementation of the "SIM Unlock" is completely different from the design specification [1] and makes it very difficult to discover.

From the specification: "If SIM PIN lock is turned on, the SIM PIN authentication prompt appears immediately after phone boot."

With the current implementation, the user must open the network indicator, scroll down the list of Wifi AP, tap on Unlock SIM which might not even be visible right away if the number os AP is long enough, and then unlock the SIM

[1] https://docs.google.com/a/canonical.com/document/d/1VajNkWbBH61iVixXJAmOvNGiG__GWQTMXGNOZijXWJw/edit#

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: unity8 7.89+14.10.20140619.3-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.3-0ubuntu2
Architecture: armhf
Date: Mon Jun 23 09:35:59 2014
InstallationDate: Installed on 2014-06-23 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140623)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Michał Sawicz (saviq) on 2014-06-23
summary: - SIM Unlock not implemented as designed
+ SIM Unlock should be shown on boot
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in unity8:
status: New → Triaged
importance: Undecided → High

Antti notes that lp:1302049 will be necessary to complete; there are some autopilot tests in indicator-network which we'll adapt here when it's possible.

Michael Terry (mterry) on 2014-08-07
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Changed in unity8 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Michał Sawicz (saviq) on 2014-08-11
Changed in unity8:
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) on 2014-08-15
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Michael Terry (mterry) on 2014-08-15
Changed in unity8:
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Michael Terry (mterry) wrote :

@Allan, I have a branch ready for review now. What's the story with the autopilot tests that need updating?

Martin Pitt (pitti) wrote :

The SIM pin unlock dialog worked just fine until yesterday (image 207), but got broken again with image 208. I filed bug 1361518 about this. Was this actually reverted for some reason (the dialog only started working a few days ago), or is there some weird race condition somewhere?

Michał Sawicz (saviq) wrote :

No, was reverted as part of the last unity8 release http://bazaar.launchpad.net/~unity-team/unity8/trunk/revision/1202

The service part for dual-sim unlocking was not ready yet, see bug #1361074

Michael Terry (mterry) wrote :

Unassigning for now, nothing to do yet. And status seems to be tracked in bug 1361074 anyway.

Changed in unity8:
assignee: Michael Terry (mterry) → nobody
status: In Progress → Triaged
Changed in unity8 (Ubuntu):
status: In Progress → Triaged
Michał Sawicz (saviq) on 2014-09-09
no longer affects: unity8
Antti Kaijanmäki (kaijanmaki) wrote :

fixing the automatic unlocking was dropped from #1361074 . let's use this as a primary bug to track it.

Changed in indicator-network:
status: New → Triaged
Changed in indicator-network (Ubuntu):
status: New → Triaged
Changed in indicator-network (Ubuntu RTM):
status: New → Triaged
Changed in indicator-network (Ubuntu):
importance: Undecided → High
Changed in indicator-network:
importance: Undecided → High
Changed in indicator-network (Ubuntu RTM):
importance: Undecided → High
Changed in indicator-network (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in indicator-network:
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in unity8 (Ubuntu):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in indicator-network (Ubuntu RTM):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
tags: added: rtm14
Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
importance: Undecided → High
status: New → Fix Committed
summary: - SIM Unlock should be shown on boot
+ [SIM PIN] Unlock should be shown on boot
Changed in unity8 (Ubuntu):
importance: High → Critical
Changed in indicator-network (Ubuntu RTM):
importance: High → Critical
Changed in indicator-network (Ubuntu):
importance: High → Critical
importance: Critical → High
Antti Kaijanmäki (kaijanmaki) wrote :

ETA for landing: early next week.

Olli Ries (ories) on 2014-10-10
tags: added: touch-2014-10-16
Michał Sawicz (saviq) on 2014-10-13
Changed in unity8 (Ubuntu RTM):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in indicator-network:
importance: High → Critical
Changed in indicator-network (Ubuntu):
importance: High → Critical
Changed in indicator-network:
status: Triaged → In Progress
Changed in indicator-network (Ubuntu):
status: Triaged → In Progress
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
Changed in indicator-network (Ubuntu RTM):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.1+14.10.20141014-0ubuntu1

---------------
indicator-network (0.5.1+14.10.20141014-0ubuntu1) utopic; urgency=low

  [ Antti Kaijanmäki ]
  * Fix UnlockAllModems. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Tue, 14 Oct 2014 21:12:57 +0000

Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-network (Ubuntu RTM):
status: In Progress → Fix Released
Changed in indicator-network (Ubuntu RTM):
status: Fix Released → In Progress
Changed in indicator-network (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.5.1+14.10.20141015-0ubuntu1

---------------
indicator-network (0.5.1+14.10.20141015-0ubuntu1) 14.09; urgency=low

  [ Antti Kaijanmäki ]
  * deadlock if calling unlock() inside ready signal for a modem that
    does not require unlocking. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 12:47:24 +0000

Changed in indicator-network (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.00+14.10.20141015.4~rtm-0ubuntu1

---------------
unity8 (8.00+14.10.20141015.4~rtm-0ubuntu1) 14.09; urgency=low

  [ Michał Sawicz ]
  * remove qml ownership confusion for caching unitymenumodels (LP:
    #1368856)

  [ josharenson ]
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)

  [ Nick Dedekind ]
  * remove qml ownership confusion for caching unitymenumodels (LP:
    #1368856)
  * Implementation of expandable panel design (LP: #1368856)

  [ Albert Astals ]
  * CardAttributes: Specify column and row since the gridlayout gets
    confused sometimes (LP: #1381092)
  * Reset VerticalJournal until the cardTool settles (LP: #1381255)

  [ Mirco Müller ]
  * Added synchronous/confirmation notification support to unity8. (LP:
    #1232633)

  [ Michael Zanetti ]
  * drop all visual indication of "pinning" (LP: #1381054)
  * Fix lp:1370240 by making stages interactive when a snap decision is
    dismissed. (LP: #1370240)

  [ Antti Kaijanmäki ]
  * Unlock all modems on boot. (LP: #1333121)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 16:44:20 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in indicator-network:
status: In Progress → Fix Released
Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-network (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers