ubuntu tweak crash in Login Settings

Bug #665841 reported by Yangyu Huang on 2010-10-24
420
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Ubuntu Tweak
Medium
Ding Zhou

Bug Description

Distribution: Ubuntu 10.10
Application: Ubuntu Tweak 0.5.7
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 437, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: 打开文件“/tmp/tmpzW80oH”失败:权限不够

Ding Zhou (tualatrix) on 2010-10-24
Changed in ubuntu-tweak:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.5.8
assignee: nobody → Tualatrix Chou (tualatrix)
status: Confirmed → Fix Committed
Eric Afyouni (eafyn) wrote :

Has this bug been fixed? This bug has appeared in 0.5.7, but it appeared for me in 0.5.8. I'm kind of confused as to what "fix committed" means.

Ding Zhou (tualatrix) wrote :

@Eric Afyouni

Hello, can you give me your error message with 0.5.8? Thanks.

summary: - ubuntu tweak 在点击“登录设置”时崩溃
+ ubuntu tweak crash in Login Settings
Eric Afyouni (eafyn) wrote :

Distribution: Ubuntu 10.10
Application: Ubuntu Tweak 0.5.8
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 437, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: Failed to open file '/tmp/tmpRurJ2E': Permission denied

Ding Zhou (tualatrix) wrote :

Can you help me to confirm again? Maybe the first time you open with Ubuntu Tweak 0.5.8, the background daemon didn't work correctly.

I think you've reboot your computer now.

Ding Zhou (tualatrix) on 2010-12-25
Changed in ubuntu-tweak:
status: Fix Committed → Fix Released

0.5.9 ubuntu 10.04/ same bug

Distribution: Ubuntu 10.04 lucid
Application: Ubuntu Tweak 0.5.9
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 433, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: Failed to open file '/tmp/tmp6H3fAC': Permission denied

Ding Zhou (tualatrix) wrote :

Please help me to confirm one thing.

When this error happens, don't close or do anything on Ubuntu Tweak. Open your terminal, run this command and give the output to me:

   > ls -l /tmp/tmp*

Thanks!

Changed in ubuntu-tweak:
milestone: 0.5.8 → 0.5.10
status: Fix Released → Confirmed

I'm getting a similar report:

Distribution: Ubuntu 10.10 maverick
Application: Ubuntu Tweak 0.5.9
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 433, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: Datei »/tmp/tmpXb08sm« konnte nicht geöffnet werden: Keine Berechtigung

----

Output of terminal:

tim@tim-desktop:~$ ls -l /tmp/tmp*
-r----x--t 1 root root 28990 2010-12-29 14:50 /tmp/tmpXb08sm

Ding Zhou (tualatrix) on 2010-12-29
Changed in ubuntu-tweak:
status: Confirmed → Fix Committed
Ding Zhou (tualatrix) wrote :
Willeo Soeurs (ding-yeen) wrote :

I have the problem as well :

Distribution: Ubuntu 10.10 maverick
Application: Ubuntu Tweak 0.5.9
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 433, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: Failed to open file '/tmp/tmp8Fhg3_': Permission denied

Willeo Soeurs (ding-yeen) wrote :

the testing build has fixes the error

Yes, Fixed the problem. Thank YOU!!

On Dec 29, 2010, at 8:48 PM, Tualatrix Chou wrote:

> Please try this testing version to verify if it has been fixed, thanks:
>
> https://launchpad.net/~ubuntu-tweak-testing/+archive/ppa/+files/ubuntu-
> tweak_0.5.10-0~20101229~maverick1_all.deb
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (695272).
> https://bugs.launchpad.net/bugs/665841
>
> Title:
> ubuntu tweak crash in Login Settings
>
> Status in Ubuntu Tweak:
> Fix Committed
>
> Bug description:
> Distribution: Ubuntu 10.10
> Application: Ubuntu Tweak 0.5.7
> Desktop: gnome
>
> Traceback (most recent call last):
> File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 437, in setup_notebook
> page = module()
> File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
> self.__setup_logo_image()
> File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
> pixbuf = gtk.gdk.pixbuf_new_from_file(path)
> GError: 打开文件“/tmp/tmpzW80oH”失败:权限不够
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-tweak/+bug/665841/+subscribe
>

JOHNe (jmenslin) wrote :

Thanks Tualatrix 0.5.10 testing version sorted my problem !!!!

Ramón Jaramillo (ramjar) wrote :

Hi Tualatrix, happy New Year. I'm using Ubuntu 10.04 I need to solve my problem in Ubuntu Tweak 0.5.9. It's the same that I've reported previously and here.

Ramón Jaramillo (ramjar) wrote :

I've found a solution for this bug in Ubuntu 10.04. Simply, change the boot splash screen as follows:

1. Open terminal and run:
> sudo cp /usr/share/applications/gnome-appearance-properties.desktop /usr/share/gdm/autostart/LoginWindow
2. Log out.
3. You’ll see an «Appearance window» pop up. Change it to how you prefer it, then close it and login as usual.
4. When you've logged, run this command:
> sudo unlink /usr/share/gdm/autostart/LoginWindow/gnome-appearance-properties.desktop

The bug in Ubuntu Tweak has dissaparaed!.

Gary Watts (gazbook) wrote :

Appears to be the same bug, so here is the error report it gave me:

Distribution: Ubuntu 10.10 maverick
Application: Ubuntu Tweak 0.5.9
Desktop: gnome

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/mainwindow.py", line 433, in setup_notebook
    page = module()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 74, in __init__
    self.__setup_logo_image()
  File "/usr/lib/python2.6/dist-packages/ubuntutweak/modules/loginsettings.py", line 110, in __setup_logo_image
    pixbuf = gtk.gdk.pixbuf_new_from_file(path)
GError: Failed to open file '/tmp/tmpBlSTcW': Permission denied

Ramón Jaramillo (ramjar) wrote :

Hi Gay: Try the solution that I've found.

Ramón Jaramillo (ramjar) wrote :

Sorry for the error:

Hi Gary, try the solution that I've found.

Ding Zhou (tualatrix) on 2011-01-12
Changed in ubuntu-tweak:
status: Fix Committed → Fix Released
jms (prairie-squidman) wrote :

Tualatrix, I will try your patched version and report the results. Thank you so much for your attention to this issue, and for your dedication to this excellent project.

mdj (stevakat71) wrote :

installata versionehttps://launchpad.net/~ubuntu-tweak-testing/+archive/ppa/+files/ubuntu-tweak_0.5.10-0~20101229~maverick1_all.deb per me problema risolto

jms (prairie-squidman) wrote :

The newest version of Tweak gives me no problems! Thanks!

Ramón Jaramillo (ramjar) wrote :

Hi, Tualatrix, The bug had been fixed with your improvements. Thanks a lot for your dedication and contribution to make Ubuntu more easy to use!.

To post a comment you must log in.