spell check in Kde editor component in german does not accept ß

Bug #490362 reported by yannek on 2009-11-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned

Bug Description

The spell checker works in general. But it no longer accept any words written with "ß". e.g.
Maßnahme (the correct spelling before and after both german orthography reforms in the last 15 years)
Massnahme (wrong spelling)
is identified falsely as wrong in the former and correct in the latter case.
This is not an encoding issue as words containing german umlauts work as expected as long as no "ß" is contained.
It seems, as if either someone with switzerland (which uses "high german" as the written language, but no "ß") in his mind or someone who totally misunderstood the last changes to german spelling rules blindly converted all "ß" in the dictionary to "ss".
This happens on a current installation of (K)Ubuntu 9.10 with KDE as the desktop environment, and an installed and used language support for german, wich is otherwise just fine.

David Planella (dpm) wrote :

Hi yannek,

Thanks for your bug report. Could you tell us in which application you observed this behaviour, so we can determine which spellchecker or dictionary presents the problem?

Thanks!

Changed in ubuntu-translations:
status: New → Incomplete
yannek (yannek) wrote :

Sorry for not answering, I missed the last edit notice.
It was present in Kate, Kmail, Kile etc. pp..
The behaviour is now correct after an update to Lucid Lynx. As I seem to be the only person that stumbled over the problem, and lucid is the new LTS and it works there as expected I would propose to let the bug rest in peace, never to return.

Fine with you?

David Planella (dpm) on 2010-08-03
Changed in ubuntu-translations:
status: Incomplete → Fix Released
reini (rrumberger) wrote :

This happened to me since before Hardy up to and including Maverick (I haven't gotten around to installing Natty yet, but have no reason to believe it's been fixed).
I concur with the original diagnosis that someone blindly converted all 'ß' to 'ss' since the spell checker works more or less fine, otherwise.

Back when there still was a choice, I selected aspell as my dictionary. Right now I have myspell, aspell and hunspell installed, and the problem is there and has been for years. (I do have "Deutsch (Deutschland)" selected in the spell checking settings, in case anyone is wondering.)

@yannek: are you sure this is fixed in lucid, now, or did you just stumble across the "miss-spelled words don't get underlined anymore" bug?

yannek (yannek) wrote :

Well yes. Reini seems to be right. There is (still?, again?) no "on the fly" spellchecking in kate, kmail, ....
I'm using natty now. I can't tell when it vanished. Strange...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers