Comment 32 for bug 745540

For everyone eager to get this working and are using the GNOME 3 PPA
under Natty, download this:

https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-sso-client_1.3.1-0ubuntu1_all.deb

I installed this deb a couple of days ago and it works just fine.

On 28 June 2011 08:15, samuel butts <email address hidden> wrote:
> yeah i would like to access my purchased content without overhauling my
> desktop or upgrading to an alpha, natty still has a few months left,
> would love to see ubuntu-sso-client 1.3.1-0ubuntu1 for it
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/745540
>
> Title:
>  Method "CreateItem" with signature "a{sv}(oayay)b" on interface
>  "org.freedesktop.Secret.Collection" doesn't exist
>
> Status in Gwibber:
>  Invalid
> Status in Ubuntu Single Sign On Client:
>  Fix Released
> Status in “libgnome-keyring” package in Ubuntu:
>  Fix Released
> Status in “python-launchpadlib” package in Ubuntu:
>  Invalid
> Status in “ubuntu-sso-client” package in Ubuntu:
>  Fix Released
> Status in “ubuntuone-client” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Binary package hint: python-launchpadlib
>
>  Hi,
>
>  With gnome-keyring from gnome3 ppa (2.91.93) I get the following
>  traceback when trying to use requestsync --lp
>
>  The authorization page:
>   (URL)
>  should be opening in your browser. Use your browser to authorize
>  this program to access Launchpad on your behalf.
>
>  Waiting to hear from Launchpad about your decision...
>  ** Message: secret service operation failed: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist
>
>  Traceback (most recent call last):
>    File "/usr/bin/requestsync", line 328, in <module>
>      main()
>    File "/usr/bin/requestsync", line 148, in main
>      Launchpad.login(service=options.lpinstance)
>    File "/usr/lib/python2.7/dist-packages/ubuntutools/lp/lpapicache.py", line 61, in login
>      version=api_version)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 538, in login_with
>      credential_save_failed, version)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 345, in _authorize_token_and_login
>      credentials = authorization_engine(credentials, credential_store)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 465, in __call__
>      credential_store.save(credentials, self.unique_consumer_id)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 244, in save
>      raise e
>  gnomekeyring.IOError
>
>
>  I also get the same error when trying to add an account for ubuntuone
>
>  Related to bug #734671 ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/745540/+subscriptions
>