Ubuntu Single Sign On Client

Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist

Reported by Laurent Bigonville on 2011-03-30
362
This bug affects 73 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
Ubuntu Single Sign On Client
High
Manuel de la Peña
libgnome-keyring (Ubuntu)
Undecided
Unassigned
python-launchpadlib (Ubuntu)
Undecided
Unassigned
ubuntuone-client (Ubuntu)
Undecided
Unassigned
ubuntu-sso-client (Ubuntu)
Medium
Ubuntu One Client Engineering team

Bug Description

Binary package hint: python-launchpadlib

Hi,

With gnome-keyring from gnome3 ppa (2.91.93) I get the following traceback when trying to use requestsync --lp

The authorization page:
 (URL)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.

Waiting to hear from Launchpad about your decision...
** Message: secret service operation failed: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist

Traceback (most recent call last):
  File "/usr/bin/requestsync", line 328, in <module>
    main()
  File "/usr/bin/requestsync", line 148, in main
    Launchpad.login(service=options.lpinstance)
  File "/usr/lib/python2.7/dist-packages/ubuntutools/lp/lpapicache.py", line 61, in login
    version=api_version)
  File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 538, in login_with
    credential_save_failed, version)
  File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 345, in _authorize_token_and_login
    credentials = authorization_engine(credentials, credential_store)
  File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 465, in __call__
    credential_store.save(credentials, self.unique_consumer_id)
  File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 244, in save
    raise e
gnomekeyring.IOError

I also get the same error when trying to add an account for ubuntuone

Related to bug #734671 ?

ShaunS (shauns) wrote :

I am using the Gnome 3 PPA version 3.0.0 and UbuntuOne fails with the mentioned error.

promet (prometx) wrote :

I also am experiencing this issue (Gnome 3 PPA as well)...

www.ubuntuone.com site login is fine, all as expected Ubuntuone app fails, as above however.

Jacob Henderson (lmeditato) wrote :

I am experiencing this error with Gnome 3 as well when trying to add an account via gwibber-accounts

affects: launchpadlib → gwibber
Changed in gwibber:
status: New → Incomplete
status: Incomplete → Confirmed
Laurent Bigonville (bigon) wrote :

Hi,

Alright, I've found the issue, this is due to libgnome-keyring not being at the last version.

Please try to update it to version 3.0 from the gnome3 ppa

Changed in gwibber:
status: Confirmed → Invalid
Changed in python-launchpadlib (Ubuntu):
status: New → Invalid
Changed in ubuntuone-client (Ubuntu):
status: New → Invalid
Changed in libgnome-keyring (Ubuntu):
status: New → Fix Released
Laurent Bigonville (bigon) wrote :

This is not fixed for ubuntu one because it seems that ubuntu-sso-client call dbus directly

Changed in ubuntuone-client (Ubuntu):
status: Invalid → New
status: New → Invalid
Changed in ubuntu-sso-client (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in ubuntu-sso-client:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alejandro J. Cura (alecu)
hnrkg (hnrkg) on 2011-04-18
Changed in ubuntu-sso-client:
status: In Progress → Fix Released
Natalia Bidart (nataliabidart) wrote :

This has not been released yet for ubuntu-sso-client, so I'm restoring the In Progress status.

Changed in ubuntu-sso-client:
status: Fix Released → In Progress
Changed in ubuntu-sso-client (Ubuntu):
assignee: nobody → Naty Bidart (nataliabidart)
milestone: none → ubuntu-11.04
status: In Progress → Triaged
tags: added: u1-natty-sru
Changed in ubuntu-sso-client (Ubuntu):
assignee: Naty Bidart (nataliabidart) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
hnrkg (hnrkg) wrote :

Weird. I don't remember changing the status on this bug...

Changed in ubuntu-sso-client (Ubuntu):
importance: High → Medium
milestone: ubuntu-11.04 → none
Tim (timchesonis) wrote :

I too, can confirm that this is still an issue, and it's now April 28, 2011, (the release date of Ubuntu 11.04).

Tim, considering the change in status, not being able to connect to Ubuntu One is considered not too important to make it in for the release of Natty...even though the release notes for Natty discuss the wonderful improvements of Ubuntu One.

Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Laurent Bigonville (bigon) wrote :

Hi,

I've patched the current ubuntu version of ubuntu-sso-client (1.2.1-0ubuntu2) and it still doesn't work.

It seems that the 1st call (with the new signature) returns "Invalid properties argument"

Changed in ubuntu-sso-client:
status: Fix Committed → New
Rodney Dawes (dobey) wrote :

The "CreateItem" not existing issue is fixed, though. Please don't change bugs back to New from a more advanced status, when they have been fixed.

If there are additional issues, then perhaps another bug should be filed.

Changed in ubuntu-sso-client:
status: New → Fix Committed
Leonel Nunez (leonelnunez) wrote :

Just installed Gnome3 and ubuntuone can't login do you know when this fixed bug will be released ??

Leonel Nunez (leonelnunez) wrote :

HeY !!!

Just applied those two patches and is working !!

GREAT WORK
Thank you

gyp (gyp-impulzus) wrote :

The above two patches do indeed fixed the problem for me.

Javier Puiggros (jpuiggrosv) wrote :

Hi, still have the same problem with two patches aplied.
ubuntu-sso-client: 1.2.1-0ubuntu2 (natty-updates)
libgnome-keyring0: 3.0.0-2 natty1

I am also having this same issue with 2 separate PCs running Gnome3 from the gnome PPAs over Natty
I have both the mentioned patches applied as well:
ubuntu-sso-client 1.2.1-0ubuntu2
libgnome-keyring0: 3.0.0-2

juri (eng-juri) wrote :

The same Issue here....

Gnome3+ubuntu 11
2.6.38-8-generic

Waiting to hear from Launchpad about your decision...

** Message: secret service operation failed: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist

I can confirm this. I'm using oneiric

ubuntu-sso-client: 1.2.1-0ubuntu2
libgnome-keyring0: 3.0.0-2

matez (mates-fendrych) wrote :

Hi, same issue here.

gnome3, 2.6.38-8-generic
ubuntu-sso-client: 1.2.1-0ubuntu2
libgnome-keyring0: 3.0.0-2 natty 1

Javier Puiggros (jpuiggrosv) wrote :

Any News on this?? mark as solved but the bug is present.

PeterPall (peterpall) wrote :

The same is true on Oneiric pre-alpha even with the ubuntuone-daily ppa.

John Lenton (chipaca) wrote :

@Javier, @Peter, is "the bug is present" actually this CreateItem issue, or is it something similar but different?

Michael Terry (mterry) wrote :

The bug is now that the first CreateItem call errors out ("Invalid properties argument") and then the code falls back to previous CreateItem signature, which generates the same error again.

The invalid properties argument is because they also changed the names of properties like "Label" to "org.freedesktop.blah.blah.Label".

I was talking to dobey on IRC about it, but I don't know if he did any work on the issue.

Rodney Dawes (dobey) wrote :

I was looking into the issue, but haven't come up with a fix yet. It is not clear to me whether using the new property names will break when running on older versions of gnome-keyring. If not, the fix should be pretty easy. If so, then the fix is very complex, as we have to fall back to the old names when using the old version. And there doesn't seem to be a good way to tell what version of the API is implemented on the server, because it could be any implementation that we are talking to, and not just gnome-keyring (for instance, could be kwallet, or some other secrets store that implements the APIs).

Alejandro J. Cura (alecu) wrote :

There have been a few changes in the keyring protocol from Gnome 2 to Gnome 3, like the change in the "Secret" structure that affects CreateItem, and the changes to the properties names as mterry says, and probably some other change that we have yet to find.

ubuntu-sso-client currently works fine with Gnome 2, but breaks with Gnome 3. We want it to support both versions, but there's no way to find out via DBus what keyring version is running other than trying one of the changed methods or properties, catching the error and retrying with the other signature.

We've started doing that each time CreateItem was called in the first branch, but a few of the other changes popped up, and it fails again. So we'll work on a different approach that will switch to the keyring 3 protocol the first time one of this errors happens, and it will use the new property names and other possible changes.

Pavol Klačanský (pavolzetor) wrote :

Hi, when will it be fixed in oneiric? thx, I cannot live without U1

I have a machine with ubuntuone working before upgrade, and this machine can synchronize correctily.
I have a netbook and want configure ubuntuone to synchronize with my main machine, but this error occurs.

There is not a manual fix? Since ubuntuone works in a machine configured before upgrade, I think if I can manually copy the config files from this machine to my netbook and do some change I can have U1 working. And maybe this manual fix can help the others here with the problem until it's officially fixed.

Rodney Dawes (dobey) wrote :

No, there is no manual fix. If you use the gnome3 PPA or 11.10 devel, it will be broken. We should have a fix soon, but until we can get the fix done and into 11.10, it will be broken. There are also other changes coming to 11.10 which will break Ubuntu One. However, we also need to try and maintain compatibility for previous supported versions of Ubuntu. This makes fixing the issues much harder, because the upgrade to some GNOME 3 libraries just breaks things.

Please be patient, and we will try to get these fixes out as soon as possible. Thanks.

Rodney Dawes (dobey) on 2011-06-23
Changed in ubuntu-sso-client:
milestone: none → 1.3.1
Rodney Dawes (dobey) on 2011-06-23
Changed in ubuntu-sso-client (Ubuntu):
milestone: none → oneiric-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 1.3.1-0ubuntu1

---------------
ubuntu-sso-client (1.3.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Invalid signature for CreateItem call (LP: #745540)
    - Never sees NetworkManager connection (LP: #791548)
    - Support new property names in secrets API (LP: #800294)
    - Deprecated DBus interfaces not marked as such (LP: #770269)
  * Update the watch file to point at the correct place.
 -- Rodney Dawes <email address hidden> Fri, 24 Jun 2011 15:14:18 -0400

Changed in ubuntu-sso-client (Ubuntu):
status: Triaged → Fix Released
Rodney Dawes (dobey) on 2011-06-25
Changed in ubuntu-sso-client:
status: Fix Committed → Fix Released
Andre Rossouw (rossouwap) wrote :

Will ubuntu-sso-client 1.3.1-0ubuntu1 be coming to Natty at all?

samuel butts (samuel-butts) wrote :

yeah i would like to access my purchased content without overhauling my desktop or upgrading to an alpha, natty still has a few months left, would love to see ubuntu-sso-client 1.3.1-0ubuntu1 for it

For everyone eager to get this working and are using the GNOME 3 PPA
under Natty, download this:

https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-sso-client_1.3.1-0ubuntu1_all.deb

I installed this deb a couple of days ago and it works just fine.

On 28 June 2011 08:15, samuel butts <email address hidden> wrote:
> yeah i would like to access my purchased content without overhauling my
> desktop or upgrading to an alpha, natty still has a few months left,
> would love to see ubuntu-sso-client 1.3.1-0ubuntu1 for it
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/745540
>
> Title:
>  Method "CreateItem" with signature "a{sv}(oayay)b" on interface
>  "org.freedesktop.Secret.Collection" doesn't exist
>
> Status in Gwibber:
>  Invalid
> Status in Ubuntu Single Sign On Client:
>  Fix Released
> Status in “libgnome-keyring” package in Ubuntu:
>  Fix Released
> Status in “python-launchpadlib” package in Ubuntu:
>  Invalid
> Status in “ubuntu-sso-client” package in Ubuntu:
>  Fix Released
> Status in “ubuntuone-client” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Binary package hint: python-launchpadlib
>
>  Hi,
>
>  With gnome-keyring from gnome3 ppa (2.91.93) I get the following
>  traceback when trying to use requestsync --lp
>
>  The authorization page:
>   (URL)
>  should be opening in your browser. Use your browser to authorize
>  this program to access Launchpad on your behalf.
>
>  Waiting to hear from Launchpad about your decision...
>  ** Message: secret service operation failed: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist
>
>  Traceback (most recent call last):
>    File "/usr/bin/requestsync", line 328, in <module>
>      main()
>    File "/usr/bin/requestsync", line 148, in main
>      Launchpad.login(service=options.lpinstance)
>    File "/usr/lib/python2.7/dist-packages/ubuntutools/lp/lpapicache.py", line 61, in login
>      version=api_version)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 538, in login_with
>      credential_save_failed, version)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 345, in _authorize_token_and_login
>      credentials = authorization_engine(credentials, credential_store)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 465, in __call__
>      credential_store.save(credentials, self.unique_consumer_id)
>    File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 244, in save
>      raise e
>  gnomekeyring.IOError
>
>
>  I also get the same error when trying to add an account for ubuntuone
>
>  Related to bug #734671 ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/745540/+subscriptions
>

lemoineo (lemoineo) wrote :

It's running ...
Thank's for your job!
Olivier

ckaude giddey (claude-giddey) wrote :

Thank you, it's running fine

Le mardi 28 juin 2011 à 10:01 +0000, Henrik Görlin a écrit :
> For everyone eager to get this working and are using the GNOME 3 PPA
> under Natty, download this:
>
> https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-sso-
> client_1.3.1-0ubuntu1_all.deb
>
> I installed this deb a couple of days ago and it works just fine.
>
> On 28 June 2011 08:15, samuel butts <email address hidden> wrote:
> > yeah i would like to access my purchased content without overhauling my
> > desktop or upgrading to an alpha, natty still has a few months left,
> > would love to see ubuntu-sso-client 1.3.1-0ubuntu1 for it
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/745540
> >
> > Title:
> > Method "CreateItem" with signature "a{sv}(oayay)b" on interface
> > "org.freedesktop.Secret.Collection" doesn't exist
> >
> > Status in Gwibber:
> > Invalid
> > Status in Ubuntu Single Sign On Client:
> > Fix Released
> > Status in “libgnome-keyring” package in Ubuntu:
> > Fix Released
> > Status in “python-launchpadlib” package in Ubuntu:
> > Invalid
> > Status in “ubuntu-sso-client” package in Ubuntu:
> > Fix Released
> > Status in “ubuntuone-client” package in Ubuntu:
> > Invalid
> >
> > Bug description:
> > Binary package hint: python-launchpadlib
> >
> > Hi,
> >
> > With gnome-keyring from gnome3 ppa (2.91.93) I get the following
> > traceback when trying to use requestsync --lp
> >
> > The authorization page:
> > (URL)
> > should be opening in your browser. Use your browser to authorize
> > this program to access Launchpad on your behalf.
> >
> > Waiting to hear from Launchpad about your decision...
> > ** Message: secret service operation failed: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist
> >
> > Traceback (most recent call last):
> > File "/usr/bin/requestsync", line 328, in <module>
> > main()
> > File "/usr/bin/requestsync", line 148, in main
> > Launchpad.login(service=options.lpinstance)
> > File "/usr/lib/python2.7/dist-packages/ubuntutools/lp/lpapicache.py", line 61, in login
> > version=api_version)
> > File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 538, in login_with
> > credential_save_failed, version)
> > File "/usr/lib/pymodules/python2.7/launchpadlib/launchpad.py", line 345, in _authorize_token_and_login
> > credentials = authorization_engine(credentials, credential_store)
> > File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 465, in __call__
> > credential_store.save(credentials, self.unique_consumer_id)
> > File "/usr/lib/pymodules/python2.7/launchpadlib/credentials.py", line 244, in save
> > raise e
> > gnomekeyring.IOError
> >
> >
> > I also get the same error when trying to add an account for ubuntuone
> >
> > Related to bug #734671 ?
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/gwibber/+bug/745540/+subscriptions
> >
>

Javier Puiggros (jpuiggrosv) wrote :

Working!!! Thanks to all involved.

noa097 (noa097) wrote :

The file "ubuntu-sso-client_1.3.1-0ubuntu1_all.deb" solved the problem.
Magical..
Thank you.

Works fine, thanks a lot!!

Philippe (philippe-leuridan) wrote :

Perfect ! Thank you

Bruno Jesus (brunojesus) wrote :

Thanks, problem solved!

joshg (joshg) wrote :

This problem persists for me! In ubuntu Software Center

for me too in Oneiric with Ubuntu One and Software Center

Alejandro J. Cura (alecu) wrote :

mandel: ralsina says you are already on Oneiric; would you mind taking a look at this bug, to see if you can reproduce it?

thanks!

Changed in ubuntu-sso-client:
assignee: Alejandro J. Cura (alecu) → Manuel de la Peña (mandel)
Maxim Kuznetsov (mackuzzz) wrote :

And for me in Ubuntu One and Gwibber.

John Lenton (chipaca) wrote :

On Fri, 07 Oct 2011 17:14:58 -0000, Andrea Mazzilli <email address hidden> wrote:
> for me too in Oneiric with Ubuntu One and Software Center
>
> --
> You received this bug notification because you are a member of Ubuntu
> One Desktop+ team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/745540
>
> Title:
> Method "CreateItem" with signature "a{sv}(oayay)b" on interface
> "org.freedesktop.Secret.Collection" doesn't exist
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gwibber/+bug/745540/+subscriptions

could you check what PPAs you have enabled, and list them here? Thank
you.

Here the long list
I removed all the disabled PPA and enabled but not found (not support oneiric yet)

Maybe useful a list of local package? It's not a fresh install, so I have a lot of old packages installed, and also a maverick PPA of a theme

Alessio (alessio) wrote :

this bug affect me on fresh installed oneiric beta2 and fully updated without add any PPAs
I installed the beta from a usb pendrive, and also gnome-keyring didn't remember passwords

Updated four machines from up-to-date natty (all of which were working with u1 before) to Oneiric beta2 last night. Three laptops all worked fine, but the desktop ended up with an ubuntu one which would just sit and spin on the account page (and all others). I removed all files named ubuntuone, removed the ubuntu one key from the gnome keyring, killed all ubnutuone processes, and ran u1sdtool -q. I also removed this machine from my Ubuntu One account through the web interface. I've tried doing all that and logging out / logging back in, and tried rebooting after doing all that. Ubuntu One still will not reconnect - giving this error - even though this is basically a new machine as far as it should know. Using the incorrect credentials does fail as expected. No PPAs are enabled.

I did an update and a dist-upgrade within the past 5 minutes, and the ubuntu-one-client was included in the update. The problem did not go away during the session in which I performed the update.

Maxim Kuznetsov (mackuzzz) wrote :

Renamed files in ~/.gnome2/keyring to *.bak and tried to log in to Ubuntu One. When gnome-keyring asked for password, left password fields empty, and it worked for Ubuntu One!
Tried to add Twitter account to Gwibber and got the same problem with it: the accounts window closed after logging in to Twitter, and Twitter account didn't appear.
Repeated step 1 for Gwibber, added empty password as described higher, and now accounts window is hanging.

Maxim Kuznetsov (mackuzzz) wrote :

as I see now, when I tried to log in to Ubuntu One without password, file default.keyring was made. After removing default.keyring again and logging in to Twitter in Gwibber and adding an empty password again, file основная.keyring was made with Russian name. Does it matter something? The second language in my system is Russian and interface is Russian.

Ravioli (ravioli) wrote :

this bug affects me on a fresh install of 11.10 final. i am using unity2d (don't know if that matters) and the problem occurs in ubuntu one as mentioned above. i have also problems adding accounts to gwibber.

Alejandro J. Cura (alecu) wrote :

Can anyone that has been recently affected by this bug paste a full log of the error?
Thanks.

Maxim Kuznetsov (mackuzzz) wrote :

How can I take this log?

Ravioli (ravioli) wrote :

Does that help?

Oct 15 14:33:21 ubuntu2 gnome-keyring-daemon[1261]: egg_symkey_generate_simple: assertion `iterations >= 1' failed
Oct 15 14:33:21 ubuntu2 gnome-keyring-daemon[1261]: couldn't prepare to write out keyring: /home/ravioli/.gnome2/keyrings/login.keyring
Oct 15 14:33:21 ubuntu2 gnome-keyring-daemon[1261]: couldn't unwrap item secret: Internal error

Francesco Castellana (xfranky) wrote :

Confirming that deleting the default keyring (login.keyring) and creating a new one, which gets created automatically with a localized name (e.g. predefinito.keyring in Italian), seems to work.

Alessio (alessio) wrote :

Ravioli your log is about gnome-keyring-daemon, I don't know if this is the cause of this bug or not, but it affect any application that store passwords into gnome-keyring
I opened a bug at https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/874501 about it

and for me deleting keyring files didn't work as gnome-keyring-daemon seems can't write keyring files

Download full text (3.7 KiB)

Similarly for me - renaming the keyring file and creating a new keyring just makes the login prompt for UbuntuOne tell me that the keyring wasn't unlocked, or that a user pressed cancel on a dialog. It appears that Gnome Keyring just can't update keyring files.

I attached strace to the gnome keyring file, and this is the interesting part that happens:

open("/home/sauer/.gnome2/keyrings/default", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
stat64("/home/sauer/.gnome2/keyrings", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
stat64("/home/sauer/.gnome2/keyrings/login.keyring", {st_mode=S_IFREG|0600, st_size=2476, ...}) = 0
sendmsg(8, {msg_name(0)=NULL, msg_iov(2)=[{"l\3\1\1P\0\0\0\207\1\0\0O\0\0\0\6\1s\0\6\0\0\0:1.325\0\0"..., 96}, {"K\0\0\0Object does not have the 'or"..., 80}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 176
poll([{fd=4, events=POLLIN}, {fd=12, events=POLLIN}, {fd=14, events=POLLIN}, {fd=5, events=POLLIN}, {fd=15, events=POLLIN}, {fd=8, events=POLLIN}], 6, -1) = 1 ([{fd=8, revents=POLLIN}])
recvmsg(8, {msg_name(0)=NULL, msg_iov(1)=[{"l\1\0\0012\0\0\0001\0\0\0\227\0\0\0\1\1o\0(\0\0\0/org/fre"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 218
recvmsg(8, 0xbffd67c8, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)

It repeatedly tries to open a file named default - which does not exist - and then ultimately does this:

send(16, "<35>Oct 16 15:16:51 gnome-keyrin"..., 110, MSG_NOSIGNAL) = 110
write(2, "\n** (gnome-keyring-daemon:2080):"..., 109) = -1 EBADF (Bad file descriptor)
time(NULL) = 1318796211
send(16, "<36>Oct 16 15:16:51 gnome-keyrin"..., 129, MSG_NOSIGNAL) = 129
write(2, "\n** (gnome-keyring-daemon:2080):"..., 127) = -1 EBADF (Bad file descriptor)
sendmsg(8, {msg_name(0)=NULL, msg_iov(2)=[{"l\3\1\1)\0\0\0\212\1\0\0O\0\0\0\6\1s\0\6\0\0\0:1.325\0\0"..., 96}, {"$\0\0\0Couldn't create item: Intern"..., 41}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 137

On a later attempt, I see this:

link("/home/sauer/.gnome2/keyrings/login.keyring", "/home/sauer/.gnome2/keyrings/login.keyring.temp-1811546333") = 0
gettimeofday({1318796511, 400588}, NULL) = 0
open("/home/sauer/.gnome2/keyrings/.temp-2MBJ3V", O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0600) = 22
write(22, "GnomeKeyring\n\r\0\n\0\0\0\0\0\0\0\5login\0\0\0"..., 2476) = 2476
fsync(22) = 0
close(22) = 0
rename("/home/sauer/.gnome2/keyrings/.temp-2MBJ3V", "/home/sauer/.gnome2/keyrings/login.keyring") = 0
unlink("/home/sauer/.gnome2/keyrings/login.keyring.temp-1811546333") = 0
sendmsg(8, {msg_name(0)=NULL, msg_iov(2)=[{"l\3\1\1\35\0\0\0\222\1\0\0O\0\0\0\6\1s\0\6\0\0\0:1.325\0\0"..., 96}, {"\30\0\0\0Couldn't set item secret\0", 29}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 125
poll([{fd=4, events=POLLIN}, {fd=12, events=POLLIN}, {fd=14, events=POLLIN}, {fd=5, events=POLLIN}, {fd=15, events=POLLIN}, {fd=8, events=POLLIN}], 6, -1) = 1 ([{fd=8, revents=POLLIN}])
recvmsg(8, {msg_name(0)=NULL, msg_iov(1)=[{"l\1\0\1\274\1\0\0D\0\0\0\267\0\0\0\1\1o\0(\0\0\0/org/fre"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOE...

Read more...

Later on, I copied my existing login.keyring to a file named "default,keyring". That caused the ubuntuOne application to prompt me to create a new keyring named default. If I typed a password in, each time, I would be told that a user pressed cancel on the application. But if I allowed the keyring daemon to "create a new keyring named default", and just hit ok with no password (and clicked "store passwords insecurely"), It worked fine.

I'm now connected to UbuntuOne on the broken machine, but in the passwords and keys app, I have an empty keyring named default, my old keyring named login, and a new one named default_1 which contains my UbuntuOne password.

Oddly, the file command shows that default_1.keyring is just ASCII text, while the login.keyring is recognized as
login.keyring: GNOME keyring, major version 0, minor version 0, crypto type 0 (AEL), hash type 0 (MD5), name "login", last modified Mon Dec 14 08:11:29 2009, created Mon Dec 14 08:11:29 2009, not locked if idle, hash iterations 1653, salt 3211078258452735141, 6 item(s)

So, I went in and changed the password on default_1 - the new keyring created when I started up UbuntuOne. I could still run u1sdtool -q / -c, and it would reconnect fine. Then I shut down UbuntuOne, deleted the UbuntuOne password from default_1, and ran u1sdtool -c. It opened up the login prompt as it should, and went ahead and logged in. It created a new entry (ID #2, even though #1 was deleted) in the default_1 keyring.

So, this seems to be a collection of keyring failures:
 1) creating a new-format keyring with a password always returns failure (probably because it defaults to not being unlocked?)
 2) whatever call UbuntuOne is using, it can't seem to add entries to the old format keyring
  2a) the password and keys app can happily add and remove passwords from both the new and old-format keyrings

The full workaround for UbuntuOne appears to be
  1) move old keyring file out of the way
  2) allow UbuntuOne to create a new keyring with an empty password
  3) move the old keyrinng back into the keyrings directory
  4) start up Passwords and Keys and set an actual password on the new keyring

Roman Yepishev (rye) wrote :

Ubuntu SSO now may now show this error if gnome-keyring is not willing to cooperate. I.e. the failure to request the keys leads the code to try the older method signature and fails even though the original error is not related to the signature.

tehu (canclaux) on 2011-10-28
description: updated
kapetr (kapetr) wrote :

I have the same problem as described in #50.

- clean installation of U 11.10 (with all updates)
- Unity 2D
- can not connect to my Ubuntu One account

I'm glad to see, that this Bug has "high" priority, but it is quite old ?!
How is it possible, that is it not still repaired ?
Does it appear on all Oneiric Ocelot installations ?! Or just by someone ?

Roman Yepishev (rye) wrote :

Could those who experience this error please clarify what locale are you using?

fishears (johnnyp-ntlworld) wrote :

LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

kapetr (kapetr) wrote :

Hello again, I have make some tests.

This bug report is about ubuntuone-client set as invalid, but I have great problem even with U1.

- I have clean !!! installation of U11.10 final with all updates (no upgrade, no imported HOME or .gnome(2) dirs, no created accounts of on-line services, ....)
- used Unity 2D, encrypted HOME, no autologin (if this matter)

- when I run U1 client and try to sign-in in my existent U1 account (cloud storage) with proper email/password I get discussed ERROR: Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist

I have read all here, but it seem that this should be already repaired - but it isn't :

- ubuntu-sso-client version: 1.4.0

It is discussed here and elsewhere, it affect only upgraded systems with imported "old" style keyrings or what - sorry I don't understand these things ..

- I have .gnome2 and .gnome2_private in HOME, but I didn't create them. U11.10 did it - so they are for something necessary.
Tests:

a/ if I rename login. keyring in ~/.gnome2/keyrings I get from U1 error: Authentication failed (with correct email/pass of course)
b/ if I rename whole ~/.gnome2 then after enter email/passw in U1 I get popup for new password for new created keyring, but after doing that I get from U1 error message: "The user canceled a prompt." (on the U1 login window again).
c/ If I rename the /.gnome2, then after log off -> log in is it created again (with login.keyring). If I try then U1, then I get again the ------- Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist ------ error message on U1 login screen.

So ... I really need U1 (Ubuntu One) and therefore is U11.10 final! for me somewhat unusable.

Once again - this is not old fixed bug, it happens in newest updated final release of U11.10

Please - how to fix this ?
It is really this bug (discussed in this bug report) ? Is it not different - bug?

Thanks and sorry please my English ;-)

P.S.: see also

http://askubuntu.com/questions/73504/i-cant-login-to-ubuntu-one/
http://askubuntu.com/questions/74035/not-able-to-sign-in-ubuntu-one-with-org-freedesktop-secret-collection-error

Roman Yepishev (rye) wrote :

Hello all,

In order to help to debug this (and at least see what's the underlying error) I have built a package that does not use the fallback code path. Those who experience this bug on Oneiric can test it from my PPA:
https://launchpad.net/~rye/+archive/ubuntuone-support

sudo apt-add-repository ppa:rye/ubuntuone-support
sudo apt-get update
sudo apt-get install ubuntu-sso-client

Please relogin after installing this package and try to reproduce the issue. I am extremely interested in the message that will be displayed now. I suspect it will be somehow different from the one in the bug title.

kapetr (kapetr) wrote :

Hello (rye).

After doing that, I get in U1 login window error message: "Couldn't set item secret."

Or if you have mean some logs, then you must me tell how to get them - what I have to run from cmd line, ....

Roman Yepishev (rye) wrote :

kapetr, great. This looks like a gnome-keyring bug after all.
Could you please create a new bug report using the command "ubuntu-bug gnome-keyring" and give the link to it here so that we could redirect the users who see this signature-related error in Oneiric to a new bug report?

kapetr (kapetr) wrote :

Did it right now.
I hope it will help.

Thank you

Alessio (alessio) wrote :

kapter your gnome-keyring bug maybe could be a duplicate of mine https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/874501

take a look into /var/log/auth.log to see if you have the same log messages I reported

Roman Yepishev (rye) wrote :

I have built a gnome-keyring package with the patch from bug #874501 in ppa:rye/ubuntuone-support
Please update the package repositories and install new gnome-keyring version:
sudo apt-get update
sudo apt-get upgrade

Alessio (alessio) wrote :

Roman your packages seems work, now gnome-keyring correctly save passwords and fix the ubuntuone login
as I suspected the problem was gnome-keyring

Alejandro J. Cura (alecu) wrote :

Thanks a lot Roman for your work on uncovering this elusive issue.
I'm interested in adding a check for this in txsecrets, so a similar bug is not recognized as a mismatched gnome-keyring version, but instead reported as the original error. Any ideas?

Roman Yepishev (rye) wrote :

So, If you see the message "Method "CreateItem" with signature "a{sv}(oayay)b" on interface "org.freedesktop.Secret.Collection" doesn't exist" now in Oneiric, this is gnome-keyring bug LP: #874501

kapetr (kapetr) wrote :

Thank you very much, gentlemen !

After upgrade of all files in this PPA (just upgrade gnome-keyring was not enough - I have try it) I could finally log in Ubuntu One storage :-))

I would like to ask just two Q more:

1. It seems to be common error, which should affect all users of U11.10.
But it is not so. How is possible, that someone could log in Ubuntu One without this error and other not ?

2. What exactly mean, that "Fix is released" ? I mean - will this fix in short time be available in "normal" Ubuntu 11.10 repos or will it be only in this PPA up to release of U12.04 ? (I mean it in common, not just in this bug case)

Ones more thanks

--kapetr

Ravioli (ravioli) wrote :

Okay, it seems that this bug is finally fixed. Thanks!

I have the same question as kapetr: Will this fix be officially available via Update Manager? It definitely should be!

John Dyson (thejohndyson) wrote :

I have this problem still. Even after the upgrade above and again I am using fresh install of 11.10
John

meist3r (meist3r) wrote :

Same issue here, fresh install of Oneiric 11.10 then installed lubuntu-desktop and now using Lubuntu/LXDE. Proposed Updates from repositories. ubuntu-sso-client 1.4.0-ubuntu1.

Ubuntu One works fine on my upgraded Oneiric install on laptop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments