No defualt root fs was found, or one was found and it didn't containg a message = congig file

Bug #454277 reported by fraggle@ptd.net on 2009-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu PS3 Port
Undecided
Unassigned

Bug Description

No prior install performed. I attempted to try petit but all the files on line were corrupt. Trying to install Ubuntu 9.04 with kboot 11

Any idea's

fraggle@ptd.net (fraggle-ptd) wrote :

Step by step followed was format hhd custom w/10gigs to other os. installed kboot, restarted the PS3 and now this is where I am stuck.

Burhan Gondal (burhangondal) wrote :

i m having the same bug/problem with my ps3....even tho i went through installation and everything was going ok but wen it was done installing and rebooted and i got this error message...duno wadda hell is wrong with this....help will be appreciated thanks...

Burhan Gondal (burhangondal) wrote :

nvm i solved the problem by installing ubuntu 9.04....everything works perfectly...problem seems to be in new version of ubuntu 9.10....its not stable yet as i think....developers gotta fix this bug thanks

Arnaud Jeansen (ajeans) wrote :

@ Burhan
Your bug is different from the first reporter as you managed to do the Ubuntu install.
In my opinion, it didn't work because the new filesystem default on 9.10 is ext4, which is not accepted by kboot (there are other bugs mentioning this in launchpad).
Using 9.04 installs correctly with default options, because ext3 was still the default at that time.

@ Fraggle
Did you install the kboot provided on the ubuntu cd or was it one from a different site / distribution ? I always use ubuntu's kboot because it works for me.I have never used petitboot, but if ubuntu's kboot doesn't work for you, you should try it (maybe ask on ps3buntu forums, there are serious tweakers there :-)).

MHAQS (mhaqsb) wrote :

The only reason for the PS3 to show that error is because PS3 can't read ext4. Format your drive to ext3 and reinstall ubuntu.

I can confirm that choosing another filesystem during install:
10,2 gb [b]ext3[/b] and use as: "root filesystem" "/"
509 mb swap swap
does work out with the Ubuntu 9.10 altenate install .iso + kboot bundled with it
[i]or[/i]
something I came across as mentioned on [url]http://psubuntu.com/forums/viewtopic.php?f=5&p=8575][/url]
using an upgraded petitboot.

Quipeace (quipeace) wrote :

The problem here is that the kboot version bundled with 9.10 isn't compatible with ext4... Install petitboot, at least for now.

Quipeace (quipeace) wrote :

Oops, read the wrong post...
Anyway, try installing petitboot anyway, and redownload and reburn the disk at the lowest speed possible (4x or so)

Itchione (paulmika) wrote :

Today i downloaded xubuntu 10.04 desktop edition ISO and burned it to DVD.
After formatting the complete PS3 HDD and allocating 10GB to 'other-os', i installed the boot manager (kboot) from the DVD.
All dialogs were processed ok and the system was for all purposes installed using the automatic partitioning option.
However it hung at the last reboot stage but before the DVD was ejected.
On power cycling the PS3, i also received warnings of no default root file system being found.
I googled to find that the cause was due to combination of kboot and/or the PS3's inability to 'see' the EXT4 file system.
Seems that kboot and/or PS3 still has the EXT4 issue!

I installed a new boot manager, petitboot but obviously EXT4 was still an issue and no default root fs was found.
I then reinstall xubuntu over the top of the existing install but this failed at the manual partitioning stage.
I was offered a partitioning dialogue to 'try again', 'continue' or 'cancel'.
I tried again but later canceled the partitioning/install after again being presented with the same partitioning dialogue.
Finally I again reformatted the complete PS3 HDD allocating 10G to other-os.
I then installed petitboot followed by xubuntu but chose custom partitioning creating an ext3 file system and some swap.
This time all went well, though it took some time, the DVD was ejected and the PS3 restarted OK.

So in summery, xubuntu 10.04 installs but kboot/ext4 is still an issue.
There is some odd problems with the partitioning tool on xubuntu if you try and reinstall over the top of EXT4 partition.
Petitboot works well and has a nice graphical interface and with a simple 'delete' key press goes back to XMB.

Have yet to check if/how one connects the PS3 bluetooth controller (& later the keyboard) so it can work with petitboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers