gnome-language-selector is not MATE compatible [debdiff attached]

Bug #1550325 reported by Martin Wimpress on 2016-02-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
im-config (Ubuntu)
Medium
Gunnar Hjalmarsson
language-selector (Ubuntu)
Medium
Martin Wimpress

Bug Description

The gnome-language-selector fallback input method is 'xim', which is not compatible with some applications when running under MATE. For example:

  * https://bugs.launchpad.net/synapse-project/+bug/1219314

gnome-language-selector should use the same defaults for MATE as it does for Unity.

description: updated
Martin Wimpress (flexiondotorg) wrote :

The attached debdiff adds MATE support to language-selector.

summary: - The default input method configured by gnome-language-selector is not
- MATE compatible
+ The input method configured by gnome-language-selector is not MATE
+ compatible [debdiff attached]
summary: - The input method configured by gnome-language-selector is not MATE
- compatible [debdiff attached]
+ gnome-language-selector is not MATE compatible [debdiff attached]
description: updated
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Martin,

language-selector-gnome reflects what im-config does in this respect, so this requires that im-config is changed too to keep them in sync.

I uploaded language-selector and attach an im-config patch.

affects: language-selector → language-selector (Ubuntu)
Changed in language-selector (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → Medium
status: New → Fix Committed
Changed in im-config (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.157

---------------
language-selector (0.157) xenial; urgency=medium

  * LanguageSelector/ImConfig.py: Add MATE compatibility. (LP: #1550325)

 -- Martin Wimpress <email address hidden> Fri, 26 Feb 2016 13:17:41 +0000

Changed in language-selector (Ubuntu):
status: Fix Committed → Fix Released
Martin Wimpress (flexiondotorg) wrote :

Gunnar, thanks very much for helping with this. It is much appreciated :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package im-config - 0.29-1ubuntu9

---------------
im-config (0.29-1ubuntu9) xenial; urgency=medium

  * debian/patches/02-ubuntu-system-default.patch:
    Make "auto" the system default for MATE (LP: #1550325).

 -- Gunnar Hjalmarsson <email address hidden> Fri, 26 Feb 2016 17:34:00 +0100

Changed in im-config (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-mate:
status: New → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

Martin,

It struck me that the fix of this bug probably makes bug #1501832 resurrect. Comments?

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-03-05 19:24, Gunnar Hjalmarsson wrote:
> It struck me that the fix of this bug probably makes bug #1501832
> resurrect.

Second thoughts: I no longer think it will be a problem, but I sent a message to the bug reporter and asked him to test.

Martin Wimpress (flexiondotorg) wrote :

I also don't think it will be a problem because selecting fcitx will do "the right thing". This fix is to ensure a no action configuration doesn't default to xim.

Alkis Georgopoulos (alkisg) wrote :

Hi, this patch indeed caused bug #1501832 to resurrect.

Test case:
Boot with ubuntu-mate-16.04.1-desktop-i386.iso
Select "Greek" in syslinux.
Select the live session.
Open mate-terminal.
Press Alt+Shift to switch to the Greek keyboard layout.
Type ; and then type a.
This is supposed to show ά.
Instead, it shows ´α.

Alkis Georgopoulos (alkisg) wrote :

Since both gnome-flashback and MATE have the same issue,
while Unity doesn't have it,
I think MATE should match gnome-flashback in both language-selector and /etc/default/im-config, not Unity.

Btw, when I experience this issue, `ps aux` shows [fcitx] <defunct>.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2016-07-21 21:57, Alkis Georgopoulos wrote:
> Hi, this patch indeed caused bug #1501832 to resurrect.

There is an issue with the Ubuntu MATE live session, but I don't think the fix of this bug is the primary cause. I could see the issue when running a live Swedish session, i.e. the dead keys were broken.

On 2016-07-21 22:01, Alkis Georgopoulos wrote:
> Btw, when I experience this issue, `ps aux` shows [fcitx] <defunct>.

Right. The fcitx-bin package is present in the live session, and it looks like im-config tries to start fcitx but fails. The IM configuration is inconsistent:

ubuntu-mate@ubuntu-mate:~$ env | grep -E '(_IM|XMOD)'
CLUTTER_IM_MODULE=xim
QT_IM_MODULE=xim
XMODIFIERS=@im=fcitx
QT4_IM_MODULE=xim
GTK_IM_MODULE=xim

Btw, the issue was present also when I tried a live Chinese session.

I would suggest that a separate bug is submitted about IM configuration in Ubuntu MATE live session.

With that said, I have filed <https://launchpad.net/bugs/1605408>, and when it has been fixed, making Ubuntu MATE work in the same way as e.g. Xubuntu and Lubuntu in this respect would be an option. But that wouldn't address this new issue for those who need fcitx in the live session.

Alkis Georgopoulos (alkisg) wrote :

Gunnar Hjalmarsson (gunnarhj) wrote 2 hours ago:
> I would suggest that a separate bug is submitted
> about IM configuration in Ubuntu MATE live session.

Reverting the fix of this current bug report solves the regression, but OK, I've filed LP bug 1605571 as you requested.

I found out that this happens when fcitx-bin is installed with --no-install-recommends, as is the case in the ubuntu-mate live CD.

Let's continue there. Thanks! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers