Crashes on keyboard input

Bug #1219314 reported by Lee Hyde on 2013-08-31
158
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Synapse
High
Rico Tzschichholz

Bug Description

For approximately a week now, whenever I type anything into Synapses input/search box Synapse crashes. Synapse starts fine (as far as I can see), is summoned and visible on-screen, but typing elicits no visible input in Synapse and it swiftly crashes there after. Running Synapse via terminal results in the following output (note that the last line corresponds to when I started typing input):

ch2lah@SBCS627LHLT:~/Download$ synapse
[21:26:46.035379 Info] Starting up...
[21:26:46.408337 Info] [UILauncher] Binding activation to <Control>space
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[21:26:46.451816 Info] [GuiViewEssential] Screen is composited.
[21:26:46.453465 Info] [GuiViewEssential] Using xim input method.
[21:26:46.876001 Warning] desktop-file-service.vala:319: Desktop session type is not recognized, assuming GNOME.
[21:26:47.346996 Warning] [DesktopFileInfo] Unable to create AppInfo
Error calling StartServiceByName for org.gnome.Caribou.Keyboard: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/caribou/antler-keyboard exited with status 1
[21:26:47.811254 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:47.811301 Warning] desktop-file-service.vala:101: is not understood
[21:26:47.924533 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:48.359551 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:48.510031 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.174302 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.493411 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.566732 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.613029 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.613106 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.642978 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.654804 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.655929 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.727330 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.850143 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:49.852717 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.120087 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.132845 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.191471 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.222507 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.296179 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.335992 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.347822 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.376388 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.912889 Warning] desktop-file-service.vala:101: Pantheon is not understood
[21:26:50.946012 Warning] desktop-file-service.vala:101: Pantheon is not understood
Segmentation fault (core dumped)

Running Synapse version 0.2.99~bzr513+i18n+505~raring1 on an up to date Ubuntu 12.04 (Raring) x86-64 system. If there's any other debug information I can provide, please do not hesitate to request it.

Related branches

Changed in synapse-project:
assignee: nobody → Tom Beckmann (tombeckmann)
aslam karachiwala (akwala) wrote :

Happens consistently in Kubuntu 14.04, at the first attempt to input in the query field after launching.

Synapse v. 0.2.99~bzr520+i18n+522~ubuntu14.04.1

Command line output:
$ synapse
[20:36:08.925587 Info] Starting up...
[20:36:09.038667 Info] [UILauncher] Binding activation to <Control>space
[20:36:09.039973 Info] [GuiViewEssential] Using KWin compatibility mode.
[20:36:09.062625 Info] [GuiViewEssential] Screen is composited.
[20:36:09.063634 Info] [GuiViewEssential] Using xim input method.
[20:36:09.080133 Gdk-Critical] gdk_window_shape_combine_region: assertion 'GDK_IS_WINDOW (window)' failed
[20:36:09.080168 Gdk-Critical] gdk_window_shape_combine_region: assertion 'GDK_IS_WINDOW (window)' failed
[20:36:09.319682 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.327053 Warning] [DesktopFileInfo] Not Application-type desktop entry
[20:36:09.354272 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.372955 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.375063 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.375508 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.375733 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.377408 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.379551 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.380220 Warning] [DesktopFileInfo] Unable to create AppInfo
[20:36:09.391546 Warning] [DesktopFileInfo] Unable to get exec for Evolution Data Server
[20:36:09.410731 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.411176 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.411335 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.411717 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.412201 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.412367 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.412524 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.412685 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.412844 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.413497 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.413670 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.414049 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.414627 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.415452 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.415609 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.415773 Warning] desktop-file-service.vala:487: Invalid key name: Path[$e]
[20:36:09.653153 Info] [HybridSearchPlugin] keeps in cache now 895 file names
Segmentation fault (core dumped)

Nikke (nmellegard) wrote :

I had the same issue and it was caused by the xim input method. For some reason (probably my own) synapse suddenly switched from ibus to xim, and the problem started.

Try:
1. Remove ~/.xinputrc
2. Run im-config and set it to Auto
3. Restart X

Then, run synape again and verify that the debug printout says:
[20:36:09.063634 Info] [GuiViewEssential] Using ibus input method.

If is still shows xim, run sudo im-config

All the best,
Niklas

Joe Gibken (joegibken) wrote :

Edit: Oops. Jejeh. Kindly disregard #3 & #4. Sorry.

I'm also getting the same error. And I can't seem to change xim into ibus and I don't have ~/.xinputrc. Even when I used sudo im-input, the "xim input method" is still there. (Of course, I already restarted X).

This is what shows in my im-config now:

Current configuration for the input method:
 * Active configuration: ibus (normally missing)
 * Automatic configuration: ibus (normally ibus or fcitx or uim)
 * Number of valid choices: 2 (normally 1)

My version is synapse 0.2.99~bzr520+i18n+522~ubuntu14.04.1

[14:52:15.231038 Info] Starting up...
[14:52:15.318332 Info] [UILauncher] Binding activation to <Control>space
[14:52:15.343902 Info] [GuiViewVirgilio] Screen is composited.
[14:52:15.345270 Info] [GuiViewVirgilio] Using xim input method.
[14:52:15.396194 Warning] desktop-file-service.vala:321: Desktop session type is not recognized, assuming GNOME.
[14:52:15.484361 Warning] [DesktopFileInfo] Unable to create AppInfo
[14:52:15.501997 Warning] [DesktopFileInfo] Unable to create AppInfo
[14:52:15.502247 Warning] [DesktopFileInfo] Unable to create AppInfo
[14:52:15.562117 Warning] [SshPlugin] /home/<user>/.ssh/config: Error opening file: No such file or directory
[14:52:15.798678 Info] [HybridSearchPlugin] keeps in cache now 341 file names
Segmentation fault

Any help in fixing this is appreciated.

Mario (dodiesis) wrote :

Try to set GTK_IM_MODULE='' before running synapse

$ GTK_IM_MODULE='' synapse

Download full text (3.2 KiB)

I have been using synapse with cairo-dock for quite some time now without a hitch. Works very well and I need it on my machine. But after a reinstall of Ubuntu 14.10 it has started crashing as soon as any keyboard input is sent to it.

The messages when synapse is run from the terminal are given below. Synapse version is 0.2.99.1 from the synapse core repo.

(Note: " Binding <Super>y failed because the key combo is being used by Gnome-do at the moment :). )

WHAT WORKED FOR ME: Mario's suggestion that I set GTK_IM_MODULE=' ' before running synapse.

WHAT DID NOT WORK: the im-config and sudo im-config stuff

Cheers

*********************************************************
[synapse-main:268] Starting up...
[INFO 13:14:54.080743] [synapse-main:211] Binding activation to <Super>y
[WARN 13:14:54.081081] Binding '<Super>y' failed!
[INFO 13:14:54.095911] [view-base:251] Screen is composited.
[INFO 13:14:54.096512] [controller:59] Using xim input method.
[WARN 13:14:54.232100] [desktop-file-service:193] Unable to get exec for Photos lens for Unity
[WARN 13:14:54.260799] [desktop-file-service:193] Unable to get exec for Evolution Data Server
[WARN 13:14:54.262483] [desktop-file-service:193] Key file contains key 'Terminal' which has a value that cannot be interpreted.
[WARN 13:14:54.275924] [desktop-file-service:193] Unable to create AppInfo for /home/pramathesh/.local/share/applications/userapp-kodi-SMVTRX.desktop
[WARN 13:14:54.276158] [desktop-file-service:193] Unable to create AppInfo for /home/pramathesh/.local/share/applications/userapp-kodi-S9JNRX.desktop
[INFO 13:14:54.281124] [gnome-session-plugin:158] org.gnome.SessionManager is available
[WARN 13:14:54.306387] [ssh-plugin:116] /home/pramathesh/.ssh/config: Error opening file: No such file or directory
[INFO 13:14:54.325429] [hybrid-search-plugin:179] keeps in cache now 1218 file names
Segmentation fault (core dumped)
pramathesh@niranjan-ub:~/Downloads/synapse-0.2.99.1/src/ui$ sudo synaptic
[sudo] password for pramathesh:
pramathesh@niranjan-ub:~/Downloads/synapse-0.2.99.1/src/ui$ ./synapse
[INFO 13:17:16.348226] [synapse-main:268] Starting up...
[INFO 13:17:16.406435] [synapse-main:211] Binding activation to <Super>y
[WARN 13:17:16.406712] Binding '<Super>y' failed!
[INFO 13:17:16.422526] [view-base:251] Screen is composited.
[INFO 13:17:16.423159] [controller:59] Using xim input method.
[WARN 13:17:16.569157] [desktop-file-service:193] Unable to get exec for Photos lens for Unity
[WARN 13:17:16.596306] [desktop-file-service:193] Unable to get exec for Evolution Data Server
[WARN 13:17:16.598024] [desktop-file-service:193] Key file contains key 'Terminal' which has a value that cannot be interpreted.
[WARN 13:17:16.611509] [desktop-file-service:193] Unable to create AppInfo for /home/pramathesh/.local/share/applications/userapp-kodi-SMVTRX.desktop
[WARN 13:17:16.611725] [desktop-file-service:193] Unable to create AppInfo for /home/pramathesh/.local/share/applications/userapp-kodi-S9JNRX.desktop
[INFO 13:17:16.616765] [gnome-session-plugin:158] org.gnome.SessionManager is available
[WARN 13:17:16.639890] [ssh-plugin:116] /home/pramathesh/.ssh/config: Error opening file: No such file or dir...

Read more...

aamadis (aamadis) wrote :

Using "GTK_IM_MODULE='' synapse" in a terminal also worked for met I didn't want to have to runsynapse in a terminal every time I used it I added these lines to my .bashrc file located in the HOME folder.

# set gtk im module to default (to make synapse work)
 export GTK_IM_MODULE=" "

The first line is just for clarity's sake and not necessary, but now Synapse works properly.

jay armstrong (jayarmstrong) wrote :

+1 in Xubuntu 15.04

workaround in #6 works

Changed in synapse-project:
importance: Undecided → Medium
assignee: Tom Beckmann (tombeckmann) → nobody
summary: - Segmentation Fault Upon Attempting to Type in the Input/Search Box
+ Crashes on keyboard input
Changed in synapse-project:
milestone: none → 0.2.99.3
assignee: nobody → Rico Tzschichholz (ricotz)
importance: Medium → High
status: New → In Progress
status: In Progress → Fix Committed
James Pack (james-packjr) wrote :

#6 'Try to set GTK_IM_MODULE='' before running synapse

$ GTK_IM_MODULE='' synapse'

Works for me too on Ubuntu MATE 16.04

Song (syqlds) wrote :

#6 works but still waiting for the fix release

Guy Verrijdt (gverrijdt) wrote :

#6 works for me too, but can't seem to make it work on autostart, so waiting for the fix as well...

Linux Mint 17.2 MATE

Changed in synapse-project:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers