java crashed with SIGABRT in soup_session_feature_detach()

Bug #1163501 reported by Francesco Astegiano on 2013-04-02
234
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Eclipse
Fix Released
Medium
Ubuntu GNOME
Undecided
GNOME3 Team
openjdk-7 (Ubuntu)
Undecided
Unassigned

Bug Description

Eclipse was working fine before last openjdk update (Sun, 31 Mar 2013, version 7u17-2.3.8-1ubuntu1). Now I have random jvm crashes whith the following trace and attached dump.

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fb64ef6b049, pid=26217, tid=140421837121280
#
# JRE version: 7.0_17-b02
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libsoup-2.4.so.1+0x6e049] soup_session_feature_detach+0x19
#

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: openjdk-7-jre-headless 7u17-2.3.8-1ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Tue Apr 2 17:25:05 2013
ExecutablePath: /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java
InstallationDate: Installed on 2013-02-11 (50 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130210)
MarkForUpload: True
ProcCmdline: /usr/bin/java -Xms40m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.dist.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib/eclipse//plugins/org.eclipse.platform_3.8.1.dist/splash.bmp -launcher /usr/lib/eclipse/eclipse -name Eclipse --launcher.library /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.dist/eclipse_1503.so -startup /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.dist.jar --launcher.overrideVmargs -exitdata 1208006 -vm /usr/bin/java -vmargs -Xms40m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.dist.jar
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: openjdk-7
StacktraceTop:
 soup_session_feature_detach () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: java crashed with SIGABRT in soup_session_feature_detach()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

information type: Private → Public
g00fy (herbert-software) wrote :

Today i upgraded to 13.04 - same problem here.

My openjdk-7 version: 7u17-2.3.8-1ubuntu1

While my eclipse crashed several times i also had Wuala and JDownloader running (both java-applications), none of them crashed.

Changed in openjdk-7 (Ubuntu):
status: New → Confirmed
g00fy (herbert-software) wrote :

Now i manually downgraded to openjdk-7 version 1.7.0_15 from quantal (12.10), but the problem persists.

The crash happens approximatly a half to one second after the code-context-menu shows up. i don't know the official name of this menu, i mean the window which shows up if you type for example "System." it shows up after typing the dot on the end.

Created attachment 229266
Patch for the crash

With recent versions of WebKitGTK+, Eclipse crashes whenever Javadoc hover help is to be displayed in Java editor.

Looks this happens because WebKit doesn't attach a default Authenticate listener and therefore WebKitGTK.soup_session_get_feature() returns 0 in WebKit.create(). See attached patch for fix.

Reproduced with all 3.8, 4.2 and 4.3 versions of SWT.

Created attachment 229267
Example crash report

Created attachment 229268
Patch for the crash

Bug unrelated to openjdk, same behavior with previous versions or oracle jdk
Purging gnome3 ppa did solved the issue so I'm moving it against gnome-shell project

affects: openjdk-7 (Ubuntu) → gnome-shell
Changed in gnome-shell:
status: Confirmed → New
assignee: nobody → GNOME3 Team (gnome3-team)

Thanks for investigating this Jakub, targeting for 4.3. From the crash report:

Stack: [0x00007f3e62e0d000,0x00007f3e62f0e000], sp=0x00007f3e62f0b3a0, free space=1016k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libsoup-2.4.so.1+0x72d59] soup_session_feature_detach+0x19

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.swt.internal.webkit.WebKitGTK._soup_session_feature_detach(JJ)V+0
j org.eclipse.swt.internal.webkit.WebKitGTK.soup_session_feature_detach(JJ)V+9
j org.eclipse.swt.browser.WebKit.create(Lorg/eclipse/swt/widgets/Composite;I)V+919
j org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/Composite;I)V+81
j org.eclipse.jface.internal.text.html.BrowserInformationControl.isAvailable(Lorg/eclipse/swt/widgets/Composite;)Z+12
j org.eclipse.jdt.internal.ui.text.java.hover.JavadocHover$HoverControlCreator.doCreateInformationControl(Lorg/eclipse/swt/widgets/Shell;)Lorg/eclipse/jface/text/IInformationControl;+18
j org.eclipse.jface.text.AbstractReusableInformationControlCreator.createInformationControl(Lorg/eclipse/swt/widgets/Shell;)Lorg/eclipse/jface/text/IInformationControl;+20
j org.eclipse.jface.text.AbstractInformationControlManager.getInformationControl()Lorg/eclipse/jface/text/IInformationControl;+176
j org.eclipse.jface.text.AbstractInformationControlManager.internalShowInformationControl(Lorg/eclipse/swt/graphics/Rectangle;Ljava/lang/Object;)V+18
j org.eclipse.jface.text.AbstractInformationControlManager.presentInformation()V+70
j org.eclipse.jface.text.AbstractHoverInformationControlManager.presentInformation()V+64
j org.eclipse.jface.text.TextViewerHoverManager.doPresentInformation()V+1
j org.eclipse.jface.text.TextViewerHoverManager$5.run()V+4
j org.eclipse.swt.widgets.RunnableLock.run()V+11
j org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Z)Z+29
j org.eclipse.swt.widgets.Display.runAsyncMessages(Z)Z+5
j org.eclipse.swt.widgets.Display.readAndDispatch()Z+61
j org.eclipse.ui.internal.Workbench.runEventLoop(Lorg/eclipse/jface/window/Window

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: gnome-shell → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Josh Adams (knewter) wrote :

I'm experiencing this same bug. Started happening today.

Java version:

$ java -version
java version "1.7.0_15"
Java(TM) SE Runtime Environment (build 1.7.0_15-b03)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

libsoup issue:

# Problematic frame:
# C [libsoup-2.4.so.1+0x6e049] soup_session_feature_detach+0x19

Tim (darkxst) wrote :

This is more likely due to an ABI change in the updated libsoup package on the gnome3 ppa, it is definitely not related to gnome-shell

affects: gnome-shell (Ubuntu) → ubuntu-gnome
Rajesh KSV (rajeshksv37-h) wrote :

Any updates plz ? Eclipse is no longer usable with this bug :( Please fix it. Thanks

Rajesh KSV (rajeshksv37-h) wrote :

Or any workaround to use eclipse ?

Simon Cedergren (c-simon) wrote :

I'm also affected by this bug.

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fb7a3912ff9, pid=12614, tid=140429420054272
#
# JRE version: 7.0_17-b02
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libsoup-2.4.so.1+0x6cff9] soup_session_feature_detach+0x19
#

ReeCreate (reesclissold) wrote :

Same issue running Oracle JDK 7.

Ubuntu 13.04 / Gnome 3.8 from official Gnome PPA.

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007eff6acc2049, pid=4791, tid=139638173193984
#
# JRE version: 7.0_17-b02
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libsoup-2.4.so.1+0x6e049] soup_session_feature_detach+0x19
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/rees/hs_err_pid4791.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

ReeCreate (reesclissold) wrote :

Have just run an apt-get upgrade and there are now some updates to various eclipse-related packages. This seems to have resolved the issue.

Simon Cedergren (c-simon) wrote :

Where did you get your updates from? Mine does not upgrade any eclipse-related packages.

ReeCreate (reesclissold) wrote :

According to "apt-cache policy" the following packages were updated at 2013-04-11 at 13:11 BST:

eclipse-jdt:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

eclipse-platform-data:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

eclipse-pde:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

eclipse-rcp:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

eclipse:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

eclipse-platform:
  Installed: 3.8.1-1ubuntu1
  Candidate: 3.8.1-1ubuntu1
  Version table:
 *** 3.8.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

It appears from the above that all of the packages came from the GB mirror of the official raring universe repos. Of course, I'm not sure if these are the packages that fixed the bug as there were some other packages relating to Unity and Compiz, however I think it's a fairly safe assumption to make.

My previous apt-get upgrade to this was at 10:42 BST yesterday morning (2013-04-10).

keyrn (pjayala-gmail) wrote :

Although those packages might work, that still means you can't download and run Eclipse from the web site or any other "eclipse" built, like SpringToolSuite.

Richard Ayotte (rich-ayotte) wrote :

Same problem in Aptana Studio which of course is based on Eclipse.

# JRE version: 7.0_17-b02
# Java VM: OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libsoup-2.4.so.1+0x6e049] soup_session_feature_detach+0x19

Hi,

Same problem also with Vuze.

Andrea Baccega (vekexasia) wrote :

Having the same issue here. Tried 2 different versions of oracle java and did not change the result.

I confirm it does not work with a downloaded version of eclipse. Indeed the android sdk bundle does not work due to this bug but it was working before.

A workaround would be really appreciated :)

Tim (darkxst) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in ubuntu-gnome:
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Tim (darkxst) wrote :

This bug was caused by incompatiblity with the webkit update. It has been fixed in swt-gtk 3.8.2-1.

Pre-built download binaries will need to be patched, but that is not something we have any control.

Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in eclipse:
importance: Unknown → Medium
status: Unknown → Confirmed
Richard Ayotte (rich-ayotte) wrote :

I don't have swt-gtk installed and Aptana still crashes with this error.

dpkg-query: package 'libswt-gtk-3-jni' is not installed and no information is available
dpkg-query: package 'libswtchart-java' is not installed and no information is available
dpkg-query: package 'libswt-cairo-gtk-3-jni' is not installed and no information is available
dpkg-query: package 'libswtcalendar-java' is not installed and no information is available
dpkg-query: package 'scilab-swt' is not installed and no information is available
dpkg-query: package 'libswt-gtk-3-java' is not installed and no information is available
dpkg-query: package 'libswt-gnome-gtk-3-jni' is not installed and no information is available
dpkg-query: package 'libswtchart-java-doc' is not installed and no information is available
dpkg-query: package 'libjfreechart-swt-java' is not installed and no information is available
dpkg-query: package 'libswt-gtk-3-java-gcj' is not installed and no information is available
dpkg-query: package 'libswt-webkit-gtk-3-jni' is not installed and no information is available
dpkg-query: package 'libswt-glx-gtk-3-jni' is not installed and no information is available

Richard Ayotte (rich-ayotte) wrote :

Aptana backtrace.

no longer affects: aptana-studio-installer
Tim (darkxst) wrote :

Richard, probably Aptana needs to be patched upstream (it doesnt seem to exist in our archives?), so best bet would be to file a bug on their bug tracker, linking to the upstream and/or debian reports.

Richard Ayotte (rich-ayotte) wrote :
Richard Ayotte (rich-ayotte) wrote :

Found a workaround. Put the following line in your eclipse.ini or AptanaStudio3.ini file.

-Dorg.eclipse.swt.browser.DefaultType=mozilla

*** Bug 405786 has been marked as a duplicate of this bug. ***

Reiner Jung (prefec2) wrote :

Thanks Richard, your workaround works.

Grant,
Any plans to accept the patch soon? It is impossible to launch Kepler builds on Fedora 19 because of this.

For a workaround add the following to the end of your eclipse.ini

-Dorg.eclipse.swt.browser.DefaultType=mozilla

(In reply to comment #6)
> For a workaround add the following to the end of your eclipse.ini
>
> -Dorg.eclipse.swt.browser.DefaultType=mozilla

Mozilla is even less reliable as it breaks with every firefox update ans SWT doesn't support recent xulrunner versions (20.0 here) -at least it wasn't last I checked.

Works for me on openSUSE 12.3

In which environment, the same one with GNOME 3.8 (separate repository GNOME:STABLE) using libsoup 2.42.0? See also bug 405786.
Also in this report there was said "with recent versions of WebkitGTK+" (which is not a standard OpenSUSE 12.3)

(In reply to comment #8)
> Works for me on openSUSE 12.3

Ah I am using GNOME:Stable:3.8 repo.

(In reply to comment #10)
> Ah I am using GNOME:Stable:3.8 repo.

I use apparently (almost) the same environment OpenSUSE 12.3 + GNOME:Stable:3.8 and it crashes. Before updating to GNOME:Stable:3.8 it didn't crash for several weeks of intensive work with Eclipse. Therefore I'd rather ask:
- You don't override -Dorg.eclipse.swt.browser.DefaultType in eclipse.ini?
- Did you try the Javadoc hovers in some open Java editor for a while?

(In reply to comment #11)
> (In reply to comment #10)
> > Ah I am using GNOME:Stable:3.8 repo.
>
> I use apparently (almost) the same environment OpenSUSE 12.3 +
> GNOME:Stable:3.8 and it crashes. Before updating to GNOME:Stable:3.8 it
> didn't crash for several weeks of intensive work with Eclipse. Therefore I'd
> rather ask:
> - You don't override -Dorg.eclipse.swt.browser.DefaultType in eclipse.ini?
> - Did you try the Javadoc hovers in some open Java editor for a while?

1. I have -Dorg.eclipse.swt.browser.DefaultType=mozilla in my eclipse.ini
2. Yes I did, I opened an Android project and checked docs for multiple functions. Works fine.

Oh Ismail, sorry, I think I got the message after I've noticed your comments above. You tried the workaround, not the standard Eclipse.
The workaround with the "mozilla" default type works for me, too, using Firefox 20 (xulrunner-17.0.5-2.1.x86_64).

(In reply to comment #11)
> (In reply to comment #10)
> > Ah I am using GNOME:Stable:3.8 repo.
>
> I use apparently (almost) the same environment OpenSUSE 12.3 +
> GNOME:Stable:3.8 and it crashes. Before updating to GNOME:Stable:3.8 it
> didn't crash for several weeks of intensive work with Eclipse. Therefore I'd
> rather ask:
> - You don't override -Dorg.eclipse.swt.browser.DefaultType in eclipse.ini?
> - Did you try the Javadoc hovers in some open Java editor for a while?

(In reply to comment #5)
> Any plans to accept the patch soon? It is impossible to launch Kepler builds
> on Fedora 19 because of this.

A fix will be in for 4.3M7. I don't have a built WebKitGTK 2.0 to use yet, and I want to do a good test pass with it.

The workaround does not work for me. I'm using Gnome from Ubuntu 13.04 and the latest version of Eclipse (from its website).

Fixed > 20130425, commit: http://git.eclipse.org/c/platform/eclipse.platform.swt.git/commit/?id=b22a7d19afbe2a3811a0f8aa54c1e85d92c62a2c .

Logged bug 406605 for new problem with the WebKitGTK 2.0 default authentication prompter.

*** Bug 406736 has been marked as a duplicate of this bug. ***

Changed in eclipse:
status: Confirmed → Fix Released

*** Bug 407076 has been marked as a duplicate of this bug. ***

*** Bug 407208 has been marked as a duplicate of this bug. ***

Just wanted you to know that adding the line to eclipse.ini seems to work for me under Ubuntu Gnome 13.04, upgraded to Gnome 3.8.1. Will the fix be part of this summer's Juno successor?

If not, I think the workaround info needs somehow to be spread, because this bug renders Eclipse totally unusable on newer Gnome-based linux distros, and this entry seems somewhat hard to find using google ... I didn't, which is the reason I created the duplicate, and I fear I won't have been the last.

(In reply to comment #19)
> Will the fix be part of this summer's Juno successor?

Yes, it will be in the June 4.3 release.

Jeroen Hoek (mail-jeroenhoek) wrote :

The mozilla workaround works, but causes problems with Eclipse plugins such as the color theme plugin. Only part of its configuration panel is shown, presumably because it crashes on the preview pane.

Is there a way to get a version of Eclipse 4.2 with the fix mentioned in #44?

In , Jlmoya (jlmoya) wrote :

The workaround didn't do it for me as eclipse 4.2.2 continues to crash. Does anyone have any other suggestion as to how to fix the problem? Would anyone be kind enough to explain how to apply the patch attached?

(In reply to comment #21)

To work around this with 4.2.2 you need to add two lines to the end of your eclipse.ini:

1. the line in comment 6
2. -Dorg.eclipse.swt.browser.XULRunnerPath=<path> where <path> is the full path to a downloaded XULRunner to use (XULRunner 10 is suggested since it's the latest supported release). If for some reason this does not work then you can substitute an invalid path for <path> (eg.- "/dev/null"), which will run with no browser support (base eclipse runs generally fine without browser support).

*** Bug 408680 has been marked as a duplicate of this bug. ***

Will (war59312) wrote :

CrashPlan is having this issue as well.

Waiting on support at the moment. Informed them of this bug report.

Will (war59312) wrote :

OK same fix works for crashplan.

1.) Stop CrashPlan service via:

sudo /usr/local/crashplan/bin/CrashPlanEngine stop

2.) gksudo gedit /usr/local/crashplan/bin/run.conf

Add "-Dorg.eclipse.swt.browser.DefaultType=mozilla" to the end of the second line "GUI_JAVA_OPTS".

3.) Restart CrashPlan service via:

sudo /usr/local/crashplan/bin/CrashPlanEngine start

*** Bug 411745 has been marked as a duplicate of this bug. ***

Download full text (94.9 KiB)

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x72673683, pid=2995, tid=3076298432
#
# JRE version: 7.0-b147
# Java VM: Java HotSpot(TM) Client VM (21.0-b17 mixed mode linux-x86 )
# Problematic frame:
# C [libsoup-2.4.so.1+0x56683] soup_session_feature_detach+0x23
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

--------------- T H R E A D ---------------

Current thread (0x09140400): JavaThread "main" [_thread_in_native, id=2995, stack(0xbff60000,0xbffb0000)]

siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x00000000

Registers:
EAX=0x0a7db480, EBX=0x726a9000, ECX=0x00000001, EDX=0x00000001
ESP=0xbffad210, EBP=0xbffad248, ESI=0x00000000, EDI=0x09140400
EIP=0x72673683, EFLAGS=0x00210286, CR2=0x00000000

Top of Stack: (sp=0xbffad210)
0xbffad210: 7fca433a 0a7db480 0a815db8 7fca50e8
0xbffad220: a81ebf70 7fca50e8 a81ebf70 7fca12aa
0xbffad230: 00000000 0a056318 09140400 7fca122b
0xbffad240: b383c5cb a81ebf70 bffad284 b383c6cd
0xbffad250: 09140520 bffad28c 00000000 0a056318
0xbffad260: bffad260 bffad264 a81ebf70 bffad298
0xbffad270: a81f2170 00000000 a81ebf70 00000000
0xbffad280: bffad294 bffad2bc b3835187 8669e3f0

Instructions: (pc=0x72673683)
0x72673663: 89 5c 24 14 e8 44 51 fc ff 81 c3 94 59 03 00 89
0x72673673: 74 24 18 8b 74 24 20 e8 51 fc ff ff 89 44 24 04
0x72673683: 8b 06 89 04 24 e8 93 2f fc ff 8b 54 24 24 89 34
0x72673693: 24 89 54 24 04 ff 50 0c 8b 5c 24 14 8b 74 24 18

Register to memory mapping:

EAX=0x0a7db480 is an unknown value
EBX=0x726a9000: <offset 0x8c000> in /usr/lib/i386-linux-gnu/libsoup-2.4.so.1 at 0x7261d000
ECX=0x00000001 is an unknown value
EDX=0x00000001 is an unknown value
ESP=0xbffad210 is pointing into the stack for thread: 0x09140400
EBP=0xbffad248 is pointing into the stack for thread: 0x09140400
ESI=0x00000000 is an unknown value
EDI=0x09140400 is a thread

Stack: [0xbff60000,0xbffb0000], sp=0xbffad210, free space=308k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libsoup-2.4.so.1+0x56683] soup_session_feature_detach+0x23
j org.eclipse.swt.internal.webkit.WebKitGTK._soup_session_feature_detach(II)V+0
j org.eclipse.swt.internal.webkit.WebKitGTK.soup_session_feature_detach(II)V+9
j org.eclipse.swt.browser.WebKit.create(Lorg/eclipse/swt/widgets/Composite;I)V+892
j org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/Composite;I)V+81
j org.eclipse.jface.internal.text.html.BrowserInformationControl.isAvailable(Lorg/eclipse/swt/widgets/Composite;)Z+12
j org.eclipse.jdt.internal.ui.text.java.AbstractJavaCompletionProposal.getInformationControlCreator()Lorg/eclipse/jface/text/IInformationControlCreator;+9
j org.eclipse.jface.text.contentassist.AdditionalInfoController.computeInformation()V+18
j org.eclipse.jface.text.AbstractInformationContro...

*** Bug 411948 has been marked as a duplicate of this bug. ***

Using this workaround with fedora 19 removes the crash but displays an empty information window for autocompletes (for ctrl-space); unusable.

-Dorg.eclipse.swt.browser.DefaultType=mozilla
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner/

(In reply to comment #26)
> Using this workaround with fedora 19 removes the crash but displays an empty
> information window for autocompletes (for ctrl-space); unusable.
>
> -Dorg.eclipse.swt.browser.DefaultType=mozilla
> -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner/

Thomas, do you see this problem with 4.3 final? I don't see the crash with both Eclipse from Fedora(yum install eclipse) and downloaded one from Eclipse.org. Fedora ships with xulrunner 22 which is not supported by swt.

Upgrading to 4.3 works perfectly, thanks.

In , Mpol-l (mpol-l) wrote :

The workaround seems to work on Indigo with xulrunner 17.

*** Bug 417037 has been marked as a duplicate of this bug. ***

*** Bug 417542 has been marked as a duplicate of this bug. ***

Comment on attachment 229268
Patch for the crash

> long /*int*/ originalAuth = WebKitGTK.soup_session_get_feature (session, WebKitGTK.webkit_soup_auth_dialog_get_type ());
>- WebKitGTK.soup_session_feature_detach (originalAuth, session);
>+ if (originalAuth != 0) {
>+ WebKitGTK.soup_session_feature_detach (originalAuth, session);
>+ }
> OS.g_signal_connect (session, WebKitGTK.authenticate, Proc5.getAddress (), webView);
>- WebKitGTK.soup_session_feature_attach (originalAuth, session);
>+ if (originalAuth != 0) {
>+ WebKitGTK.soup_session_feature_attach (originalAuth, session);
>+ }

FWIW, the lookup/detach/attach code there is completely unnecessary anyway... The only line here that actually does anything is the g_signal_connect() line.

FWIW I found this thread because I was getting a similar crash after updating OpenSUSE to 13.1 and eclipse to Kepler (eclipse.buildId=4.3.0.M20130911-1000)

Here is the tail of the console log:

No bp log location saved, using default.
[000:000] Browser XEmbed support present: 1
[000:001] Browser toolkit is Gtk2.
[000:001] Using Gtk2 toolkit
No bp log location saved, using default.

Adding -Dorg.eclipse.swt.browser.DefaultType=mozilla to eclipse.ini seems to have resolved the problem... for now. I only think it is worth mentioning because this was supposedly resolved in 4.3

(In reply to Jeremiah Renfro from comment #33)

Are you sure you're seeing the same crash (the dump file from your JRE indicates that it's in the soup_session_feature_detach() call)? The fix for this was a simple null check, and I haven't heard of anyone else seeing it since the fix went in. Maybe you're seeing bug 400626?

(In reply to Grant Gayed from comment #34)
> (In reply to Jeremiah Renfro from comment #33)
>
> Are you sure you're seeing the same crash (the dump file from your JRE
> indicates that it's in the soup_session_feature_detach() call)? The fix for
> this was a simple null check, and I haven't heard of anyone else seeing it
> since the fix went in. Maybe you're seeing bug 400626?

Maybe I am experiencing 400626, thanks for pointing me there, I'll start tracking that one also.

*** Bug 426031 has been marked as a duplicate of this bug. ***

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

StacktraceTop:
 soup_session_feature_detach () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
 ?? ()
 ?? ()
 ?? ()
 ?? ()

affects: ubuntu → openjdk-7 (Ubuntu)
tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Ivo Wever (ivo-wever) wrote :

I'm seeing this crash with up-to-date trusty, openjdk 7u51-2.4.5-1ubuntu1, when trying to run a piece of proprietary software. It seems something isn't right in /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1

(In reply to Alexander Kurtakov from comment #7)
> (In reply to comment #6)
> > For a workaround add the following to the end of your eclipse.ini
> >
> > -Dorg.eclipse.swt.browser.DefaultType=mozilla
>
> Mozilla is even less reliable as it breaks with every firefox update ans SWT
> doesn't support recent xulrunner versions (20.0 here) -at least it wasn't
> last I checked.

I had the same problem in LinuxMint (petra), adding Dorg.eclipse.swt.browser.DefaultType=mozilla fixed my it. Thanks for this fix!

*** Bug 434588 has been marked as a duplicate of this bug. ***

Adam Porter (alphapapa) wrote :

After upgrading my machines to Trusty, I can no longer run CrashPlanDesktop, the UI for the CrashPlan backup service.

war59312's workaround does seem to work. It's not necessary to stop and restart the service, because it's completely separate from the UI app. Simply run this command to add the workaround to the config file, and then run CrashPlanDesktop:

$ sed -i 's/GUI_JAVA_OPTS="/GUI_JAVA_OPTS="-Dorg.eclipse.swt.browser.DefaultType=mozilla /' /usr/local/crashplan/bin/run.conf

I just submitted a support ticket to Code42 (Request #471934) detailing the bug and providing links to this and other bug reports. Hopefully they will fix it soon, and then the workaround can be removed.

Very disappointing to encounter this unfixed bug more than a year after it was first reported. But thankfully, open bug trackers like this make it easy to collaborate on fixes.

Adam Porter (alphapapa) wrote :

P.S. Launchpad "helpfully" wrapped the command onto a new line. The option should be without any spaces, like this:

-Dorg.eclipse.swt.browser.DefaultType=mozilla

using eclipse 3.8 here, using trusty
after an apt-get upgrade eclipse keeps crashing
I did add -Dorg.eclipse.swt.browser.DefaultType=mozilla to eclipse.ini
I don't seem to find xulrunner in my system at all.

removing libwebkitgtk-1.0-common solved the problem for me.

Timon Zielonka (timon) wrote :

I had the same problrm on Kubuntu 14.04. With

sudo apt-get purge libwebkitgtk-1.0-common

I solved the problem. So I guess the fatal error is caused by webkit. Does anyone know the corresponding bug in Webkit?

*** Bug 439082 has been marked as a duplicate of this bug. ***

talktogus (talktogus-l) wrote :

the only thing that fixed it for me was also #81, but gimp depends on that library, so now i can code or draw but not both :P

In , P-sub (p-sub) wrote :

*** Bug 440571 has been marked as a duplicate of this bug. ***

I can confirm that using Eclipse Luna v4.4 on Ubuntu 14.04 this doesn't happen anymore. For older Eclipse versions (e.g. 3.7.2) the -Dorg.eclipse.swt.browser.DefaultType=mozilla works for me.

*** Bug 442630 has been marked as a duplicate of this bug. ***

*** Bug 443457 has been marked as a duplicate of this bug. ***

Gregor Rosenauer (grexe) wrote :

@talktogus comment #83 I had the same problem and
http://askubuntu.com/a/80794/17403
helped me:)
Now creative coding is on again...

*** Bug 454196 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.