Technical: tighten tracking of upright+italics by -4/1000 font-wide

Bug #677149 reported by Paul Sladen on 2010-11-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Wishlist
Malcolm Wooden

Bug Description

Sometimes prose can look spaced out, ideally it would be possible to tighten up the general tracking of the typeface (at all sizes) slightly.

A suggested limit that the tracked can be pulled without changes is about -4/1000 of the em square (square of 1000 for UFF). This should lead to a reduction in overall width of set text by

The tracking of the uprights and italics already differs by approximately -4% aswell; some equivalent reduction for the italics needs to be applied to keep things in proportion.

The -4/1000 adjustment will be applied by adjusting both left-bearing and right-bearing by -2/1000 each.

Shiraaz Gabru (shiraaz) on 2010-11-19
Changed in ubuntu-font-family:
milestone: 0.70 → medium
status: Confirmed → Incomplete
Paul Sladen (sladen) wrote :

At a meeting on 2010-12-02 the decision was made to go with:

  1. a minus 4% font-wide tracking, to tighten the regular fonts across the board
  2. further document in style-guide preferred tracking reductions at larger physical sizes

The 4% is hopefully small enough that it will not require extensive re-kerning. It is accepted that the tightened difference will not generally be visible in the user interface as the differences caused by integer rounding at the hinting stages is normally more significant. Very large sizes (banners) are more likely to be professionally prepared, but we cannot expect application developers or users in general to apply this. Mark's best example was the use-case of printing users' email out on paper, and this change covers that by providing a slight perceived improvement.

The Italics are already tighter, so the 4% reduction will likely need applying to those too to keep things in proportional.

Changed in ubuntu-font-family:
status: Incomplete → Triaged
Paul Sladen (sladen) wrote :

Visual approximation of -4% tracking. Comparing the second and third lines (out of the four) shows what would happen if only the upright was tightened; the different cadence between upright and italic would be lost because there is already approximately -4% difference.

description: updated
summary: - Technical: tighten tracking of whole font by -4%
+ Technical: tighten tracking of upright+italics by -4% font-wide

The Ubuntu logotype at:

  http://design.canonical.com/the-toolkit/ubuntu-brand-guidelines/

uses a tightened arrangement for the "ubuntu" textual portion and people have asked what this tracking reduction was/is. Depending on how it is measured (Inkscape uses tracking specified in pixels rather than as percentage) as best I can attain, the logotype appears to been done at -5% (or thereabouts), which is marginally tighter than what is being proposed here for the whole regular/italic fonts.

Shiraaz Gabru (shiraaz) on 2010-12-06
Changed in ubuntu-font-family:
milestone: medium → mono
Paul Sladen (sladen) on 2010-12-13
Changed in ubuntu-font-family:
milestone: mono → 0.71
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Triaged → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Fix Committed → In Progress

I don't think it's 4%, it's 4 points or some other unit. Shiraaz, can
you confirm?

I can confirm that we are tightening the inter-glyph space by 4 em units.

Paul Sladen (sladen) wrote :

Malcolm: is that 4/1000 or 4/1024?

The em square for the Ubuntu fonts is based on 1000 units, but that may change in future releases if the design or production requires it.

Paul Sladen (sladen) wrote :

Malcolm: so the tracking change is -4/1000 (-0.4% ?).

How is it actually being done; is it just reducing the default lead-in/lead-out values of 88 or 82 down to 86 or 80?

Not 0.4%. It is a fixed value to reduce inter glyph space.
Left side space gets -2 and Right side space gets -2.

Paul Sladen (sladen) on 2011-01-06
summary: - Technical: tighten tracking of upright+italics by -4% font-wide
+ Technical: tighten tracking of upright+italics by -4/1000 font-wide
Paul Sladen (sladen) on 2011-01-06
description: updated
Shiraaz Gabru (shiraaz) on 2011-02-16
Changed in ubuntu-font-family:
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

This a new upstream version of the Ubuntu Font Family. In addition to
the extensive bug fixes it doubles the number of .ttfs files, from four
to eight with the inclusion of Light, Medium and italics.

Upstream changelog:

2010-03-08 (Paul Sladen) Ubuntu Font Family version 0.71.2

* (Production) Adjust Medium WeightClass to 500 (Md, MdIt) (LP:
#730912)

2010-03-07 (Paul Sladen) Ubuntu Font Family version 0.71.1

* (Design) Add Capitalised version of glyphs and kern. (Lt, LtIt,
Md, MdIt) DM (LP: #677446)
* (Design) Re-space and tighen Regular and Italic by amount specified
by Mark Shuttleworth (minus 4 FUnits). (Rg, It) (LP: #677149)
* (Design) Design: Latin (U+0192) made straight more like l/c f with
tail (LP: #670768)
* (Design) (U+01B3) should have hook on right, as the lowercase
(U+01B4) (LP: #681026)
* (Design) Tail of Light Italic germandbls, longs and lowercase 'f'
to match Italic/BoldItalic (LP: #623925)
* (Production) Update <case> feature (Lt, LtIt, Md, MdIt). DM
(LP: #676538, #676539)
* (Production) Remove Bulgarian locl feature for Italics. (LP: #708578)
* (Production) Update Description information with new string:
"The Ubuntu Font Family are libre fonts funded by Canonical Ltd
on behalf of the Ubuntu project. The font design work and
technical implementation is being undertaken by Dalton Maag. The
typeface is sans-serif, uses OpenType features and is manually
hinted for clarity on desktop and mobile computing screens. The
scope of the Ubuntu Font Family includes all the languages used
by the various Ubuntu users around the world in tune with
Ubuntu's philosophy which states that every user should be able
to use their software in the language of their choice. The
project is ongoing, and we expect the family will be extended to
cover many written languages in the coming years."
(Rg, It, Bd, BdIt, Lt, LtIt, Md, MdIt) (LP: #690590)
* (Production) Pixel per em indicator added at U+F000 (Lt, LtIt, Md,
MdIt) (LP: #615787)
* (Production) Version number indicator added at U+EFFD (Lt, LtIt, Md,
MdIt) (LP: #640623)
* (Production) fstype bit set to 0 - Editable (Lt, LtIt, Md, MdIt)
(LP: #648406)
* (Production) Localisation of name table has been removed because
of problems with Mac OS/X interpretation of localisation. DM
(LP: #730785)
* (Hinting) Regular '?' dot non-circular (has incorrect control
value). (LP: #654336)
* (Hinting) Too much space after latin capital 'G' in 13pt
regular. Now reduced. (LP: #683437)
* (Hinting) Balance Indian Rupee at 18,19pt (LP: #662177)
* (Hinting) Make Regular '£' less ambiguous at 13-15 ppm (LP: #685562)
* (Hinting) Regular capital 'W' made symmetrical at 31 ppem (LP: #686168)

Changed in ubuntu-font-family:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers