Hinting: Bold: Indian rupee sign

Bug #662177 reported by Vish on 2010-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Low
Unassigned

Bug Description

Now that we have the new Indian Rupee sign, Was checking out the font. the bold font is hinted odd.

Some sizes are good , some are totally different from how the symbol is intended.

The parallel lines at the top (with white space between them) are to make an allusion to the tricolor of the Indian flag, which consists of three parts of *equal* portions.

Attaching screenshot of the problem, with a comparison to the € symbol.
[the top line is bolder than the lower one, changing the shape of a standard symbol]

Notice the problem in 10,11,18,19pt font sizes.

Vish (vish) on 2010-10-17
description: updated
Vish (vish) wrote :
description: updated
Vish (vish) wrote :

In 12pt the white space is not exactly the same but atleast the lines are equal. [saffron and green folks need to be equal.. ;-)]

I take your point, but I think we're going to find it difficult to
produce something "pleasant" at small sizes with such a complicated glyph.

When we're running out of pixels, the usual tactic is to reduce the
weight of the middle stem in vertically-stacked designs - which is what
we've done here.

We can revisit the CVT values used to see what can be done.

Dave

Looking through a (printed) copy of ''The Times of India'' I have here, the Rupee symbols contained within that have an equal height top two cross-bars and the spacing between those and the knee is /not/ kept equal.

One option might be to drop down to a one-pixel crossbar height a lot sooner; even if the rest of the boldface (eg. the related Latin capital 'R') is staying at two-pixels per crossbar. This may also have to be revisited once the top-bar height of Devanagari is done... (however the Hinting does not affect the outlying metrics, so this is fine).

The fundamental problem though is lack of vertical pixels... you need you need about 12 just between the baseline and cap-height to keep the proportions; and even /without/ the doubling to two-pixels it still needs about 8 pixels...

Changed in ubuntu-font-family:
importance: Undecided → Low
milestone: none → 1.00
status: New → Confirmed
Vish (vish) wrote :

Yes, I do understand that the space is limited as the fonts get smaller.

But those two lines are not /just/ two strokes, rather they have a deeper cultural significance.
So we should try to pay more attention there, especially in the 10 and 11pt fonts. [ since they are used more commonly system-wide than the rest of the sizes..]

Paul Sladen (sladen) wrote :

Vish: if you can draw on the above screenshot your preferred alternative (which pixel rows to colour and which not to), we can try to look at it.

It doesn't need to be neat, just to how high the cross bars and knee should be at which of the sizes where the present rendering is sub-optimal.

Vish (vish) wrote :

Paul, Oh! typography! I havent tried my hand at that yet. But will give it a shot.
Will be busy with the UDS as well, so not this month. :-)

Bruno Maag (bruno-daltonmaag) wrote :

Vish - you are going to be at UDS next week? If so, I can recommend you come to my sessions on the fonts.

Vish (vish) wrote :

Hi Bruno, Yes, I'll be at the UDS, I do look forward to your session.

Paul Sladen (sladen) on 2010-12-13
Changed in ubuntu-font-family:
milestone: 1.00 → 0.71
Shiraaz Gabru (shiraaz) wrote :

Due to the limited amount of pixels, we cant completely satisfy the report. We can however probably balance the lines at 18 and 19 point.

For the smaller sizes specified, "there is not enough room to increase the weight of the central bars and reducing the weight of the top and bottom bars will make the glyph look like the regular weight.", Malcolm Wooden.

We be looking into fixing for 18-19.

Changed in ubuntu-font-family:
status: Confirmed → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-12-22
Changed in ubuntu-font-family:
status: Fix Committed → In Progress
Vish (vish) wrote :

Hi, Thanks for looking into this, I finally got around to doing a proposal for this.

IMO, Leaving out size 10 and 11 is not a good option , because they are the most common font sizes used and it is better to get those right.

The reason i noticed this issue was because size 10 looked soo totally different from the regular font and completely different from the '₹' design. (even the tail is stunted and odd for the size 10, compared to the all other sizes)

While trying to do a proposal today , another issue I noticed was that the size 11 bold ₹ was 1px smaller than the regular size 11 ₹ , I did not compare this to all other size 11 fonts, but i believe this is the odd one out here.

However I have done 2 proposals for the ₹ size 11 , if we make it 1px higher and similar to the regular it will be possible to have the same thickness, and one for size 10.

I hope you folks re-consider the 10/11 font sizes too..

Paul Sladen (sladen) on 2010-12-27
tags: added: uff-currency uff-devangari uff-latin
tags: added: uff-bold uff-hinting
Shiraaz Gabru (shiraaz) on 2011-02-16
Changed in ubuntu-font-family:
status: In Progress → Fix Committed
Paul Sladen (sladen) on 2011-03-07
summary: - Hinting:Bold:Indian rupee sign
+ Hinting: Bold: Indian rupee sign
Paul Sladen (sladen) wrote :

This a new upstream version of the Ubuntu Font Family. In addition to
the extensive bug fixes it doubles the number of .ttfs files, from four
to eight with the inclusion of Light, Medium and italics.

Upstream changelog:

2010-03-08 (Paul Sladen) Ubuntu Font Family version 0.71.2

* (Production) Adjust Medium WeightClass to 500 (Md, MdIt) (LP:
#730912)

2010-03-07 (Paul Sladen) Ubuntu Font Family version 0.71.1

* (Design) Add Capitalised version of glyphs and kern. (Lt, LtIt,
Md, MdIt) DM (LP: #677446)
* (Design) Re-space and tighen Regular and Italic by amount specified
by Mark Shuttleworth (minus 4 FUnits). (Rg, It) (LP: #677149)
* (Design) Design: Latin (U+0192) made straight more like l/c f with
tail (LP: #670768)
* (Design) (U+01B3) should have hook on right, as the lowercase
(U+01B4) (LP: #681026)
* (Design) Tail of Light Italic germandbls, longs and lowercase 'f'
to match Italic/BoldItalic (LP: #623925)
* (Production) Update <case> feature (Lt, LtIt, Md, MdIt). DM
(LP: #676538, #676539)
* (Production) Remove Bulgarian locl feature for Italics. (LP: #708578)
* (Production) Update Description information with new string:
"The Ubuntu Font Family are libre fonts funded by Canonical Ltd
on behalf of the Ubuntu project. The font design work and
technical implementation is being undertaken by Dalton Maag. The
typeface is sans-serif, uses OpenType features and is manually
hinted for clarity on desktop and mobile computing screens. The
scope of the Ubuntu Font Family includes all the languages used
by the various Ubuntu users around the world in tune with
Ubuntu's philosophy which states that every user should be able
to use their software in the language of their choice. The
project is ongoing, and we expect the family will be extended to
cover many written languages in the coming years."
(Rg, It, Bd, BdIt, Lt, LtIt, Md, MdIt) (LP: #690590)
* (Production) Pixel per em indicator added at U+F000 (Lt, LtIt, Md,
MdIt) (LP: #615787)
* (Production) Version number indicator added at U+EFFD (Lt, LtIt, Md,
MdIt) (LP: #640623)
* (Production) fstype bit set to 0 - Editable (Lt, LtIt, Md, MdIt)
(LP: #648406)
* (Production) Localisation of name table has been removed because
of problems with Mac OS/X interpretation of localisation. DM
(LP: #730785)
* (Hinting) Regular '?' dot non-circular (has incorrect control
value). (LP: #654336)
* (Hinting) Too much space after latin capital 'G' in 13pt
regular. Now reduced. (LP: #683437)
* (Hinting) Balance Indian Rupee at 18,19pt (LP: #662177)
* (Hinting) Make Regular '£' less ambiguous at 13-15 ppm (LP: #685562)
* (Hinting) Regular capital 'W' made symmetrical at 31 ppem (LP: #686168)

Changed in ubuntu-font-family:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers