Symbol: add U+20B9 INDIAN RUPEE SIGN to currency block

Bug #645987 reported by Rodrigo Rivas Costa on 2010-09-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Critical
Shiraaz Gabru

Bug Description

The font has all the currency symbols I could think of, but it lacks the new
http://en.wikipedia.org/wiki/Indian_rupee_sign
Currently, it is not available in any font I've got.

Rodrigo

Paul Sladen (sladen) wrote :

It appears that the codepoint for this was only assigned very recently (2010-08-10), it is distinct from the old generic '₨' (U+20A8) sign. I'm sure they will get tackled as part of Devanagari, as it appears to be a derivative of 'र' (ra, U+0930), but ...being a currency symbol (similar to '€' U+20AC EURO SIGN) and in the same currency block, perhaps it should be tackled sooner.

Rodrigo: thank you for filing the bug report, lets see what we can do. I know that DaltonMaag have talked about some Devanagari work, so perhaps they have a base for this, even if it might need redrawing slightly later on.

Changed in ubuntu-font-family:
importance: Undecided → Medium
milestone: none → later
status: New → Confirmed
Paul Sladen (sladen) on 2010-09-23
summary: - wish for the Indian rupee sign
+ Symbol: add U+20B9 INDIAN RUPEE SIGN to currency block
Changed in ubuntu-font-family:
importance: Medium → High
Paul Sladen (sladen) on 2010-09-23
Changed in ubuntu-font-family:
milestone: later → 0.70
Paul Sladen (sladen) wrote :

Bruno at Dalton Maag noted on 2010-09-23 that the new Indian Rupee symbol in question won an award for its designer and so ideally needs time to consider it in respect to Devanagari as a whole. Bruno additionally expressed that DM are likely to be too involved with other deadlines to focus on U+20B9 and to create a glyph within the ~1-week timeframe for final Ubuntu 10.10 preparations.

If we're really lucky, no other Operating Systems ship with this symbol out-of-the-box in the next six months, but I think it's unlikely. India have indicated that they wish to adopt the new symbol within a six-month period.

Perhaps this can be a test-case for a contributed glyph? We need to
exercise the bidirectionality of the pipeline, with changes flowing from
other contributors into DM's working tree and into the trunk.

Paul, as you pointed out, we'd be signalling that things are not final
with the 0.7 versioning of Maverick's font package, so there's room to
get the glyph to DM's standard before 1.0.

Mark

I'm not so sure of the Devanagari dependency. It looks to me that the
symbol design is more influenced by other currency symbols, as Euro or
Yen or even the latin R than the Devanagari Ra.

I've drawn a simple sketch to illustrate my point. You can see it at:

http://rodrigo.dualnot.com/rupee_sketch.png

The first row is: latin R (ubuntu-font); Devanagari Ra (don't know
which font); the Rupee Symbol (my own proposal, ubuntu-font-like).
The second row are all ubuntu-font: Euro symbol; Pound symbol; Yen symbol.
At the right there is the official Rupee Symbol design.

Note how the official Euro design
(http://en.wikipedia.org/wiki/File:Euro_Construction.svg) is adapted
to the ubuntu-font look-and-feel. I tried to do the same with the
rupee, but I'm not a designer, so feel free to disagree...

Rodrigo.

Mark Shuttleworth (sabdfl) wrote :

 importance critical

I really think we should get this done for the release, at least in an
initial cut. I agree it's not dependent on a clear plan for Devanagari.

> Note how the official Euro design
> (http://en.wikipedia.org/wiki/File:Euro_Construction.svg) is adapted
> to the ubuntu-font look-and-feel.

Missed one key point, which is the alignment of the cut line from the
top curve through the two cross bars.

Mark

Changed in ubuntu-font-family:
importance: High → Critical
Paul Sladen (sladen) wrote :

Rodrigo: (1) Please could you submit a copy of the copyright-assignment form for contributions to the Ubuntu Font Family:

  http://www.canonical.com/contributors (see full instructions)

Could you please email this to all three of the following email addresses:

  <email address hidden>,
  Iain Farrell <email address hidden>,
  Paul Sladen <email address hidden>

so that the contributions can be accepted.

(2) if you're able to, please could you try producing several (perhaps four to ten) more very slight variations on the glyph to make picking easier (eg. stem thickness, cut alignment).

When things are settled, I'll try to turn this into vectors in FontForge and mail it to Dalton Maag for them to do the engineering side and integrate.

Paul Sladen (sladen) wrote :

Rodrigo: please could you also including thin coloured lines for the intended baseline, cap-height, ... so that it's possible to see how you wish to see it sitting with other text.

> Could you please email this to all three of the following email
> addresses:
>
>  <email address hidden>,
>  Iain Farrell <email address hidden>,
>  Paul Sladen <email address hidden>
>
> so that the contributions can be accepted.
Done!

>f you're able to, please could you try producing several (perhaps
> four to ten) more very slight variations on the glyph to make picking
> easier (eg. stem thickness, cut alignment).
Oh! I never intended to draw it myself.
What the... It'll be fun.
I'll send my proposed glyphs as soon as possible.

Regards.

Behold! My glyph is ready!

I've based my design in the official proposal from the Rupee Symbol
Design Contest:
http://www.idc.iitb.ac.in/events/Indian_Rupee_Symbol.pdf
There are a lot of rationales and renders of the symbol in there.
Check particularly the design in page 17.

In the attached files you can find my proposals. I'll add some random comments.
First of all there are a few not-so-random characters, in blue, just
for quick reference of size and position.
Then there are several model of the glyph:
1a: This is just the R without the vertical stem and the right leg
moved to the left. The parallel bars are just like the Euro, but
thicker, to match the thick of the R.
2a: Here I took the parallel lines from the Euro, as is, but put it a
little bit together. The design says that the gap between them should
be the same height as the bars. I've reduced the width of the rest of
the glyph to match them.
3a: The main stroke is just like 1a and the parallel lines like 2a.
The overall width is changed as little as possible to get an
acceptable look.
4a. This is the same as 3a, but the center joint is raised to get a
proportion more similar to the official design.

The 1b, 2b, 3b and 4b glyphs are identical to their 'a' counterparts,
except for the left side of the parallel lines: in the 'a' version, it
is vertical; in the 'b' version it is slanted.
I draw both versions because although the official design has both
sides slanted, so does the Euro design, and the Euro glyph has only
the right side slanted. I just tried the same.

Paul: I really hope this is what you are asking for, because I simply
don't have any more drawing talent.

Best Regards.
Rodrigo.

Paul Sladen (sladen) wrote :

Rodrigo: I think that you're pretty much spot on with what I had in mind. I think I'm inclined to agree that the straight left-hand side fits better with the rest of the currency block. Beyond that, I've been looking back-and-forth at the left-hand block; so I'm going to sleep on it for a few hours. Since it's a stylistic concern, I'm hoping(!) that some other may be able to chip in and give their thoughts/preferences in the mean time!

tags: added: ttf-currency ttf-devanagari ttf-latin ttf-style
Paul Sladen (sladen) on 2010-09-30
Changed in ubuntu-font-family:
milestone: 0.70 → 0.69
assignee: nobody → Shiraaz Gabru (shiraaz)
Paul Sladen (sladen) wrote :

Mark: could you take have a look at the choices in comment #9 above please, I stared at them for about 30 minutes the other night, but I probably need to actually knock the character up and play with it to discern any further—there is the scope to have Dalton Maag define it later on when they've got a better idea of top-line interaction.

Shiraaz Gabru (shiraaz) on 2010-09-30
Changed in ubuntu-font-family:
status: Confirmed → Fix Committed
Paul Sladen (sladen) on 2010-09-30
Changed in ubuntu-font-family:
status: Fix Committed → In Progress
Paul Sladen (sladen) wrote :

Forwarded to Bruno and Malcom (in various formats, PDF, EPS, SVG) on 2010-09-30.

Paul Sladen (sladen) wrote :

ubuntu-font-family-sources (0.69+ufl-0ubuntu1) maverick; urgency=low

  * New upstream release 0.69 ("Indian Rupee sign") (LP: #653035)

  [Dalton Maag]
  * Italic
    - Hinting on lowercase Italic l amended 19ppm (LP: #632451)
    - Hinting on lowercase Italic u amended 12ppm (LP: #626376)

  * Regular, Italic, Bold, BoldItalic
    - New Rupee Sign added @ U+20B9 (LP: #645987)
    - Ubuntu Roundel added @ U+E0FF (LP: #651606)

  [Paul Sladen]
  * All
    - Removed "!ubu" GSUB.calt ligature for U+E0FF (LP: #651606)
 -- Paul Sladen <email address hidden> Tue, 5 Oct 2010 01:40:00 +0100

Changed in ubuntu-font-family:
status: In Progress → Fix Released
Vish (vish) wrote :

The ₹ is not displayed in gucharmap , it seems hidden. I had to manually search for the U+20B9 to find it there.

When I check the character details, it says :
------------
[not a printable character]

U+20B9 <not assigned>

General Character Properties

Unicode category: Other, Not Assigned

Various Useful Representations

UTF-8: 0xE2 0x82 0xB9
UTF-16: 0x20B9

C octal escaped UTF-8: \342\202\271
XML decimal entity: &#8377;
------------------

while details for the older symbol says : U+20A8 RUPEE SIGN

Is this a bug in the Ubuntu font that it is not assigned or.. a bug elsewhere?

Paul Sladen (sladen) wrote :

Vish: →bug #655357.

Paul Sladen (sladen) on 2010-12-27
tags: added: uff-currency uff-devanagari uff-latin uff-style
removed: ttf-currency ttf-devanagari ttf-latin ttf-style
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers