darter soft lockup on dvd drive

Bug #117441 reported by digitalbenji on 2007-05-28
22
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned

Bug Description

Hi,
  This problem seems to be mostly limited to when I try to use the DVD drive. I can't playback DVDs, but then, whether I leave the disk in, or eject it, I eventually get a soft lockup where the CPU is being overtaken by some process. I've read up on it a little, and some people think it's a hal problem. I don't know.
  I'll try to get the exact 3 errors that I saw in the log. I just resinstalled Feisty, and am still having the problem. The errors said something like this hdb: drive not ready for command.

Carl Richell (carlrichell) wrote :

Thanks for your bug report. This problem is related to HAL, Intel ICH 8 chipset, and primarily Ubuntu's move to ata_piix driver in Feisty. The System76 Driver has a fix that should help with this problem. Can you install and run the System76 Driver and let us know if you still experience the problem. Directions are located at the end of our Restore how to:

http://knowledge76.com/index.php/Restoring_Your_System

digitalbenji (go-digitalbenji) wrote :

Hi,
  Thank's for the response. I love the support.
  Installing the system76 driver did seem to fix the cpu soft lockup HAL problem that I was having. However, and this may be more of a general forum question, I'm still having some strange problem when I play DVDs. I have libdvdcss2 and w32codecs installed, but when I play the DVDs back, I get a black screen, although sometimes when going from maximized to minimized I can see some video. Have you ever heard of anything like this? Progress bar moves, but the video remains black.

Thanks in advance,
Benji

digitalbenji (go-digitalbenji) wrote :

I think I figured this out. The problem seems to be DVD playback w/ Beryl enabled as the window manager. Switching to Metacity fixed the problem. Thanks!

digitalbenji (go-digitalbenji) wrote :

Looks like I spoke to soon about the soft lockup problem.
I just experienced it again, with the system 76 driver installed.
I did not hard reboot this time, but waited it out long enough to confirm with top that the problem process was:
hald-addon-storage
I killed this process, and the cpu dropped to normal right away. This is a pain though, and I'm sure a fix will be available eventually. Obviously the sooner the better. Is there a way to disable hald-addon-storage? Is it essential? What does it do exactly?

When this is going on, my kern.log gets these errors:
ide: failed opcode was: unknown
hdb: drive not ready for command
hdb: status timeout: status=0xd0 {busy}

Do you know of any temporary fixes? I'd really like to resolve this one.

Thanks,

Do you have a CD in the drive? If so, remove it and see if you still get the same problem.

----- Original Message -----
From: "digitalbenji" <email address hidden>
To: <email address hidden>
Sent: Tuesday, May 29, 2007 4:53:08 PM (GMT-0700) America/Denver
Subject: [Bug 117441] Re: darter soft lockup on dvd drive

Looks like I spoke to soon about the soft lockup problem.
I just experienced it again, with the system 76 driver installed.
I did not hard reboot this time, but waited it out long enough to confirm with top that the problem process was:
hald-addon-storage
I killed this process, and the cpu dropped to normal right away. This is a pain though, and I'm sure a fix will be available eventually. Obviously the sooner the better. Is there a way to disable hald-addon-storage? Is it essential? What does it do exactly?

When this is going on, my kern.log gets these errors:
ide: failed opcode was: unknown
hdb: drive not ready for command
hdb: status timeout: status=0xd0 {busy}

Do you know of any temporary fixes? I'd really like to resolve this
one.

Thanks,

--
darter soft lockup on dvd drive
https://bugs.launchpad.net/bugs/117441
You received this bug notification because you are a member of System76
Bugs, which is the bug contact for System76.

Carl Richell (carlrichell) wrote :

Please also post the output of the following command:

lsmod | grep piix

digitalbenji (go-digitalbenji) wrote :

As far as I can tell, this problem only occurs when I have been using/tried to use the optical disc drive. If I try to play a DVD, about 5 minutes go by before this happens. If I pop a disc in, then eject it, this problem happens. I am not sure if this does or does not occur without the use of the optical drive. It seems like the problem is that the hal daemon is probing the optical drive to often. Is there a way to slow down the probes, or turn them off altogether, or make them on demand?

:~$ lsmod |grep piix
piix 11140 0 [permanent]
:~$

Thanks, Best Regards.

digitalbenji (go-digitalbenji) wrote :

any news? I'd like to play/burn DVD/CDs, and currently I can't get more than 10 minutes into one without a lockup.

Brandan E. Lloyd (brandan) wrote :

I hate to chime in with a me too, but me too. I am seeing the same problems with my gazv3 and I have the same output with lsmod | grep piix

piix 11140 0 [permanent]

Perhaps this is related to the following bug:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/75295

Carl Richell (carlrichell) wrote :

This bug is a bit perplexing. On my Darter with the appropriate driver "piix", as you guys using, I can burn CD's and DVD's without any soft lockups. I think it is related to the above bug and bug 84603

Bug 84603 is supposed to be fixed and released with Feisty SRU but I don't have a time table from Canonical.

Because I'm not experiencing the problem I'd like to look at a potential firmware problem. Can you both remove your CD-ROM drives and provide the firmware release (usually designated with FW). Also any other information on the drive will be helpful - usually the numbers underneath a bar code.

Thanks, Carl

Changed in system76:
status: Unconfirmed → Needs Info
Carl Richell (carlrichell) wrote :

I have reproduced the problem but it's slightly different. I can play a CD for over an hour but once I stop the CD I start receiving the following error in kern.log:

Jun 6 23:01:04 lincoln kernel: [ 205.172000] hdb: drive not ready for command
Jun 6 23:01:09 lincoln kernel: [ 210.176000] hdb: status timeout: status=0xd0 { Busy }
Jun 6 23:01:09 lincoln kernel: [ 210.176000] hdb: drive not ready for command
Jun 6 23:03:27 lincoln kernel: [ 2.520152] ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
Jun 6 23:03:27 lincoln kernel: [ 3.262743] hdb: TSSTcorpCD/DVDW TS-L632D, ATAPI CD/DVD-ROM drive
Jun 6 23:03:27 lincoln kernel: [ 5.424000] hdb: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)

After your system locks run the following command:

cat /var/log/kern.log | grep hdb

and please post.

This only occurs if I have an idle CD or DVD in the drive - probably HAL poking at the drive.

Brandan E. Lloyd (brandan) wrote :

Carl,

Here is some relevant information from my kern.log

Jun 5 18:45:29 eniac kernel: [ 3.291773] ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
Jun 5 18:45:29 eniac kernel: [ 4.026649] hdb: TSSTcorpCD/DVDW TS-L632D, ATAPI CD/DVD-ROM drive
Jun 5 18:45:29 eniac kernel: [ 6.232000] hdb: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)

and the details from the bottom of my CD/DVD-RW (I couldn't pop it out as it looks built-in).

S62FP Notebook PC

N13219

MSQ-NB-S62FP(B)
15G10N349710 F2
                              YS-1

Brandan E. Lloyd (brandan) wrote :

I forgot to add the lock-up information:

Jun 5 18:41:08 eniac kernel: [ 3581.716000] hdb: drive not ready for command
Jun 5 18:41:13 eniac kernel: [ 3586.720000] hdb: status timeout: status=0xd0 { Busy }

digitalbenji (go-digitalbenji) wrote :

Strangely, I'm suddenly having trouble reproducing the problem. Last night I was even able to watch a DVD without any problem. I've tested putting a data DVD, a blank DVD-R, and a video DVD (snowboarding movie), into the drive, and I can't reproduce the problem the past few days. Strange, I wonder if this could somehow be related to the one DVD movie that was causing the problem? It was Mel Gibson's Apolypto (it was awful, actually offensive, he's a sicko), but it made the hald softlockup happen 10 minutes in, and after I removed the disc. I don't have the disc anymore, it was a rental, but I'll keep testing and trying and see what I can figure out. Sorry for the delay in my response.

Thanks again Carl,

Carl Richell (carlrichell) wrote :

That's interesting - is the snowboarding movie encrypted? maybe the lockups you experienced are a libdvdcss bug - or potentially the decrypting of that particular movie. I have trouble replicating as well. I'm sure we have a bug here but we may have to wait until Feisty's Service Release.

Brandan - can you reproduce reliably and provide us with the details.

Thanks, Carl

Brandan E. Lloyd (brandan) wrote :

I'm still seeing lockups. I have a BattleStar Galactica Season 1 Disc 5. I tried a restore of the System76 driver and a reboot but that doesn't seem to have done anything. I have attached a kern.log from the BattleStar Galactica DVD. I will try with a blank DVD-R next.

Let me know what other details you need.

Brandan E. Lloyd (brandan) wrote :

It happens with a blank DVD-R also except I get:
Jun 8 11:45:23 eniac kernel: [ 466.196000] cdrom: This disc doesn't have any tracks I recognize!

before it happens.

If there is a firmware update that I can apply I would be happy to try that out.

digitalbenji (go-digitalbenji) wrote :

Ok, so I was able to reproduce this today without trying. I had the snowboard video in the drive, but I was not watching it (and had not touch the drive through the system) and I experienced the lockup. I had this happen within 10 minutes of booting twice in a row (then I took the disk out). I have attached the output of a cat /var/log/kern.log | grep hdb from each time this happened. Both times killing the hald-addon-storage process brought the system back up. I've also noticed that when this happens my wireless connections gets disconnected, and I can't get it to come back up unless I reboot the computer.

the bottom of my optical drive says Z35M - I don't think this is the info you were looking for. What exactly do you want off the optical drive?

Thanks,

digitalbenji (go-digitalbenji) wrote :

2nd grep file

Carl Richell (carlrichell) wrote :

We may have a fix. We're building and testing a firmware update for the Darter's drive. Reports have said that this works. Gazelle Value will follow.

sherrardb (sburton-launchpad) wrote :

Carl,
even though you are hopefully well on the way to a fix, i though i'd give my $0.02. this just started happening to me recently. i have seen it both with a data cd and video dvd. i'm pretty sure that when it happened the drive had either been unused during the current session, or idle for a while. i also think that it's hal related from the little troubleshooting i did. i wanted to try and stop hal and dbus when the problem started to see if that helped, but this condition produces a very fast downward spiral into an unresponsive state. and since, as others have reported, this happens sporadically i didn't see any point in stopping those services right at login because if it didn't happen, who's to say it would have anyway?

also, even though i have had it happen while using the machine, it seems like more than a few times this was either triggered by or happened in close proximity to me opening the lid and putting in my password to cancel the screensaver after having left the machine idle for a while.

digitalbenji (go-digitalbenji) wrote :

I just watched a DVD start to finish, no problems. Ejected the DVD, used the PC for 2 hours, no problems. I then installed WinXP into a Virtualbox VM with no problems (using the XP CD). Maybe the latest kernel upgrade patched this?

perce (ghiggini) wrote :

No, it's not fixed yet. It happened to me yesterday again.

Brandan E. Lloyd (brandan) wrote :

I can reliably reproduce this. Whenever I put in a DVD it will lock up. Maybe not immediately but within a half hour or so, definitely before I finish watching the DVD. I have, seemingly, been able to prevent the lockup by killing the hald-addon-stor process after putting in a DVD. This particular process references my DVD drive in the command line arguments 'hald-addon-storage: polling /dev/hdb (every 2 sec)'. After stopping this process I can reliably watch an entire DVD without a problem. I believe that I had problems auto-mounting the DVD if I popped the DVD in after killing the process, but I can manually mount it fine. So it looks like it is a HALD problem.

Thomas Aaron (tom-system76) wrote :

The Following Fix Is For The White Darter (daru1) ONLY. It has not yet been tested on the Gazelle Value.

1.You will need two pen drives for this process. Pen drive #1 will be completely reformatted, so back up anything on it you do not wish to loose. Pen drive #2 will be used only to hold a couple of files. It will not be erased.

2. Download to your desktop the three files attached to this bug report (unfortunately, I can only seem to attach one per entry, so see the following entries for the other two). The attachments are: Sys76_BootImage , SC03.BIN, and sfdndos.exe

3. In a terminal, type: tail -f /var/log/syslog

4. Insert USB pen drive #1.

5. In the terminal, syslog will give you the /dev/* path of your USB pen drive. Record it. For a Darter, it will probably be /dev/sdb1. It is of the utmost importance that you record this path correctly. Failure to do so likely will hose your DVD drive and reduce you to a slobbering cry-baby. (But don't worry. If you hose it, we're here for you.)

6. BEFORE YOU HIT ENTER, READ THIS ENTIRE STEP!
In a terminal, type:
dd if=~/Desktop/Sys76_BootImage of=/dev/sdb bs=1M
NOTICE that I omitted the number from the USB path (i.e. /dev/sdb instead of /dev/sdb1). ALSO, if you recorded something other than /dev/sdb in step #3, you should substitute your recorded path (minus the number) for /dev/sdb. In other words, type:
dd if=~/Desktop/Sys76_BootImage of=<your usb path minus the number> bs=1M

7. Right-click on the USB pen drive icon on your desktop and select EJECT.

8. Now insert pen drive #2 in another USB port (leave the #1 USB pen drive in place).

9. Drag-and-drop SC03.BIN and sfdndos.exe into the resulting file browser. Then close the file browser.

10. Right-click on the USB pen drive icon on your desktop and select EJECT.

11. Restart your computer. When the INTEL screen appears, press ESCAPE.

12. Using your arrow keys, highlight your #1 USB pen drive (the bootable one) and Press Enter. If you can't tell which one is the bootable pen drive, just try one. If it doesn't work, try the other one.

13. Once you get a DOS prompt, you need to navigate to USB pen drive #2. On my Darter, I type "c:" (without the quotes) and press enter. The prompt should change to "C:". Now type "dir" (without the quotes) and press enter. If you are inside the #2 pen drive, you will see SC03.BIN and sfdndos.exe listed. If not, you will need to try other directories with the same procedure to locate them. (i.e. "a:" or "b:" or "d:" <without quotes>)

14. Once you are in the directory that contains sfdndos.exe and SC03.BIN, enter the following command:
sfdndos SC03.BIN PS -n

15. The resulting process will take a couple of minutes. DO NOT INTERRUPT IT (remember what I said about slobbering cry-babies?).

16. When the process finishes, remove both of your pen drives and restart your computer.

Changed in system76:
status: Incomplete → Fix Released
Thomas Aaron (tom-system76) wrote :

System 76 Bootable USB Image

Thomas Aaron (tom-system76) wrote :

sfdndos.exe

Thomas Aaron (tom-system76) wrote :

SC03.BIN

(Important: That is a ZERO, not the letter "O".)

sherrardb (sburton-launchpad) wrote :

a few things:
first off thanks for the continued hard work.

second, the boot disk creation didn't "take" for me the first few times. i don't know if it was related to hald/automount and syncing the cached original data back to disk when you umount/eject or what. but whenever i did the dd from within gnome, the boot process would just hang when i selected the usb key.

so finally i booted back into ubuntu, but instead of loging into gnome and opening a terminal, i went to a virtual terminal by pressing ctrl+alt+f1, and did the dd from there. interestingly, the usb key was /dev/sda not /dev/sdb in this context. since i was not logged into gnome, there was no automount of the usb key and therefore no umount/eject required. i rebooted and selected the usb key and everything worked fine.

lastly, for any darter owners who are windows dual-booters like i am, you can just make the executable and the firmware file available on a fat partition on the hard drive and the process should work, but ymmv.

thanks again.

digitalbenji (go-digitalbenji) wrote :

I just applied the firmware update. My drive was b:, not c:, for anyone else trying this. I will test the drive out when I get a chance, hopefully this resolved the issue.

Thanks

Martin Albisetti (beuno) wrote :

My drive was b: too, and the fix worked perfectly, and has resolved the issue completely.

Thanks Tom!

Paolo (paolo1438) wrote :

I could not apply the fix because OpenDOS didn't see my second USB memory. The second memory was indeed an MP3 player, however Ubuntu sees it also as a memory stick. Can this be the reason?

Thomas Aaron (tom-system76) wrote :

Hi, Paolo.

When you get to the command prompt, you can locate your 2nd USB drive by trying
several different directories. To do this, you type:

b: <and press Enter>
then type: dir <and press Enter> to see if you can see your files.

also try:
c:
d:
e:
etc... until you find it.
It was c: on my Darter.

The USB drive I used also shows up as a music player to Ubuntu. So, I doubt that is the problem.

Best,
Tom

----- Original Message -----
From: "Paolo" <email address hidden>
To: <email address hidden>
Sent: Tuesday, September 11, 2007 6:03:13 PM (GMT-0700) America/Denver
Subject: [Bug 117441] Re: darter soft lockup on dvd drive

I could not apply the fix because OpenDOS didn't see my second USB
memory. The second memory was indeed an MP3 player, however Ubuntu it also as a memory stick. Can this be the reason?

--
darter soft lockup on dvd drive
https://bugs.launchpad.net/bugs/117441
You received this bug notification because you are a member of System76
Bugs, which is the bug contact for System76.

Paolo (paolo1438) wrote :

Thanks Tom.

I tried to change drive the way you mentioned, but b: showed the same files as a: and from c: on the drives were non existing. The second memory I used didn't show up as a MP3 player, it was an MP3 player, which of course can work as memory stick as well.

pak33m (pak33m) wrote :

Hi Tom (and everybody else concerned),

I just wanted to let you know that I successfully flashed the firmware as you described above without any problem on my Gazelle Value (gazv4). Since then I have been putting my laptop through heck and have not suffered the soft lock ups that I did previously.

I will post with anything different if it happens.

Thank you again for the fix. This has saved me many, many headaches.

Thanks,

Jimmy

gmayer (gunther-mayer) wrote :

I just wanted to say that I managed to get rid of lots of weird ata soft resets and other related problems (see bug 75295 and bug 104581) thanks to Tom's instructions using two flash drives. Nice FreeDOS image, Tom, I was looking for a way to avoid downloading a monstrous 150MB live CD FreeDOS image...

Btw, I'm not running any of the above systems, I'm on a Samsung Q35 laptop with the notorious TSSTcorp TS-L632D DVD writer (used to be firmware_version SC02, now SC04, downloaded). I have no Windows partition as I completely nuked it a while back, I'm an Ubuntu purist ;-). The FreeDOS's USB drivers work perfectly on my laptop too so that I had no problem accessing once I had booted from the first flash drive.

So I can vouch for Tom's instructions and would consider them as generic as long the reader has the same drive as above and no access to a Windows partition.

Joe Erickson (firstclown) wrote :

Has this bee tested on a gaz3v yet? I'd like to try this out for myself since the gaz3v has the same problem. If there's a back out scheme, I'll be happy to test it for you.

Thomas Aaron (tom-system76) wrote :

Hi, Joe.

It should work fine for the GazV3. If there is a problem, it will not run.

Best,
Tom

----- Original Message -----
From: "Joe Erickson" <email address hidden>
To: <email address hidden>
Sent: Monday, December 3, 2007 4:31:25 PM (GMT-0700) America/Denver
Subject: [Bug 117441] Re: darter soft lockup on dvd drive

Has this bee tested on a gaz3v yet? I'd like to try this out for myself
since the gaz3v has the same problem. If there's a back out scheme,
I'll be happy to test it for you.

--
darter soft lockup on dvd drive
https://bugs.launchpad.net/bugs/117441
You received this bug notification because you are a member of System76
Bugs, which is the bug contact for System76.

AusIV (linux-ausiv) wrote :

Joe,

I can attest that this works on the Gazelle V3. I had no problem running it, and my system has run like a champ ever since.

Joe Erickson (firstclown) wrote :

Just wanted to verify that this did work on the gaz3v. Thanks!

I was reluctant to try this fix because I thought it was related to my DVD drive which up to this point was not a problem. None-the-less, It worked. Thank you.

IgnacioMiller (dan-17) wrote :

Hello,

I was directed here to fix my Gazv3 random hanging issues. I followed all the steps up until the DOS prompt step. I typed dir and saw both the necessary files in the USB thumb drive. I then typed the command sfdndos SCO3.BIN PS -n and received this message:
-------------------------------------------------------------------------
SFDNDOS 2.23.6
FLASH DOWNLOAD PROGRAM for DOS, ATAPI DRIVE
Program by Lee, KI-JU
2005.11 Toshiba Samsung Storage Technology Corporation

FILE OPEN FAIL !!
---------------------------------------------------------------------------

I have tried changing the permissions on the file, but I can't seem to be able to change them on the thumb drive and I cannot change permissions on my desktop and then transfer the permissions to my thumb drive, the permissions revert to as they were before. I have also tried using a different USB thumb drive as drive #2 and it still threw the same error.

Anything I am doing wrong? How can I flash my CDROM drive?

Thanks!
IgnacioMiller

Thomas Aaron (tom-system76) wrote :

Make sure you do not have a disk in the drive while flashing.
If that doesn't make it work, you can send your drive to me for flashing.
(I've encountered several gazv3's that will not flash the drive. However,
the old, white darters will flash them with no problem.)

I've replied to your post on the forums, as well.

Contact me via email (support(at)system76(dot)com) for shipping info.

KevinStarkey (kstarkey1) wrote :

I tried the fix, using the 2 usb drives, it booted to the a-prompt, I switched to c-prompt, did 'dir' saw my files, ran the command 'sfdndos SC03.BIN PS -n', everything seemed fine. The last line it wrote out was 'Downloading File : TSST....', and then it just sit there. I kept waiting and waiting, since I didn't want to interrupt it and screw things up. I dozed off and a couple of hours later nothing had changed. I kept waiting for he c-prompt to return telling me it had finished or something; nothing. I shut down and went back into Ubuntu. The drive seemed ok enough, I can read data cds, but when I checked the firmware it still shows AS05. I even plugged in the ethernet cable and tried it again, thinking that maybe it was really trying to download something it needed; same results. Any thoughts?

Thomas Aaron (tom-system76) wrote :

There are two possibilities:

1. Your using a Gazelle Value that won't download the file. I see this every once in a while.
2. You're cd drive is bad.

Either way, contact support via email with your order number for further assistance.
support(at)system76(dot)com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers