Synaptic crashes when using orca or Accerciser

Bug #607605 reported by Max Nicosia on 2010-07-20
550
This bug affects 130 people
Affects Status Importance Assigned to Milestone
synaptic
New
Unknown
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

TESTCASE:
1) Enable Accessibility
2) Start synaptic

Result: synaptic crashes

Original Description:
This crash seems to only happen when the search returns no results and you tab
around the application. Regardless if you use tab or shift+tab once you are
going to land on the are that is blank (to get orca to read that there are no
matches) synaptic crashes, but orca keeps on running.

Below is the output when ran from terminal and the backtrace.

Cheers

terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Program received signal SIGABRT, Aborted.
0x0012d422 in __kernel_vsyscall ()
(gdb) thread apply all bt

— Trace 222907

Thread 1 (Thread 0xb7fd6730 (LWP 2643))

    * #0 __kernel_vsyscall
    * #1 raise
      from /lib/tls/i686/cmov/libc.so.6
    * #2 abort
      from /lib/tls/i686/cmov/libc.so.6
    * #3 __gnu_cxx::__verbose_terminate_handler()
      from /usr/lib/libstdc++.so.6
    * #4 ??
      from /usr/lib/libstdc++.so.6
    * #5 std::terminate()
      from /usr/lib/libstdc++.so.6
    * #6 __cxa_throw
      from /usr/lib/libstdc++.so.6
    * #7 std::__throw_out_of_range(char const*)
      from /usr/lib/libstdc++.so.6
    * #8 ??
    * #9 gtk_tree_model_iter_children
      from /usr/lib/libgtk-x11-2.0.so.0
    * #10 ??
      from /usr/lib/gtk-2.0/modules/libgail.so
    * #11 ??
      from /usr/lib/gtk-2.0/modules/libgail.so
    * #12 atk_object_get_n_accessible_children
      from /usr/lib/libatk-1.0.so.0
    * #13 ??
      from /usr/lib/gtk-2.0/modules/libgail.so
    * #14 atk_object_get_index_in_parent
      from /usr/lib/libatk-1.0.so.0
    * #15 ??
      from /usr/lib/libatk-1.0.so.0
    * #16 ??
      from /usr/lib/gtk-2.0/modules/libgail.so
    * #17 ??
      from /usr/lib/gtk-2.0/modules/libgail.so
    * #18 atk_object_ref_state_set
      from /usr/lib/libatk-1.0.so.0
    * #19 ??
      from /usr/lib/libspi.so.0
    * #20 _ORBIT_skel_small_Accessibility_Accessible_getState
      from /usr/lib/libspi.so.0
    * #21 ??
      from /usr/lib/libORBit-2.so.0
    * #22 ORBit_OAObject_invoke
      from /usr/lib/libORBit-2.so.0
    * #23 ORBit_small_invoke_adaptor
      from /usr/lib/libORBit-2.so.0
    * #24 ??
      from /usr/lib/libORBit-2.so.0
    * #25 ??
      from /usr/lib/libORBit-2.so.0
    * #26 ??
      from /usr/lib/libORBit-2.so.0
    * #27 ORBit_handle_request
      from /usr/lib/libORBit-2.so.0
    * #28 giop_connection_handle_input
      from /usr/lib/libORBit-2.so.0
    * #29 ??
      from /usr/lib/libORBit-2.so.0
    * #30 ??
      from /usr/lib/libORBit-2.so.0
    * #31 g_main_context_dispatch
      from /lib/libglib-2.0.so.0
    * #32 ??
      from /lib/libglib-2.0.so.0
    * #33 g_main_loop_run
      from /lib/libglib-2.0.so.0
    * #34 gtk_main
      from /usr/lib/libgtk-x11-2.0.so.0
    * #35 ??
    * #36 __libc_start_main
      from /lib/tls/i686/cmov/libc.so.6
    * #37 ??

UndiFineD (k.dejong) wrote :

$ sudo gdb synaptic
GNU gdb (Ubuntu/Linaro 7.3-0ubuntu2) 7.3-2011.08
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/sbin/synaptic...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/sbin/synaptic
[Thread debugging using libthread_db enabled]
terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Program received signal SIGABRT, Aborted.
0x00007ffff4d513a5 in __GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
 in ../nptl/sysdeps/unix/sysv/linux/raise.c
(gdb)

Du Chuanwei (meishi-zhaoshi2) wrote :

I accidentally "solved" the problem.I use orca,turn all the “universal access” on,I found that when using orca and Screen keyboard,the screen seems to be reloaded,and when these two things on,synaptic will crash.When start orca from terminal,after several interval settings,terminal will crash at the last moment,and I have to restart orca,then screen will be reloaded as it flashes.The flash also appears when using screen keyboard from "universal access",and turn off the keyboard will flash the screen again.So it seems that the screen keyboard and the screen reader/orca are the problem,turn them off temprorily untill bug fixed.

Extender (msveshnikov) on 2011-10-08
Changed in synaptic:
status: New → Confirmed
Du Chuanwei (meishi-zhaoshi2) wrote :

simply use onboard will not cause this crash,but screen keyboard will run both onboard and a transparent keboard which is perfect for touchpad.The transparent one is the reason.

Changed in synaptic:
status: Confirmed → Incomplete
status: Incomplete → Confirmed
dmiranda (dmiranda) wrote :

This bug also affects oneiric.

Vadim Rutkovsky (roignac) wrote :

Confirmed on oneiric and precise

Changed in synaptic (Ubuntu):
status: New → Confirmed
description: updated
tags: added: testcase
Mauro (jasmines) wrote :

Solved:

gsettings set org.gnome.desktop.interface toolkit-accessibility false

Michael (idmer) wrote :

gsettings set org.gnome.desktop.interface toolkit-accessibility false

Works for me.

David Raviv (davrav) wrote :

gsettings set org.gnome.desktop.interface toolkit-accessibility false

Works for me.

mcbazza (barry-mccauley) wrote :

Kudos to you ^^^^^ all for the 'gsettings' fix!!

I had played around with Orca after seeing it, and that was when SPM started failing. I tried turning the screen reader on/off/etc, and even removing it. Nothing resolved it.
Then I found this 'gsettings' command.

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
Bob Baird (bbaird67401) wrote :

Thank-you for this fix!!!

Julien Olivier (julo) wrote :

gsettings set org.gnome.desktop.interface toolkit-accessibility false

doesn't change a thing for me: I still can't launch synaptic when using gnome-shell's onscreen keyboard.

terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

Jeremy Bicha (jbicha) on 2011-11-16
Changed in synaptic (Ubuntu):
status: Fix Released → Confirmed
Derduden (martin---007) wrote :

gsettings set org.gnome.desktop.interface toolkit-accessibility false
doesn't work for me.
It still crashes.

AZ (m-dev) wrote :

The bug is still present in oneiric with oneiric-updates enabled.
Disabling screen keyboard in gnome-control-center helps for me, gsettings ... does not help (object not found).

Vadim Rutkovsky (roignac) wrote :
Changed in synaptic:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in synaptic:
status: Unknown → New
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please try with the latest version in precise? I fixed one potential crash in this code with the latest upload.

Julien Olivier (julo) wrote :

I confirm that I still have the problem with synaptic-0.75.2ubuntu9 on Precise.

Michael Vogt (mvo) wrote :

Hello Julien Olivier, there should be version 0.75.5~exp2 now in precise.

Vadim Rutkovsky (roignac) wrote :

Michael 0.75.5~exp2 seems to have failed to build - see https://launchpad.net/ubuntu/+source/synaptic/0.75.5~exp2/+build/3136028 for instance

BavarianPH (bavarianph) wrote :

BavarianPM:

it may interest some to know, that,

debian 6.04 wheezy/sid gnome

not only works with gnome 3.2.2

but Synaptic PM works well with

caribou on-screen keyboard.

Ubuntu 11.10 repositories &

gnome 3 keep me with Ubuntu

for now.

Unless Ubuntu starts giving users

freedom to choose destinations, and

adapt to users, as PCs, OSs should do,

solving minor problems like Synaptic PM

being compatible with Universal Access,

debian is starting to look good to me,

especially debian 7.

BavarianPH,
U(buntu)ser friendly OS forever?

Jeremy Bicha (jbicha) wrote :

The latest version of Synaptic works for me even when accessibility is enabled. Thanks!

Changed in synaptic (Ubuntu):
status: Confirmed → Fix Released
crf (chrisfahlman) wrote :

Synaptic crashes with:

terminate called after throwing an instance of 'std::out_of_range'
  what(): vector::_M_range_check

I just updated to Ubuntu 11.10
It worked fine before.

I'm having the same symptoms since I upgraded to 11.10. The difference is that I don't use Orca, never turn it on. If I apply the command "gsettings set org.gnome.desktop.interface toolkit-accessibility false", it fixes the problem but reoccurs when I login back again. Any permanent fix?

Francesco Fumanti (frafu) wrote :

The problem does not occur anymore in Ubuntu Precise (Ubuntu 12.04). I suppose that the updated version should be backported to precise, if possible.

To post a comment you must log in.