Spherical mirror distortion shows almost white sky

Bug #1777320 reported by Phil Shepherd on 2018-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Guillaume Chereau

Bug Description

Starting from version 0.18.0 in Windows 64bit version, when Spherical Mirror Distortion is switched on, the sky immediately goes white.

- The time is set to 17-Jun-2018 at midnight.
- I have 0.17 & 0.18 loaded into different directories, & have tested using the same config.ini file.
- 0.17 works fine... 0.18 does not.

Find attached screen shot from 0.18

Thanks,
Phil

Phil Shepherd (psjshep) wrote :
Phil Shepherd (psjshep) wrote :

config.ini file attached

gzotti (georg-zotti) wrote :

Indeed. Thanks for reporting, this should be fixed ASAP.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
Phil Shepherd (psjshep) wrote :

Nice 1 - appreciate the urgency, Thanks
Phil

gzotti (georg-zotti) on 2018-06-17
Changed in stellarium:
assignee: nobody → Guillaume Chereau (guillaume-chereau)
Phil Shepherd (psjshep) wrote :

Not sure if this might help...

In previous versions, the exact same issue happened if the Milky Way brightness was NOT ticked

i.e
Sky & viewing options -> Sky -> Milky Way Brightness (not ticked, same white sky)

Therefore it was not possible in earlier versions to switch off the Milky Way AND have Spherical Distortion Mirror.

Phil

gzotti (georg-zotti) wrote :

Good observation. This may help in tracing the bug, thanks!

I just pushed a commit that should fix this problem.

On Mon, Jun 18, 2018 at 12:26 AM, gzotti <email address hidden> wrote:
> Good observation. This may help in tracing the bug, thanks!
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1777320
>
> Title:
> Spherical mirror distortion shows almost white sky
>
> Status in Stellarium:
> Confirmed
>
> Bug description:
> Starting from version 0.18.0 in Windows 64bit version, when Spherical
> Mirror Distortion is switched on, the sky immediately goes white.
>
> - The time is set to 17-Jun-2018 at midnight.
> - I have 0.17 & 0.18 loaded into different directories, & have tested using the same config.ini file.
> - 0.17 works fine... 0.18 does not.
>
> Find attached screen shot from 0.18
>
> Thanks,
> Phil
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/stellarium/+bug/1777320/+subscriptions

gzotti (georg-zotti) wrote :

Sorry, this did not fix it. From looking into the effects in V0.18 again, it appears that possibly a glClear is missing somewhere. Without atmosphere I see Milky Way getting increasingly bright, and any grids are overdrawing when I move the view.

My commit added the glClear in core::preDraw, that should be called
even with the effects on. I tested on both linux and windows and it
worked, but there might be some OpenGL problem that make this not work
with other GPU maybe?

On Mon, Jun 18, 2018 at 6:01 PM, gzotti <email address hidden> wrote:
> Sorry, this did not fix it. From looking into the effects in V0.18
> again, it appears that possibly a glClear is missing somewhere. Without
> atmosphere I see Milky Way getting increasingly bright, and any grids
> are overdrawing when I move the view.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1777320
>
> Title:
> Spherical mirror distortion shows almost white sky
>
> Status in Stellarium:
> Confirmed
>
> Bug description:
> Starting from version 0.18.0 in Windows 64bit version, when Spherical
> Mirror Distortion is switched on, the sky immediately goes white.
>
> - The time is set to 17-Jun-2018 at midnight.
> - I have 0.17 & 0.18 loaded into different directories, & have tested using the same config.ini file.
> - 0.17 works fine... 0.18 does not.
>
> Find attached screen shot from 0.18
>
> Thanks,
> Phil
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/stellarium/+bug/1777320/+subscriptions

gzotti (georg-zotti) wrote :

I just run latest build on Win10, Qt5.11, either Intel HD530 or Geforce 960M.
In both cases, switching to Spherical mirror distortion, I see the ground curved around the screen bottom. When switching off ground, I see a white area around what could be the horizon (may be the fog texture, but very bright?). I cannot move the scene with the mouse (i.e. the landscape texture is always presented in one orientation), and sky objects are not visible. With the Guereins landscape, the sky is black, with another one it is bright up to the curved border near top of screen, but not full white, similar to Phil's screenshot above.

Switching off both ground and atmosphere, the sky is displayed correctly with distortion.

Maybe some texture or framebuffer numbers? I tried also with Scenery3D plugin switched off, same problem.

I am really not sure. I will make more tests with same Qt version, see
if I can reproduce.
Did you try with configuration all set to default?

On Tue, Jun 19, 2018 at 6:10 PM, gzotti <email address hidden> wrote:
> I just run latest build on Win10, Qt5.11, either Intel HD530 or Geforce 960M.
> In both cases, switching to Spherical mirror distortion, I see the ground curved around the screen bottom. When switching off ground, I see a white area around what could be the horizon (may be the fog texture, but very bright?). I cannot move the scene with the mouse (i.e. the landscape texture is always presented in one orientation), and sky objects are not visible. With the Guereins landscape, the sky is black, with another one it is bright up to the curved border near top of screen, but not full white, similar to Phil's screenshot above.
>
> Switching off both ground and atmosphere, the sky is displayed correctly
> with distortion.
>
> Maybe some texture or framebuffer numbers? I tried also with Scenery3D
> plugin switched off, same problem.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1777320
>
> Title:
> Spherical mirror distortion shows almost white sky
>
> Status in Stellarium:
> Confirmed
>
> Bug description:
> Starting from version 0.18.0 in Windows 64bit version, when Spherical
> Mirror Distortion is switched on, the sky immediately goes white.
>
> - The time is set to 17-Jun-2018 at midnight.
> - I have 0.17 & 0.18 loaded into different directories, & have tested using the same config.ini file.
> - 0.17 works fine... 0.18 does not.
>
> Find attached screen shot from 0.18
>
> Thanks,
> Phil
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/stellarium/+bug/1777320/+subscriptions

gzotti (georg-zotti) wrote :

Ah right. I should walk through the other plugins as well. With a default config.ini, it seems to work!

gzotti (georg-zotti) wrote :

Very strange. With default config.ini, I enabled first half, then all plugins again, and it still works correctly!
I also tested DSS&HiPS surveys with spherical mirror mode, this has a nasty flicker while loading. But no more issues like above. Must cross-check old and new configs for other reasons.

Alexander Wolf (alexwolf) wrote :

Georg, are you set specific color for sky?

gzotti (georg-zotti) wrote :

Good idea. But no, it's 0/0/0 in both config.ini's. Sorry, must do something else now.

Phil Shepherd (psjshep) wrote :

I'll also do a complete config reset on one of my windows PC & go from there... I should have some time this evening

Phil

Phil Shepherd (psjshep) wrote :

I have tried from a complete new install, having removed everything "stellarium" from my laptop.

No matter what options I try (I have tried a defult config file) I cannot get it to display correctly using Spherical distortion in 0.18.

Georg, can you attach the config file which seemed to work for you?

Phil

Phil Shepherd (psjshep) wrote :

Apologies - just re-read Georg's post a few back - "I just run latest build on Win10, Qt5.11, either Intel HD530 or Geforce 960M."

Do you have a copy of the latest build I can run - I am not able to compile on Windows..

Phil

gzotti (georg-zotti) wrote :

Alexander usually makes weekly betas. But he might have had some other tasks last weekend?

Phil Shepherd (psjshep) wrote :

K - I await a beta release... I have some spare cycles to do some digging, if so...

Phil

Alexander Wolf (alexwolf) wrote :

Please check 0.18.1RC1

Phil Shepherd (psjshep) wrote :

Thanks... got it...

Phil Shepherd (psjshep) wrote :

The RC1 seems to have fixed the issue...

Nice 1.

Phil

gzotti (georg-zotti) on 2018-06-21
Changed in stellarium:
status: Confirmed → Fix Committed
gzotti (georg-zotti) on 2018-07-07
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers