When I type a 'P' followed by an 'i' in the search window, the program crashes

Bug #1184599 reported by Les Thorn on 2013-05-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Medium
Alex Gamper

Bug Description

When I type a 'P' followed by an 'i' in the search window, the program crashes. I have tried all the other letters of the alphabet followed by an 'i' with no problem. This is in version 0.12.1, which I downloaded yesterday.

Related branches

Alexander Wolf (alexwolf) wrote :

I cannot reproduce this issue. Please attach log.txt.

Hi,

I'm sorry you can't reproduce the problem. Please tell me where to find the
log.txt if the two copies below are not what you require, as I've tried
searching for it without success. I have also tried sending the Microsoft
report, but all I can copy to you is the appcompat.txt.
I should add that I'm running Win XP

Regards,

Les Thorn

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 28/05/2013
Time: 15:45:26
User: N/A
Computer: FAMILY
Description:
Faulting application stellarium.exe, version 0.0.0.0, faulting module
libstelmain.dll, version 0.0.0.0, fault address 0x0023e159.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 73 74 65 ure ste
0018: 6c 6c 61 72 69 75 6d 2e llarium.
0020: 65 78 65 20 30 2e 30 2e exe 0.0.
0028: 30 2e 30 20 69 6e 20 6c 0.0 in l
0030: 69 62 73 74 65 6c 6d 61 ibstelma
0038: 69 6e 2e 64 6c 6c 20 30 in.dll 0
0040: 2e 30 2e 30 2e 30 20 61 .0.0.0 a
0048: 74 20 6f 66 66 73 65 74 t offset
0050: 20 30 30 32 33 65 31 35 0023e15
0058: 39 0d 0a 9..

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: 28/05/2013
Time: 15:47:16
User: N/A
Computer: FAMILY
Description:
Faulting application stellarium.exe, version 0.0.0.0, faulting module
libstelmain.dll, version 0.0.0.0, fault address 0x0023e159.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 73 74 65 ure ste
0018: 6c 6c 61 72 69 75 6d 2e llarium.
0020: 65 78 65 20 30 2e 30 2e exe 0.0.
0028: 30 2e 30 20 69 6e 20 6c 0.0 in l
0030: 69 62 73 74 65 6c 6d 61 ibstelma
0038: 69 6e 2e 64 6c 6c 20 30 in.dll 0
0040: 2e 30 2e 30 2e 30 20 61 .0.0.0 a
0048: 74 20 6f 66 66 73 65 74 t offset
0050: 20 30 30 32 33 65 31 35 0023e15
0058: 39 0d 0a 9..

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Alexander Wolf
Sent: 28 May 2013 13:34
To: <email address hidden>
Subject: [Bug 1184599] Re: When I type a 'P' followed by an 'i' in the
searchwindow, the program crashes

I cannot reproduce this issue. Please attach log.txt.

--
You received this bug notification because you are subscribed to the bug
report. https://bugs.launchpad.net/bugs/1184599

Title:
  When I type a 'P' followed by an 'i' in the search window, the program
  crashes

Status in Stellarium:
  New

Bug description:
  When I type a 'P' followed by an 'i' in the search window, the program
  crashes. I have tried all the other letters of the alphabet followed
  by an 'i' with no problem. This is in version 0.12.1, which I
  downloaded yesterday.

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1184599/+subscriptions

Alexander Wolf (alexwolf) wrote :

Please try find here: Start -> Programs -> Stellarium -> Last run log

Les Thorn (les-9) wrote :

Hi Alexander,

Found it!

Les

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Alexander Wolf
Sent: 28 May 2013 17:08
To: <email address hidden>
Subject: [Bug 1184599] Re: When I type a 'P' followed by an 'i' in the
searchwindow, the program crashes

Please try find here: Start -> Programs -> Stellarium -> Last run log

--
You received this bug notification because you are subscribed to the bug
report. https://bugs.launchpad.net/bugs/1184599

Title:
  When I type a 'P' followed by an 'i' in the search window, the program
  crashes

Status in Stellarium:
  New

Bug description:
  When I type a 'P' followed by an 'i' in the search window, the program
  crashes. I have tried all the other letters of the alphabet followed
  by an 'i' with no problem. This is in version 0.12.1, which I
  downloaded yesterday.

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1184599/+subscriptions

Alexander Wolf (alexwolf) wrote :

Can you show log after crash?

Changed in stellarium:
importance: Undecided → Medium
Keatah (keatah) wrote :
Download full text (4.9 KiB)

I got the same crash too.

log.txt

2013-05-29T03:14:58
Windows XP
Compiled using MinGW GCC 4.6.2
Qt runtime version: 4.8.4
Qt compilation version: 4.8.4
Addressing mode: 32-bit
Total memory: 2014 MB (unreliable)
Total virtual memory: 2047 MB (unreliable)
Physical memory in use: 45%
Processor speed: 1694 MHz
Processor name: Intel(R) Pentium(R) M processor 1.70GHz
C:\Program Files\Stellarium\stellarium.exe --safe-mode --user-dir C:\Program Files\Stellarium\data2
 -------------------------------------------------------
[ This is Stellarium 0.12.1 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "C:/Program Files/Stellarium/data2/log.txt"
File search paths:
  0 . "C:/Program Files/Stellarium/data2"
  1 . "."
Config file is: "C:/Program Files/Stellarium/data2/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "1.3.0 - Build 4.14.10.4497"
Qt GL paint engine is: "OpenGL"
StelQGL2Renderer::init : Failed because Qt paint engine is not OpenGL2
If paint engine is OpenGL3 or higher, this code needs to be updated
Failed to initialize the OpenGL 2 renderer, falling back to the OpenGL 1 renderer
OpenGL supported version: "1.3.0 - Build 4.14.10.4497"
Qt GL paint engine is: "OpenGL"
GL vendor is "Intel"
GL renderer is "Intel 855GM"
Cache directory is: "C:\Documents and Settings\Owner\Local Settings\Application Data\stellarium\stellarium\cache"
Sky language is "en_US"
Application language is "en_US"
Loading Solar System data ...
Loaded 75 / 75 planet orbits from "C:/Program Files/Stellarium/data2/data/ssystem.ini"
Loading star data ...
"Loading "./stars/default/stars_0_0v0_2.cat": 0_0v0_2; 4963"
"Loading "./stars/default/stars_1_0v0_2.cat": 1_0v0_2; 21598"
"Loading "./stars/default/stars_2_0v0_2.cat": 2_0v0_2; 150090"
"Loading "./stars/default/stars_3_1v0_1.cat": 3_1v0_1; 423540"
"Loading "C:/Program Files/Stellarium/data2/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
"Loading "C:/Program Files/Stellarium/data2/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
"Loading "C:/Program Files/Stellarium/data2/stars/default/stars_6_2v0_0.cat": 6_2v0_0; 26615233"
"Loading "C:/Program Files/Stellarium/data2/stars/default/stars_7_2v0_0.cat": 7_2v0_0; 57826266"
ERROR: SpecialZoneArray( 8 )::SpecialZoneArray: QFile( "C:/Program Files/Stellarium/data2/stars/default/stars_8_2v0_0.cat" .map( 5242912 , 701538504 ) failed: "Not enough storage is available to process this command."
"Loading "C:/Program Files/Stellarium/data2/stars/default/stars_8_2v0_0.cat": 8_2v0_0; - initialization failed"
Finished loading star catalogue data, max_geodesic_level: 7
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 400 / 400 NGC name records successfully
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Loaded 88 / 88 constellation records successfully for cul...

Read more...

Keatah (keatah) wrote :

@AlexWolf - I'm using the Western sky culture. And this problem seems to be related to that. I tried all the other included sky cultures and the "pi" search bug didn't seem to show up..

For example - I was able to successfully search "pinwheel galaxy" in every sky culture EXCEPT Western. Western seems broke but good.

When using Western culture..
I CAN search Jupiter.
I CAN search Telescopium.

I CANNOT search Pisces.
I CANNOT search Pinwheel Galaxy.

Hope this helps narrow it down.

Keatah (keatah) wrote :

One more thing. Probably unrelated, but why do only 3215 out of 4359 scientific names load?

log.txt
.
.
.
Loaded 3215 / 4359 scientific star names

Keatah (keatah) wrote :

I am able to search for Pisces or Pictor in the the Western sky culture *if* I type:

isces

and then left-arrow-over it or use the home key to get to the beginning

and then type

p

thus resulting in the word "pisces" being entered in the search box in a roundabout way, so to speak. Does that make sense?

To seach pictor, I do the same thing.

Type "ictor" and left-arrow to the beginning and type "p", making the word "pictor".

To search Pinwheel Galaxy I have to type "inwheel", arrow-back, type "p". Then it works.

Alex Gamper (agamper) wrote :

Hi Alexander

The issue seems to be caused by SearchDialog.cpp line 341 "matches += objectMgr->listMatchingObjectsI18n(greekText, (5 - matches.size()));"

greekText is set to the Pi mathematical symbol, and matches.size() is > 5

Changed in stellarium:
status: New → Confirmed
Alexander Wolf (alexwolf) wrote :

Hi Alex, you are right. Thanks for debugging!

Changed in stellarium:
assignee: nobody → Alex Gamper (agamper)
milestone: none → 0.12.2
status: Confirmed → Fix Committed
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 6059 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/6059

Note: this issue was reproducible only with English locale

Keatah (keatah) wrote :

Do you mean Locale = Sky Culture?

Alexander Wolf (alexwolf) wrote :

No, locale = language

Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers