Screenlets applications moving around after a restart in Ubuntu 11.10

Bug #885322 reported by john Alatalo on 2011-11-02
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Screenlets
High
Unassigned

Bug Description

I have noticed that the screenlets applications moving to a differents place on the screen after a restart in Ubuntu 11.10.
Even if the settings are set at "lock on screen"
http://screenlets.org/index.php/Home

The clock can move behind the calendar for example. That never happend in the previous 11.04 version.

Related branches

How it looks after a restart.

Märt Põder (boamaod) on 2011-11-02
Changed in screenlets:
status: New → Confirmed
importance: Undecided → High
Märt Põder (boamaod) wrote :

It's probably connected to the comments in the end of this report: https://bugs.launchpad.net/screenlets/+bug/345359

So the screenlets move regularly into the same y-axis position, but x-axis is fine? Any more regularities?

Are you using the latest Screenlets from PPA? What is the exact version?

I have downloaded the Screenlets from the "Ubuntu software center" and all avaible updates ared done to. So I suppose it's the latest version of it.

Sometimes they are at the correct place after a restart. And next time it can be on the wrong place again.

I also installed Ubuntu 11.10 in a friends laptop and the behaviour is same there as in my own PC.

After the latest updates it seems like this problem are solved. My Screenlets are at same place now even after a restart.
So I suppose this can be closed if nobody else still got this problem.

Märt Põder (boamaod) wrote :

Please let us know if the problems continue to happen. I see that three people say they are affected by this problem. Maybe the problem occurs only after some of the first launches and then disappears?

Märt Põder (boamaod) wrote :

It seems that the problem is caused by Unity changing screen parameters in the middle of a screenlets loading/drawing themselves.

There are things in the logs like:

   Screen geometry changed
   Starting unity-window-decorator
   DEBUG 2011-11-04 20:01:21 glib <unknown>:0 Setting to primary screen rect: x=0 y=0 w=1024 h=768

And it seems when a screenlet is loaded during these changes, it will place itself wrong. I think that the solution would be to delay starting of screenlets, i. e. in ~/.config/autostart/*Screenlet.desktop add on the "Exec= sleep 5 && python -u ..." to delay starting the screenlet 5 seconds later (when Unity is probably already loaded).

If you have this problem and this solution works, please tell us so, maybe this bug can be fixed for good.

Märt Põder (boamaod) wrote :

Oh, probably you cannot just put "sleep 5 &&" there in the middle, but have to do it like

   Exec= bash -c "sleep 5 && python -u /usr/share/screenlets/screenlets-pack-basic/Lipik/LipikScreenlet.py"

It have happend again for me. So I will stop using the Screenlets to this problem are solved.

I have noticed this seems to happend after some update packages are released and when it ask to "restart" the computer.

Märt Põder (boamaod) wrote :

I think I have found a workaround for the problem. I hope it will be available in Screenlets Dev PPA in next 24h.

Märt Põder (boamaod) on 2011-12-14
Changed in screenlets:
status: Confirmed → In Progress
Märt Põder (boamaod) on 2011-12-14
Changed in screenlets:
status: In Progress → Fix Committed

Is this bug a duplicate of bug #872755?

Märt Põder (boamaod) wrote :

Now I marked this bug as duplicate of #872755, but it should be the other way around.

Still an issue with latest version 0.1.7~bzr836 on both Ubuntu 12.04 and 12.10 (both 64-bit).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers