SchoolTool server does not start after upgrade to Karmic

Bug #462254 reported by Gediminas Paulauskas
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SchoolTool
Critical
Gediminas Paulauskas

Bug Description

SchoolTool server fails to start with an error:

http://pastebin.com/f2a5d3337

Talk about issues on karmic:

http://schooltool.pov.lt/irclogs/search?q=karmic

Revision history for this message
Gediminas Paulauskas (menesis) wrote :
Changed in schooltool:
status: New → Confirmed
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

it is my immediate priority to create schooltool (and all the dependencies, including zope) packages for karmic

Changed in schooltool:
assignee: nobody → Gediminas Paulauskas (menesis)
importance: Undecided → Critical
milestone: none → 1.2.0
Changed in schooltool:
status: Confirmed → In Progress
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

I have uploaded python-schooltool_2009.04.17-2 to https://edge.launchpad.net/~schooltool-owners/+archive/ppa/+build/1312575

You may need to manually resolve dependencies. Choose to upgrade python-schooltool and downgrade python-zope.component to version 3.4.0 from SchoolTool PPA.

Doing so would fix the exception posted in paste.log

Please try and reply if the server now starts, sudo /etc/init.d/schooltool-2009 start

Changed in schooltool:
milestone: 1.2.0 → 1.0.4
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

So if you upgraded to karmic, you may have to downgrade some packages manually. Use SchoolTool PPA for jaunty, and downgrade the following packages:

zodb < 3.9.0
zope.component < 3.6.0
zope.i18n < 3.6.0
zope.location < 3.5.0
zope.publisher < 3.6.0
zope.security < 3.6.0
zope.traversing < 3.6.0

python-schooltool 1:1.0.3-2ubuntu2 package puts that into depends, upgrade it and then resolve other dependencies.

Revision history for this message
Gediminas Paulauskas (menesis) wrote :

After doing so, your schooltool server should work on karmic, it does on my machine.

Revision history for this message
Tom Hoffman (tom-hoffman) wrote :

How does one actually do that?

Revision history for this message
Gediminas Paulauskas (menesis) wrote :

I solve all dependency problems using `aptitude`. With it you can choose, which solution to use when there is a conflict.

Or I think this would work:
  apt-get install python-schooltool python-zope.component/jaunty python-zodb/jaunty ...

You can pin packages to specific source in apt.conf, but I do not have an example now.

Revision history for this message
Gediminas Paulauskas (menesis) wrote :

This bug was fixed by:

python-schooltool (1:1.0.3-2ubuntu2) jaunty; urgency=low

 * Require versions compatible with SchoolTool 1.0 (Closes LP: #462254):
   - zope.i18n < 3.6.0
   - zope.location < 3.5.0
   - zope.publisher < 3.6.0
   - zope.security < 3.6.0
 * Restore a replace of PILwoTk with PIL in setup.py and requires.txt

 -- Gediminas Paulauskas <email address hidden> Fri, 30 Oct 2009 17:53:50 +0200

Changed in schooltool:
status: In Progress → Fix Released
Revision history for this message
Gediminas Paulauskas (menesis) wrote :

All the packages are now in karmic PPA, but the dependencies cannot be automatically satisfied. To get schooltool installed and not be bothered by upgradable packages that would break schooltool, add this to /etc/apt/preferences ::

Explanation: prefer packages from SchoolTool PPA
Package: *
Pin: release o=LP-PPA-schooltool-owners
Pin-Priority: 1001

Instead of selecting all packages (*), you can pin only the conflicting packages, see the attached file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers