Dock disappears after a short amount of use.

Bug #1073426 reported by David Wales
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Plank
High
Unassigned

Bug Description

You can see application names when you move your mouse where you'd expect the dock to be, but you can't see the dock or any icons, and you can't open any applications with it.

(I'm running Luna in a VMWare Fusion virtual machine on a Mac, if that makes any difference.)

ProblemType: Bug
DistroRelease: elementary OS 0.2
Package: elementary-desktop 1.284-0~355~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic-pae 3.2.30
Uname: Linux 3.2.0-32-generic-pae i686
ApportVersion: 2.0.1-0ubuntu14+elementary3~precise1
Architecture: i386
CrashDB: elementary_meta
Date: Tue Oct 30 18:20:37 2012
InstallationMedia: elementary OS 0.2 "Luna" - Build i386 LIVE Binary 20121027-03:48
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
David Wales (daviewales) wrote :
description: updated
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

I can confirm but only on LiveCD

Changed in elementaryos:
status: New → Confirmed
Revision history for this message
Thang Nguyen (thang-nguyencao) wrote :

Same on my laptop Dell vostro V3550. Upgraded from unstable build 01112011 to beta 1.

Revision history for this message
Rick Kerkhof (rick-2288) wrote :

I can also only confirm this on a liveCD. It is kind of annoying though since I use my Live USB to have my "computer" with me when at school, and I have to guess where Plank's hiding itself.

Revision history for this message
Lilian A. Moraru (lilianmoraru) wrote :

On live "cd" now and I confirm the bug.
Here is a screenshot.

Revision history for this message
Lilian A. Moraru (lilianmoraru) wrote :

Rick Kerkhof, if you maximize a window, the dock will appear back.

Cody Garver (codygarver)
Changed in elementaryos:
milestone: none → luna-rc1
Changed in pantheon-dock:
milestone: none → luna-rc1
Changed in elementaryos:
importance: Undecided → High
Changed in pantheon-dock:
importance: Undecided → High
status: New → Incomplete
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Got this on an installed system once, here's a screencast.

Revision history for this message
Rick Kerkhof (rick-2288) wrote :

Lilian A. Moraru, that doesn't work on any of my computers.

Cody Garver (codygarver)
Changed in pantheon-dock:
milestone: luna-rc1 → 0.3-beta1
Revision history for this message
Cody Garver (codygarver) wrote :

I can't reproduce this.

Changed in elementaryos:
status: Confirmed → Incomplete
Cody Garver (codygarver)
Changed in elementaryos:
milestone: luna-rc1 → none
Revision history for this message
Justin Zobel (justin-zobel) wrote : Re: [Bug 1073426] Re: Dock disappears after a short amount of use.

This actually happened in Luna final today in the live boot environment pre
installation.
On 11 Aug 2013 11:25, "Cody Garver" <email address hidden> wrote:

> ** Changed in: elementaryos
> Milestone: luna-rc1 => None
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1185370).
> https://bugs.launchpad.net/bugs/1073426
>
> Title:
> Dock disappears after a short amount of use.
>
> Status in elementary OS:
> Incomplete
> Status in Pantheon Dock:
> Incomplete
>
> Bug description:
> You can see application names when you move your mouse where you'd
> expect the dock to be, but you can't see the dock or any icons, and
> you can't open any applications with it.
>
> (I'm running Luna in a VMWare Fusion virtual machine on a Mac, if that
> makes any difference.)
>
> ProblemType: Bug
> DistroRelease: elementary OS 0.2
> Package: elementary-desktop 1.284-0~355~precise1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.2.0-32.51-generic-pae 3.2.30
> Uname: Linux 3.2.0-32-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu14+elementary3~precise1
> Architecture: i386
> CrashDB: elementary_meta
> Date: Tue Oct 30 18:20:37 2012
> InstallationMedia: elementary OS 0.2 "Luna" - Build i386 LIVE Binary
> 20121027-03:48
> SourcePackage: elementary-meta
> SuspiciousXErrors:
>
> ThirdParty: True
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1073426/+subscriptions
>

Revision history for this message
yEdubart (vps1992) wrote :

This happen to me once with the OS installed.

Revision history for this message
Peste Razor (peste-razor) wrote :

Yes it happened to me too, when I was trying the Live CD.

Revision history for this message
Rico Tzschichholz (ricotz) wrote :

Please reconfirm this problem using a recent version of plank, 0.4.0+bzr922 and later.

affects: elementaryos → plank
Changed in pantheon-dock:
status: Incomplete → Confirmed
Changed in plank:
status: Incomplete → Confirmed
Changed in pantheon-dock:
status: Confirmed → Incomplete
Changed in plank:
status: Confirmed → Incomplete
Revision history for this message
Ujjwal Sharma (ujjwal-sharma) wrote :

Can confirm this on a proper install on a HP 430 Notebook PC.Plank has been updated but the problem persists with Plank disappearing however the icons can be clicked and the description text is visible.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for Plank because there has been no activity for 60 days.]

Changed in plank:
status: Incomplete → Expired
Revision history for this message
Robert Dyer (psybers) wrote :

This actually happened to me the other day. For me, it was shortly after the dock started.

I believe it happened twice. And I of course always run the latest version.

Changed in plank:
status: Expired → Confirmed
Revision history for this message
Robert Dyer (psybers) wrote :

Just happened again. Only this time I noticed the gnome-panel is behaving similarly. I think this might be a compositing manager bug and not Plank specific. A 'metacity --replace&' fixed it right up.

Revision history for this message
Cody Garver (codygarver) wrote :

I am unable to reproduce this on an Isis iso so I removed it from the beta1 milestone

Changed in pantheon-dock:
milestone: isis-beta1 → none
Revision history for this message
nixxx (nixxx) wrote :

I still have it in a Isis iso. If it can help sometimes I can see the dock fastly sliding up on the desktop in the direction of wingpanel before disappearing.

Revision history for this message
Mateusz Sieprawski (crom9153) wrote :

Same problem here. I've only installed Tweaks recently. But after installing Tweaks dock was working correctly. Now when I turn on system I see it only for 2 seconds. Then sometimes I can see the dock fastly sliding up on the desktop.

Revision history for this message
Rico Tzschichholz (ricotz) wrote :

Please try to reproduce with r1060. r1059 and r1060 might have an impact on this problem.

Daniel Fore (danrabbit)
no longer affects: pantheon-dock
Revision history for this message
indigocat (indigocat) wrote :

Same thing that happened to shnatsel, happened to me in the same way in Freya (but not even icon labels were visible).

It happens every time I open Shotwell and maximize it.
Dock reappears a minute after closing Shotwell.

Revision history for this message
vamshi krishna (vamshi9666) wrote :

i am facing same . plank is disappearing if any window is opened in full size .if i try to click on plank .its hiding .In ubuntu 18.04

Revision history for this message
ALinuxUser (buntulongername-new) wrote :

This may have to do with libraries - things outside Plank. For, I had the problem on Mint 18, but on Mint 19 I no longer do.

Ana Ortiz (ggortiz)
Changed in plank:
status: Confirmed → In Progress
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers