Pipelight stopped working with Chrome 35 (NPAPI deprecation)

Bug #1321505 reported by Felipe Castillo on 2014-05-21
122
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Pipelight
Critical
Unassigned

Bug Description

The plugin doesn't work any more with any website after the release of the new Chrome version, it still works under Firefox.
I'm using:

Chrome 35.0.1916.114
Ubuntu 14.04 64bit with Unity
Nvidia drivers

Eric Nemchik (eric-nemchik) wrote :

this is essentially the same bug as Bug #1307989 but hopefully this is considered a high priority since google has pushed chrome 35 out as a stable release and this will affect a lot of people

Sebastian Lackner (slackner) wrote :

This bug is no duplicate of #1307989: While #1307989 is referring to Chrome 34 on Ubuntu Trusty, where the Ubuntu developers backported Aura (and which will most probably be closed anyway, because it doesn't make any difference anymore now), this bug report is referring to Chrome 35 and the NPAPI deprecation in general.

Eric Nemchik (eric-nemchik) wrote :

@slackner, sorry I didn't mean to imply it was a duplicate, merely provide it as reference since it is the same circumstance (npapi disabled breaking pipelight).

As I doubt Google will be taking any backward strides in this department, for pipelight to work it would have to be converted/remade to ppapi.

Changed in pipelight:
status: New → Confirmed
Sebastian Lackner (slackner) wrote :

@eric-nemchik: No problem.

During the last months we tried out several approaches how to make it possible to continue providing Pipelight, and I'll summarize the results below.

* Our first approach was also the idea to add some additional wrapper on top of the existing Pipelight code, to make it possible to load the plugin as PPAPI. To be a bit more precise, there is not only PPAPI, there is NaCl and PPAPI. Both are basically the same plugin interface, but NaCl is highly sandboxed. Since Pipelight depends on the communication to external processes, we cannot use a sandboxed plugin interface. Concerning PPAPI: There is already a working prototype, but:

- There is no way to "install" PPAPI plugins. You either have to pass a very long command line or even to recompile Chromium
- By default PPAPI plugins are still executed in a sandbox, which has to be disabled for the whole browser to get it working
- PPAPI uses a different Cross-Origin policy handling than NPAPI, which could result in a lot of new plugin errors, where we cannot do anything to fix them
- no embedding of the plugin window into the browser
- ...

Thats why we also started a second approach:

* Providing some patches for Chromium to add back minimal NPAPI support. They are written by Michael Müller and linked in the bug report above. Even though embedding is still not supported (because its not implemented/possible by their new rendering engine anymore), it seems to be the much cleaner approach.

Regards,
Sebastian

Felipe Castillo (fcastillo.ec) wrote :

@slackner: I'm going to guess that pipelight will take the second approach to fix this issue. Will this patches be ported to Google Chrome also? Many of us use the official Chrome version instead of Chromium

Sebastian Lackner (slackner) wrote :

@fcastillo.ec: Its very unlikely that Chrome will add these patches. Their goal is to stop people from using NPAPI in favor of NaCl-Modules (which only work in Chrome+Chromium) and HTML5/JavaScript solutions - I highly doubt that they would do the effort to add this feature back, just to remove it a few weeks/months later again.

So far only LInux is affected by this deprecation, but the plan is to do the same on Windows at the end of this year - which basically means that it will not be possible anymore to use Chrome or Chromium to watch Netflix or other VOD services at all, because they're all using Silverlight or Internet-Explorer-DRM (at least at the moment).

Changed in pipelight:
status: Confirmed → Triaged
Sebastian Lackner (slackner) wrote :

I've marked this bug report as critical (although its unlikely that it can be fixed in the near future) as a lot of new users encounter this problem. This should hopefully allow them to find the reason a bit faster ;)

summary: - PIpelight stopped working with Chrome 35
+ Pipelight stopped working with Chrome 35
Changed in pipelight:
importance: Undecided → Critical
summary: - Pipelight stopped working with Chrome 35
+ Pipelight stopped working with Chrome 35 (NPAPI deprecation)
Felipe Castillo (fcastillo.ec) wrote :

I really can't go back to Firefox, it's lacking so many things and even with speed is a lot slower than Chrome. The only "workaround" that I could come up with is downgrading to a previous version of Chrome. I've attached the deb package from my /var/cache/apt/archives
I only have the 64bit version, sorry to anybody that uses 32bit maybe somebody else with 32bit could post their package.

I know this is not an optimal solution at all, you'll have to stick to older features without mentioning all the security fixes that will be lacking. It's risky but it's worth it for me.

Sebastian Lackner (slackner) wrote :

For those that have the same problem:

You can also grab old versions of google-chrome from here:
http://mirror.pcbeta.com/google/chrome/deb/pool/main/g/google-chrome-stable/

Direct links to the last version with NPAPI support:

http://mirror.pcbeta.com/google/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_34.0.1847.137-1_amd64.deb
(sha256sum: 3237f3cb756576e8f2adbba14a9592316668cc59d0f57e1923fe08638e580f93)

http://mirror.pcbeta.com/google/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_34.0.1847.137-1_i386.deb
(sha256sum: d449afbd5999df2d72b47712136ff5ae3df4cb7322736c9099149a6329b18932)

I used Firefox to watch a movie on Netflix tonight and it worked great. No troubles. I can wait until the Chrome bugs are fixed.

Emanuele (minuz71) wrote :

I think that also firefox will exclude NPAPI plugins soon..... and looking at the problems encountered about ppapi I'm quite worried...

Jon Paul Sapsford (studiorion) wrote :

I'm having the same bug. xubuntu 14.04 . I downloaded a few of the older versions of Chrome to get it working again, but aside from it yelling at me about my profile not working, nothing seems to have changed. Anyone have any suggestions? I've even done a 100% fresh install of the OS to ensure that no traces of Chrome 35 were there and still nothing works.

Sebastian Lackner (slackner) wrote :

@Jon Paul Sapsford:
You should probably open a separate question ( https://answers.launchpad.net/pipelight/+addquestion ) about this issue, since this is not really related to this bug report. Did you enable the Silverlight plugin, so the browsers do even load it (pipelight-plugin --list-enabled-all)? Did you also install a user agent switcher again and set it up according to the FAQ? Sometimes the diagnostic page (http://fds-team.de/pipelight) or the new system-check-tool (pipelight-plugin --system-check) also helps to find issues. Please note that you can ignore when specific libs are missing, this is not really a problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers