Rendering error on multiple monitors

Reported by Jorge O. Castro on 2011-03-17
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
overlay-scrollbar
Medium
Unassigned

Bug Description

Sometimes the grippie thing shows up on the wrong monitor. (See red highlights in the screenshot)

Jorge O. Castro (jorge) wrote :
Andrea Cimitan (cimi) wrote :

That's a feature! So that you are sure to use both monitors :D ahaha

(I'm kidding)

Well, will figure out... looks like I'm not getting the screen size of the right monitor

Andrea Cimitan (cimi) wrote :

the bug is in os_scrollbar_sanitize_x and os_scrollbar_sanitize_y.
We should use gdk_screen_get_monitor_geometry instead gdk_screen_get_width... (or a combo), if someone is willing to do these calculations, it is pure math (bitesize bug?)

Changed in ayatana-scrollbar:
status: New → Triaged
importance: Undecided → Medium
tags: added: ayatana-scrollbar-bitesize-bug
Jorge O. Castro (jorge) on 2011-03-18
tags: added: bitesiz
removed: ayatana-scrollbar-bitesize-bug
tags: added: bitesize
removed: bitesiz
Andrea Cimitan (cimi) on 2011-03-18
tags: added: ayatana-scrollbar-bitesize-bug
tags: added: ayatana-scrollbar-bitesize
removed: ayatana-scrollbar-bitesize-bug
tags: added: ayatana-scrollbar-bitesize-bug
removed: ayatana-scrollbar-bitesize
Diska (discardi-nicola) wrote :

with nautilus and gedit scrollbar work fine for me. can you try if it work bad only with that specific program? and tell me what program you was using?

Andrea Cimitan (cimi) wrote :

Diska it's clearly a bug in the positioning, I'm not taking into account the phisical monitors, the thumb should be constrained to the phisical screen where the scrollbar is

Diska (discardi-nicola) wrote :

i understand. i was trying to reproduce case but with application above all work fine.

Bilal Akhtar (bilalakhtar) wrote :

I'll try fixing this.

Changed in ayatana-scrollbar:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Bilal Akhtar (bilalakhtar) wrote :

Hi Andrea,

I've tested my branch on a dual monitor setup. In the test I opened a window of gedit and I checked whether the scrollbars worked well on both the monitors. I tested corner cases as well. However there was 1 small flaw detected in the test: In the first monitor the grippie came on the right side when not maximized and left side when maximized. But on the second monitor the grippie came on the left side always, regardless of the fact whether the window was maximised or not. A very small flaw, but the rest was flawless.

I am proposing this branch to be merged into trunk

Bilal Akhtar (bilalakhtar) wrote :

Weird. I downgraded to the PPA version, and the bug didn't exist there! It was a completely flawless experience there, and even the left-side grippie problem (which is evident in my branch) didn't occur there.

Jorge, Can you confirm whether this is fixed for you? If it is, then this bug is closed without any branch merge, etc.

Andrea Cimitan (cimi) wrote :

it can't be fixed, because my code is clearly bugged :D
I will fix id someday, if you are not going to fix this

Andrea Cimitan (cimi) on 2011-03-28
Changed in ayatana-scrollbar:
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: In Progress → Triaged
Bilal Akhtar (bilalakhtar) wrote :

After discussion with Cimi on IRC, I decided to leave this bug as my way of fixing it failed partially. Anyone wanting to fix this bug can look at the linked branch which contains the code I wrote for fixing this bug.

Changed in ayatana-scrollbar:
status: Triaged → Confirmed
Andrea Cimitan (cimi) on 2011-03-28
Changed in ayatana-scrollbar:
status: Confirmed → Triaged
Andrea Cimitan (cimi) on 2011-03-30
Changed in ayatana-scrollbar:
status: Triaged → Fix Committed
Andrea Cimitan (cimi) on 2011-03-30
Changed in ayatana-scrollbar:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers