[Upstream] [hardy] OpenOffice should warn users before saving in /tmp

Bug #39854 reported by Tero Karvinen on 2006-04-17
52
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

1. Open a document from the web (say from a web-based email site).
2. Edit the document, save changes.
3. Shut down the computer.
4. Turn the computer back on ... your file is gone!

This is a very common problem, I have seen tens of persons saving to /tmp/.

I think it should be fixed in OpenOffice.org save as dialog. When the "File: Save as" dialog is shown:
1) Check if "Save in folder" is /tmp/ or /var/tmp/
2) If yes, change the "Save in folder" to $HOME

In Evince pdf document viewer, it is already solved like this. In the highly unlikely (imposible?) case that user wants to store a document under /tmp, he is free to navigate to that directory. It is most important to correct this in OpenOffice - more than 95% saves in /tmp/ I have seen are done with OpenOffice. This bug is also filed against Firefox, I copied the reproduce steps from bug #15179.

Note: the original reporter indicated the bug was in package 'openoffice'; however, that package was not published in Ubuntu.

KarlGoetz (kgoetz) wrote :

I can confirm this, after spending half an hour explaining to someone why an email atchment saved from thunderbird isnt there now.
This should probably be marked a dupe of the bug linked to above, but filed against both packages.

Changed in openoffice.org:
status: Unconfirmed → Confirmed
Chris Burgan (cburgan) on 2007-04-02
Changed in openoffice.org:
importance: Medium → Wishlist

I'm an experienced user in every sense of the word. I've been using Linux exclusively for several years, and I am comfortable with it at all levels. I just suffered a CDL (catastrophic document loss ;-) ) because of this very bug. OpenOffice goes to great length to remind me when I'm saving a file in plaintext, or saving a file as PPT, or in any other document format that I *just might* lose some data if I save in this format.

Allowing me to repeatedly save a document that will then be totally and utterly destroyed is unacceptable user interface.

Chris Cheney (ccheney) on 2007-10-19
description: updated
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-03-31
Changed in openoffice.org:
importance: Wishlist → High
status: Confirmed → In Progress
Chris Cheney (ccheney) wrote :

This is partially alleviated by programs like Firefox now making transient files read-only which puts OOo into read-only mode as well, when clicking on the edit button it causes the save to default to the users home directory probably halfway by accident.

Topher (hunt-topher) wrote :

Good point, Chris. I've noticed that sometimes OpenOffice seems to act as though directly downloaded documents were opened from template, so I'd need to perform a Save As... instead of Save. But even if document loss is less likely when used with an up-to-date Firefox, OpenOffice should probably be more robust to preventing such (potentially severe) data loss.

Chris Cheney (ccheney) wrote :

Topher,

I agree and there is already an upstream bug report to deal with the overall issue. I was just mentioning it seems like the common causes of the problem have been resolved by Firefox (and it appears Evolution) making downloaded/attachments read-only which causes OOo to go into read-only mode as well.

Chris

Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: In Progress → Triaged
Chris Cheney (ccheney) on 2009-03-20
Changed in openoffice.org:
importance: High → Medium
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy
Changed in openoffice.org (Ubuntu):
importance: Medium → Wishlist
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

KarlGoetz (kgoetz) wrote :

I've just tried using libreoffice on debian (version at end) and it opened the document read only. Once 'save as' is used, it still defaults to the temporary directory. I'd suggest this means the bug is still open on the build I have, so I'm inclined to think this bug still exists. Can anyone still produce it on Ubuntu?

LibreOffice 3.3.2
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Debian package 1:3.3.2-2~bpo60+1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.