Please provide indicator-applet support in empathy

Bug #340180 reported by none on 2009-03-09
120
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ayatana Ubuntu
High
Ken VanDine
Empathy
Expired
Low
NULL Project
Undecided
Unassigned
empathy (Ubuntu)
Wishlist
Ken VanDine
Karmic
Wishlist
Ken VanDine

Bug Description

The Empathy IM application does not seem to be supported by the indicator applet. Such support would be nice to have.

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy:
status: Unknown → New
Ted Gould (ted) wrote :

Nothing to be done in the indicator applet for this.

Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Update to 2.27.2 and include the patch with indicator support

Changed in empathy:
status: New → Confirmed
Nicolò Chieffo (yelo3) on 2009-06-15
Changed in null:
status: New → Invalid
summary: - Please provide Empathy support
+ Please provide indicator-applet support in empathy
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.27.3-1ubuntu1

---------------
empathy (2.27.3-1ubuntu1) karmic; urgency=low

  * Merge from debian experimental, remaining changes: (LP: #388590)
    - Add Suggests on telepathy-idle
    - Bump telepathy-butterfly and telepathy-haze to recommends
  * debian/patches/001_add_indicator.patch:
    - Add libindicate support (LP: #340180)
  * debian/patches/099_autoreconf.patch: Run autoreconf

empathy (2.27.3-1) experimental; urgency=low

  * New upstream release.
    - Bump libraries soname and adjust .symbols files
  * debian/control: Bump libtelepathy-glib-dev build-dep
  * debian/libempathy-gtk-common.install: Add default adium theme

 -- Laurent Bigonville <email address hidden> Tue, 23 Jun 2009 11:43:15 +0200

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
Hooman Baradaran (hoomanb) wrote :

This bug is back in 2.27.4 .

Hooman Baradaran (hoomanb) wrote :

The bug is back - Version 2.27.4

Changed in empathy (Ubuntu):
status: Fix Released → Confirmed
Vish (vish) wrote :

Still present in empathy 2.27.5-0ubuntu1

Nominated for Karmic , since empathy is now the default IM client

Nicolò Chieffo (yelo3) wrote :

Aren't we in feature freeze now?

Ken VanDine (ken-vandine) wrote :

Yes we are, but this is actually a regression for our default IM client (even though packages changed). It is planned to be fixed before the beta.

Nicolò Chieffo (yelo3) wrote :

Thanks for the information Ken

Changed in empathy (Ubuntu):
assignee: Ken VanDine (ken-vandine) → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Working on updating this patch to the latest empathy

Changed in indicator-messages:
milestone: none → ubuntu-9.10-beta-freeze
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
status: New → Confirmed
Changed in indicator-messages:
status: Confirmed → In Progress
Vish (vish) wrote :

Robert Ancell , could you also look into Bug #409828 , which is about empathy showing wrong icon in notifications.
We need to patch it to use "notification-message-im" icon instead of "im-message-new".
Thanks!

Changed in empathy (Ubuntu):
status: Confirmed → New
assignee: Robert Ancell (robert-ancell) → nobody
Ken VanDine (ken-vandine) wrote :

I am getting crashes here and it isn't hiding the indicator, please don't upload just yet. I am working on it.

Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: New → In Progress
Robert Ancell (robert-ancell) wrote :
Download full text (3.8 KiB)

I can't reproduce the crashes but there is a glib warning:

GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
IA__g_logv (log_domain=<value optimized out>, log_level=G_LOG_LEVEL_WARNING,
    format=0xdf5c38 "instance of invalid non-instantiatable type `%s'", args1=0xbfffe8bc "")
    at /build/buildd/glib2.0-2.21.6/glib/gmessages.c:512
512 /build/buildd/glib2.0-2.21.6/glib/gmessages.c: No such file or directory.
 in /build/buildd/glib2.0-2.21.6/glib/gmessages.c
(gdb) bt
#0 IA__g_logv (log_domain=<value optimized out>, log_level=G_LOG_LEVEL_WARNING,
    format=0xdf5c38 "instance of invalid non-instantiatable type `%s'", args1=0xbfffe8bc "")
    at /build/buildd/glib2.0-2.21.6/glib/gmessages.c:512
#1 0x07e89056 in IA__g_log (log_domain=0xdf093c "GLib-GObject", log_level=G_LOG_LEVEL_WARNING,
    format=0xdf5c38 "instance of invalid non-instantiatable type `%s'") at /build/buildd/glib2.0-2.21.6/glib/gmessages.c:526
#2 0x00de0ce3 in IA__g_type_check_instance (type_instance=0x8247bc0) at /build/buildd/glib2.0-2.21.6/gobject/gtype.c:3807
#3 0x00ddbae6 in IA__g_signal_connect_data (instance=0x8247bc0, detailed_signal=0x8085240 "contact-presence-changed",
    c_handler=0x806e910 <event_manager_presence_changed_cb>, data=0x82475b8, destroy_data=0, connect_flags=0)
    at /build/buildd/glib2.0-2.21.6/gobject/gsignal.c:2238
#4 0x0806e7ca in empathy_event_manager_init (manager=0x82475b8) at empathy-event-manager.c:1059
#5 0x00de93bf in IA__g_type_create_instance (type=136096560) at /build/buildd/glib2.0-2.21.6/gobject/gtype.c:1674
#6 0x00dccd38 in g_object_constructor (type=136096560, n_construct_properties=0, construct_params=0x0)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1338
#7 0x0806e55b in event_manager_constructor (type=136096560, n_props=0, props=0x0) at empathy-event-manager.c:973
#8 0x00dcd8cc in IA__g_object_newv (object_type=136096560, n_parameters=0, parameters=0x0)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1215
#9 0x00dce502 in IA__g_object_new_valist (object_type=136096560, first_property_name=0x0,
    var_args=0xbfffecf8 "`{$\b\364\17", <incomplete sequence \340>) at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1278
#10 0x00dce67e in IA__g_object_new (object_type=136096560, first_property_name=0x0)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1060
#11 0x0806e39b in empathy_event_manager_dup_singleton () at empathy-event-manager.c:1066
#12 0x0807dfb6 in empathy_indicator_manager_init (manager=0x8247b60) at empathy-indicator-manager.c:333
#13 0x00de93bf in IA__g_type_create_instance (type=136096296) at /build/buildd/glib2.0-2.21.6/gobject/gtype.c:1674
#14 0x00dccd38 in g_object_constructor (type=136096296, n_construct_properties=0, construct_params=0x0)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1338
#15 0x0807de6b in indicator_manager_constructor (type=136096296, n_props=0, props=0x0) at empathy-indicator-manager.c:290
#16 0x00dcd8cc in IA__g_object_newv (object_type=136096296, n_parameters=0, parameters=0x0)
    at /build/buildd/glib2.0-2.21.6/gobject/gobject.c:1215
#17 0x00dce502 in IA...

Read more...

Ken VanDine (ken-vandine) wrote :

The warning is still there, but the critical and the crashers are fixed. We should get this uploaded and get more people using it ASAP.

lp:~ubuntu-desktop/empathy/ubuntu

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.27.92-1ubuntu3

---------------
empathy (2.27.92-1ubuntu3) karmic; urgency=low

  [Ken VanDine]
  * debian/control:
    - Added libindicate-gtk-dev and libindicate-dev (>=0.2.0) to build depends
  * debian/patches/30_raise_not_toggle.patch:
    - Always raise contact list when clicked (LP: #392153)
  * debian/patches/99_autoconf.patch added

  [Robert Ancell]
  * debian/patches/10_use_notify_osd_icons.patch:
    - Use the notify-OSD icons for new messages (LP: #409828)
  * debian/patches/20_libindicate.patch:
    - Integrate into messaging menu (LP: #340180)
  * debian/control:
    - Remove Debian VCS links as they confuse debcheckout

 -- Ken VanDine <email address hidden> Mon, 21 Sep 2009 14:34:40 +0200

Changed in empathy (Ubuntu Karmic):
status: In Progress → Fix Released
Ernst (ernst-blaauw) wrote :

I have Empathy installed on Jaunty using this repository:
https://launchpad.net/~telepathy/+archive/ppa

The indicator applet does not synchronize the user status between Empathy and the applet (it stays on offline). Is this fix also backported to this ppa?

Nicolò Chieffo (yelo3) wrote :

There's something wrong with the implementation: the indicator icon
does not change, but the new message is listed in the popup menu (but
it has the wrong place, because it's over evolution and under the
separator).
Is this a problem in the indicator applet?

Ted Gould (ted) on 2009-09-21
affects: indicator-messages → ayatana-ubuntu
Changed in ayatana-ubuntu:
milestone: ubuntu-9.10-beta-freeze → none
Ted Gould (ted) on 2009-09-21
Changed in ayatana-ubuntu:
milestone: none → ubuntu-9.04-beta-freeze
Changed in ayatana-ubuntu:
assignee: Robert Ancell (robert-ancell) → Ken VanDine (ken-vandine)
status: In Progress → Fix Released
Fabio Rafael Rosa (rafaelfdr) wrote :

Empathy is showing this bug again at current version.
I have a fresh install of karmic from alpha 6, up to date.
Indicator applet shows a gray icon, and all status change is disabled.

rafael@f2r-laptop:~$ dpkg -l | grep empathy
ii empathy 2.28.0-0ubuntu1 High-level library and user-interface for Te
ii empathy-doc 2.28.0-0ubuntu1 High-level library and user-interface for Te
ii libempathy-common 2.28.0-0ubuntu1 High-level library and user-interface for Te
ii libempathy-gtk-common 2.28.0-0ubuntu1 High-level library and user-interface for Te
ii libempathy-gtk28 2.28.0-0ubuntu1 High-level library and user-interface for Te
ii libempathy30 2.28.0-0ubuntu1 High-level library and user-interface for Te
rafael@f2r-laptop:~$

Changed in empathy (Ubuntu Karmic):
status: Fix Released → Confirmed
Ken VanDine (ken-vandine) wrote :

The status change items aren't in the messaging menu, it is in the indicator-session-applet (fusa replacement). The status changes being broken is related to changing from mission-control-4 to mission-control-5. There should be a release of indicator-session on Sept 25th with that fix.

Martin Pitt (pitti) wrote :

Closing empathy task again.

Changed in empathy (Ubuntu Karmic):
status: Confirmed → Fix Released
Jeremy Nickurak (nickurak) wrote :

So, as an empathy user, should I have an Indicator Applet, or an Indicator Applet Session, or both? Should I automatically have something changed when I upgrade to karmic, or is manual intervention required?

I am also wondering: it should be fixed (indicator session) but it
doesn't work for me.
Do we have to be patient or does this require more tinkering?

Ted Gould (ted) wrote :

On Thu, 2009-09-24 at 21:10 +0000, Ruben Verweij wrote:
> I am also wondering: it should be fixed (indicator session) but it
> doesn't work for me.
> Do we have to be patient or does this require more tinkering?

Patient, like was uploaded this evening :) bug 427643

Okay, thank you!

Ted Gould schreef:
> On Thu, 2009-09-24 at 21:10 +0000, Ruben Verweij wrote:
>
>> I am also wondering: it should be fixed (indicator session) but it
>> doesn't work for me.
>> Do we have to be patient or does this require more tinkering?
>>
>
> Patient, like was uploaded this evening :) bug 427643
>
>

--
Mijn nieuwe e-mailadres is <email address hidden>

Ruben Verweij (ruben-verweij) wrote :

I installed the update, when starting empathy the indicator-session applet recognizes the status okay. But I am not able to change it from within indicator-session and if I change it in empathy, the change isn't reflected in indicator-session.
Also, the indicator session applet crashed on startup, but I was unable to send an apport report.

Ken VanDine (ken-vandine) wrote :

Please comment on bug 427643 instead, that isn't related to this bug. Also please note your versions of indicator-session and indicator-messages.

Thanks

Ernst (ernst-blaauw) wrote :

If Empathy uses the indicator-applet, it is not possible to answer a call: there is no accept button. See also bug https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/440865.

Rykel from Singapore (rykel98) wrote :

Hi,

I used to see Empathy showing up in Indicator-Applet, but not anymore.

Currently running Indicator-Applet 0.1 and Empathy 2.28.1.1 on Ubuntu Karmic. I also believe my Empathy is downloaded from ppa:telepathy.

Thanks for helping, and let me know how I can help too!

Rykel
Singapore

Ken VanDine (ken-vandine) wrote :

Indicator support for Empathy is a distro patch for ubuntu, so the version in ppa:telepathy doesn't support the messaging indicator. You will need to switch back to the default version in karmic to get that.

how do i switch back? i've deleted the ppa:telepathy and then uninstalled all empathy packages completely. but if i now want to install empathy, Synaptic says:

empathy:
depends on: libempathy-gtk28, but it will not be installed
depends on: libempathy30, but it will not be installed

what i have to do?

Brian Curtis (bcurtiswx) wrote :

RUSirius: that means that there are either earlier or later version still installed on your machine. In this case I'm going to assume the latter. Once you remove the later versions it should install ok.

ok, i uninstalled the remaining telepathy packages and install then works just fine, now i've Empathy back in the indicator-applet.
thanks

Changed in empathy:
importance: Unknown → Low
Changed in empathy:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.