Visual notification for/correct user response to incoming voice calls and subscription requests not obvious

Bug #440865 reported by Sebo on 2009-10-02
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Low
Ken VanDine
Declined for Karmic by Sebastien Bacher
Lucid
Low
Ken VanDine

Bug Description

Binary package hint: empathy

[description]
There is some problem with Empathy interactions - seems like there is no ui to take an action.

1. If somebody is calling me via SIP, I see a notification and hear ringing, but there is no ui to answer/reject the call.
2. If somebody is requesting my presence subscription on XMPP I see a notification, but there is no ui to accept/reject the request.

Sorry for two bugs in one - I think that the root reason is the same in both.

[steps to reproduce]
1.
a. add XMPP account to empathy
b. from other account and client add above JID to a roaster
c. empathy/gnome will show notification that somebody is requesting presence subscription but it will not be able to accept/reject such request

2.
a. add SIP accout to empathy (use telepathy-sofiasip as the backend)
b. call you SIP number from other client (eg. mobile)
c. a notification will appear and you will head ringing but it will not be possible to answer the call

[expected]
A. Message window with appropriate buttons to take an action.
or B. Extra panel in Empathy with the buttons.
or C. Buttons directly in notifications (I read somewhere that work on "action notifications" is in progress, isn't it)?

[priority]
IMHO this is a showstopper for this IM client - it is not usable for XMPP nor SIP

ProblemType: Bug
Architecture: i386
Date: Fri Oct 2 21:33:13 2009
DistroRelease: Ubuntu 9.10
Package: empathy 2.28.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: empathy
Uname: Linux 2.6.31-11-generic i686

Sebo (sebastian-baberowski) wrote :
Sebo (sebastian-baberowski) wrote :

Preferences./Notifications/(de-select)Use message indicators

This seems to workaround this problem. At least I have icon which I can click on to accept calls.

Chris Irwin (chrisirwin) wrote :

Same issue. I received a notice that I had a subscription request (a buddy added me). I ended up having to use pidgin to authorize the request. Afterwards, the buddy appeared in empathy properly.

empathy probably expects notification-daemon with interactive notifications.

John Markh (dragonsol) wrote :

I have exactly the same problem using Empathy 2.28.0.1.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in empathy (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

the bug is not a karmic blocker

Ernst (ernst-blaauw) wrote :

Here, I can't answer the calls on Google Talk (I guess it's the same dialog). I think the importance should be higher, as calling with Emapthy is one of the key features of Empathy (and one of the reasons it has replaced Pidgin).

Ernst (ernst-blaauw) wrote :
Guillaume Desmottes (cassidy) wrote :

Note that this problem is Ubuntu specific and has been introduced by the indicator patch which has been considered as not mature enough by upstream.

Xavier Claessens (zdra) wrote :

How can this bug be of low importance? Maybe ubuntu team should finally start listening to upstream devs that repeat for months now that the libindicate patch should be fixed or droped. And IMO that should be BLOCKER for karmic.

Lasse Havelund (lhavelund) wrote :

I'm inclined to agree with Xavier; while I think libindicate is fantastic, things like this certainly shows its limits. I disagree that this should be a BLOCKER for Karmic, but I still think the importance should be set to HIGH, or even CRITICAL.

Ken VanDine (ken-vandine) wrote :

I haven't tested the SIP case myself, but incoming video/audio calls over jabber do work fine. The event appears in the messaging indicator if you have it in your panel, if not it will blink the status icon. Incoming calls in the messaging indicator should behave differently, but we need to design that. We will surely have discussions about that at UDS to improve it for Lucid.

Here is what happens currently in karmic when there is a call received and the indicator applet is present:
 * Notification bubble appears notifying you of the incoming call
 * Sound notification, sounds like a phone ringing
 * The indicator gets the event and sets "draw-attention" which will change the look of the messaging icon
 * To answer the call, you have to click on the event in the messaging indicator or on the blinking event in the contact list

This work flow works ok, but I admit the first couple times I had to think "How do I answer this thing?". We will put some thought in this for Lucid and hopefully design a much better work flow.

Ken VanDine (ken-vandine) wrote :

Forgot to respond about subscription requests, these appear as events in the indicator as well. Clicking on them allows you to respond to them. If you are not using the indicator, you will see the request with the status icon.

I agree; this is a real problem for a lot of users who want to use
Empathy. As a lot of laptops have a builtin camera, video calls become
more popular. This bug should either be high or critical, I think.

2009/10/23, Lasse Havelund <email address hidden>:
> I'm inclined to agree with Xavier; while I think libindicate is
> fantastic, things like this certainly shows its limits. I disagree that
> this should be a BLOCKER for Karmic, but I still think the importance
> should be set to HIGH, or even CRITICAL.
>
> --
> Empathy - cannot answer SIP calls nor accept XMPP subscription request
> https://bugs.launchpad.net/bugs/440865
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Verzonden vanaf mijn mobiele apparaat

Ernst (ernst-blaauw) wrote :

Ok, I did not notice those possibility's yet. So does a friend of
mine, who is also running Karmic. The next time we try to call, I will
see if I indeed receive such notifications. I agree this needs some
polishing for karmic+1.

2009/10/23, Ernst Blaauw <email address hidden>:
> I agree; this is a real problem for a lot of users who want to use
> Empathy. As a lot of laptops have a builtin camera, video calls become
> more popular. This bug should either be high or critical, I think.
>
> 2009/10/23, Lasse Havelund <email address hidden>:
>> I'm inclined to agree with Xavier; while I think libindicate is
>> fantastic, things like this certainly shows its limits. I disagree that
>> this should be a BLOCKER for Karmic, but I still think the importance
>> should be set to HIGH, or even CRITICAL.
>>
>> --
>> Empathy - cannot answer SIP calls nor accept XMPP subscription request
>> https://bugs.launchpad.net/bugs/440865
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
> --
> Verzonden vanaf mijn mobiele apparaat
>

--
Verzonden vanaf mijn mobiele apparaat

Changed in empathy (Ubuntu):
status: New → Confirmed
summary: - Empathy - cannot answer SIP calls nor accept XMPP subscription request
+ Visual notification for/correct user response to incoming voice calls
+ and subscription requests not obvious
Ken VanDine (ken-vandine) wrote :

We will spec this out for Lucid at UDS

Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Omer Akram (om26er) on 2010-02-21
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Ken, did that ever got discussed? Is that something we should change there for lucid? Didn't we say we would display the dialog on incoming calls?

Changed in empathy (Ubuntu Lucid):
status: Triaged → Confirmed
milestone: none → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 2.29.93-0ubuntu1

---------------
empathy (2.29.93-0ubuntu1) lucid; urgency=low

  * New upstream release
  * debian/patches/38_accounts_window_title.patch
    - removed, merged upstream
  * debian/patches/20_libindicate.patch
    - refreshed to apply against 2.29.93
  * debian/patches/38_raise_voip_calls.patch
    - Raise the answer call dialog for incoming calls (LP: #440865)
  * debian/rules
    - make sure favourite-contacts is disabled, it requires telepathy-logger
 -- Ken VanDine <email address hidden> Tue, 16 Mar 2010 09:29:13 -0400

Changed in empathy (Ubuntu Lucid):
status: Confirmed → Fix Released

how do these beta testing bugs work thier way into final releases?

The subscription request part is still a problem in Empathy 2.30.0.1
It happened with me on yahoo! protocol.

Ken VanDine (ken-vandine) wrote :

The subscription request should appear in your messaging menu, can you confirm that it did or didn't?

Neal McBurnett (nealmcb) wrote :

I'm running lucid. This was confusing for me also. I got a subscription request, and saw the notification, and dug around in the empathy client for a while before I eventually noticed the indicator was colored and there was an address under the Chat menu item which could be clicked to respond.

But why not also have a way to respond in the empathy client?

It's aggravated by the fact that when I select a VOIP call, the dialog that
than says "accept/refuse" usually pops up underneath everything.

Maybe in the VOIP case, the indicator should have accept/refuse options *in
the indicator*, so you select one or the other, and the conversation pops up
immediately as a result?

Matt Hines (matt-ablegroups) wrote :

I am in the latest version of Ubuntu - 10.04 and according to Update Manager, everything is up to date so I assume I have the latest of everything.

I am still experiencing this issue. I hear the ringing but I can not find ANY POSSIBLE way to accept the call.

It would be nice if Empathy would all around expand on its SIP functionality. SIP is a great protocol and it would be nice to have more options and a keypad or something similar to how other softphones have (Counterpath Products like X-lite http://counterpath.com)

It is absolutely pivotal, though, to be able to answer a damn call. Without that ability, the SIP part of Empathy is all but useless.

Ken VanDine (ken-vandine) wrote :

You should see the incoming call in the messaging menu and a notification event. Clicking on the indicator will raise the call answer dialog letting you accept or reject the call. Please confirm you are getting the indicator in the messaging menu.

Maybe this would be better if there were 2 indicators... one to accept and
one to reject?

When a call's coming in, you don't want to waste time with multiple clicks,
looking for dialog boxes, etc. You should go indicator->accept call, and
start talking ASAP.

On Wed, Sep 1, 2010 at 11:05, Ken VanDine <email address hidden> wrote:

> You should see the incoming call in the messaging menu and a
> notification event. Clicking on the indicator will raise the call
> answer dialog letting you accept or reject the call. Please confirm you
> are getting the indicator in the messaging menu.
>
> --
> Visual notification for/correct user response to incoming voice calls and
> subscription requests not obvious
> https://bugs.launchpad.net/bugs/440865
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jeremy Nickurak -= Email/XMPP: -= <email address hidden> =-

Matt Hines (matt-ablegroups) wrote :

Which Messaging Window are you referring to?? The Contact List??

I messed with the notification options and turned off a notification box and finally found a combination of options that allowed me to answer a call. Basically, I got it to where you will see a blinking green icon in the status bar and clicking that will give you the ability to answer or reject.

It would be nice if they added in some special display options for SIP like an option to have a type of phone window open up. Most sip softphones have an interface with numbers 0 through 9 that resembles a cellphone or dialpad. It would be nice if Empathy had something similar. Or, even the ability of a display option that would allow you to get a popup box for each call so you could easily answer or reject.

fermulator (fermulator) wrote :

Same problem in Empathy 2.30.2.

 * Ubuntu 10.04 LTS
 * Empathy 2.30.2
 * 2.6.32-23-generic

Under preferences, Notifications tab, I unchecked everything, and then the notification just doesn't happen.

fermulator (fermulator) wrote :

Ah; So while the workaround didn't work, when I click on the "mail icon" in the applet, I was able to control the request. Shouldn't this functionality be available in Empathy itself? (rather than using the applet?)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.