HVR-1300 HVR-3000 HVR-4000 broken in kernel

Reported by DFdario on 2009-09-30
254
This bug affects 40 people
Affects Status Importance Assigned to Milestone
MythTV
Invalid
Unknown
Mythbuntu
High
Unassigned
Debian
Fix Released
Unknown
linux (Ubuntu)
High
Unassigned

Bug Description

This is a continuation of bug #436564. Please refer to that for relevant dmesg'.
The capture card I have is the Hauppauge HVR-1300.
The card is now correctly recognized as DVB-T but channel scan fails with message "Timed out, no signal" at each channel is scanned.
The command scan <location> > channels.conf ends correcly and file channels.conf is feeded with all tunable channels.
I tried to import such channels.conf with the same result.
Increasing the signal and channel timeout in the DVB settings (now up to 1000 but I planned to increase to ignore) doesnt solve the problem.
Tonight I will try what Marc suggested - mythtv-setup --verbose channelscan,siparser,channel,record - then I will report the log.

DFdario (dfdario) wrote :

After set timeouts signal to 60,000 and tuning to 65,000 the result is the same as reported above.

Attached is mythbacked.log

Steve Goodey (stevegoodey) wrote :

Tried as suggested, mythtv-setup --verbose channelscan,siparser,channel,record > test.txt but didn't get much.

 * Stopping MythTV server: mythbackend
   ...done.
 * Restarting MythTV server: mythbackend
No /usr/bin/mythbackend found running; none killed.
   ...done.
test.txt (END)

I suspect I've done something wrong.

What I have noticed is that during the scan process the signal/noise meter is pegged at 98% all the time. Putting the card in a mythbuntu 8.04 setup which I'm currently running signal/noise is at 0% unless locked to a station.

Regards, Steve.

DFdario (dfdario) wrote :

Log kept by log grabber are available at http://mythbuntu.pastebin.com/f761e3c93

MarcRandolph (mrand) wrote :

Steve, you captured the output of mythtv-setup, which is actually a wrapper that automatically stops and starts the backend. Not sure where the output went though... if one or both of you could try:

mythbackend stop

then do

mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > mythtv-setup.log

maybe we will get some useful info yet!

MarcRandolph (mrand) wrote :

Oops, pasted the wrong thing.

sudo /etc/init.d/mythtv-backend stop

and then

sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > mythtv-setup.log

replace "stop" with "restart" to relaunch the backend. Sorry for the bug spam.

DFdario (dfdario) wrote :

Attached is mine

Steve Goodey (stevegoodey) wrote :

Ok, here it is.

Steve.

Steve Goodey (stevegoodey) wrote :

Whoops.

MarcRandolph (mrand) wrote :

Thanks for the logs. Forwarded upstream - we'll see what happens! By chance, someone else has also reported a similar issue.

Changed in mythbuntu:
status: New → Confirmed
Changed in mythtv:
status: Unknown → New
kalibur (kaliburx) wrote :

I have the same problem with the same DVB tuner on alpha 6, here are my two cents.
1. The tuner works fine on mythbuntu 9.04
2. On mythbuntu 9.10 the tuner works fine with kaffeine. (be sure to setup mythtv to use the card on demand).
3. The 9.10 mythtv setup existing transports screen is black whilst the one on my 9.04 has about six entries similar to the line below:

 QAM-16 505833330 Hz netid 9018 tid 4100 (DVB-T)

4. On 9.04 mythtv-backend setup input connections my tuner is
    [DVB:0] (DVBInput->XMLTV
    On 9.10 mythtv-backend setup input connection my tuner is
    [DVB:/dev/dvb/adapter0/frontend0](DVBInput)->XMLTV

Am thinking of coping some configuration files from my 9.04 installation to 9.10 to see what happens, problem is am a lamar and I dont know what files and where to locate them.

Changed in mythtv:
status: New → Confirmed
Steve Goodey (stevegoodey) wrote :

I see that remote bug mythtv-bugs #7215 is marked as a duplicate of 7232 which has a patch that fixes the problem. Any idea when that will reach trunk?

Thanks Steve

Mario Limonciello (superm1) wrote :

Have to keep an eye on http://svn.mythtv.org/trac/ticket/7232 to determine when. We're pulling in new builds pretty frequently though, especially knowing that 0.22 is gonna branch off soon...

Changed in mythtv:
status: Confirmed → Unknown
MarcRandolph (mrand) wrote :

Should be fixed in [22254]. Look for it after tonights nightly build.

Changed in mythbuntu:
status: Confirmed → Fix Committed
Changed in mythtv:
status: Unknown → Fix Released
MarcRandolph (mrand) wrote :

Fix was pushed to official karmic package.

Changed in mythbuntu:
status: Fix Committed → Fix Released
DFdario (dfdario) wrote :

Sorry to revive this bug but I am still stumbled upon this problem.
The release I am running and reported by the command apt-cache policy mythtv-backend
mythtv-backend:
  Installed: 0.22.0~trunk22350-0ubuntu0~mythbuntu3
  Candidate: 0.22.0~trunk22350-0ubuntu0~mythbuntu3
  Table version:
 *** 0.22.0~trunk22350-0ubuntu0~mythbuntu3 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     0.22.0~trunk22304-0ubuntu1 0
        500 http://it.archive.ubuntu.com karmic/multiverse Packages

Attached are also dmesg and debug file kept by the command: sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > mythtv-setup.log

DFdario (dfdario) wrote :

dmesg file

DFdario (dfdario) wrote :

Forgot to say that release I installed is the daily build as of 10/10/2009 64 bit version.

DFdario (dfdario) wrote :

Forgot to say that release I installed is the daily build as of 10/10/2009 64 bits that after a lot of pain I installed on my 945GCLF2 2GB RAM.

DFdario (dfdario) wrote :

Ops, the patch it shouldn't be available yet should it?

MarcRandolph (mrand) wrote :

Yes, the patch should be in the build that you are using.
Could you please try extending the timeouts and report your results back? I don't know if it is possible to use unlimited timeout, but if so, please try that.

Changed in mythbuntu:
status: Fix Released → Confirmed
DFdario (dfdario) wrote :

The "sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra" produced the output annexed

Settings are:
Signal timeout: 10000 msec
Tuning timeout: 10000 msec
DVB tuning delay: 100 msec
On this machine Mythbuntu 9.04 was up and running until yesterday.

I stopped channel scan on channel 26 because major transports are on channels 22 and 26.

DFdario (dfdario) wrote :

Making a single frequency scan the log reports

MarcRandolph (mrand) on 2009-10-11
Changed in mythtv:
status: Fix Released → Unknown
Changed in mythtv:
status: Unknown → New
Gunni (fgunni) wrote :

I have exactly the same problems. I had channels in jaunty, upgraded to karmic.
In karmic: dvb stopped working (so not only scanning but also recording and watching tv).
I deleted the dvb card, added it again, and then i saw scanning does not work.

I tried nightly builds and karmic builds, event tried compiling latest hg repo from linuxtv (first i thought could be a module problem).
Running:
karmic 64it,
mythtv nightly (actual build: 0.22.0~trunk22354-0ubuntu0~mythbuntu3)
Hauppauge HVR-1300 (cx23880)

Dont know if this is of any use, but when running dvb in kaffeine i get a lot of following lines in /var/log/messages:
......
[ 120.499153] cx88[0]: irq aud [0x1001] dn_risci1* dn_sync*
[ 120.499166] cx88[0]: irq aud [0x1001] dn_risci1* dn_sync*
[ 120.499173] cx88[0]/1: IRQ loop detected, disabling interrupts

Gunni (fgunni) wrote :

I just checked my dpkg.log. Last version i ran on jaunty was:

2009-10-06 22:37:39 status installed mythtv-backend 0.22.0~trunk22260-0ubuntu0~mythbuntu1

Is this version available somewhere for karmic, to check if this works?

Mario Limonciello (superm1) wrote :

Here's the closest you'll get to that:
https://launchpad.net/ubuntu/+source/mythtv/0.22.0~trunk22242-0ubuntu1

Click your architecture and then grab the debs you need.

Gunni (fgunni) wrote :

Ok, i installed the version Mario pointed me to, but still no channel scan.
I do a reboot now to be sure.

Gunni (fgunni) wrote :

Still no luck, no lock, timeout, no sender with build 22242.
As stated above in jaunty with 22260 mythbackend was running (ok i dont know about scanning, as i did not do a channel scan with 22260).

Good point. Just because you were on 22260 when you left 9.04 doesn't
mean channel scanning was working then. Did you even channel scan with
0.22, or was it on 0.21 that was then upgraded?

I do not remember if it was in 0.21, or if i did a scan again in 0.22.
I think i once rescanned with 0.22, but dont knock me down on that.
Now searching for a database backup ( i know i did one some time ago, hope i did not delete it in some cleanup session)

Gunni (fgunni) wrote :

I revived my channels and dvb conf with a bakcup, but still watching live-tv or channel scan does not work.

Gunni (fgunni) wrote :

I opened mythbackend with verbose output, startet tv on frontend for a few seconds (well not really started, black screen), and ended. Complete log attached.

May this has to do with this:

2009-10-11 21:18:26.325 MythEvent: SIGNAL 9
2009-10-11 21:18:26.325 Got data on select
2009-10-11 21:18:26.325 MythSocket(db6570:39): write -> 39 456 BACKEND_MESSAGE[]:[]SIGNAL 9[]:[]Signal Lock[]:[]slock 0 1 0 1 3000 1 1[]:[]Signal Power[]:[]signal 52428 0 0 65535 3000 1 1[]:[]Seen PAT[]:[]seen_pat 0 1 0 1 0 1 1[]:[]Matching PAT[]:[]matching_pat 0 1 0 1 0 1 1[]:[]Seen PMT[]:[]seen_pmt 0 1 0 1 0 1 1[]:[]Matching PMT[]:[]matching_pmt 0 1 0 1 0 1 1[]:[]Signal To Noise[]:[]snr 32768 0 0 65535 0 1 1[]:[]Bit Error Rate[]:[]ber 16383 65535 0 65535 0 0 1[]:[]Uncorrected Blocks[]:[]ucb 0 65535 0 65535 0 0 1
2009-10-11 21:18:26.326 MythSocket(db6570:39): writeBlock(0x140307588977784, 464)
2009-10-11 21:18:26.326 Processing ready reads
2009-10-11 21:18:26.326 MythSocketThread: Total read time: 0ms, on sockets
2009-10-11 21:18:26.326 Reacquired ready read lock
2009-10-11 21:18:26.326 ProcessAddRemoveQueues
2009-10-11 21:18:26.326 Construct FD_SET
2009-10-11 21:18:26.326 Waiting on select..
2009-10-11 21:18:26.376 SM(/dev/dvb/adapter0/frontend0)::AddFlags: Seen() Match() Wait(Sig,)
2009-10-11 21:18:26.384 MythEvent: SIGNAL 9
....

Gunni (fgunni) wrote :

Additional comment, from me as amateur:

Seems like the backend has no access to the dvb card, or does not know how to handle it.
Kaffeine works fine, so dvb is working, but not for myth.
As i tested even an older version, that did run on jaunty, i think its something different in karmic that prevents mythbackend from accessing the dvb device.
Anyways updating the cx88 module with mercurial version from linuxtv did not help, so i think it is not the module, too.
Well, many presumptions here from me, but thats all i can do because of missing knowledge.

Gunni (fgunni) wrote :

I updated again (Now 22373), and did recompile the cx88 modules with reverting two patches.
Now i get recordings. Can definitly check when i am at home again. Here is what i did:
http://svn.mythtv.org/trac/ticket/7292#comment:4

Gunni (fgunni) wrote :

I now got no response from my server, so maybe did something wrong :)
Be careful if you try that :)

Gunni (fgunni) wrote :

Ok, i got picture in mythfrontend now.
You wont believe me, why i did not get any response on remote:
The CPU cooler broke (this damn little pin that holds the cooler) Good is, that i had an old board here to exchange it.
So after watching heroes, i will check which patch is exactly responsible.

MarcRandolph (mrand) on 2009-10-12
description: updated
Changed in mythbuntu:
importance: Undecided → High
Gunni (fgunni) wrote :

So, i found the part of the patch that is responsible for the bug:

http://<email address hidden>/msg02195.html

Only the part in cx88-dvb.c
Attention, this is not a patch, THIS PATCH has to be REVERTED:

snip----------

diff -r 576096447a45 -r d2eedb425718 linux/drivers/media/video/cx88/cx88-dvb.c
--- a/linux/drivers/media/video/cx88/cx88-dvb.c Thu Dec 18 07:28:18 2008 -0200
+++ b/linux/drivers/media/video/cx88/cx88-dvb.c Thu Dec 18 07:28:35 2008 -0200
@@ -1135,40 +1135,44 @@ static int cx8802_dvb_advise_acquire(str
                 * on the bus. Take the bus from the cx23416 and enable the
                 * cx22702 demod
                 */
- cx_set(MO_GP0_IO, 0x00000080); /* cx22702 out of reset and
enable */
+ /* Toggle reset on cx22702 leaving i2c active */
+ cx_set(MO_GP0_IO, 0x00000080);
+ udelay(1000);
+ cx_clear(MO_GP0_IO, 0x00000080);
+ udelay(50);
+ cx_set(MO_GP0_IO, 0x00000080);
+ udelay(1000);
+ /* enable the cx22702 pins */
                cx_clear(MO_GP0_IO, 0x00000004);
                udelay(1000);
                break;
---------snip

Shurik (sacha-hemmail) wrote :

All right, but how to apply this non-patch? I have a similar proble as described above with my HVR-4000.
Any instructions somewhere?

DFdario (dfdario) wrote :

If all stated is true I can't figure why by executing the scan command and outputting the result to channels.conf it finds all channels and if I try to import the channels.conf just produced I got the channel time out.
For my point of view the bug should resides in channel scan and not on cx88.dvb or either but I leave programmers to decide that.
Thank you for the effort guys

Shurik (sacha-hemmail) wrote :

For myself w-scan does not find any DVB-T channels while scan works well.

Gunni (fgunni) wrote :

@Shurik: Sorry that i cant really help on that, cause it can be different for that card, and i dont know what i am doing :)
ddafre: As i dont know what i did by reverting that patch, i cant comment on that. I leave that to the programmers, too

Seems to be a odd timing problem, as for me it worked with some programs, and did not with others:

kaffeine 0.8.7 everything fine
kafffeine 1.0pre2 watching TV works, for switching channels you have to: switch channel (picture stalls), end kaffeine. start kaffeine, channel is set to new channel
mythtv: No TV, no scanning (as mythbackend may have tried to switch the channel already, that may be the reason for nothing working)

Changed in mythtv:
status: New → Invalid
MarcRandolph (mrand) on 2009-10-29
Changed in mythbuntu:
status: Confirmed → Triaged
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
summary: - Channel scan timed out
+ HVR-1300 HVR-3000 HVR-4000 broken in kernel
106 comments hidden view all 186 comments
Gunni (fgunni) wrote :

1. Get source code like described here: http://linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers#Using_Mercurial

2. Edit the file v4l-dvb/linux/drivers/media/video/cx88/cx88-dvb.c
- search for CX88_BOARD_HAUPPAUGE_HVR1300 (somewhere around line 1470 )
- change the lines that they look like:

 switch (core->boardnr) {
 case CX88_BOARD_HAUPPAUGE_HVR1300:
  /* We arrive here with either the cx23416 or the cx22702
   * on the bus. Take the bus from the cx23416 and enable the
   * cx22702 demod
   */
  /* Toggle reset on cx22702 leaving i2c active */
  cx_set(MO_GP0_IO, 0x00000080);
  //udelay(1000);
  //cx_clear(MO_GP0_IO, 0x00000080);
  //udelay(50);
  //cx_set(MO_GP0_IO, 0x00000080);
  //udelay(1000);
  /* enable the cx22702 pins */
  cx_clear(MO_GP0_IO, 0x00000004);
  udelay(1000);
  break;

3. then go on like described in the wikipage how to build and install. Maybe you have to disable firedtv card in the config by first doing a "make menuconfig" and disable it there.

gumis (gumis) wrote :

Gunni, you're gentleman. I'll give it a try now...

Thank you.

iCe (iceclow) wrote :

Thanks Gunni I'll try It when I get in front of my computer.

iCe (iceclow) wrote :

Thanks a lot Gunni it's working now!

I have made a patch to ease the process instead of manually commenting those lines. I'm wondering, why this workaround cannot be merged into the v4l tree, what is preventing to solve this bug since 2009-09-30?

Here I left some instructions to other with this problem, download the attachment to this post and follow these steps:

1- Download v4l source code from repository:
     hg clone http://linuxtv.org/hg/v4l-dvb
2- Copy the patch file to v4l-dvb/linux/drivers/media/video/cx88/
3- Apply the patach
    patch cx88-dvb.c cx88-dvb.c.patch
4- Go back to the root v4l-dvb folder and compile v4l:
    make
5- If on ubuntu, make sure to remove FireDTV modules, for that do:
    make menuconfig
6- Install the drivers:
    sudo make install

Now reboot, and it should be working.

xinodelparque (xino-gasco) wrote :

good

I am new to this Linux and Mythbuntu.

So if the teachers here, could explain step by step how to operate the hvr 4000 on a clean install of Mythbuntu 10.10 .... I would be most grateful ....

I go from windows to linux ... but have two HVR 4000 cards and for reasons unknown to me .... I can not run ....

That is why I request a pastel step guide to make it work ...

I hope that does not involve much work for you ...

But understand that many people like me .. they do not have much idea and lost a bit ....

I have followed the steps in the last post and do not work ... so I ask this guide ....

forsake me not in windows ...

thanks .....

translated by google translator .... I'm Spanish ... understand?

gumis (gumis) wrote :

So far everything looks good for HVR-1300 with patch applied as per Gunni's instructions on #147.
Need more testing, I think some of the channels are missing... Will report back ASAP.

I'm still strugling with HVR-4000 though...
Did anyone managed to get this card working on 10.10 ? I can't get a Lock when scanning for DVB-T channels (haven't tried DVB-S or S2 yet...). Perhaps another patch to be applied manually?

Gunni (fgunni) wrote :

gumis: Maybe you should download the Repo from Darron and the upstream source, and see the differences on both sources for the HVR-4000 and edit it manually. I cant test that as i do not have a HVR-4000.

tags: added: patch
Peter Childs (pchilds-bcs) wrote :

Commenting out the 5 lines also works on the HVR3000 but the 5 lines are in a different place. (But the same file and same 5 lines, looking at the code says it should also work for the HVR4000 but that is untested.

FireDVT can be found in menuconfig under Mnultimedia support -> DVB/ATSC adaters -> FireDTV and FloppyDTV.

(Tested on Ubuntu 10.04 and 10.10 64bit)

mateuz (vitauts-g) wrote :

Can someone please write complite How to?

I am using HVR-1300 I have tried to get it working in ubuntu since 7.10, but no success. I am very pleased with boot-up speed of mythbuntu 10.10, but this tunning failed issue makes me crazy. also if I try MeTV it says "No DVB device available"

But please make some very detailed instructions how to get it working in mytbuntu or ubuntu. if there is something I need to report more some log file or terminal message please let me know so I can give some investment of time to solve this problem. on win hauppauge rocks but on ubuntu...

Not sure if it is relevant or not...
After a reboot mythtv cannot tune any channels and femon doesn't show a 'locked' message UNTIL I run a scan (after stopping mythtv-backend...). Femon shows 'locked' during the scan and channels are found & the locked message persists after the scan finishes (or I kill it with ctl-c!) and mythtv will then tune channels. Possible difference in card initialisation ?

HOWEVER I have just updated to 23.1 and now cannot get myth to lock, am doing a full remove/distclean/make/install to see if it fixes the problem...

David

frednet (andrew-walker27) wrote :

Just followed your quick guide and patched my HVR-1300 on Mythbuntu 10.10 64bit and worked like a charm. Let's hope this bug gets fixed, I've been struggling with this card for months after the breakage.
Many thanks, the DVB-T works, just the analog side and radio to get going now!

nicola76b (bortolotti-nicola) wrote :

Ubuntu 10.4 64bit and HVR-3000
Follow Peter Childs (#154) instructions get my board working again.

Unfortunately some channels continue not working (mediaset doesn't work, so I cannot hook Iatalia1, canale5, rete4)
but many other yes. Please release a complete working patch.
PS: anyway compliments for this one, I do all the work without understant nothing... :-|

Thankyou for your support!!

Jason Cullen (jcullen86) wrote :

Ubuntu 10.10 64bit and HVR-4000 and Mythtv 0.24

Can also confirmed that after NEVER having my tuner working under ubuntu that commenting out the line as per (#154)
have worked and now my card is working like a charm with DVB-T.

Thank you so much mythtv is so much better with live tv :-D

Changed in debian:
status: Unknown → New
webaake (webaake) wrote :
Download full text (4.2 KiB)

My hvr 1300 doesn't seem to work no matter what I do. The symptoms are the same for all 2.6.37.x kernels; the cards IS recognized - dmesg | grep cx88;
cx88_audio 0000:01:07.1: PCI INT A -> Link[LNKB] -> GSI 18 (level, low) -> IRQ 18
cx88[0]: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56,insmod option], frontend(s): 1
cx88[0]: TV tuner type 41, Radio tuner type -1
cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.8 loaded
cx88[0]: i2c init: enabling analog demod on HVR1300/3000/4000 tuner
cx88/0: cx2388x v4l2 driver version 0.0.8 loaded
tuner 1-0043: chip found @ 0x86 (cx88[0])
tuner 1-0061: chip found @ 0xc2 (cx88[0])
cx88[0]: hauppauge eeprom: model=96019
cx88[0]/1: CX88x/0: ALSA support for cx2388x boards
cx88[0]/2: cx2388x 8802 Driver Manager
cx88-mpeg driver manager 0000:01:07.2: PCI INT A -> Link[LNKB] -> GSI 18 (level, low) -> IRQ 18
cx88[0]/2: found at 0000:01:07.2, rev: 5, irq: 18, latency: 64, mmio: 0xdb000000
cx8800 0000:01:07.0: PCI INT A -> Link[LNKB] -> GSI 18 (level, low) -> IRQ 18
cx88[0]/0: found at 0000:01:07.0, rev: 5, irq: 18, latency: 64, mmio: 0xdd000000
wm8775 1-001b: chip found @ 0x36 (cx88[0])
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/0: registered device radio0
cx88/2: cx2388x dvb driver version 0.0.8 loaded
cx88/2: registering cx8802 driver, type: dvb access: shared
cx88[0]/2: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]
cx88[0]/2: cx2388x based DVB/ATSC card
cx8802_alloc_frontends() allocating 1 frontend(s)
DVB: registering new adapter (cx88[0])
cx88/2: registering cx8802 driver, type: blackbird access: shared
cx88[0]/2: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]
cx88[0]/2: cx23416 based mpeg encoder (blackbird reference design)
cx88[0]/2-bb: Firmware and/or mailbox pointer not initialized or corrupted
cx88[0]/2-bb: Firmware upload successful.
cx88[0]/2-bb: Firmware version is 0x02060039
cx88[0]/2: registered device video1 [mpeg]

All the modules seem to load - lsmod | grep cx88;
cx88_blackbird 13254 1
cx2341x 15408 1 cx88_blackbird
cx88_dvb 19559 1
cx88_vp3054_i2c 1520 1 cx88_dvb
videobuf_dvb 3938 1 cx88_dvb
dvb_core 75727 3 cx88_dvb,videobuf_dvb
cx8800 24226 1 cx88_blackbird
cx8802 11179 2 cx88_blackbird,cx88_dvb
cx88_alsa 6991 0
cx88xx 66327 5 cx88_blackbird,cx88_dvb,cx8800,cx8802,cx88_alsa
v4l2_common 5844 6 cx88_blackbird,cx2341x,wm8775,cx8800,tuner,cx88xx
videodev 57747 8 cx88_blackbird,cx2341x,wm8775,cx8800,tuner,cx88xx,v4l2_common
i2c_algo_bit 4191 2 cx88_vp3054_i2c,cx88xx
videobuf_dma_sg 7224 6 cx88_blackbird,cx88_dvb,cx8800,cx8802,cx88_alsa,cx88xx
videobuf_core 13399 6 cx88_blackbird,videobuf_dvb,cx8800,cx8802,cx88xx,videobuf_dma_sg
ir_common 3506 1 cx88xx
ir_core 12818 8 ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,cx88xx,ir_common
tveeprom 10577 ...

Read more...

Gunni (fgunni) wrote :

@webaake: The bug is still present in kernel 2.6.38, but the patch does still work, too.
I am now on ubuntu natty with 2.6.38 self compiled v4l modules with patch applied manually, and it still does work, althoug my mythtv is a bit unstable since the update and i dont know why, but that is not related to this bug.

John Bergqvist (jlbergqvist) wrote :

Just a thought (this is concerning the HVR-1300 only), but seeing as it appears that everyone is having this problem, with recent kernels, and it only needs to be fixed by commenting out those same few lines in the source code, and recompiling. Wouldn't it save a whole load of hassle if we were able to sorta have those 5 lines commented out/removed in the first place, so that from then on, the drivers would work out of the box, without the need to download and recompile them? Maybe someone could contact the v4l guys and try and get it sorted? Just a thought, please tell me if there's anything preventing that?

Gunni (fgunni) wrote :

John: I contacted them long time ago, but got nothing happened. So i gave up disappointed.
It seems common to me that open source developers only do what _they_ want to do, or if someone they know contacts them, but if a common user does this nothing happens.

Gunni (fgunni) wrote :

Just to make it precise it was back then: http://osdir.com/ml/linux-media/2009-10/msg00511.html

Only reaction was "noted"

John Bergqvist (jlbergqvist) wrote :

Should we keep nagging them? I mean its 5 lines that need to be commented out, it surely can't have that much of a knock-on effect. I doubt it would affect other cards.

James Pond (jp-raven) wrote :

Hello there,

Owner of an HVR4000 and trying to make it work on recent Ubuntu/MythTV. Hopefully will succeed to appy and compile the patch sooner or later.

@John @Gunni

Gunni is probably right about (free) open source developpers doing only what they want to do. Of course, remember they are doing it for free.

Now from a more technical point of view, there may be very good reasons for those people not to simply apply the patch. What if the fix breaks something else? The code change that provoked the issue was certainly written for very good reasons, is it wise to simply cancel it?

Anyway, I hope I will be able to report good news about my HVR4000 soon.

James Pond (jp-raven) wrote :

Wooooooh!

Finally got to scan something today in MythTV with my Hauppauge HVR4000. On Ubuntu 10.04 LTS.

It was stunning to finally see it work as expected. Like, after so many failed attempts I was so sure it would never work.

What I did:
- follow instructions of comment #50
- but with repository given in comment #128
- (of course) the removal of kernels must be adjusted to the actual kernel version used
- some commands failed but succeeded when used with sudo
- both 'make' and 'make install' ended at first in a Segmentation Fault, but completed when retried after a reboot (why???)
- also I installed the sources of the kernel

I am a little bit concerned with the segmentation fault: is it normal or does it suggest a problem with my box? Maybe overheating, or maybe bad software? Should I avoid upgrading the kernel?

What do you think?

James Pond (jp-raven) wrote :

Me again,

I have been able to play with MythTV, it works beautifully and is a gem. I am happy to have put so many effort in order to try it.

About segmentation faults and other weird behaviors of my box, Memtest86+ tells me that my memory has defects. So, the problem is on my side, not on software's. Asking for a RMA.

Fer (fernando-gil-lopez) wrote :

Hello!

It works for me in Ubuntu 10.10 kernel 2.6.35-28 generic with a Hauppage HVR4000:

1. Downloading v4l source of comment #150

     hg clone http://linuxtv.org/hg/v4l-dvb

2. Edit the file: v4l-dvb/linux/drivers/media/video/cx88/cx88-dvb.c

    And commenting out the five lines:

     case CX88_BOARD_HAUPPAUGE_HVR4000:
  /* Toggle reset on cx22702 leaving i2c active */
  cx_set(MO_GP0_IO, 0x00000080);
  //udelay(1000);
  //cx_clear(MO_GP0_IO, 0x00000080);
  //udelay(50);
  //cx_set(MO_GP0_IO, 0x00000080);
  //udelay(1000);

3. As comment #150 says, it was necessary to remove FireDTV modules.
    Before, I ned to install libncurses & libncurses5 (I used synaptics to do it). Then, I entered menuconfig:

         make menuconfig

        and unmarking with (N) the module "FireDTV and FloppyDTV"
        you can find it under Multimedia Support --> DVB/ATSC adapters

4. Compiling and installing the driver:

    make

    sudo make install

It works fine in MythTV but I have some problems in Mythbox pluggin under XBMC. I can watch the first channel selected, but if I select a second channel, XBMC hangs. I don't know if the error is related to this driver.

I tried to do the same in Mythbuntu 11.04 kernel 2.6.38-8, but I obtained a lot of errors related to IOCTL when tried to compile.

Daniel (hackie) wrote :

Hey..

I just tried to do the same work-araounds in natty (11.04, kernel 2.6.38-9), but whatever I try (#147, #150, #167, #169), it either does not compile because of different apis or it compiles but without positive effect to the tv app.

There are 169(+1) comments already and it is hard to see which one is the most useful.

How about maintaining a Wiki page somewhere with copy-paste instructions and keeping it up-to-date? Annoying enough that this patch is not mainstream yet...

Vemboca (vemboca) wrote :

Same problem here. Worked for 2 days and then kaffeine didn't start anymore.

Hauppauge HVR-1300 DVB-T Chip: CX22702

It first worked after manually compiling v4l-dvb.

James Pond (jp-raven) wrote :

Tried with Mythbuntu 11.04, does not work for the same reason than Daniel on comment #170.

Reverted back to Ubuntu 10.04 LTS and worked again like previously told in coments #167 & #168.

Finally had a chance to debug this issue using an HVR-1300. It's actually a race condition in DVB core which effects all three cards. Have submitted the attached patch to linux-media, which should result in all three cards working properly, and should supersede any patches floating around which rip out the GPIO code (which is the incorrect fix).

Users are welcome to try the frontend_dvb_init.patch against the latest media_build, and it should address the issue. Please report back success/failure either way.

Thanks,

Devin Heitmueller
Kernel Labs Inc.

Gunni (fgunni) wrote :

Devin: That sounds great ... what do i say ... it sounds awesome.
I only hope that the patch gets integrated in the kernel, so finally the patching is over.
There are some more patches from Darron, do you think they can get in as well. For me its the remote control patch that made my remote control work after some yoears without: http://hg.kewl.org/pub/v4l-dvb-20100517/rev/b2c126d4f749

I will try your patch when i am back home in a few hours. I post here if there is a problem with that patch.

description: updated
nicola76b (bortolotti-nicola) wrote :
Download full text (4.9 KiB)

Hi all, I've just tried #173 patch, but error appears.

I've HVR3000 and run ubuntu Linux version 2.6.38-8-generic (buildd@allspice) (gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu3) ) #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011

after type "sudo make menuconfig"
 -> Multimedia Support -> DVB/ATSC adapters -> disable FireDTV and FloppyDTV

Here my output
----
htpc@HTPC:~/v4l-dvb/linux$ patch -p1 < frontend_dvb_init.patch
patching file drivers/media/dvb/dvb-core/dvb_frontend.c
Hunk #1 succeeded at 1981 (offset -8 lines).
htpc@HTPC:~/v4l-dvb/linux$ cd ..
htpc@HTPC:~/v4l-dvb$ cd ..
htpc@HTPC:~$ cd v4l-dvb
htpc@HTPC:~/v4l-dvb$ sudo make menuconfig
make -C /home/htpc/v4l-dvb/v4l menuconfig
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
No version yet, using 2.6.38-8-generic
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
./scripts/make_kconfig.pl /lib/modules/2.6.38-8-generic/build /lib/modules/2.6.38-8-generic/build
Preparing to compile for kernel version 2.6.38

***WARNING:*** You do not have the full kernel sources installed.
This does not prevent you from building the v4l-dvb tree if you have the
kernel headers, but the full kernel source may be required in order to use
make menuconfig / xconfig / qconfig.

If you are experiencing problems building the v4l-dvb tree, please try
building against a vanilla kernel before reporting a bug.

Vanilla kernels are available at http://kernel.org.
On most distros, this will compile a newly downloaded kernel:

cp /boot/config-`uname -r` <your kernel dir>/.config
cd <your kernel dir>
make all modules_install install

Please see your distro's web site for instructions to build a new kernel.

WARNING: You're using an obsolete driver! You shouldn't be using it!
  If you want anything new, you can use:
  http://git.linuxtv.org/media_build.git.
  The tree is still here just to preserve the development history.
  You've been warned.
Created default (all yes) .config file
/lib/modules/2.6.38-8-generic/build/scripts/kconfig/mconf ./Kconfig
#
# configuration written to .config
#

*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

./scripts/fix_kconfig.pl
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
htpc@HTPC:~/v4l-dvb$ sudo make
make -C /home/htpc/v4l-dvb/v4l
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
scripts/make_makefile.pl
./scripts/make_myconfig.pl
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
perl scripts/make_config_compat.pl /lib/modules/2.6.38-8-generic/build ./.myconfig ./config-compat.h
creating symbolic links...
ln -sf . oss
make -C firmware prep
make[2]: Entering directory `/home/htpc/v4l-dvb/v4l/firmware'
make[2]: Leaving directory `/home/htpc/v4l-dvb/v4l/firmware'
make -C firmware
make[2]: Entering directory `/home/htpc/v4l-dvb/v4l/firmware'
  CC ihex2fw
Generating vicam/firmware.fw
Generating dabusb/firmware.fw
Generating dabusb/bitstream.bin
Generating ttusb-budget/dspbootcode.bin
Generating cpia2/stv0672_vp4.bin
Generating av7110/bootcode.bin
make[2]: Leaving directory `/home/htpc/v4l-dvb/v4l/firmware'
Kernel build dire...

Read more...

Gunni (fgunni) wrote :

The new patch workes for me on ubuntu 11.10 alpha with kernel 2.6.39
Kernel 3.0 wont complie against media build as the build scripts seem to need the three version numbers.

nicola76b: Dont know about your problem, as for me it worked now, but i remember that i had to diable not only firedtv sometimes, but cant remember the other to disable. Try to find something with "flexcop" in menuconfig and disble it.

nicola76b (bortolotti-nicola) wrote :
Download full text (4.5 KiB)

Thank you Gunni, but it seems don't work.

I try disable firedtv and also
*** Supported FlexCopII (B2C2) Adapters ***
< > Technisat/B2C2 FlexCopII(b) and FlexCopIII adapters

(follow output), but without results.
Can you try to remember whatelse should I disable/enable?

THANK YOU VERY MUCH,

    Nicola

htpc@HTPC:~/v4l-dvb$ sudo make menuconfig
make -C /home/htpc/v4l-dvb/v4l menuconfig
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
No version yet, using 2.6.38-8-generic
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
./scripts/make_kconfig.pl /lib/modules/2.6.38-8-generic/build /lib/modules/2.6.38-8-generic/build
Preparing to compile for kernel version 2.6.38

***WARNING:*** You do not have the full kernel sources installed.
This does not prevent you from building the v4l-dvb tree if you have the
kernel headers, but the full kernel source may be required in order to use
make menuconfig / xconfig / qconfig.

If you are experiencing problems building the v4l-dvb tree, please try
building against a vanilla kernel before reporting a bug.

Vanilla kernels are available at http://kernel.org.
On most distros, this will compile a newly downloaded kernel:

cp /boot/config-`uname -r` <your kernel dir>/.config
cd <your kernel dir>
make all modules_install install

Please see your distro's web site for instructions to build a new kernel.

WARNING: You're using an obsolete driver! You shouldn't be using it!
  If you want anything new, you can use:
  http://git.linuxtv.org/media_build.git.
  The tree is still here just to preserve the development history.
  You've been warned.
Created default (all yes) .config file
/lib/modules/2.6.38-8-generic/build/scripts/kconfig/mconf ./Kconfig
#
# configuration written to .config
#

*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.

./scripts/fix_kconfig.pl
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
htpc@HTPC:~/v4l-dvb$ make
make -C /home/htpc/v4l-dvb/v4l
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
scripts/make_makefile.pl
./scripts/make_myconfig.pl
make[1]: Leaving directory `/home/htpc/v4l-dvb/v4l'
make[1]: Entering directory `/home/htpc/v4l-dvb/v4l'
perl scripts/make_config_compat.pl /lib/modules/2.6.38-8-generic/build ./.myconfig ./config-compat.h
creating symbolic links...
ln -sf . oss
make -C firmware prep
make[2]: Entering directory `/home/htpc/v4l-dvb/v4l/firmware'
make[2]: Leaving directory `/home/htpc/v4l-dvb/v4l/firmware'
make -C firmware
make[2]: Entering directory `/home/htpc/v4l-dvb/v4l/firmware'
  CC ihex2fw
Generating vicam/firmware.fw
Generating dabusb/firmware.fw
Generating dabusb/bitstream.bin
Generating ttusb-budget/dspbootcode.bin
Generating cpia2/stv0672_vp4.bin
Generating av7110/bootcode.bin
make[2]: Leaving directory `/home/htpc/v4l-dvb/v4l/firmware'
Kernel build directory is /lib/modules/2.6.38-8-generic/build
make -C /lib/modules/2.6.38-8-generic/build SUBDIRS=/home/htpc/v4l-dvb/v4l modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M] /home/htpc/v4l-dvb/v4l/tuner-xc2028.o
  CC [M] /home/htpc/v4l-dvb/v4l/tuner-simple.o
  C...

Read more...

larsekm (lars66) wrote :

I have a HVR4000 and 2.6.38-8-generic linux kernel.

I could successfully build the v4-dvb drivers by abandoned the hg checkout and moved to git. The page, http://www.mythtv.org/wiki/Hauppauge_HD-PVR#HD-PVR_Driver_Compilation_Howto has a good description how to do it.

    git clone git://linuxtv.org/media_build.git
    cd media_build
    ./check_needs.pl
    make -C linux/ download
    make -C linux/ untar
    make stagingconfig
    make
    sudo make install

....and the best part was that after applying Devin Heitmueller's patch my tv-card was able to find channels during scan.

That made my day,
Lars

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Daniel (hackie) wrote :

Thanks Devin (#173). I just compiled my 2.6.38-10-generic in Natty and it works, and it seems even more stable than ever before.

But what happens with this bug report now? I'm not sure what I should think about #179

John Bergqvist (jlbergqvist) wrote :

#173 Fantastic! After 3 years we finally have a proper solution! The previous method of commenting out those 4 or 5 lines would have a nasty side-effect where my PC would completely freeze after booting up every 2 or 3 times, so hopefully this doesn't do that :)

Do you know when/if the patch will be approved, and what releases of vl4 & the kernel, it will be included in, so it will work out of the box without applying the patch manually? I would assume it will be included in Mythbuntu 11.10, not that that would be your decision.

Gunni (fgunni) wrote :

Looks like the patch got into 3.0 so finally in oneiric (as it uses kernel 3.0 ) it should be fixed:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=2d1969312d6319d28ae9609a84f969b6933bd51c

Gunni (fgunni) wrote :

It was just the first time in the last 1,5 years, i booted my mythtv backend with a kernel i did not compile myself, and it works.

The patch of Devin is integrated in the oneiric 11.10 Kernel linux-image.3.0.0-7

Daniel (hackie) wrote :

I want to know if I am the only one with that problem. I am using the patch as described in comment #178. It worked ok for the first weeks, but now I sometimes have the problem that me-tv tells me: "There are no DVB devices available"

Patch was already included, I just checked the sources which I used for my last git-pull & compilation on Aug 22 (for 2.6.38-11-generic, x86_64). See attached dmesg for more details.

PS: If the device is found, locking works too, so maybe they introduced another bug?

Looking at the dmesg output Daniel provided, this issue appears to be completely unrelated to the bug in question. The dmesg shows a general initialization failure during system boot where the demodulator didn't respond to the i2c request in time. When the i2c request fails during the probe of the demod, it results in the DVB device nodes not being created.

I don't doubt that this is some sort of timing bug in board initialization, but it is completely separate from the bug in question and should probably have a new ticket opened.

Devin

TJ (tj) wrote :

This bug appears to be masking another related but independent problem with the same devices which causes the i2c on the tuner to fail resulting in the infra-read receiver not working:

tveeprom 1-0050: Huh, no eeprom present (err=-6)?
tveeprom 1-0050: Encountered bad packet header [00]. Corrupt or not a Hauppauge eeprom.
cx88[0]: warning: unknown hauppauge model #0
cx88[0]: hauppauge eeprom: model=0

I'm tracking the issue in LP bug #836062 "[media/video] cx88xx HVR-1300,HVR-3000, HVR-4000 tveeprom: Huh, no eeprom present"

Gunni (fgunni) on 2012-06-26
Changed in mythbuntu:
status: Triaged → Fix Released
Changed in debian:
status: New → Fix Released
Displaying first 40 and last 40 comments. View all 186 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.