Support microphone toggle button instead of push-to-talk

Bug #876139 reported by RJ Skerry-Ryan on 2011-10-17
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Daniel Schürmann

Bug Description

For some use-cases, toggling the microphone is better than push-to-talk.

RJ Skerry-Ryan (rryan) on 2011-10-17
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
Daniel Schürmann (daschuer) wrote :

Idea:

We may do it like the power window in my car:
Short push: enable microphone
Second short push: disable microphone
Long push t > 0,5 s: push-to-talk

That sounds like a good way to do it to me.

2011/10/17 Daniel Schürmann <email address hidden>

> Idea:
>
> We may do it like the power window in my car:
> Short push: enable microphone
> Second short push: disable microphone
> Long push t > 0,5 s: push-to-talk
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/876139
>
> Title:
> Support microphone toggle button instead of push-to-talk
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/876139/+subscriptions
>

Until this is implemented, I found a workaround: put your mouse pointer over the talk button then hold the left mouse button, then hold the right one down too, then release the left, then release the right. That will cause the talk button to "stick" on for as long as you like. (Simply left-clicking it will release it.)

I also like the power window idea. We could also/instead use the right mouse button to toggle it while the left does PTT.

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Hi Sean,
your workaround does not work on ubuntu oneiric.

I am currently trying to make a power window button with an additional latching function with the right mouse button.

Daniel Schürmann (daschuer) wrote :

The attached patch introduces a power window mode for push buttons.
It works for mouse, keyboard and midi. The skins are updated for the microphone button.

It was tested together with the patch from bug #900255 and bug #686377 on lp:mixxx #2972

Daniel Schürmann (daschuer) wrote :

Updated patch for current lp:mixxx #2973

Daniel Schürmann (daschuer) wrote :

The attached patch is obsolete, please use the patch from Bug #906310

jus (jus) wrote :

Using the "Power window" patch since a while and it works really well.
Since the related lp:906310 is nominated for 1.11 , il add this one to 1.11 as well.

TODO: Update skins tooltips to reflect the new functionality if patch get merged.

Changed in mixxx:
milestone: none → 1.11.0

I will also appreciate a toggle feature. I use the microphone in ways that are incompatible with holding a button down. I usually prefer the keyboard button ("`") to the mouse click.

I had some success with a workaround: press the "`" or mouse button, keep it down while capturing the keyboard focus in another window, then release. I had record on for some minutes this way, but at some point I was unable to turn it off (the display showed it going on and off, but the microphone input still played through and showed on the level meters). I haven't had a chance to chase down the alternatives.

My best workaround is mechanical: a small flashlight pressing the "`" key.

Daniel Schürmann (daschuer) wrote :

Updated patch against lp:mixxx #3025.
Changed short klick time from 300 to 200 ms optimised to the use for EQ-Kill Switch bug #918470

RJ Skerry-Ryan (rryan) wrote :

After some careful testing I think this looks good. Since the patch also included some other stuff from another one of your patches I committed only the powerwindow-specific things to lp:mixxx. I also see now how the toggling for single-state WPushButton's that was done previously could have easily led to button-getting-out-of-sync issues that we have seen over the years so thanks for fixing that too.

I changed your patch a little bit so that a <PowerWindow> block doesn't have to be added to buttons in the skin. Instead, it looks at the controls connected to the left and right click on WPushButton and records their button-mode in WPushButton. When clicks happen on WPushButton, it checks the left button-mode to see if powerwindow mode is enabled. I think this is cleaner since it makes sure that a skin designer can't accidentally forget to enable power-window mode for things like talkover.

Changed in mixxx:
status: In Progress → Fix Committed
sahin (adim-sahin) on 2013-01-16
tags: added: microphone
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers