panel disapears with Maximus activated (Jaunty + Metacity with compositor)

Bug #335730 reported by antistress on 2009-02-28
This bug affects 4 people
Affects Status Importance Assigned to Milestone

Bug Description

With Jaunty, if i start maximus and switch between 2 applications with the Windows selector, the panel becomes invisible but is still there.
Left or right click on the invisible panel is still ok.
Cliking on the Fast User Switch applet or the Time applet may sometimes restore the panel but then switching between windows doesn't work very well (can't take an application sitting in the background to the foreground)
Then the panel disapears again...

I have an INTEL GMA 950 with xserver-xorg-video-intel drivers 2:2.6.1-1ubuntu3 and UXA activated

antistress (antistress) wrote :
description: updated
description: updated
antistress (antistress) wrote :

panel disappears while running vlc with full screen movie window named "vlc (xvideo output)"

other bugs are :
- when clicking time/calendar applet or fast user switch applet, their window are hidden behind the current window
- firefox menu bar doesn't show its menu while clicking on a menu

they seem all related since the occur quite simultaneously

antistress (antistress) on 2009-02-28
description: updated
Neil J. Patel (njpatel) wrote :

Thanks for reporting this bug.

If you do not run Maximus, then things work fine with window-switcher-applet? Even if you maximise all the windows manually and switch between them? If so, it could be something to do with Maximus undecorating the windows...

Changed in netbook-remix:
status: New → Triaged
antistress (antistress) wrote :

ineed the bug occurs when maximus is running
even without vcl or any video application
running Firefox and Specto maximised with Maximus makes that bug occur

Michael Alexander (beefsack) wrote :

Also affected by the problem with xserver-org-video-intel 2:2.6.3-0ubuntu2 installed (on my Samsung NC10 using Intel 945GME).

I experience graphical glitches with other full screen programs and games (tearing and artefacting, pieces of the screen missing) such as XMoto, but does not seem to affect them when they are windowed.

Michael Alexander (beefsack) wrote :

Solution for me was to turn off desktop effects in appearance.

Neil J. Patel (njpatel) wrote :

I've reproduced this without maximus running, so I'm thinking it's a video driver/xorg bug rather than a maximus one. The panel just disappears without any warning, and then comes back into view at random times. It must be something to do with the GL launcher below the panel.

I'll mark as invalid once I've figured out where this bug is occuring.

dome (ildome) wrote :

Same bug here with Acer aspire one 110l with jaunty 9.04 final release fully updated (but same issues with the last beta).
After the first (fresh) installation everything works fine.
But if desktop-switcher is used, at the pc reboot the panel in the netbook interface doesn't appear and windows are without any decoration.
Switching more and more times from netbook to classic interface things can change randomly: netbook interface could work fine, but classic desktop could lose both two panels, without anything on the desktop, apart the background image (Why CTRL + ALT + DEL doesn't work?). And sometimes (in the beta version) emerald doesn't work.
If you reboot pc when it is in classic desktop interface, at restart the desktop will be empty as often as not.
Switching from netbook to classic interface sometimes appears this error:
In the netbook interface you couldn't write in a text box (e.g. google search field in firefox, or in the command box field in the short-cuts keyboard preferences) if mouse arrow isn't stopped over the window (undecorated) in which there is the blinking cursor. I don't know if this is due to the bug we discuss here.

My trials to solve it in the beta version: I searched the word "netbook" and removed from synaptic every program that results installed.
I unchecked from the startup programs list "maximus", "UME Desktop Launcher", "UNR Launcher" and reboot.
Nothing helped.

How can I obtain the classic gnome desktop, until you fix the bug?

Hope this can help. Regards.

JensOtto (jos-ideatore) wrote :

I've switched to normal UI and all panels etc. was gone. How do I get back the UNR interface ? As it is now I can use the pc (Acer Aspire One with the small SSD)

Any advice would be appreciated. Thanks


dome (ildome) wrote :

Can you use the right click mouse menu to create an application launcher? If yes create one on your desktop and write into this command:

Or if you can open the gnome-terminal with a short-cuts keyboard execute the same command to switch.

JensOtto (jos-ideatore) wrote :

Thanks for the advice - that worked only partially.
I had tried the command "gnome-panel" and thereby I got some menus back and could call the desktop-switcher applicatioon but it did not fully restore the UNR interface. e.g. the Ubuntu icon in the upper leftmost part of the screen was missing and applications didn't show the application bar.
 In the end I have resorted to a clean install from my usb-stick - that works and I'm not going to try to call the desktop-switcher again soon!


Neil J. Patel (njpatel) wrote :

@Jens, the issue you are experiencing with desktop-switcher is a bug, for which you can find the resolution (and an updated package) at it's bug report here: We are seeking an SRU to get the fix into Jaunty, sorry for the trouble :).

dome (ildome) wrote :

Thanks Neil, after fixing desktop-switcher I haven't had problems with panels and windows decoration (apart bug n° 326341).

Best regards.

Paul Larson (pwlars) wrote :

moved this to maximus for the time being, just to get it out of netbook-remix. Neil, do you have an idea where the problem actually lies?

affects: netbook-remix → maximus
Neil J. Patel (njpatel) wrote :

Can someone see if this bug is still an issue in Karmic? Jaunty UXA was pretty experimental, but it shouldn't happen at all in Karmic. To be clear, the bug I'm referring to is the top panel going missing which switching between applications in UNR with UXA activated.

antistress (antistress) wrote :

i'll try in a couple of days, after my hollidays

Jason Smith (jassmith) wrote :

I am affected by this bug personally. However it is unrelated to maximus, it just so happens maximus makes it easier to trigger. The metacity compositor is to blame here. Since we do not use this by default in UNR (so far as I know) this should not be a widespread issue. It also seems to only effect intel graphics users on UXA. The bug is still present in git versions of the driver and git kernels, so likely still exists in Karmic. However fixing it is not a maximus issue at all. When this bug is triggered Docky (from GNOME Do) is also made invisible.

If I had to make a WAG, I would say what is going on is that the desktop window is being painted on top of the panel windows (despite the x windows being in the right spots) by the compositor. This results in invisible panel windows that are still responsive to click events. This however cannot be a complete picture if it is true to say that this only effects intel users on UXA. If it is intel related, there is likely some strange interaction going on here that will be difficult and painful to track down :(

I have yet to find a reliable trigger for this bug, however it does seem tangentially related to the desktop window being completely obscured by other windows (such as a maximized window). On a positive note, running "metacity --replace" will provide immediate relief.


Jason Smith (jassmith) wrote :

As per my previous comment, this is not exactly a maximus issue and certainly not an issue maximus can fix.

Changed in maximus:
status: Triaged → Invalid
antistress (antistress) wrote :

this bug doesn't seem to exist anymore with Karmic alpha 5

antistress (antistress) wrote :

sorry, the bug is still present in Karmic

Zatara214 (zatara214) wrote :

This bug can be solved by going into your gconf settings, going down to apps>maximus and unchecking the 'undecorate' option. Windows will retain their frames when maximized, but the panel will no longer disappear. I'd call that a good trade-off for now.

Vassily Gavrilyak (gavrilyak) wrote :

It is still here in Karmic, and it is easy to reproduce. With maximized, not decorated window you need to open dialog from any panel applet. E.g. bluetooth-applet -> send files to device or user-switcher -> Edit Personal Information. Then close the dialog and panel will disappear.
To get panel back again I use power button which brings shutdown dialog. Sometimes I need to press it twice. Shutdown dialog will appear and panel will appear too.

Vassily Gavrilyak (gavrilyak) wrote :

This happens with dialog-style windows. E.g gnome-ppp, gnome-appearance-properties etc. It doesn't look like driver problem. I tested this with intel, nvidia and nouveau drivers. So it is some window managment (can be both maximus and metacity) issue with handling dialog-style windows.

Neoprenanzug (raketenforscher) wrote :

I can confirm this bug on a EeePC 701 4G running Karmic.

The panel and other desktop elements (like Docky) disappear when Metacity compositing and maximus with enabled undecoration come together. Disabling compositing or undecoration brings back the invisible objects.
However, this bug does not appear with compiz. I think, because when you use compiz, you have tu turn off Metacity's compositing.

Neoprenanzug (raketenforscher) wrote :

Correction: unchecking maximus' "undecorate" does not bring back the panel directly, but prevents it from disappearing in the first place, as Zatara stated.

dastillero (dastillero) wrote :

Same problem here with Metacity compositing and Maximus "undecorate" feature enabled on Lucid Netbook edition. HP 2133 Mini Note with Via Chrome9 graphics. I'm using the openChrome drivers.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments