Feedback notification from own comment

Bug #1374674 reported by Stéphane Lavoie on 2014-09-27
14
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Robert Lyon

Bug Description

Situation goes as such :

- A view has been commented by another user :
     - the owner receives a notification --> Good
- the owner replies to the comment in his view
     - the owner gets a notification --> not required
     - the user who left a comment should be notified that a new comment has been made (bug 738882)

Part of the situation has already been reported (bug 738882)
but part of it has not.

The person who writes a comment on his own view should not be notified of a new comment.

Robert Lyon (robertl-9) on 2014-10-02
Changed in mahara:
milestone: none → 1.11.0
assignee: nobody → Robert Lyon (robertl-9)
importance: Undecided → Medium
Robert Lyon (robertl-9) on 2014-10-03
Changed in mahara:
status: New → In Progress
Changed in mahara:
importance: Medium → Wishlist
Aaron Wells (u-aaronw) on 2014-10-08
description: updated
Robert Lyon (robertl-9) wrote :

To deal with not getting any more comment notifications again - seen as one can't un-subscribe to comments I propose this:

1) I comment on something and the system records I'm interested in the view/artefact's comments

2) When the next user comments on view/artefact it sends me an email notification

3) If I go to view the view/artefact again (as logged in user) in my browser the system again records I'm interested in the view/artefact's comments (whether I choose to comment this time or not)

4) When the next user comments on view/artefact it sends me an email notification I'm sent another email

5) But if I never visit the view/artefact again after getting my email I never receive another comment notification from that view/artefact again.

Aaron Wells (u-aaronw) wrote :

Hi Robert,

The problem is, the notification that we send out, includes the comment text (I think). In which case, a user who is interested in the conversation being held through comments doesn't have any reason to go visit the page. They'll read the comment in the notification, assume that they're still subscribed to continue receiving comment notifications for that page, and go on their merry way.

I think what we need is:

1. We add the ability to manually subscribe/unsubscribe from comments on the page. Sort of like the watchlist toggle we currently have.

2. When you comment on a page, you automatically get subscribed to comments on that page.

Of course the problem here is that we're adding yet another checkbox, right? So we'd want to give some careful thought on how to do this unintrusively.

Stéphane (smlavoie) wrote :

Hi,

I totally agree with your second need, Aaron. For the first, though, I'm not sure.

The fact that I want to watch a page, it means I want to be notified of any change on that page. Adding a comment to a page is on change on the page and I should be notified.

Do we really need two levels of notification on a page? One for displayed artefacts and one for the comments?

Aaron Wells (u-aaronw) wrote :

Hi Stephane,

Oh, I like this idea!

1. If you put a page on your watchlist, you receive notifications about comments on that page.

2. If you comment on a page, that page is automatically added to your watchlist. (You can of course manually unsubscribe.)

That neatly combines the two things, without adding any new controls or subscriptions. The one part that gives me pause is the second part. I think there will be use-cases where, say, a teacher is commenting on dozen of student submissions and then no longer cares about the page afterwards. They will probably find it annoying to have to manually unsubscribe from those pages. But I think that's a minor annoyance, and if it becomes an issue we could maybe later add a user preference about whether or not to automatically "watch" pages you comment on.

So yeah, I think this ^ is the way we should go. :)

Cheers,
Aaron

Robert Lyon (robertl-9) wrote :

I agree with the idea of adding the comment leaver to the watchlist for the view so I have adjusted my patch to handle this

Jinelle Foley-Barnes (jinelleb) wrote :
Download full text (3.7 KiB)

ERROR MESSAGE:

[WAR] 43 (lib/htmltotext/htmltotext.php:27) DOMDocument::loadHTML(): htmlParseEntityRef: expecting ';' in Entity, line: 1
Call stack (most recent first):

    log_message("DOMDocument::loadHTML(): htmlParseEntityRef: expec...", 8, true, true, "/var/www/html/maharagerrit/htdocs/lib/htmltotext/h...", 27) at /var/www/html/maharagerrit/htdocs/lib/errors.php:441
    error(2, "DOMDocument::loadHTML(): htmlParseEntityRef: expec...", "/var/www/html/maharagerrit/htdocs/lib/htmltotext/h...", 27, array(size 3)) at Unknown:0
    DOMDocument->loadHTML("<head><meta http-equiv="Content-Type" content="tex...") at /var/www/html/maharagerrit/htdocs/lib/htmltotext/htmltotext.php:27
    HtmltoText->__construct("<head><meta http-equiv="Content-Type" content="tex...", "https://boris.wgtn.cat-it.co.nz/maharagerrit/htdoc...") at /var/www/html/maharagerrit/htdocs/lib/web.php:3447
    html2text("<p><img width="960" height="960" style="" src="htt...") at /var/www/html/maharagerrit/htdocs/artefact/comment/lib.php:1533
    ActivityTypeArtefactCommentFeedback->__construct(object(stdClass), false) at /var/www/html/maharagerrit/htdocs/lib/activity.php:69
    handle_activity(object(stdClass), object(stdClass)) at /var/www/html/maharagerrit/htdocs/lib/activity.php:42
    activity_occurred("feedback", object(stdClass), "artefact", "comment") at /var/www/html/maharagerrit/htdocs/artefact/comment/edit.php:135
    edit_comment_submit(object(Pieform), array(size 5)) at Unknown:0
    call_user_func_array("edit_comment_submit", array(size 2)) at /var/www/html/maharagerrit/htdocs/lib/pieforms/pieform.php:532
    Pieform->__construct(array(size 5)) at /var/www/html/maharagerrit/htdocs/lib/pieforms/pieform.php:162
    Pieform::process(array(size 5)) at /var/www/html/maharagerrit/htdocs/lib/pieforms/pieform.php:71
    pieform(array(size 5)) at /var/www/html/maharagerrit/htdocs/artefact/comment/edit.php:94

[WAR] 43 (lib/htmltotext/htmltotext.php:27) DOMDocument::loadHTML(): htmlParseEntityRef: expecting ';' in Entity, line: 1
Call stack (most recent first):

    log_message("DOMDocument::loadHTML(): htmlParseEntityRef: expec...", 8, true, true, "/var/www/html/maharagerrit/htdocs/lib/htmltotext/h...", 27) at /var/www/html/maharagerrit/htdocs/lib/errors.php:441
    error(2, "DOMDocument::loadHTML(): htmlParseEntityRef: expec...", "/var/www/html/maharagerrit/htdocs/lib/htmltotext/h...", 27, array(size 3)) at Unknown:0
    DOMDocument->loadHTML("<head><meta http-equiv="Content-Type" content="tex...") at /var/www/html/maharagerrit/htdocs/lib/htmltotext/htmltotext.php:27
    HtmltoText->__construct("<head><meta http-equiv="Content-Type" content="tex...", "https://boris.wgtn.cat-it.co.nz/maharagerrit/htdoc...") at /var/www/html/maharagerrit/htdocs/lib/web.php:3447
    html2text("<p><img width="960" height="960" style="" src="htt...") at /var/www/html/maharagerrit/htdocs/artefact/comment/lib.php:1533
    ActivityTypeArtefactCommentFeedback->__construct(object(stdClass), false) at /var/www/html/maharagerrit/htdocs/lib/activity.php:69
    handle_activity(object(stdClass), object(stdClass)) at /var/www/html/maharagerrit/htdocs/lib/activity.php:42
    activity_occurred("feedback", o...

Read more...

Reviewed: https://reviews.mahara.org/3736
Committed: http://gitorious.org/mahara/mahara/commit/4ae687a090d56595b9cf1fbbf5c5fb7ce947d7e7
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 4ae687a090d56595b9cf1fbbf5c5fb7ce947d7e7
Author: Robert Lyon <email address hidden>
Date: Thu Oct 2 15:53:46 2014 +1300

Allowing all interested parties to get notified of feedback (Bug 1374674)

On personal pages / artefacts

- while ignoring the user that left the feedback from the list of users to email
- but still including the owner of the view/artefact if needed
- but then ignoring owner if the owner is the user leaving feed back

Also when a user adds a public comment to a view/artefact they automatically
become a watcher of the view - to allow them to receive notifications
about future comments left on the artefact/view

Change-Id: I0fc7109c74581266024c52ee40edbaff6dbb99d2
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

Merged!

I did some issues, which we can address in further bugs/patches. Here is a list of things to fix:

Need to fix before 15.04.0:
1. The "Add page to watchlist" link needs to update to "Remove page from watchlist" when we display the new comment via AJAX. Currently it doesn't change til you reload the page.

2. Putting feedback on a page shouldn't add the page to your watchlist, if you are the page owner.

3. Feature only half-works for group pages, site pages, and institution pages. It adds the page to your watchlist, but you don't receive feedback notifications for the page. We need to either make it work all the way for group, institution, and site pages, OR make it so that it doesn't add the page to your watchlist for those pages.

Additional things it would be good to fix:

1. In the inbox, the "From" says "System". It should say the name of the commenter. Or at least the name of the commenter should be in the message somewhere. Currently the message just has the text of the comment and the page title, but not who left the comment.

2. Send out a notification to page watchers when a private comment is made public. (or when a moderated comment is approved)

3. Text on the notification email to tell watchers that they received this email because they're watching the page, and they can unwatch the page to unsubscribe.

4. Make it work for group pages, site pages, and institution pages. Make sure that people who would receive a feedback notification already, for each of these page types, do not get the page redundantly added to their watchlist. (Sort of like how the page owner of a user page, shouldn't get their own page added to their watchlist). For group pages, the "already notified" list is a setting in the group config. For institution pages, it's site & institution admins (and staff?). For site pages, it's site admins (& staff?)

tags: added: nominatedfeature
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4461

Dirk Meyer (dirkca68) wrote :

Something to consider:
It would be useful when receiving feedback on artifacts and pages who has left the feedback within the notification message. This could be resolved by replacing the name 'system' with the actual users name. Also, why not have a separate tab next to 'Compose' in 'Notifications' called 'Feedback' where you will get a list of feedback that you have left to others and received by others.
This would be so essential for creating effective feedback loops.

Reviewed: https://reviews.mahara.org/4460
Committed: http://gitorious.org/mahara/mahara/commit/42deac8b23fcccaa6f179b0994b4b713eba2afca
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 42deac8b23fcccaa6f179b0994b4b713eba2afca
Author: Robert Lyon <email address hidden>
Date: Tue Mar 24 12:51:50 2015 +1300

Updating watchlist link on leaving feedback (Bug #1374674)

If user is added to watchlist as part of their leaving a comment

Fix for point 1 in bug report

Change-Id: I3d256dff82c9c767d64541ac203e9fea20d6d6e0
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4584
Committed: http://gitorious.org/mahara/mahara/commit/e5c4abfcce90ef8edac5ce1dc417f726d5edf36b
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit e5c4abfcce90ef8edac5ce1dc417f726d5edf36b
Author: Robert Lyon <email address hidden>
Date: Tue Mar 24 12:51:50 2015 +1300

Updating watchlist link on leaving feedback (Bug #1374674)

If user is added to watchlist as part of their leaving a comment

Fix for point 1 in bug report

Change-Id: I3d256dff82c9c767d64541ac203e9fea20d6d6e0
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4461
Committed: http://gitorious.org/mahara/mahara/commit/1832522582bb4aebf6db669a8ded6e68dccacc8a
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 1832522582bb4aebf6db669a8ded6e68dccacc8a
Author: Robert Lyon <email address hidden>
Date: Tue Mar 24 13:02:48 2015 +1300

Not adding page owner to watchlist when leaving feedback (Bug #1374674)

If the commenter is also the owner of the view don't add them to the
watchlist

Fix for point 2 in bug report

Change-Id: Ia17dbe015eab1ec135c538add7e505aa2ccc8ecf
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4585
Committed: http://gitorious.org/mahara/mahara/commit/a5b617b00fad3b3d94300bcdb21322eb4a954ba1
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit a5b617b00fad3b3d94300bcdb21322eb4a954ba1
Author: Robert Lyon <email address hidden>
Date: Tue Mar 24 13:02:48 2015 +1300

Not adding page owner to watchlist when leaving feedback (Bug #1374674)

If the commenter is also the owner of the view don't add them to the
watchlist

Fix for point 2 in bug report

Change-Id: Ia17dbe015eab1ec135c538add7e505aa2ccc8ecf
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

I've spun off Bug 1443280 to address issue #3 above.

Aaron Wells (u-aaronw) wrote :

I've spun off Bug 1443282 to address issue #4 above.

Aaron Wells (u-aaronw) wrote :

Spun off Bug 1443284 for adding the unsubscribe link to feedback notifications.

Spun off Bug 1443286 for notifications about comments made public

Spun off Bug 1443287 for redundant watchlist adds, for group, site, and institution pages.

And I think with those spin-offs, we've addressed all the remaining issues for this bug, so we can mark it "Fix Committed".

Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers