no support for sis 671/771 video cards

Bug #301958 reported by bgerlich on 2008-11-25
462
This bug affects 73 people
Affects Status Importance Assigned to Milestone
Linux Mint
Wishlist
Unassigned
X.Org X server
Confirmed
Medium
Arch Linux
New
Undecided
Unassigned
Baltix
Undecided
Unassigned
xserver-xorg-video-sis (Debian)
Fix Released
Unknown
xserver-xorg-video-sis (Fedora)
Unknown
Unknown

Bug Description

sis 671/771 driver is not available for Ubuntu but there is a working driver in the newest Mandriva. The driver in Mandriva is based on http://www.linuxconsulting.ro/xorg-drivers/ ( I think) .

Not having the driver makes the installation of Ubuntu a PITA on laptops with sis 671/771 based integrated graphics card. Making the laptop usable requires playing with xorg.conf and module compilation or switching to Vesa 1280x768 mode deformed to fit 1280x800 LCD.

sis 671/771 driver is not available for Ubuntu but there is a working driver in the newest Mandriva. The driver in Mandriva is based on http://www.linuxconsulting.ro/xorg-drivers/ ( I think) .

Not having the driver makes the installation of Ubuntu a PITA on laptops with sis 671/771 based integrated graphics card. Making the laptop usable requires playing with xorg.conf and module compilation or switching to Vesa 1280x768 mode deformed to fit 1280x800 LCD.

Timo Aaltonen (tjaalton) wrote :

seems like that work has not been submitted upstream. Instead they've forked 0.9.1 and added the changes on top of it, without any changelog. Nice.

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi bgerlich,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-video-sis:
status: New → Incomplete
luca (l-savio) wrote :

I tried with new mandriva on my daghter's Asus with SiS 671/771, but does not work: resolution is correct, but just 16 colors! Last DreamLinux and Opensuse work fine with video (but have several other problems, Intrepid is the only OS that makes usable that laptop (Asus X58C)).

luca (l-savio) wrote :

Hi Bryce.
Maybe it's useful this one, having the same problem. Intrepid has been installed few minutes ago, all synaptic upgrades done, xorg.conf was not modified. screen resolution available: 800x600 or 640x400 @61Hz, sis 671/771.

bgerlich (bgerlich) wrote :

For convenience I have prepared a debian package with sisimedia driver patched by fedora forum's user "bahamot" to work with xserver 1.5.x.

I have made a few very minor changes so that the driver would seem more seamless, namely - buggy 2D acceleration is now disabled by default. I have also included a pciid file, so that the card is detected automatically. Just install the deb and restart your xserver.

Remember to remove any driver names and such from xorg conf manualy or by typing sudo dpkg-reconfigure -phigh xserver-xorg in terminal.

bgerlich (bgerlich) wrote :

Oh, and this is Ubuntu Intrepid version only, will provide a Jaunty soon.

luca (l-savio) wrote :

Hi bgerlich, I got your driver and it works fine! I hope it will be included in Jaunty. Thanks and happy new year.

Stephan202 (sschroev) wrote :

I'd like to confirm that this driver works on Intrepid for the Asus X58C laptop that I have here. Many thanks!

I tried to used this package, but it divides my screen in two horizontal screens...

mikeloco14 (mikeloco14) wrote :

It works fine, it is much faster than stupid vesa... But when i restarted X, it looked like widescreen compressed on my 4:3 monitor... The monitor said it was 800x600, so I went to System -> Preferences -> Screen Resolution. It said it was 960x600, and there was no 1024x768... My monitor is capable of 1024x768 and so is the card (in windows it could use 1024x768 and so it could with vesa.)

I don't know how to fix this... Could someone help!???

This are the log and configuration file with the xserver-video-sis671 installed. After installing the package, the display turns into two horizontal 640x400 screens, mirroring each other. Really weird...

bgerlich (bgerlich) wrote :

Sulamita - simply load a default xorg.conf using "sudo dpkg-reconfigure -phigh xserver-xorg" . Your problem is most probably caused by the monitor configuration which is not needed.

On a similar note, it took me long enough but I finally got around to it.

Below is a beta version of sis 771/671 driver package for Ubuntu Jaunty. Now with working 2D Acceleration (XAA).

As before - simply install the deb package and make sure that your xorg.conf is the one provided by the system (no modifications required).

Thank you very much, it works perfect for me!

mikeloco14 (mikeloco14) wrote :

That did not work for me.
Forgot to say, it's Ubuntu Intrepid.

bgerlich (bgerlich) wrote :

Have you tried "sudo dpkg-reconfigure -phigh xserver-xorg" ?

Jeff (jeffmart) wrote :

Report for beta jaunty in SiS671 onboard notebook: Work like a charm for me! Thanx!!! We just need a working 3D driver now... :) There are a brazilian distro, called Satux, that has one. It is the original distro that is selling with my notebook. But it is Debian Etch based, so, all in there is so obsolete...

bgerlich (bgerlich) wrote :

We won't have it any time soon. SiS has written a 3D driver actually. It is based on standard sis xorg driver but it has been not worked on since a long time. It doesn't use the __driDriverExtensions API so it won't work with Mesa > 7.1 (intrepid and up). It doesn't look like Satux team is working on it ... so we have no chance for a 3D driver soon, at least until SiS releases the source code.

bgerlich (bgerlich) wrote :

Here's a least modified version of the source, that's the most similar to xorg sis driver and works properly. One unnecessary thing I left is a check that stops the driver from working with chips other than sis 771/671 - the only chip this version of the driver was tested on.

This driver supports 1440x900 resolution?

Ropechoborra (securetux) wrote :

Thank you very much ! This driver works perfectly on an Olivetti 520 laptop !

Chipping (chipping) wrote :

I finally took the plunge and decided to experiment with a linux operating system. Having done a little research over the weekend I decided to install Ubuntu 9.04 as a second OS on my Fujitsu Siemens Esprimo laptop. On the whole I am really pleased with the install and initial operation of the new OS but the laptop has a SiS 671 based GPU and although the built in monitor works well I am unable to output the display to an external monitor or projector . I came to this site looking for an alternative driver. I have downloaded the version uploaded on April 4th and extracted the files to my desktop but I cannot figue out how to install it. Have I downloaded the correct file and if so could someone please provide me with a step by step instalation guide?

Chipping (chipping) wrote :

Ok I have installed the deb 2D version instead this is working fine with an external monitor but not with my tv which displays a signal that mode is not supported. Does anyone know of a solution to this?

I am a total Linux newbie, having just installed Ubuntu 9.04 on an Acer Aspire 3000 laptop which is having serious issues running Windows XP. It has an SIS graphics chipset. The display of Ubuntu on the laptop is terrible!
I have downloaded and applied "xorg-driver-sis671_0.9_i386.deb" (it tells me the package is already applied, or something).
To illustrate the problem I took a screenshot on the laptop, transferred it to my desktop (running Windows XP Pro). To my surprise, the screenshot looks perfect!
The attached picture shows my desktop PC displaying the screenshot saved on the laptop next to it. The laptop shows its usual Ubuntu picture. Clearly there is a major difference! The laptop seems to only be displaying a few colours and has a constantly scrolling horizontal flicker.
Any ideas? I would be most grateful for any assistance.

bgerlich (bgerlich) wrote :

You have some problems with the rom data on your graphics card. Add the line

Option "useROMData " "False"

to the "Device" section on your /etc/X11/xorg.conf . You can edit it typing the command sudo gedit /etc/X11/xorg.conf in the terminal (you'll find that in Applications->Accesories).

The "Device" snippet will look something like that after the edit:

Section "Device"
 Identifier "Configured Video Device"
        Option "useROMData " "False"
EndSection

Thiago Galesi (thiagogalesi) wrote :

bgerlich driver works good on 01:00.0 0300: 1039:6351 (rev 10), thanks!

not much faster than 9.04 netbook remix interface then vesa though...

Not faster at all actually. Netbook Remix interface uses the Clutter toolkit
- that's basically OpenGL wrapped in a simpler API, so it requires 3D
acceleration to get a performance boost.

I've written to maintainer of the satux driver, and he said that their driver is based on code from here : http://www.linuxconsulting.ro/xorg-drivers/ with some patches. He promised to publish them on his blog - but haven't done this yet, apparently.

Daniel Uranga (fersbery-77) wrote :

I think i have the same problem than Sulamita Garcia. My screen divides in two. I send a photo to illustrate.

bgerlich (bgerlich) wrote :

Daniel, post your /etc/X11/xorg.conf and your /var/log/Xorg.log.0

Daniel Uranga (fersbery-77) wrote :

The driver for 8.04 works ok. In only have this problem with 8.10 and 9.04.

Daniel Uranga (fersbery-77) wrote :

@bgerlich: what do you think causes the error that i have posted here? Is there any hope that might fix this?

Here i post the output of lspci:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
03:00.0 System peripheral: JMicron Technologies, Inc. Unknown device 2382
03:00.2 SD Host controller: JMicron Technologies, Inc. Unknown device 2381
03:00.3 System peripheral: JMicron Technologies, Inc. Unknown device 2383
03:00.4 System peripheral: JMicron Technologies, Inc. Unknown device 2384

Daniel Uranga (fersbery-77) wrote :

Another photo. I will try to hack the code to make it work, where could I start?

Suggestion: It looks like a non-free driver for SiS graphics cards exists - this should be packaged alongside / similarly to the nvidia non-free graphics drivers?

http://ubuntuforums.org/showthread.php?t=615094&highlight=M671

tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - no working driver for sis 671/771 video cards
+ [needs-packaging] no working driver for sis 671/771 video cards
Changed in xserver-xorg-video-sis (Ubuntu):
importance: Undecided → Wishlist

At least for me, the driver from Sis doesnt works. I can only get the video working correctly with Ubuntu 8.04.

luca (l-savio) wrote :

Will bgerlich's driver work with Karmic?

LoCusF (suomalainen-aleksi) wrote :

I can confirm that Djalma's workaround works perfectly. Now we just need similar packages for Ubuntu :)

Changed in xserver-xorg-video-sis (Ubuntu):
status: Incomplete → Triaged
Changed in xorg-server:
status: Unknown → Confirmed
Changed in xorg-server:
importance: Unknown → Medium
178 comments hidden view all 238 comments

Please get the latest from https://bugs.launchpad.net/xorg-server/+bug/301958 which is pointing to http://ajoliveira.com/ajoliveira/uk/software/xorg.php

Note, resolutions higher than 800x600 *are* possible.

Please fix this bug which is more than two years old so the driver can get into the next release and eventually be packaged by Ubuntu to be enjoyed by all.

Changed in xserver-xorg-video-sis (Debian):
status: Unknown → New
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium

*** Bug 29668 has been marked as a duplicate of this bug. ***

20 comments hidden view all 238 comments
komputes (komputes) wrote :

Pander said:
"Would be nice to know how to set it by default. Anyone?"

Try the following command to launch the Multimedia Systems Selector:
$ gstreamer-properties

Under the Video Tab, for Default Output select "X Windows System (X11/XShm/Xv)". Please let us know if this works.

Pander (pander) wrote :

No that does not work.

Pander (pander) wrote :

What is an alternative to try? What made it work by default on 10.04 LTS?

Pander (pander) on 2012-07-12
tags: added: 12.10
Timo Aaltonen (tjaalton) on 2012-10-11
summary: - [needs-packaging] no working driver for sis 671/771 video cards
+ no support for sis 671/771 video cards

Hello

I have been trying to compile the old driver, modified over and over on 12.10. I succeeded to compile it, but the modifications were too many, and the driver does not work properly. Why are we in need of so many modifications? xorg 1.3.0 widthdrawed XAA acceleration, just EXA is supported, and the code was not ready in terms of function structure together with defines to be used withou XAA. I will keep you posted as soon as I have some news. I would like to know if there is somebody out there doing the same kind of stunt :-)

rectification, X version is 1.13.0

helpfulboy02 (helpfulboy02) wrote :

will the updated fix be Back ported to 12.10?
or Earlier?
It is an important bug

Unfortunately my spare time is scarce. Fortunately my working PC uses this board and my eyesight needs the updated driver. :-) will try again early this week.

Antonio J. de Oliveira wrote:
> Unfortunately my spare time is scarce. Fortunately my working PC uses
> this board and my eyesight needs the updated driver. :-) will try again
> early this week.
>
Thanks & yes it's hard but happy that you will fix it
Will it be backported?

Hello, new attempt, new failure, I ported all the code to 1.13.0, suspect I have a couple of pointer problems with the swap function. The remainder was accurately migrated. Will keep on...

Vadim Barsukov (vadbars) wrote :

Is there any news with this driver? One man made a driver for the gentoo - https://github.com/rasdark/xf86-video-sis671. Perhaps it will be useful for ubuntu?

Thanks for the tip. The code you refer to does not compile, it stops at one of the functions I already patched. But this weekend I will give it a look, maybe he solved what I didn't and vice-versa...

Vadim Barsukov (vadbars) wrote :

The new version of ubuntu 12.10 uses Xorg 1.13. Is it possible to downgrade to Xorg 1.12, to use your driver for ubuntu 12.04 and 11.10?

Vadim Barsukov (vadbars) wrote :

Apparently, this is a very difficult task ...

I have been very busy, but meanwhile two builds have been carried out with no success. I choose to start from scratch again, and I hope to get a new build ready very soon.

Jonas Schwabe (jonas-schwabe) wrote :

I got it compiled without xaa headers but with the same results in the end.
Have been very busy as well. What do you mean by starting from scratch
exactly? Maybe merging it with the xorg sis driver would help, but that
driver was completely rewritten in the meantime afaic.
I will send you my changes later today.
Am 26.11.2012 11:03 schrieb "Antonio J. de Oliveira" <<email address hidden>
>:

> I have been very busy, but meanwhile two builds have been carried out
> with no success. I choose to start from scratch again, and I hope to get
> a new build ready very soon.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/301958
>
> Title:
> no support for sis 671/771 video cards
>
> Status in X.Org X server:
> Confirmed
> Status in “xserver-xorg-video-sis” package in Ubuntu:
> Triaged
> Status in Arch Linux:
> New
> Status in Baltix GNU/Linux:
> New
> Status in “xserver-xorg-video-sis” package in Debian:
> New
>
> Bug description:
> sis 671/771 driver is not available for Ubuntu but there is a working
> driver in the newest Mandriva. The driver in Mandriva is based on
> http://www.linuxconsulting.ro/xorg-drivers/ ( I think) .
>
> Not having the driver makes the installation of Ubuntu a PITA on
> laptops with sis 671/771 based integrated graphics card. Making the
> laptop usable requires playing with xorg.conf and module compilation
> or switching to Vesa 1280x768 mode deformed to fit 1280x800 LCD.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xorg-server/+bug/301958/+subscriptions
>

Hi, Jonas

I coudn't get the proper results and some people complained that they could not use 1366x768 panels, and that were the two reasons I took the original http://linuxconsulting.ro/ driver and am modifying all modules. I expect to have a few hours today to get to this :-)

Cheers all

Davidmp (davidmp) wrote :

Hello everyone,
I have installed the video sis 771/671 drivers provided by Mr. Oliveira in an ubuntu 12.04 and worked perfectly from the beginning and the screen resolution is right at 1280x800, so thanks a lot; but later on I have found that when trying to play a video with Totem the screen turns into black and then returns to the login screen. When I try to play it with vlc, the video plays quite well unless I don't try to modify vlc window's dimensions or clicking on it so it understands to get to full screen, in that case everything crashes and I get the login screen again, just as with Totem. (Sometimes vlc shows a message that says that the video will be played at a very large resolution, but if you click Ok it shows in rather small window.)

Is there anything to do to solve this problem or just it's the most it can be achieved with a sis 771/671 in ubuntu 12.04?
Thanks for your attention,
David

luca (l-savio) wrote :

@Dmedina: in vlc you can choose x11 output in preferences/video, in totem you should do the same thing, but I don't know in which conf file :)

Pander (pander) wrote :

Can this become part of the installation and deinstallation scripts?

Sorry for late reply. Still no time left. Yes, this question is a repeating one, I will create a faq on my page very shortly. Thanks.

2 comments hidden view all 238 comments
William Berzoff (berzoffw) wrote :

@ Antonio J. de oliveira: any hope for a new driver solution ? I have read your remark about the 12.04+ Ubuntu's, but my hope is that you still manage to find a new solution at some point. Too bad that Ubuntu refuses to help out. It sucks to be a minority.

@William Berzoff, I gave up for the moment being, as my driver page ( http://ajoliveira.com/ajoliveira/uk/software/xorg.php ) states. At this point I got no time left, the code I used is there. I made 4 attempts to correct the code with 4 different sources. I even grabbed archlinux sources, patched and recompiled from scratch. No way, the driver crashes xorg.

I have to add that I got problems on 2 other laptops using Trident and Intel graphics boards and I had to revert to 12.04, because those became unusable. I therefore do not recommend anything other than 12.04 for an usable, stable system.

I managed to successfully run the original sisimedia driver (http://www.linuxconsulting.ro/xorg-drivers/) modified for Xorg 13, maintained now by Mandriva developers and Arch Linux developers. Here's the package page from Arch Linux:
https://www.archlinux.org/packages/?name=xf86-video-sisimedia
If you need the initial source code, just look into PKGBUILD file, it has all the info including tarball, patch order and building. Maybe this can be adopted to Ubuntu?

@Radoslaw, I used that one on my last attempt.

fcole90 (fcole90) on 2013-02-11
affects: xserver-xorg-video-sis (Ubuntu) → linuxmint
Changed in linuxmint:
status: Triaged → Confirmed
Pander (pander) wrote :

what is the latest update for 12.10 and 13.04. Can I use the driver on Quantal already, otherwise I am not even going to start the dist upgrade.

Pander (pander) wrote :

I managed to build it on Quantal but using it indeed it fails. Two questions:

1) How can I trouble shoot it? (I have limited knowledge on fixing X but willing to help out testing some ideas.)

2) Can we get some backwards compatability support from X on this?

Pander (pander) on 2013-04-27
tags: added: 13.04 13.10
removed: 12.10
Pander (pander) wrote :

I would be more than happy to provide financial support or compensation for whoever fixes this bug. We could create feature request funding at https://www.catincan.com/

Pander (pander) wrote :

Good news, here is a workable driver but without acceleration at the moment:
  http://lists.x.org/archives/xorg-devel/2013-May/036222.html

Emilio (emilio-moretti) wrote :

Latest patch in:
https://www.archlinux.org/packages/?name=xf86-video-sisimedia

fixed the crash and it seems to have fixed the acceleration, since "NoAccel" parameter is no longer needed

Build and installation instructions for Lubuntu 13.04
1) sudo apt-get build-dep xserver-xorg-video-sis
2)Download ALL files (source + patches) from https://www.archlinux.org/packages/?name=xf86-video-sisimedia
3)Now manually merge the patches to the source files following PKGBUILD instructions (*).
4)sudo make install
5)Edit /etc/X11/xorg.conf to look like this:
Section "Device"
 Identifier "Configured Video Device"
 Driver "sisimedia"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 DefaultDepth 24
EndSection

(notice that the acceleration in enabled)
6) Log out and log in again :)

(*)About step 2. you should extract the sisimedia source code, and move all patches to the source folder. then open PKGBUILD to see the right order to apply the patches. Hint: it's in the build() section.

Here is an example:

  patch -Np1 -i "./xf86-video-sis-0.9.1-20102701.patch"
  patch -Np1 -i "./0002-Remove-XFree86-Misc-PassMessage-support.patch"
  patch -Np1 -i "./0003-Fix-build-with-Werror-format-security.patch"
  patch -Np1 -i "./0005-Fix-backlight-off-on-SiS30x.-video-bridges.patch"
  patch -Np1 -i "./0006-Add-IgnoreHotkeyFlag-driver-option.patch"
  patch -Np1 -i "./xf86-video-sis-0.9.1-dump-regs-after-video-init.patch"
  patch -Np1 -i "./0007-Remove-useless-loader-symbol-lists.patch"
  patch -Np1 -i "./0008-update-to-xextproto-7-1-support.patch"
  patch -Np1 -i "./0009-update-for-rac-removal.patch"
  patch -Np1 -i "./0010-change-to-use-abi-version-check.patch"
  patch -Np1 -i "./0011-more-rac-removal.patch"
  patch -Np1 -i "./0001-Remove-xorgconfig-xorgcfg-from-See-Also-list-in-man-.patch"
  patch -Np1 -i "./0004-Make-sisRegs3D4-big-enough-to-hold-all-values-writte.patch"
  patch -Np1 -i "./0005-Correct-bounds-check-of-blitClip-array-access.patch"
  patch -Np1 -i "./xserver19.patch"
  patch -Np1 -i "./xserver112.patch"
  patch -Np1 -i "./pciTag-removal-workaround.patch"
  patch -Np1 -i "./Untangle-XF86DRI.patch"
  patch -Np1 -i "./swap-func-rename.patch"
  patch -Np1 -i "./xf86MapDomainMemory-pci_device_map_legacy.patch"
  patch -Np1 -i "./sync-with-freedesktop.patch"
  patch -Np0 -i "./fix-xv-crash.patch"
  patch -Np1 -i "./sisimedia-no-xaa.patch"
  patch -Np1 -i "./sisimedia-xorg-1.13.patch"
  patch -Np1 -i "./remove_mibstore.h.patch"

  patch -Np1 -i "./deprecated-sym2.patch"
  patch -Np1 -i "./disable-UploadToScreen-DownloadFromScreen.patch"

  sed -i -e 's,sis_drv,sisimedia_drv,g' src/Makefile.am
  sed -i -e 's,\"sis\",\"sisimedia\",g' src/sis.h
  sed -i -e 's,sisModuleData,sisimediaModuleData,g' src/sis_driver.c

  sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac

  autoreconf -fi

  ./configure --prefix=/usr --disable-dri
  make

Notice that these steps will change with new releases, so don't forget too check PKGBUILD file to get the latest instructions.

Hello. I tried to upgrade to 13.04. That left my working system in a completely unusable state, and even deleting xorg.conf could not prevent the system to successively reboot after a login attempt.
If I go back and have a look at all my obsolete PCs with Trident and Intel graphic chipsets, all became unusable after 12.04. A non-accelerated driver is no good, so I went back to 12.04 on all PCs, and am very happy with it.

Pander (pander) wrote :

Thanks, Pander.

Pander (pander) on 2013-10-23
tags: added: 14.04
luca (l-savio) wrote :

On my pc with Sis card now I run 12.04: next year probably will switch to Mageia, which has support for it (tested last summer).

Changed in xserver-xorg-video-sis (Debian):
status: New → Fix Released
Davidmp (davidmp) wrote :

Hello. I also have recently tried Mageia 4 beta (it's due out in February) on a laptop with Sis 671/771 graphic card and the display was correct out of the box from the live iso. The only problem were the drop-down menus, which appered to be scrambled and its contents, the options available, unreadable. I have seen on other laptops using vesa that this seems to be a semi-problem too, because you must click on the drop-down menu twice before you can read what is in it, but you can use them just with a little patience. Despite of it, with Mageia 4 this is not the case, apparently. The drop-down menus are not usable, at least from the live iso, even if you click on them several times and wait to be loaded. The doubt here is that you don't know if once the system is installed this would persist or not. If not, Mageia may be a good solution, or the solution, and it could be taken as an example. Anyone have tried it? Is there another distribution with a similar or better behaviour? Thanks.

hede (michael-heide) wrote :

With Ubuntu 14.04 there's still no support for SiS 671/771. So I've made a deb from the Arch Linux Sources (xf86-video-sisimedia) and added it to my ppa. It compiles for i386 but because of bad code quality the AMD64 build is rejected (even if it compiles, it's supposed to segfault because of implicit integer->pointer conversions).

I'm using the driver with Ubuntu 14.04 i386 and it's basically working. There's no 3D acceleration and even 2D is SLOW.

Pander (pander) wrote :

I have a laptop with such a graphics card and use to build the driver for myself on it. If someone would like to actively support the driver I could send you the laptop of you pay for the shipping. Send me a personal message *only* if you are seriously interested.

Changed in linuxmint:
status: Confirmed → Opinion
Renno Reinurm (rreinurm) wrote :

Thanx for your work! I tried to give the second life for FujitsuSiemens Esprimo laptop with Lubuntu 14.04 and had an interesting challenge to get video working. There are still some performance/quality issues then playing videos, but other use cases are working much better than using vesa. Just curious, the provided xorg.conf in early postage is enough, or is there some options which could help to optimize performance even more?

Displaying first 40 and last 40 comments. View all 238 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.