Lenovo Thinkpads with Core i5 and i7 suspend/resume (with kernel oops) once then fail horribly on next suspend

Reported by Jeremy Zimmer on 2010-03-05
388
This bug affects 63 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
OEM Priority Project
Critical
Alex Chiang
linux (Ubuntu)
Critical
Alex Chiang
Lucid
Critical
Alex Chiang

Bug Description

THIS HAPPENS ONLY TO THINKPADS WITH i5 or i7 PROCESSORS: Thinkpad T410, T510 and X201 models are affected (intel integrated graphics, nvidia discrete graphics). The first suspend/resume completes successfully. The second suspend appears to work, but when waking, a few LEDs flicker, but the laptop stays suspended (moon LED on the lid stays lit, LED around power button continues to pulse). Pressing the power button again causes a reboot (no other buttons seem to do anything in this state).

Per https://wiki.ubuntu.com/DebuggingKernelSuspend:

$ grep -A4 Magic .tmp/dmesg.txt
[ 1.148585] Magic number: 0:523:347
[ 1.148587] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:471
[ 1.148615] pci0000:00: hash matches

That's the DRAM Controller.

Same results from the "xterm" session, and also without X, so no gnome-power-manager interactions.

This issue effects:
Thinkpads X201, T410, T510, W510
& possibly T410s

Jeremy Zimmer (jeremyz) wrote :
Jeremy Zimmer (jeremyz) wrote :
Jeremy Zimmer (jeremyz) wrote :
Jeremy Zimmer (jeremyz) wrote :
Jeremy Zimmer (jeremyz) wrote :
Tom Gelinas (tomgelinas) on 2010-03-07
Changed in linux (Ubuntu):
status: New → Confirmed
Tom Gelinas (tomgelinas) wrote :

I confirm this behavior on my t510 4313 with nVidia nvs3100m discrete graphics.
However, my second resume shows the Lenovo BIOS splash indefinitely.

I filed a similar bug last month: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/519375 , post 11 has logs from similar methodology. I will test again with the latest Ubuntu and mainline kernels.

tags: added: kernel-series-unknown
Tom Gelinas (tomgelinas) wrote :

This occurs under Linux oo 2.6.32-16-generic #25-Ubuntu SMP Tue Mar 9 16:33:12 UTC 2010 x86_64 GNU/Linux
AKA current Lucid Alpha 3. Post 5 confirms this.

Tom Gelinas (tomgelinas) wrote :

I see the same hash match, it is not associated with PCI though.
[ 1.181366] registered taskstats version 1
[ 1.182071] Magic number: 0:523:740
[ 1.182151] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:471

Peter Petrakis (peter-petrakis) wrote :

Confirmed T510 Intel i5 with Intel graphics, Intel 6300 wireless, bluetooth, & SSD drive.
2.6.32-16-generic x86_64. Tried updating to latest bios, no change.

Tried adding mem=nopentium with 2.6.32-16 which resulted in a early kernel panic. Seeing if 2.6.33 fairs any better...

Tried 2.6.33-020633-generic, same outcome. Also tried removing the iwlagn module
before sleeping, same outcome.

With regards to the T510

1 comments hidden view all 144 comments
Tom Gelinas (tomgelinas) wrote :

So should we be reporting this upstream? It's safe to assume that Canonical is not going to be doing a lot of kernel hacking in this case, right? The issue persists upstream, and 2.6.27 is nearing completion: http://kerneltrap.org/Linux/2.6.27-rc8_This_One_Should_Be_The_Last_One Where do we need to volunteer to get the ball rolling? The e1000e eeprom bug is still rearing its ugly head, but I'm guessing our warranties will cover that so we don't have a whole lot to be afraid of.

tags: added: lucid
removed: kernel-series-unknown
David Strauss (davidstrauss) wrote :

@Tom I'm not sure why you're mentioning 2.6.27. That's quite an old kernel; see the date of the post you linked.

I've confirmed this issue in 2.6.32.9 and 2.6.33, installed to Ubuntu 9.10 from http://kernel.ubuntu.com/~kernel-ppa/mainline.

David Strauss (davidstrauss) wrote :

Because suspending to disk (hibernating) works fine, users of T410 and T510 models may want to use the power control panel to have the sleep key press, lid closing event, and possibly other events map to hibernation. This will at least avoid data loss from closing the lid (or doing something else) that puts the laptop into normal suspend mode a second time.

David Strauss (davidstrauss) wrote :

I take that back. Hibernating isn't working, either.

Tom Gelinas (tomgelinas) wrote :

@ David: I blame that stupidness on fatigue.

Hibernate actually works when using Nouveau, but not with proprietary nVidia drivers.

David Strauss (davidstrauss) wrote :

@Tom I'm using Intel drivers. I specifically avoided discrete video hardware for this machine.

jlgoolsbee (jlgoolsbee) wrote :

This bug has been reported at kernel.org as well: http://bugzilla.kernel.org/show_bug.cgi?id=15407

(Just trying to make sure any relevant conversation that takes place over there is linked here.)

description: updated
Bryn Hughes (linux-nashira) wrote :

Just to add this also affects the W510, and probably also affects the T410s.

I was the one who reported it upstream - unfortunately I haven't been able to get a Ubuntu kernel package to build yet as the documentation hasn't been updated for Lucid. Anyone who knows how to do the latest voodoo who can compile a kernel with ACPI_PROCESSOR as a module? That's what's stalling the upstream bug report right now.

Bryn Hughes (linux-nashira) wrote :

This also affects the Lenovo W510 (multiple models) and probably affects the T410s as well.

The upstream bug report is stalled because I can't sort out how to compile a kernel the "ubuntu way" under Lucid - the latest public documentation I can find is still targeting Karmic, and a lot of the scripts, etc have changed. They're looking for a kernel to be compiled with the ACPI_PROCESSOR code compiled as a module so it can be unloaded, or disabled altogether.

Corey Quinn (kb1jwq) wrote :

d3mia7, you may want to take a look at https://wiki.ubuntu.com/KernelTeam/KernelMaintenance -- it seems to answer the questions you have. If you get stuck, ping me on freenode (same nick) and I'll work on it with you.

Bryn Hughes (linux-nashira) wrote :

Thanks, got a missing piece of the puzzle out of there that (in combination) with some other docs got it going. Updated the upstream bug - machines will still fail to resume on the second time even with ACPI_PROCESSOR blacklisted.

Jeremy Zimmer (jeremyz) wrote :

> However, my second resume shows the Lenovo BIOS splash indefinitely.

Sorry, I left that out of my original report, but I can confirm what Tom is seeing with the hang at the BIOS splash.

Also possibly worth noting, I updated the bios to 1.12, which is still the latest available on Lenovo's website, before reporting this bug. Today the link I bookmarked broke (see "temporarily unavailable" at http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74582), which suggests they might be releasing a new revision soon.

Another discovery from this morning, the following sequence works fine: suspend, resume, hibernate, wake, suspend, resume.

So the hibernate/wake cycle is equivalent to a reboot in the context of this bug. Two consecutive suspend/resume cycles still break in the same way after hibernating.

Jerone Young (jerone) wrote :

This issue effects all Intel Core i5 Thinkpads. This happens on the T410 & X210 I have here. There is a kernel oops after the first suspend, this is ultimately leading to the reboot.

The issue is worst as after the oops the usb ports are also unusable after the first suspend. So the kernel oops put the machine in a bad state.

dmesg from X201 is attached. It looks as though pm suspend looks to be triggering the issue.

Jerone Young (jerone) on 2010-03-26
Changed in oem-priority:
importance: Undecided → Critical
summary: - [Lenovo 2537AD3, 2537AB8] one successful suspend/resume per boot
+ Lenovo Thinkpads suspend/resume (with kernel oops) once then fail
+ horribly on next suspend
summary: - Lenovo Thinkpads suspend/resume (with kernel oops) once then fail
- horribly on next suspend
+ Lenovo Thinkpads with Core i5 suspend/resume (with kernel oops) once
+ then fail horribly on next suspend
Changed in linux (Ubuntu Lucid):
importance: Undecided → Critical
summary: - Lenovo Thinkpads with Core i5 suspend/resume (with kernel oops) once
- then fail horribly on next suspend
+ Lenovo Thinkpads with Core i5 and i7 suspend/resume (with kernel oops)
+ once then fail horribly on next suspend
Colin King (colin-king) wrote :

Just to clarify what the "notsc" kernel parameter addresses:

The CPU#0 stuck messages in comment #26 are because of a math error in the softlockup code which gets confused when the TSC warps backwards when coming out of S3:

[1266874885.662888] BUG: soft lockup - CPU#0 stuck for 0s! [pm-suspend:1512]
[1266874885.662889] Modules linked in: binfmt_misc ppdev joydev snd_hda_codec_intelhdmi fbcon tileblit font bitblit softcursor vga16fb vgastate arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device iwlagn iwlcore thinkpad_acpi i915 drm_kms_helper led_class snd mac80211 nvram drm i2c_algo_bit psmouse serio_raw video output cfg80211 intel_agp soundcore snd_page_alloc agpgart lp parport e1000e
[1266874885.662915]
[1266874885.662917] Pid: 1512, comm: pm-suspend Not tainted (2.6.32-16-generic #25-Ubuntu) 3626F8U
[1266874885.662919] EIP: 0060:[<c059ddf5>] EFLAGS: 00000292 CPU: 0
[1266874885.662925] EIP is at _spin_unlock_irqrestore+0x15/0x20
[1266874885.662926] EAX: 00000292 EBX: 00000292 ECX: 00000100 EDX: 00000292
[1266874885.662928] ESI: f7002cbd EDI: 00000000 EBP: f47f1d10 ESP: f47f1d0c
[1266874885.662929] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[1266874885.662930] CR0: 8005003b CR2: 08346b18 CR3: 33097000 CR4: 000006d0
[1266874885.662932] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[1266874885.662933] DR6: ffff0ff0 DR7: 00000400
[1266874885.662934] Call Trace:

Using the kernel parameter "notsc" will disable the TSC and stop these false-positives. I have a patch (http://linux.derkeiler.com/Mailing-Lists/Kernel/2010-03/msg08854.html) that should get into the mainline kernel very soon now that addresses the math overflow error that trips these false-positive errors.

Colin King (colin-king) wrote :

Just another point to consider, looking at the S3 magic number debug:

[ 1.181366] registered taskstats version 1
[ 1.182071] Magic number: 0:523:740
[ 1.182151] hash matches /build/buildd/linux-2.6.32/drivers/base/power/main.c:471

This corresponds to the device_resume() function terminating correctly with a error value of 0 (which means it worked successfully) - so it appears that all the drivers have been resumed correctly in this function.

Colin King (colin-king) wrote :

Jerone, there are a whole bunch of BUG messages in your kernel log because of the TSC issue. Also, there is one final warning because IRQ 9 is not being handled, which is very odd:

[ 5.496247] irq 9: nobody cared (try booting with the "irqpoll" option)
[ 5.496257] Pid: 0, comm: swapper Not tainted 2.6.32-16-generic #25-Ubuntu

I suggest:

1) Using kernel boot parameters notsc and also irqpoll
2) Try again.

Also please attach the output from /proc/interrupts - I suspect IRQ 9 is handled by acpi which may explain some of the resume weirdness if IRQ 9 is being missed.

Thanks.

Tom Gelinas (tomgelinas) wrote :

Hi, here's the info you requested. This is from my T510 with nVidia GPU.
Sorry if there was a way to add multiple attachments to a post.

5 comments hidden view all 144 comments
Tom Gelinas (tomgelinas) wrote :

Ah and an explanation: I booted using notsc, irqpoll and text. The system failed to sleep a second time, the screen never turned off and the system never entered sleep (ie. no blinking power light) This is possibly an nVidia specific behaviour, though.

David Pollak (dpp+launchpad) wrote :

This bug hits me as well. I'm running an X201s which has the video on the processor... so it's not nVidia specific.

David Pollak (dpp+launchpad) wrote :

Oh... and this seems to be related to #531309 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/531309

Our Core i7s have Intel video and this problem, too.

------Original Message------
From: David Pollak
Sender: <email address hidden>
To: David Strauss
ReplyTo: Bug 532374
Subject: [Bug 532374] Re: Lenovo Thinkpads with Core i5 and i7 suspend/resume(with kernel oops) once then fail horribly on next suspend
Sent: Mar 27, 2010 14:24

This bug hits me as well. I'm running an X201s which has the video on
the processor... so it's not nVidia specific.

--
Lenovo Thinkpads with Core i5 and i7 suspend/resume (with kernel oops) once then fail horribly on next suspend
https://bugs.launchpad.net/bugs/532374
You received this bug notification because you are a direct subscriber
of the bug.

Jerone Young (jerone) on 2010-04-01
Changed in oem-priority:
status: New → In Progress
Jerone Young (jerone) on 2010-04-01
description: updated
Jerone Young (jerone) on 2010-04-18
Changed in linux (Ubuntu Lucid):
status: Confirmed → Invalid
64 comments hidden view all 144 comments
Jerone Young (jerone) wrote :

Hi all,
     Lenovo has released bios updat to fix this bug for the T410
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74582

    More coming.

Anmar Oueja (anmar) wrote :

Jerone: Thanks for your continued effort. One details though. I have an X201. Do you know if Lenovo is working on updating the BIOS for the X201 and other Intel i5 machines?

I can confirm that updating to BIOS version 1.18-1.07 released by Lenovo on 2010/04/22 solves this problem (but NOT the USB issue) for this system: Lenovo T410, nvidia, arch amd64, kernel 2.6.31-21-generic. Thanks!

Sse (sse123) wrote :

Hi Alex,

thanks for your help!

Could you please also post the applied patch here?
Unfortunately, there's no clue about when Lenovo is going to update the BIOS for my machine (W510)...

Thank you again

Sse (sse123) wrote :

never mind, found your patch at https://bugzilla.kernel.org/show_bug.cgi?id=15407
works perfectly, aside from a kernel message repeated a few times at boot time: ACPI: Invalid _PSD data
and sorry for raising the noise level...

Hi Alex,

regarding the kernel you mentioned in #102:

I'd like to give it a go, but the package

linux-headers-2.6.32-22

is missing and

linux-headers-2.6.32-22-generic

depends on it.

Thanks for your work. Will the USB problem be solved with the next BIOS or will we need a different kernel with/or ehci as modules?

SIncerely

loke (developer-loke) wrote :

It worked like charm, but now it's away after the recent update. I am writing after updating right now. Please, we need to have it back.

loke (developer-loke) wrote :

Sorry, I forgot to mention the symptoms. They are same as I posted in my first post:
1. The system suspends OK when never logged in, and will show the symptoms even after logging out.
2. The system seems to suspend, but the moon light keeps blinking, and the processor fan continues to run
3. The system has to be hard reset

I will be glad to provide any log files.

loke (developer-loke) wrote :

Here it is after updating to firware 2.21 on Thinkpad x61. No difference.

Hi Alex,

I can confirm that your test kernel fixes this bug on my x201s (BIOS version 1.05)

loke (developer-loke) wrote :

Since this bug does not affect x61, I have added a new bug at https://bugs.launchpad.net/oem-priority/+bug/569882 . Please follow it there.

Thanks

Lanoxx (lanoxx) wrote :

I think I am experiencing this bug (or a similar one) on my X61 notebook. After a reboot i can suspend one or two times and also wake up successfully. However the next time when I try to suspend the gnome password dialog (like after the screen saver) appears, the screen freezes and the little half moon keeps flashing (blinking).

Sometimes the screen just goes dark without the gnome password dialog appearing but the system freezes anyway, this bug has started appearing a few days ago.

Cheers Lanoxx

Tom Gelinas (tomgelinas) wrote :

Lanoxx, please look 1 post above yours, which refers to the bug report for x61s. https://bugs.launchpad.net/oem-priority/+bug/569882 . Nobody without an i5/i7 Thinkpad is affected by this particular bug.

description: updated
tags: added: t410 t410s t510
tags: removed: glucid
Tom Gelinas (tomgelinas) on 2010-04-26
description: updated
tags: added: x201
description: updated
Jerone Young (jerone) on 2010-04-26
tags: added: w510
Jerone Young (jerone) on 2010-04-26
Changed in oem-priority:
status: In Progress → Fix Released

I can confirm that this problem as well as https://bugs.launchpad.net/ubuntu/+source/linux/+bug/566149 on a T410s is fixed by using Alex Chiang's Patch!

wahlau (wahlau) wrote :

i can confirm that this problem is fixed using the kernel offered by Alex. However i can only install the kernel-image, and not the kernel headers. Using Lucid 64 bit on T410s. USB is still working after suspend and wake up twice.

ltmon (lukemonahan) wrote :

Lenovo have released BIOS: 1.17 / ECP: 1.10 (for W510 anyway, other version numbers for other models) with this entry in the release notes:

"(Fix) Fixed an issue where system might not be resumed on non-Windows ACPI OS."

Martin Spacek (mspacek) wrote :

I can confirm that the new 1.17 BIOS fixes this issue for the W510.

Jerone Young (jerone) wrote :

Hi all,
         Lenovo has now released bios updates to address this isssue for:
                 T410, T510, X201, & W510

         Lenovo has not released an update for the T410s just yet that would address this issue.

Jeremy Zimmer (jeremyz) wrote :

Verified that this is fixed on the T410 (intel graphics) and X201.

After applying the BIOS update to my W510, it now refuses to suspend entirely. The complaint seems to be about the usb3 device (snip from kern.log):

May 3 12:10:34 ubuntu-w510 kernel: [ 1772.781779] PM: Syncing filesystems ... done.
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.061346] PM: Preparing system for mem sleep
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.061351] Freezing user space processes ... (elapsed 0.00 seconds) done.
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.061923] Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.061971] PM: Entering mem sleep
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.061984] Suspending console(s) (use no_console_suspend to debug)
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.327870] PM: suspend of drv:psmouse dev:serio2 complete after 249.881 msecs
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.447893] PM: suspend of drv:ieee80211 dev:phy0 complete after 120.083 msecs
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.447954] pm_op(): usb_dev_suspend+0x0/0x20 returns -2
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.447957] PM: Device usb3 failed to suspend: error -2
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.447960] PM: Some devices failed to suspend
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.507597] PM: resume of devices complete after 59.668 msecs
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.609372] PM: resume devices took 0.160 seconds
May 3 12:10:34 ubuntu-w510 kernel: [ 1773.609378] PM: Finishing wakeup.

This is on a fresh install of Lucid, amd64, using the alternate installer. dmidecode output attached.

Also notable (but not necessarily related) from dmesg:

[ 14.609984] usb usb3: config 1 interface 0 altsetting 0 endpoint 0x81 has no SuperSpeed companion descriptor

Martin,

Does your W510 have USB 3.0? I didn't see that as an optional feature on lenovo's site.

I'll open a new bug if no one else knows of one that matches the symptoms I'm seeing.

Martin Spacek (mspacek) wrote :

@Jeremy,

I've unloaded the USB 3.0 module on my W510. See bug #522998.

madbiologist (me-again) wrote :

For users who either won't or can't upgrade their BIOS, a workaround for this problem has been included upstream in kernel 2.6.34-rc7, and also cc'd to the stable kernel branch (meaning 2.6.33 and possibly 2.6.32). from the changelog:

commit 07bedca29b0973f36a6b6db36936deed367164ed
Author: Alex Chiang
Date: Tue Apr 20 08:03:14 2010 -0600

    ACPI: DMI init_set_sci_en_on_resume for multiple Lenovo ThinkPads

    Multiple Lenovo ThinkPad models with Intel Core i5/i7 CPUs can
    successfully suspend/resume once, and then hang on the second s/r
    cycle.

    We got confirmation that this was due to a BIOS defect. The BIOS
    did not properly set SCI_EN coming out of S3. The BIOS guys
    hinted that The Other Leading OS ignores the fact that hardware
    owns the bit and sets it manually.

    In any case, an existing DMI table exists for machines where this
    defect is a known problem. Lenovo promise to fix their BIOS, but
    for folks who either won't or can't upgrade their BIOS, allow
    Linux to workaround the issue.

    https://bugzilla.kernel.org/show_bug.cgi?id=15407
    https://bugs.launchpad.net/ubuntu/+source/linux/+bug/532374

    Confirmed by numerous testers in the launchpad bug that using
    acpi_sleep=sci_force_enable fixes the issue. We add the machines
    to acpisleep_dmi_table[] to automatically enable this workaround.

    Cc: <email address hidden>
    Cc: Colin King
    Signed-off-by: Alex Chiang
    Signed-off-by: Len Brown

Alex Chiang (achiang) wrote :

All the patches needed to solve this issue have hit upstream's -stable tree for both the .32 and .33 release streams.

What this means is that at some point in the unspecified future, the Lucid kernel will be rebased onto the latest .32-stable release, and the fix will appear in Ubuntu.

I do not know when the kernel team will do the rebase, so at this point, there's not much more for me to do from my perspective. We just have to wait for the kernel team to rebase and then release.

Thanks.

Alex Chiang (achiang) on 2010-05-10
Changed in oem-priority:
assignee: nobody → Alex Chiang (achiang)
Changed in linux (Ubuntu):
assignee: nobody → Alex Chiang (achiang)
Changed in linux (Ubuntu Lucid):
assignee: nobody → Alex Chiang (achiang)
vojtec (vojtec) wrote :

Hello,
I have X200s and I have no success with the kernel 2.6.34-rc7, the problem with the second suspend still remains. Also the new bios haven't been released yet... Have anybody x200s too with the same problem?

AmenophisIII (amenophisiii) wrote :

bios release for t410s: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74943

(btw updating the bios without windows and cd/dvd:
wget new geteltorito (>=0.5) from http://www.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/geteltorito
use that on the bootable .iso from lenovo to get the boot .img
than you can boot that .img from local ssd/hdd with grub like http://www.thinkwiki.org/wiki/BIOS_Upgrade#GRUB2)

Alex Chiang (achiang) wrote :

@vojtec, that is correct, I do not expect the kernel to succeed with your machine, since it's not listed in the DMI table.

With the upstream kernel, you can pass the command line parameter. This will not work with the current Lucid kernel, but the next Lucid release will support the command line param.

I will propose adding your machine to the Lucid kernel as a SAUCE patch as well.

e b (erblair) wrote :

Updating the bios does not fix the problem on this T410. "IRQ 9: nobody cared" messages are gone, but new messages are present on boot. USB does not work after resume from suspend and at least one USB device is not handled properly on boot. Pre-suspend dmesg is attached, will attach a post-resume dmesg in a bit.

[ 152.208901] unregister_netdevice: device wlan0/ffff880068e00000 never was registered
[ 152.208904] ------------[ cut here ]------------
[ 152.208915] WARNING: at /build/buildd/linux-2.6.32/net/core/dev.c:4650 rollback_registered+0xff/0x130()
[ 152.208919] Hardware name: 2516CTO

[ 152.209112] Pid: 44, comm: khubd Tainted: P W 2.6.32-22-generic #33-Ubuntu
[ 152.209114] Call Trace:
[ 152.209118] [<ffffffff8145dd5d>] netdev_run_todo+0x13d/0x180
[ 152.209124] [<ffffffff81469afe>] rtnl_unlock+0xe/0x10
[ 152.209128] [<ffffffff8145e763>] unregister_netdev+0x23/0x30
[ 152.209134] [<ffffffffa0d2b1d5>] rtl8187_usb_disconnect+0x2b/0x8d [r8187]
[ 152.209139] [<ffffffff813d92d4>] usb_unbind_interface+0x124/0x170
[ 152.209144] [<ffffffff81368c8f>] __device_release_driver+0x6f/0xe0
[ 152.209148] [<ffffffff81368dfd>] device_release_driver+0x2d/0x40
[ 152.209152] [<ffffffff81367e1a>] bus_remove_device+0x9a/0xc0
[ 152.209156] [<ffffffff81365f77>] device_del+0x127/0x1d0
[ 152.209160] [<ffffffff813d5a98>] usb_disable_device+0xa8/0x130
[ 152.209165] [<ffffffff813cf832>] usb_disconnect+0xd2/0x170
[ 152.209169] [<ffffffff813cfeaf>] hub_port_connect_change+0x8f/0x980
[ 152.209174] [<ffffffff813d11a2>] hub_events+0x3b2/0x5a0
[ 152.209178] [<ffffffff8153e768>] ? thread_return+0x48/0x420
[ 152.209182] [<ffffffff813d13e5>] hub_thread+0x55/0x190
[ 152.209187] [<ffffffff81085320>] ? autoremove_wake_function+0x0/0x40
[ 152.209191] [<ffffffff813d1390>] ? hub_thread+0x0/0x190
[ 152.209195] [<ffffffff81084fa6>] kthread+0x96/0xa0
[ 152.209199] [<ffffffff810141ea>] child_rip+0xa/0x20
[ 152.209203] [<ffffffff81084f10>] ? kthread+0x0/0xa0
[ 152.209206] [<ffffffff810141e0>] ? child_rip+0x0/0x20
[ 152.811996] rtl8187: WW:Card reset timeout!
[ 153.021861] rtl8187: wlan driver removed
[ 153.021864]

e b (erblair) wrote :

Attached is the post-resume dmesg output. More logs and info can be found at the duplicate bug report I accidentally filed: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580783

e b (erblair) wrote :

Please disregard posts #130 and #131. Sorry.

vojtec (vojtec) wrote :

@Alex: thanks for adding my machine to the patch... I have tried to use current upstream kernel (both 2.6.34-020634rc7 and current daily build) with added grub parameter acpi_sleep=sci_force_enable, but both of them with no success, the problem with second wakeup still remains.... I will wait for next Lucid kernel release and report the state, thanks ...

Alex Chiang (achiang) wrote :

@vojtec,

Hm, that is disturbing that adding that kernel command line param didn't work, as it definitely should have.

Can you please attach the output of your dmesg?

Thanks.

vojtec (vojtec) wrote :

@alex,

here is my dmesg after 1st suspend, thanks!

TJ Merritt (tjmerritt) on 2010-05-25
Changed in oem-priority:
status: Fix Released → Fix Committed
Jerone Young (jerone) wrote :

@vojtec
         Update your bios and your issue will be resolved.

Changed in oem-priority:
status: Fix Committed → Fix Released
vojtec (vojtec) wrote :

@Jerome
                      I have the most recent BIOS from IBM for my X200s - it is from 27 March ( http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70476 ) but the problem still remains.

Changed in oem-priority:
status: Fix Released → Fix Committed
wahlau (wahlau) wrote :

had anyone recently problem with suspend? my thinkpad t410s was working well with the custom kernel and bios update, but since a week plus the system will just blink indefinitely when i try to suspend. running latest kernel and bios.

On Wed, Jun 9, 2010 at 1:19 AM, wahlau <email address hidden> wrote:
> had anyone recently problem with suspend? my thinkpad t410s was working
> well with the custom kernel and bios update, but since a week plus the
> system will just blink indefinitely when i try to suspend. running
> latest kernel and bios.

Welcome to https://bugs.launchpad.net/bugs/550479.

Jerone Young (jerone) on 2010-06-14
Changed in oem-priority:
status: Fix Committed → Fix Released

Hello, I have exactly same problem as Paladin: only one suspend/resume works and USB doesn't work (I'm sure no energy is there - "always powered" port too ^_^)
I use actualized Lucid
$ uname -r
2.6.32-22-generic
Also I have problem with hibernation - it seems hibernated but after boot It boots "normally" - no wakeup
I use proprietary nVidia driver - you can look in attachment...

Matt Price (matt-price) wrote :

i have a t410 and of course suffer from this bug like everyone else. i appear to have BIOS version 1.09:
$ sudo dmidecode -s bios-version
6IET49WW (1.09 )

i would like to update to the newest bios but i'm a little terrified to do so -- can anyone out there give or point me to a reliable and complete set of instructions as to what I ought to do to make this work? Thank you so much,

also: will i have to update to 2.6.34, as suggested in some postings, or will that workaround no longer be necessary after the bios update? Thanks,
matt

Regarding the update, I just burnt the bootable CD available from the lenovo
site... Boot it, the rest is all pretty straight forward. Reading the readme
file could also be useful. -- Have no fear ;)

Cheers, Reinhard.

2010/6/20 Matt Price <email address hidden>

> i have a t410 and of course suffer from this bug like everyone else. i
> appear to have BIOS version 1.09:
> $ sudo dmidecode -s bios-version
> 6IET49WW (1.09 )
>
> i would like to update to the newest bios but i'm a little terrified to
> do so -- can anyone out there give or point me to a reliable and
> complete set of instructions as to what I ought to do to make this work?
> Thank you so much,
>
> also: will i have to update to 2.6.34, as suggested in some postings, or
> will that workaround no longer be necessary after the bios update? Thanks,
> matt
>
> --
> Lenovo Thinkpads with Core i5 and i7 suspend/resume (with kernel oops) once
> then fail horribly on next suspend
> https://bugs.launchpad.net/bugs/532374
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Unknown
> Status in OEM Priority Project: Fix Released
> Status in “linux” package in Ubuntu: Invalid
> Status in “linux” source package in Lucid: Invalid
>
> Bug description:
> THIS HAPPENS ONLY TO THINKPADS WITH i5 or i7 PROCESSORS: Thinkpad T410,
> T510 and X201 models are affected (intel integrated graphics, nvidia
> discrete graphics). The first suspend/resume completes successfully. The
> second suspend appears to work, but when waking, a few LEDs flicker, but the
> laptop stays suspended (moon LED on the lid stays lit, LED around power
> button continues to pulse). Pressing the power button again causes a reboot
> (no other buttons seem to do anything in this state).
>
> Per https://wiki.ubuntu.com/DebuggingKernelSuspend:
>
> $ grep -A4 Magic .tmp/dmesg.txt
> [ 1.148585] Magic number: 0:523:347
> [ 1.148587] hash matches
> /build/buildd/linux-2.6.32/drivers/base/power/main.c:471
> [ 1.148615] pci0000:00: hash matches
>
> That's the DRAM Controller.
>
> Same results from the "xterm" session, and also without X, so no
> gnome-power-manager interactions.
>
> This issue effects:
> Thinkpads X201, T410, T510, W510
> & possibly T410s
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/linux/+bug/532374/+subscribe
>

AmenophisIII (amenophisiii) wrote :

no need to burn a cd...

# get the .iso
# get geteltorito (1) and make it executable (chmod +x),
# get memdisk (2),
mkdir /boot/bios
cp /usr/lib/syslinux/memdisk /boot/bios/
# execute "./geteltorito -o /boot/bios/eltorito.img <bla>.iso" or similar
echo "menuentry "BIOS Update" {
 linux16 /bios/memdisk
 initrd16 /bios/eltorito.img
}" >> /etc/grub.d/40_custom
update-grub
reboot
#select "BIOS Update" from the grub menu
#enjoy :)

1: http://www.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/geteltorito
2: ubuntu package syslinux
tested with one of the previous t410s bioses and hopefully correctly recalled by me... w/o any warranty etc.

wimped out and burned the CD after all. my suspend problem appears to be
definitively fixed. still using tuxonice suspend-to-both out of fear
it'll crash, but no problems so far. yay and THANKS to everyone, this
is a big help.

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 144 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.