Hibernate can oops in resume on Arrandale CPUs

Bug #531309 reported by Colin Ian King on 2010-03-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Colin Ian King
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.31

When resuming from hibernate on Arrandale CPUs, the restoring of the kernel image causes an oops. This always seems to occur on the final 4K of a 4M boundary, such as at address 0xc03ff000. The oops can be worked around by using kernel parameter "mem=nopentium" to stop using mixed 4M/4K pages or disabling the kernel from being restored into 4M pages (just force the use of 4K pages). The oops occurs in the following code:

00000043 <copy_loop>:
  43: 85 d2 test %edx,%edx
  45: 74 11 je 58 <done>
  47: 8b 32 mov (%edx),%esi
  49: 8b 7a 04 mov 0x4(%edx),%edi
  4c: b9 00 04 00 00 mov $0x400,%ecx
  51: f3 a5 rep movsl %ds:(%esi),%es:(%edi) <---- oopsing here
  53: 8b 52 08 mov 0x8(%edx),%edx
  56: eb eb jmp 43 <copy_loop>

This can also be fixed by an appropriate TLB flush.

Changed in linux (Ubuntu):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Colin King (colin-king)
tags: added: karmic
Colin Ian King (colin-king) wrote :

Discussed with Intel. We now have a patch (https://patchwork.kernel.org/patch/83694/) that will hit post rc1 and will backport this once it hits upstream.

David Pollak (dpp+launchpad) wrote :

This seems to be related to/duplicate of #532374 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/532374

Andy Whitcroft (apw) on 2010-03-31
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux-ec2 into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux-mvl-dove into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Stefan Bader (smb) wrote :

Fix was already released in Lucid as part of 2.6.32-23.37.

Changed in linux (Ubuntu Lucid):
status: New → Fix Released
Colin Ian King (colin-king) wrote :

Verified (since I was the author of the fix).

tags: added: verification-done
removed: verification-needed
Colin Ian King (colin-king) wrote :

I should say, I worked on the initial fix, the final patch was thanks to Shaohua Li <email address hidden>

Martin Pitt (pitti) wrote :

Colin, did you actually test the proposed kernel debs from the archive on this hardware? Just being the author of the original fix is not the same as testing the actually built result. Thanks!

Martin Pitt (pitti) wrote :

Setting back to v-needed until previous question gets answered.

tags: added: verification-needed
removed: verification-done
Martin Pitt (pitti) wrote :

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-22.68

---------------
linux (2.6.31-22.68) karmic-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: docs -- fix doc strings for fc_event_seq

  [ Brad Figg ]

  * SAUCE: (no-up) Modularize vesafb -- fix initialization
    - LP: #611471

  [ Chase Douglas ]

  * SAUCE: sched: update load count only once per cpu in 10 tick update
    window
    - LP: #513848

  [ Ike Panhc ]

  * SAUCE: agp/intel: Add second set of PCI-IDs for B43
    - LP: #640214
  * SAUCE: drm/i915: Add second set of PCI-IDs for B43
    - LP: #640214

  [ Steve Conklin ]

  * SAUCE: Fix compile error on ia64, powerpc, and sparc

  [ Upstream Kernel Changes ]

  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * PCI: Ensure we re-enable devices on resume
    - LP: #566149
 -- Steve Conklin <email address hidden> Fri, 22 Oct 2010 09:05:13 -0500

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers