acpi wakeup doesn't work with HP tx2510us unless hpet is disabled

Reported by Pietro Battiston on 2008-12-11
70
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have an HP tx2510.

Following instructions on
http://www.mythtv.org/wiki/index.php/ACPI_Wakeup#Using_.2Fsys.2Fclass.2Frtc.2Frtc0.2Fwakealarm
(which do work on another laptop), it doesn't wake up from sleep.

After giving the commands:

   echo 0 > /sys/class/rtc/rtc0/wakealarm
   echo `date '+%s' -d '+ 200 minutes'` > /sys/class/rtc/rtc0/wakealarm

I can see with

   cat /proc/driver/rtc

that the wakeup seems to be set correctly. But I tried to wait a lot of time (6 hours: notice my local time differs only 1 hour from UTC) and it never wakes up.
Notice that:
- in the BIOS there is no option to enable/disable it, but it does work from Windows Vista. In particular, I tried all the programs from http://acpi-wakeup.qarchive.org/ , and WakeupOnStandby works (while WakeUp and AtriseWakeup don't).
- after (the acpi wakeup didn't work and) I manually wake up the computer, in the output of "cat /proc/driver/rtc" I can see that

    alrm_date : 2008-12-11

has become

    alrm_date : ****-**-**

(while the time line stays unchanged). This is also what happens when I set an alarm in the past, so it seems to me OK.

uname -a says
    Linux vousci 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:06 UTC 2008 x86_64 GNU/Linux

I'm attaching the output of "sudo demidecode".

Pietro Battiston (toobaz) wrote :
Pietro Battiston (toobaz) wrote :

Found what seems to be the corresponding upstream bug, in the sense that the suggested workaround, adding "hpet=disable" at boot prompt, works.

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Undecided → Medium
status: New → Triaged
Andre Schild (andre-schild) wrote :

I see the same problem on my toshiba tecra a9, but hpet=disable does not help.
Should a new bug be opened ?

https://wiki.ubuntu.com/LaptopTestingTeam/ToshibaTecraA9

petski (petski) wrote :

Andre, same here with a HP Compaq 6710b. I already reported #349768

Mariner09 (smcmackin) wrote :

I have the same experience from my Lenovo T61 running 2.6.28-11-generic kernel. This was seen from the kernel suspend/resume test script.

kulight (kulight) wrote :

same problem here my laptop does not wakeup after 20 sec
it only wake up when pressing power button

my laptop is hp compaq 6715s

linusr (linusr) wrote :

same problem here on Dell Vostro 1500 (with nvidia proprietary driver ) does not wakeup after 20 sec

forgot this info

i have a ati card uisng open drivers

************************************************************************************
This footnote confirms that this email message has been scanned by
PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
************************************************************************************

Beni (benjamin-lutz) wrote :

Samsung Q45 (nvidia) does not wake up after 20sec in kernel suspend/resume test script, too.

same problem here my HP Compaq nx6310 laptop does not wakeup after 20 sec

foxynet (foxynet) wrote :

same problem here my hp Compay 2150p does not wakeup after 20s in the kernel suspend/resume test script, even with hpet=disable

Don Cristóbal (doncristobal) wrote :

Same problem on my IBM T42 with Jaunty Beta.

Johan Ehnberg (johan-ehnberg) wrote :

Same on AMD790GX desktop jaunty beta.

H.i.M (hir-i-mogul-gmail) wrote :

Kubuntu Jaunty 64 beta
Does not wakeup after 20s on Sony Vaio VGN-NR320AH.
After manual wakeup Xserver restarts.
Did all the tests in console after Xrestart. (with manual wakeup)

Craig Ringer (ringerc) wrote :

Dell XPS M1330 (BIOS revision A06; graphics nVidia 8400M using nvidia-glx-177) also fails to resume after 20s. Manual resume is fine.

Jan Weiher (jweiher) wrote :

I tried to run the Suspend/Resume Testing script and experienced the same problem. I tried hpet=disable but that did not help at all. Manual resume is fine.
System: Lenovo Ideapad S10e
I'm adding the output of dmidecode to my comment.

Pietro Battiston (toobaz) wrote :

If hpet=disable does not help, YOU ARE NOT AFFECTED FROM THIS BUG.

If you didn't even test hpet=disable, you may be but may not. Test and then, in case you are, report.

If you are not affected, PLEASE stop posting here reports that have nothing to do.

The page for generic suspend feedback is
https://wiki.ubuntu.com/KernelTeam/SuspendResumeTesting/Feedback

Craig Ringer (ringerc) wrote :

Tested with hpet=disable. No change, so the XPS M1330 (NVidia 8400M) is *NOT* affected by this specific bug.

Johan Ehnberg (johan-ehnberg) wrote :

Tested my Asus M4A78T-E (AMD790GX), hpet=disable did not help. NOT affected.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Vendacious (vendacious) on 2010-09-07
Changed in linux (Ubuntu):
status: Incomplete → New
Pietro Battiston (toobaz) wrote :

I also tested a 2.6.36 kernel today, and the issue is there too.

Changed in linux:
importance: Unknown → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux:
status: Confirmed → Won't Fix
Changed in linux:
status: Won't Fix → Confirmed
Brad Figg (brad-figg) on 2011-07-19
Changed in linux (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.