requires a refresh after boot (on unity8 desktop)

Bug #1595944 reported by kevin gunn
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Libertine Scope
Status tracked in Trunk
Release
Fix Committed
Medium
Larry Price
Trunk
Fix Committed
Medium
Larry Price
libertine-scope (Ubuntu)
Fix Released
Medium
Larry Price

Bug Description

If I log into unity8 desktop session, the libertine scope consistently appears empty, even though I have libertine apps installed.
If I refresh the dash everything appears as expected.

Related branches

Revision history for this message
kevin gunn (kgunn72) wrote :

setting to medium, but we should check devices (M10, Pro5) - i suspect it may happen there as well, if so, need to change this bug to high

Changed in libertine-scope (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Christopher Townsend (townsend) wrote :

Hmm, I have not seen this behavior (and I'm using a fully up to date xenial+overlay) nor have we gotten any other feedback for something like this happening.

Could you attach ~/.cache/upstart/scope-registry.log shortly after this occurs?

Changed in libertine-scope (Ubuntu):
status: New → Incomplete
kevin gunn (kgunn72)
tags: added: unity8-desktop
Revision history for this message
Christopher Townsend (townsend) wrote :

Larry has also confirmed this behavior, so marking Confirmed. Seems to be an issue exacerbated by the new no Unity Greeter login on the desktop now and a race between the Libertine Scope loading and the Dash being ready.

Changed in libertine-scope (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Larry Price (larryprice) wrote :

Happening way less consistently now on latest yakkety, though it does still happen.

Larry Price (larryprice)
Changed in libertine-scope (Ubuntu):
assignee: nobody → Larry Price (larryprice)
status: Confirmed → In Progress
Revision history for this message
Libertine CI Bot (libertine-ci-bot) wrote :

Fix committed into lp:libertine-scope at revision 60, scheduled for release in libertine-scope, milestone Unknown

Changed in libertine-scope:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libertine-scope - 1.3.2+16.10.20160801-0ubuntu1

---------------
libertine-scope (1.3.2+16.10.20160801-0ubuntu1) yakkety; urgency=medium

  [ Larry Price ]
  * Use full scope name in canned queries to properly return from Show/Hide
    actions.
  * Initialize libertine object in Query::run() to allow constructor to execute
    in time. (LP: #1595944)
  * Showing/hiding applications should retain filter state. (LP: #1592407)

 -- Christopher Townsend <email address hidden> Mon, 01 Aug 2016 13:27:26 +0000

Changed in libertine-scope (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers