Launchpad is not available over IPv6

Bug #776040 reported by Erik B. Andersen on 2011-05-03
160
This bug affects 42 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Junien Fridrick

Bug Description

Launchpad is not reachable over IPv6 only connections. This has the side effect of making Ubuntu systems on IPv6 only connections unable to report bugs with apport.

To reproduce the Ubuntu specific problem, run 'ubuntu-bug update-manager' on a machine with an IPv6 only connection. (You can do this if you have IPv6 by opening network manager, selecting your Internet connection, going to the *IPv4* tab, and selecting disable on the menu, Applying changes, and reconnecting.)
Apport will fail with the error

"Cannot connect to crash database, please check your Internet connection.

<urlopen error [Errno 101] Network is unreachable>"
.

Robert Collins (lifeless) wrote :

This is a fair question but not a code bug with launchpad - launchpad runs behind stock apache servers in the Canonical datacentre; I'm not sure if/when we're going to IP6 enable the datacentre, but when we do LP shouldn't need any changes. As such I'm going to close this.

You should be able to use 6to4 to file bugs; I suggest filing a bug on Ubuntu itself if that isn't working.

Changed in launchpad:
status: New → Invalid
Robert Collins (lifeless) wrote :

I've had it pointed out to me that 6to4 is not what my vague memories of it were. Still - nat64 is apparently the right thing to use to interoperate with services that are not yet ipv6 enabled.

Martin Pool (mbp) wrote :

I don't think closing bugs based on whether they need Launchpad upstream code changes or not is the right line. Whether it does or not, it's a user-affecting issue and it's useful to have a public handle for it, so that we can see how many people are affected etc, and if that's not a bug there's no obvious other place for it. I guess ultimately it will turn into an IS request, but that's not accessible to users and perhaps not worth opening far in advance.

We could do a FAQ, but as the bug tracker is the work queue for
developers, I think its harmful to have non-code things in the
tracker.

Martin Pool (mbp) wrote :

I talked a bit to Robert because I was concerned about closing user-affecting issues as invalid with no way to progress, just on the grounds that one Canonical team would have to change them rather than another or that we'd have to make a configuration rather than code change.

This bug is closed because the state of ipv6 deployment as of 2011, as we understand it, is that it's just not a reasonable or common case to have a machine that cannot reach ipv4 servers, through either having an an ipv4 route too or having a nat64 gateway at your ISP. If/when that changes (or if it's wrong now) and people are happily using ipv6-only machines, we can reconsider it.

Changed in launchpad:
status: Invalid → Won't Fix
Dag Stenstad (dag-stenstad) wrote :

Now it is 2013, and we have basically run out if IPv4 space. Please reconsider.

Martin Pool (mbp) wrote :

I said two years ago

> it's just not a reasonable or common case to have a machine that cannot
reach ipv4 servers

and I've seen no evidence it's not still true.

Martin: The Asia-Pacific region has been out of IPv4 addresses since 2011, Europe and the Middle-East since 2012. In those regions more and more IPv6-only networks are appearing. I run such networks as well. I am very happy that archive.ubuntu.com is reachable over IPv6 so that normal updates work in an IPv6-only environment. Launchpad is now the next site that I run into.

Please re-open this ticket, now that IPv4 addresses have run out in multiple regions of the world this is very much needed.

Thank you,
Sander Steffann]

Martin Pool (mbp) wrote :

Hi Sander,

My impression is that IPv6-only networks without an http proxy or NAT64 are
still very rare and not practical for general use. A network configured as
in rfc6586 would probably work fine with Launchpad.

I can't see any data on how many sites are strictly-IPv6-only. I would be
interested if you know of any.

Practically: I'm no longer involved with Launchpad, so it's not for me to
reopen it, nor is it possible for me to do anything about it. I doubt that
the Canonical team will allocate time to fix this.

Robert Collins (lifeless) wrote :

I too am no longer active on the LP project, but:
 - this still isn't a code bug in LP: it's entirely possible to run it IPv6 - *there is nothing to fix here* : it's an operational deployment issue, and best raised as a support ticket.
 - There are a growing number of environments where obtaining IPv4 addresses is impossible, but as Martin says there is little evidence that such environments have no access to either NAT64 or an http[s] proxy on a dual-stack machine, so this really sits in the category of 'migration to IP6 requires access to the IPv4 internet via a proxy - thats the standard for deployment'.

As a data point, AWS EC2 still doesn't support IPv6 at all - thats one of the largest public clouds in existance. They do support IPv6 ELB, but not direct to EC2 instances. So there's a huge amount of things out there for which IPv4 connectivity is required: the onus is on people migrating to arrange connectivity (thats the whole point of the migration).

Thiago Martins (martinx) wrote :

Guys, please, fix this! Enable ppa.launchpad.net over IPv6... I already have lots of servers that already are IPv6-Only... IPv4 is dead.... :-P

Oles Pisarenko (doctornkz) wrote :

Please, fix this bug. If you don't have IPv6 you don't ready for the future. IPv4 is dead, wake up.

Kevin Otte (nivex) wrote :

Perhaps this should be added to the IPv6 issue open with Canonical IS per #1260855 ?

Mikaela Suomalainen (mikaela) wrote :

In Finland we recently had national IPv6 launch day and currently two biggest (W)ISPs provide dualstack (lite) meaning native IPv6 + IPv4 with CGN.

The carrier grade NAT (or NAT66) could have performance issues and as IPv4 addresses have ran out years ago it would be important to be ready for IPv6 by supporting it at Launchpad.

Colin Watson (cjwatson) wrote :

At least ppa.launchpad.net already has a ticket open with Canonical IS (RT#75360). We can't do much more than that from our end.

Thomas (t.c) wrote :

pls.. 2 years ago and no change?! Still no IPv6 for launchpad :'(

Junien Fridrick (axino) on 2017-10-11
Changed in launchpad:
status: Won't Fix → In Progress
importance: Undecided → Medium
assignee: nobody → Junien Fridrick (axino)
Rhys (rhvs) wrote :

Now that this is assigned to someone, is there any progress? T'is not that hard.

Thomas (t.c) wrote :

Any News? apport-collect and ubuntu-bug and so on won't work on my ipv6 only host.

Junien Fridrick (axino) wrote :

Hi all, sorry this is taking so long. It's still on my radar. I will keep you posted.

Rhys (rhvs) wrote :

Anything?

Junien Fridrick (axino) wrote :

This should be done by EOY.

Marco Davids (mdavids) wrote :

The last 1/12 of this year will start soon. Will the planning be met?

Junien Fridrick (axino) wrote :

Going to be tough, but I'm actively working on it.

@Junien: you have some IPv6 experts subscribed to this ticket. Let us know if there is anything we can do :)

Junien Fridrick (axino) wrote :

@sander-steffann : thanks for the offer ! The problem isn't IPv6 in itself though, just the complexity of Launchpad. I'm also decoupling hosts and services, which wasn't done for everything in IPv4.

There's good news though, the production frontend *hosts* now have an IPv6. I'm going to let that brew for a bit, and then it'll just be a matter of adding an IPv6 for the vhosts. Targeting January 2019 for this.

Junien Fridrick (axino) wrote :

I have (finally) enabled IPv6 on the launchpad vhosts present on the web frontends. I believe you should be able to run "apport-collect" and "ubuntu-bug" from IPv6-only hosts now, but if that's not the case please let me know.

I still have some more work to do to enable IPv6 on the remaining services (notably codebrowse), so I'll keep this bug opened for now.

Hi Junien,

> I have (finally) enabled IPv6 on the launchpad vhosts present on the web
> frontends. I believe you should be able to run "apport-collect" and
> "ubuntu-bug" from IPv6-only hosts now, but if that's not the case please
> let me know.
>
> I still have some more work to do to enable IPv6 on the remaining
> services (notably codebrowse), so I'll keep this bug opened for now.

Thanks! I'll try it out when I'm back in the office.

Cheers!
Sander

Marco Davids (mdavids) wrote :

๐Ÿ˜„๐Ÿ‘๐Ÿฝ๐Ÿ˜๐Ÿ…๐Ÿ™๐Ÿฝ๐Ÿ†

This issue is not fixed as ppa.launchpad.net is not reacheable over IPv6, as it lacks IPv6 address.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions