ipw3945 not working (Edgy 2.6.17-9-generic #2 SMP)

Bug #62452 reported by Chris Lee on 2006-09-26
68
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

ipw3945 wireless has always worked flawlessly in Dapper Drake, but does not work in Edgy.

The driver is loaded on boot:

[17179595.164000] NET: Registered protocol family 23
[17179595.272000] ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver
for Linux, 1.1.0mp
[17179595.272000] ipw3945: Copyright(c) 2003-2006 Intel Corporation
[17179595.272000] ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 74
[17179595.272000] PCI: Setting latency timer of device 0000:03:00.0 to 64
[17179595.280000] ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection

But the driver does not seem to provide an eth* address for the wireless card.

I'm not sure what more information I can provide to help diagnose this. Let me know what I can do. I don't see anything interesting in the log files.

$ cat /sys/bus/pci/drivers/ipw3945/0000\:03\:00.0/status
cat: /sys/bus/pci/drivers/ipw3945/0000:03:00.0/status: Resource temporarily unavailable

Diogo Matsubara (matsubara) wrote :

Not a launchpad bug

Changed in launchpad:
status: Unconfirmed → Rejected
Simon Law (sfllaw) wrote :

Hello Chris,

I have a few questions before we start. How is your Ubuntu machine hooked up to its network? How is it expected to get an IP address for the wireless card?

Also, please run the following commands:
   $ ifconfig -a 2>&1 | tee /tmp/ifconfig.log
   $ lspci -v 2>&1 | tee /tmp/lspci.log

Then, attach /tmp/ifconfig.log, /tmp/lspci.log, and /var/log/kern.log to this bug report using its web page.

Thanks!

Chris Lee (chris-lee-gertner) wrote :
Chris Lee (chris-lee-gertner) wrote :
Chris Lee (chris-lee-gertner) wrote :

Normally, the wireless card should use dhcp (in Dapper, I use network-manager). But on the Edgy partition, I haven't set this up because eth1 is not present. I tried adding a eth1 stanza in /etc/network/interfaces and doing ifup eth1, but this doesn't work because no eth1 is present.

Chris Lee (chris-lee-gertner) wrote :

Normally, the wireless card should use dhcp (in Dapper, I use network-manager). But on the Edgy partition, I haven't set this up because eth1 is not present. I tried adding a eth1 stanza in /etc/network/interfaces and doing ifup eth1, but this doesn't work because no eth1 is present.

Chris Lee (chris-lee-gertner) wrote :

> How is your Ubuntu machine hooked up to its network?

Hi Simon,

In case this info is useful: the wireless card fails both with and without a wired connection on eth0 (the wired connection is made via DCHP).

Roland Dreier (roland.dreier) wrote :

I believe I had a similar problem with the default Edgy install on my ThinkPad X60s, which has ipw3945 wireless. After the install, there was no wireless network interface, even though the ipw3945 kernel module was loaded.

I noticed that there was no ipw3945d binary blob running in userspace. This was because ipw3945d is in the restricted modules package, which is not installed by default. After installing linux-restricted-modules-generic and reloading ipw3945, eth1 magically appeared and worked fine.

So I guess the resolution to this issue is to make sure that ipw3945d is installed on systems that use ipw3945.

Chris Lee (chris-lee-gertner) wrote :

Roland,

Your suggestion solved the problem for me! I had thought that I had these modules installed (in my attempt to get my ATI card running), but I really had not. I'm running wireless in Edgy now!

Simon Law (sfllaw) wrote :

There should be some way of recommending linux-restricted-modules-generic. At the very least, a message spit out by the ipw3945.ko driver would be in order.

Peter Liedler (peter-liedler) wrote :

Same here on asus w5f.
edgy eft rc1.
The ipw3945 was detected by the life system but the restricted package is not installed. Should be default to install when hardware which is in restricted modules is detected.

Larakin (larakinsystems) wrote :

I am having a similar issue with my Dell Inspiron E705 w/ ipw3945.

Every time I boot I get about a 30-45 sec stall while initializing network interfaces. When the system boots the card is detected and enabled but does not and will not connect to anything untill I go into networking and disable->re-enable the card. once this is done it all works fine. I have had the same problem since 2.6.17-8. I had to re-install the linux-restricted-modules-generic when I upgraded to 2.6.17-8 from 2.6.17-7 to get it to be detected at all, and that is when the problem really started.

It was working fin in 2.6.17-7

nikwik (niklas-wikstrom) wrote :

Solved same problem otherwise (HP nw9440):

/etc/modprobe.d/ipw3945 tries to launch /sbin/ipw3945d-$(uname -r), but without the linux-restricted-modules-generic, there is no (e.g.) ipw3945d-2.6.17-10-generic only the ...-386. So
ln -s ipw3945d-2.6.17-10-386 ipw3945d-2.6.17-10-generic
solved my probs. Will install the linux-restricted-modules-generic now however. Thanks!

FuturePast (4uturepast) wrote :

Confirm that this is also a problem for Dell Latitude D620.

this was also an issue on a Lenovo 3000 N100.

Tom John (tomcjohn) wrote :

This was also an issue on a Dell XPS M1210 laptop.

I had a couple of failed attempts at installing the latest version (v1.2.15) of the ieee80211 subsystem (as instructed by the installation notes for the ipw3945 drivers from http://ipw3945.sourceforge.net/) which ended up screwing up my kernel and affecting other modules such as my nVidia drivers (through my own clumsiness I must admit).

Through looking around it seems that whilst the ipw3945 driver module comes with the kernel and is loaded at boot time the required micro-code has been moved to the linux-required-modules-<kernel-type> package (I'm using the linux-required-modules-generic package).

So to resolve I bit the bullet and did a full re-install, then installed the linux-required-modules-generic package and the wireless device suddenly appeared in network-admin.

She's roses! :)

Steve Frécinaux (nud) wrote :

I also got issues under feisty with my inspiron 945m from dell.

the kernel:
Linux mejai 2.6.20-6-generic #2 SMP Wed Jan 31 20:53:39 UTC 2007 i686 GNU/Linux

the card:
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

the issue:
while networkmanager can see wireless networks, it didn't manage to connect any, be it protected or not.

the solution:
$ wget http://bughost.org/ipw3945/ucode/ipw3945-ucode-1.14.2.tgz
$ tar xzvf ipw3945-ucode-1.14.2.tgz
$ sudo cp ipw3945.ucode /lib/firmware/2.6.20-6-generic/ipw3945.ucode

And everything worked just fine after reloading the kernel module.
Hope this helps

bobosky (codemonkey) wrote :

Okay I am really new here and this is all greek to me.
I have a 2003 Toshiba P3 I just installed 7.04 my fires Linux install ever, and all I want is for the wireless to work.
So how do I get this ipw3945 on to my Ubuntu computer and installed?
Please don't talk in code. Can you format this in steps?

The steps I think I have done so far.
- download ipw3945 from http://bughost.org/ipw3945/ucode/ipw3945-ucode-1.14.2.tgz on another computer
- put ipw3945 on a removeable drive
- save ipw3945 on the Ubuntu 7.04 computer's desktop
- Go to Applications then Accessories thenTerminal
- type SOMETHING....?

That is about all I got Please correct me!

Bobosky: Please use the 'Answers' part of Launchpad to ask for help. This is the bug reporting section. Go to https://answers.launchpad.net/

The restricted driver managment system should mean that this is fixed in Feisty and Gutsy - it is for me.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Released
bobosky (codemonkey) wrote :

Sorry for asking a question in the wrong place. Now the question is at https://answers.launchpad.net/ubuntu/+question/8863

And I am glad it works for some people but I would be very thankful for some help.

Are there any details missing in my question that should be included to make it easer to answer?

Tim

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers